Added patch to fix compilation error due to exceptions not being enabled.

See https://svnweb.freebsd.org/ports?view=revision&revision=389789

Fixes PR pkg/50078
This commit is contained in:
jaapb 2015-08-04 12:56:02 +00:00
parent 4cf1bfe4ce
commit 0508cefd1a
2 changed files with 16 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.18 2014/11/14 22:02:56 markd Exp $
$NetBSD: distinfo,v 1.19 2015/08/04 12:56:02 jaapb Exp $
SHA1 (libkdcraw-4.14.3.tar.xz) = 52b8c0031baec1f2231c07e646383bfa299d6759
RMD160 (libkdcraw-4.14.3.tar.xz) = 28d68f4ebcecaa8658c2d3838ab3c71ff1d9f50b
Size (libkdcraw-4.14.3.tar.xz) = 100176 bytes
SHA1 (patch-libkdcraw_CMakeLists.txt) = 8a9ba09a06e50383670d9fbb7d8291a09593b0fc

View file

@ -0,0 +1,14 @@
$NetBSD: patch-libkdcraw_CMakeLists.txt,v 1.1 2015/08/04 12:56:02 jaapb Exp $
Enable exceptions for compilation
--- libkdcraw/CMakeLists.txt.orig 2014-07-06 07:20:12.000000000 +0000
+++ libkdcraw/CMakeLists.txt
@@ -22,6 +22,8 @@
#
# ============================================================
+add_definitions (${KDE4_ENABLE_EXCEPTIONS})
+
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/version.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/version.h)
SET(kdcraw_LIB_SRCS kdcraw.cpp