Fix broken 64-bit build, and patch makefile to stop on error. There

are a lot of woolly things going on here, so PKGREVISION++ as a
precaution.
This commit is contained in:
dholland 2008-09-05 05:27:30 +00:00
parent 63b224a4aa
commit 053674084d
15 changed files with 332 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.25 2008/04/12 22:43:02 jlam Exp $
# $NetBSD: Makefile,v 1.26 2008/09/05 05:27:30 dholland Exp $
DISTNAME= cint5.15
PKGNAME= cint-5.15.174
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= lang
MASTER_SITES= ftp://root.cern.ch/root/
#MASTER_SITES= ${MASTER_SITE_BACKUP}
@ -97,4 +97,12 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/doc/man3/statistics.h.3 \
${DESTDIR}${PREFIX}/${PKGMANDIR}/man3
# The library seems to want these but the pertinent parts still don't
# build, so I'm reluctant to bother.
#
#.include "../../graphics/glu/buildlink3.mk"
#.include "../../graphics/MesaLib/buildlink3.mk"
#.include "../../x11/xproto/buildlink3.mk"
#.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,19 @@
$NetBSD: distinfo,v 1.5 2005/05/19 17:11:45 drochner Exp $
$NetBSD: distinfo,v 1.6 2008/09/05 05:27:30 dholland Exp $
SHA1 (cint-5.15.174/cint5.15.tar.gz) = 7061acb210dafb86413536dc91e0aa24e9ef3ee9
RMD160 (cint-5.15.174/cint5.15.tar.gz) = 4d403e150fc290feba38785b385f282a28d15dcd
Size (cint-5.15.174/cint5.15.tar.gz) = 1983029 bytes
SHA1 (patch-aa) = 7f0c6c93b146507fecca71d6c596d98194cfc7ad
SHA1 (patch-ab) = ae2689e7b90f6c6acf5914bb4fe19b8d0735896b
SHA1 (patch-ac) = c10a2524ce9395f606bcaf0a0e32901d13f24fbf
SHA1 (patch-ad) = 2bf67f2e7e8a1aa73c38d54963018ff9c99af2c7
SHA1 (patch-ae) = 254ea7ca3df473ac6ce025af96896bf9c8e69310
SHA1 (patch-af) = 949493ae618766134d1c46a281bf1776be599491
SHA1 (patch-ag) = f04a490d04b450e68c64f47a8ba5a4b6fa40b84d
SHA1 (patch-ah) = e03dfadf3341b6988422e36985dda38b73da2da7
SHA1 (patch-ai) = 9ccb89fb804af6b728edf46b84dddc7f8e7f1572
SHA1 (patch-aj) = 032e81af2ed1b2740696abe03109d7caeda7b510
SHA1 (patch-ak) = d42e9b51f5dde832d51d2dbda141b7b9824cfc13
SHA1 (patch-al) = bff446f0f1670919be05443f01e95d66f247cdfd
SHA1 (patch-am) = 2702bc344bf937b45c8138339cf6d35214bb096f
SHA1 (patch-an) = 0233b78422396f6a1081589b76bda4c3ec19fa0e

View file

@ -0,0 +1,63 @@
$NetBSD: patch-ab,v 1.5 2008/09/05 05:27:30 dholland Exp $
--- Makefile~ 2005-05-06 04:49:09.000000000 -0400
+++ Makefile 2008-09-04 23:42:47.000000000 -0400
@@ -91,7 +91,7 @@ include/iosenum.h : cint include/stdio.h
then \
touch include/iosenum.h; \
else \
- (cd include;rm -f stdfunc.dll;../cint -I. iosenum.cxx); \
+ (cd include;rm -f stdfunc.dll;../cint -I. iosenum.cxx) || exit 1; \
fi
echo > done
@@ -110,10 +110,10 @@ makecint : tool/makecint.c
include/stdio.h : include/mkincld.c
$(CC) -I.. $(MACRO) -c -o include/mkincld.o include/mkincld.c
$(LD) $(OPTIMIZE) include/mkincld.o $(LDOPT) -o include/mkincld
- (cd include;./mkincld)
+ (cd include;./mkincld) || exit 1
# $(CC) -I.. $(MACRO) -o include/mkincld include/mkincld.c
-# (cd include;./mkincld)
+# (cd include;./mkincld) || exit 1
##############################################################
# Link cint executable
@@ -134,22 +134,22 @@ main/G__setup.o : main/G__setup.c G__ci.
# dependency file
##############################################################
$(CINTSYSDIR)/readline/libreadline.a : readline/*.c readline/*.h
- (cd readline ; make)
+ (cd readline ; make) || exit 1
##############################################################
# Compile cint interpreter core library
##############################################################
$(CINTSYSDIR)/src/G__ci.a : G__ci.h src/*.c src/*.cxx *.h src/*.h $(READLINEA)
- (cd src ; make CINTSYSDIR=$(CINTSYSDIR) )
+ (cd src ; make CINTSYSDIR=$(CINTSYSDIR) ) || exit 1
$(CINTSYSDIR)/libcint.so : G__ci.h src/*.c src/*.cxx *.h src/*.h $(READLINEA)
- (cd src ; make CINTSYSDIR=$(CINTSYSDIR) $(CINTSYSDIR)/libcint.so)
+ (cd src ; make CINTSYSDIR=$(CINTSYSDIR) $(CINTSYSDIR)/libcint.so) || exit 1
$(CINTSYSDIR)/libcint.sl : G__ci.h src/*.c src/*.cxx *.h src/*.h $(READLINEA)
- (cd src ; make CINTSYSDIR=$(CINTSYSDIR) $(CINTSYSDIR)/libcint.sl)
+ (cd src ; make CINTSYSDIR=$(CINTSYSDIR) $(CINTSYSDIR)/libcint.sl) || exit 1
$(CINTSYSDIR)/libcint.dll : G__ci.h src/*.c src/*.cxx *.h src/*.h $(READLINEA)
- (cd src ; make CINTSYSDIR=$(CINTSYSDIR) $(CINTSYSDIR)/libcint.dll)
+ (cd src ; make CINTSYSDIR=$(CINTSYSDIR) $(CINTSYSDIR)/libcint.dll) || exit 1
##############################################################
# Compile cint main function.
@@ -164,7 +164,7 @@ $(CINTSYSDIR)/main/G__main.o : main/G__m
# Cleanup
##############################################################
clean :
- $(RM) main/*.o cint done core include/mkincld include/stdio.h makecint include/iosenum.h ; (cd src; make clean) ; (cd readline; make clean)
+ $(RM) main/*.o cint done core include/mkincld include/stdio.h makecint include/iosenum.h ; (cd src; make clean) || exit 1 ; (cd readline; make clean) || exit 1
cleanbin :
$(RM) main/*.o src/*.o $(CINTLIB) $(CINT_V6)

View file

@ -0,0 +1,38 @@
$NetBSD: patch-ac,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- readline/readline.c.orig 2005-05-06 04:48:54.000000000 -0400
+++ readline/readline.c 2008-09-05 00:23:42.000000000 -0400
@@ -31,11 +31,13 @@ static char *xmalloc (), *xrealloc ();
#endif /* STATIC_MALLOC */
/* patched by gotom for Linux */
-#ifdef __linux__
+#if defined(__linux__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__DragonFly__)
#define VOID_SIGHANDLER
#endif
#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
#include <sys/types.h>
#include <fcntl.h>
#include <sys/file.h>
@@ -2631,7 +2633,7 @@ alphabetic (c)
return (1);
if (allow_pathname_alphabetic_chars)
- return ((int)rindex (pathname_alphabetic_chars, c));
+ return (rindex (pathname_alphabetic_chars, c) != NULL);
else
return (0);
}
@@ -3555,7 +3557,8 @@ Function *rl_completion_entry_function =
If this function exists and returns NULL then call the value of
rl_completion_entry_function to try to match, otherwise use the
array of strings returned. */
-Function *rl_attempted_completion_function = (Function *)NULL;
+/*Function *rl_attempted_completion_function = (Function *)NULL;*/
+char **(*rl_attempted_completion_function)() = NULL;
/* Local variable states what happened during the last completion attempt. */
static int completion_changed_buffer = 0;

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ad,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- readline/vi_mode.c~ 2005-05-06 04:48:54.000000000 -0400
+++ readline/vi_mode.c 2008-09-04 23:48:53.000000000 -0400
@@ -30,6 +30,7 @@
#if defined (VI_MODE)
#include <stdio.h>
+#include <string.h>
#if defined (__GNUC__)
# define alloca __builtin_alloca

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ae,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- readline/history.c~ 2005-05-06 04:48:54.000000000 -0400
+++ readline/history.c 2008-09-04 23:49:20.000000000 -0400
@@ -32,6 +32,7 @@ static char *xmalloc (), *xrealloc ();
#endif
#include <stdio.h>
+#include <string.h>
#include <sys/types.h>
#include <sys/file.h>
#include <sys/stat.h>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-af,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- malloc/xmalloc.c~ 2005-05-06 04:48:51.000000000 -0400
+++ malloc/xmalloc.c 2008-09-04 23:50:51.000000000 -0400
@@ -20,6 +20,7 @@
Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
#include <stdio.h>
+#include <stdlib.h>
static void memory_error_and_abort ();

View file

@ -0,0 +1,32 @@
$NetBSD: patch-ag,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- glob/tilde.c.orig 2005-05-06 04:48:48.000000000 -0400
+++ glob/tilde.c 2008-09-05 00:23:17.000000000 -0400
@@ -27,6 +27,8 @@
# endif
#endif
+#include <string.h>
+#include <stdlib.h>
#include <pwd.h>
#ifndef savestring
@@ -41,7 +43,7 @@ typedef int Function ();
#if defined (TEST)
static char *xmalloc (), *xrealloc ();
#else
-extern char *malloc (), *xrealloc ();
+extern char *xmalloc (), *xrealloc ();
#endif /* TEST */
/* The default value of tilde_additional_prefixes. This is set to
@@ -60,7 +62,8 @@ static char *default_suffixes[] =
standard meaning for expanding a tilde fails. The function is called
with the text (sans tilde, as in "foo"), and returns a malloc()'ed string
which is the expansion, or a NULL pointer if there is no expansion. */
-Function *tilde_expansion_failure_hook = (Function *)NULL;
+/*Function *tilde_expansion_failure_hook = (Function *)NULL;*/
+char *(*tilde_expansion_failure_hook)(char *) = NULL;
/* When non-null, this is a NULL terminated array of strings which
are duplicates for a tilde prefix. Bash uses this to expand

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ah,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- src/bc_exec.cxx~ 2005-05-06 11:37:47.000000000 -0400
+++ src/bc_exec.cxx 2008-09-04 23:52:56.000000000 -0400
@@ -35,7 +35,7 @@ extern "C" int G__bc_exec_virtualbase_by
// TODO, below is a dead copy of virtual_bytecode which may not work
- int vtagnum = (int)funcname; // tagnum of given pointer
+ int vtagnum = (int)(intptr_t)funcname; // tagnum of given pointer
int vtblindex = hash&0xffff; // virtual function table index
int vbasetagnum = hash/0x10000; // vbasetagnum
int voffset=G__struct.virtual_offset[vtagnum]; // offset for true tagnum info
@@ -100,7 +100,7 @@ extern "C" int G__bc_exec_virtual_byteco
,int hash // vtblindex,basetagnum
) {
- int vtagnum = (int)funcname; // tagnum of given pointer
+ int vtagnum = (int)(intptr_t)funcname; // tagnum of given pointer
int vtblindex = hash&0xffff; // virtual function table index
int vbasetagnum = hash/0x10000; // vbasetagnum
int voffset=G__struct.virtual_offset[vtagnum]; // offset for true tagnum info

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ai,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- lib/posix/posix.h~ 2005-05-06 04:48:49.000000000 -0400
+++ lib/posix/posix.h 2008-09-05 00:02:39.000000000 -0400
@@ -272,7 +272,7 @@ extern char *getwd(char *buf);
extern int setpgrp(pid_t _pid,pid_t _pgrp);
#elif defined(G__SUN) || defined(__sun)
extern long setpgrp(void);
-#elif defined(G__FBSD)||defined(__FreeBSD__)||defined(G__OBSD)||defined(__OpenBSD__)||((defined(G__alpha)||defined(__alpha))&&defined(G__GNUC))||((defined(G__alpha)||defined(__alpha))&&defined(G__GNUC))
+#elif defined(G__FBSD)||defined(__FreeBSD__)||defined(G__NBSD)||defined(__NetBSD__)||defined(G__OBSD)||defined(__OpenBSD__)||((defined(G__alpha)||defined(__alpha))&&defined(G__GNUC))||((defined(G__alpha)||defined(__alpha))&&defined(G__GNUC))
extern int setpgrp(pid_t _pid, pid_t _pgrp);
#elif defined(G__KCC) || defined(__KCC)
extern pid_t setpgrp(void);

View file

@ -0,0 +1,10 @@
$NetBSD: patch-aj,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- tool/ifdef/Makefile.base~ 2005-05-06 04:49:09.000000000 -0400
+++ tool/ifdef/Makefile.base 2008-09-05 00:10:44.000000000 -0400
@@ -18,4 +18,4 @@ get.o: get.c
clean:
- rm get.o ifdef.o ifdef
+ rm -f get.o ifdef.o ifdef

View file

@ -0,0 +1,24 @@
$NetBSD: patch-ak,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- readline/readline.h~ 2005-05-06 04:48:54.000000000 -0400
+++ readline/readline.h 2008-09-05 00:22:54.000000000 -0400
@@ -138,7 +138,8 @@ extern Function *rl_ignore_some_completi
If this function exists and returns NULL then call the value of
rl_completion_entry_function to try to match, otherwise use the
array of strings returned. */
-extern Function *rl_attempted_completion_function;
+/*extern Function *rl_attempted_completion_function;*/
+extern char **(*rl_attempted_completion_function)();
/* If non-zero, then this is the address of a function to call just
before readline_internal () prints the first prompt. */
@@ -164,7 +165,8 @@ extern int rl_show_star;
standard meaning for expanding a tilde fails. The function is called
with the text (sans tilde, as in "foo"), and returns a malloc()'ed string
which is the expansion, or a NULL pointer if there is no expansion. */
-extern Function *tilde_expansion_failure_hook;
+/*extern Function *tilde_expansion_failure_hook;*/
+extern char *(*tilde_expansion_failure_hook)(char *);
/* When non-null, this is a NULL terminated array of strings which
are duplicates for a tilde prefix. Bash uses this to expand

View file

@ -0,0 +1,13 @@
$NetBSD: patch-al,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- src/loadfile.c~ 2005-05-06 11:32:18.000000000 -0400
+++ src/loadfile.c 2008-09-05 00:26:18.000000000 -0400
@@ -2440,7 +2440,7 @@ char *name;
if(strlen(name)<G__MAXFILENAME-6) strcat(name,appendix);
return(name);
-#elif /*defined(G__NEVER) && */ ((__GNUC__>=3)||((__GNUC__>=2)&&(__GNUC_MINOR__>=96)))&&(defined(__linux)||defined(__linux__))
+#elif /*defined(G__NEVER) && */ ((__GNUC__>=3)||((__GNUC__>=2)&&(__GNUC_MINOR__>=96)))&&(defined(__linux)||defined(__linux__)||defined(__NetBSD__)||defined(__FreeBSD__)||defined(__OpenBSD__)||defined(__DragonFly__))
/* After all, mkstemp creates more problem than a solution. */
const char *appendix="_cint";
strcpy(name,"/tmp/XXXXXX");

View file

@ -0,0 +1,13 @@
$NetBSD: patch-am,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- tool/ifdef/ifdef.cxx~ 2005-05-06 04:49:09.000000000 -0400
+++ tool/ifdef/ifdef.cxx 2008-09-05 00:32:03.000000000 -0400
@@ -62,7 +62,7 @@ extern "C" {
char *G__calc(char*);
char *G__getexpr(char*);
char *G__getandor(char*);
-#if !defined(__hpux) && !defined(__APPLE__)
+#if !defined(__hpux) && !defined(__APPLE__) && !defined(__NetBSD__) && !defined(__FreeBSD__) && !defined(__OpenBSD__) && !defined(__DragonFly__)
char getopt(int argc,char **argv,char *optlist);
#endif
extern int optind;

View file

@ -0,0 +1,44 @@
$NetBSD: patch-an,v 1.1 2008/09/05 05:27:31 dholland Exp $
--- tool/ifdef/get.c~ 2005-05-06 04:49:09.000000000 -0400
+++ tool/ifdef/get.c 2008-09-05 00:43:19.000000000 -0400
@@ -2575,7 +2575,7 @@ struct G__param *libp;
{
char temp[ONELINE],temp1[ONELINE];
FILE *fopen();
- int fp;
+ long fp;
if(strcmp(funcname,"printf")==0) {
/* para[0]:description, para[1~paran-1]: */
@@ -2596,18 +2596,18 @@ struct G__param *libp;
if(strcmp(funcname,"fclose")==0) {
/* para[0]:filepointer */
- sprintf(result7,"%d",fclose((FILE*)atoi(libp->para[0])));
+ sprintf(result7,"%d",fclose((FILE*)atol(libp->para[0])));
return(1);
}
if(strcmp(funcname,"fgets")==0) {
/* parameter[0]:varname, para[1]:nchar,para[2]:filepointer */
- fp=atoi(libp->para[2]);
+ fp=atol(libp->para[2]);
sprintf(result7,"%ld"
,(long)fgets(temp,atoi(libp->para[1]),(FILE*)fp));
G__letvariable(libp->parameter[0]
,G__add_quotation(temp),&G__global,G__local);
- sprintf(temp,"%d",fp);
+ sprintf(temp,"%ld",fp);
G__letvariable(libp->parameter[1],temp,&G__global,G__local);
return(1);
}
@@ -2615,7 +2615,7 @@ struct G__param *libp;
if(strcmp(funcname,"fprintf")==0) {
/* parameter[0]:pointer ,parameter[1]:description, para[2~paran-1]: */
G__charformatter(result7,1,libp);
- fprintf((FILE*)atoi(libp->para[0]),"%s",result7);
+ fprintf((FILE*)atol(libp->para[0]),"%s",result7);
strcpy(result7,"");
return(1);
}