Fix "test ==".

This commit is contained in:
wiz 2006-10-18 23:38:59 +00:00
parent 4f654e6058
commit 05c4322eff
2 changed files with 24 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.15 2006/07/02 15:47:16 tron Exp $
$NetBSD: distinfo,v 1.16 2006/10/18 23:38:59 wiz Exp $
SHA1 (uae-0.8.25.tar.gz) = 41b7a70cf672d3cc516bd3856a051459a95a6517
RMD160 (uae-0.8.25.tar.gz) = 6990dc7aaf43c8bda0d7b86e6d0ae164209d1eb1
@ -10,3 +10,4 @@ SHA1 (patch-ad) = 6ac0d9bd6e60408f366f050898ae87e8730466ec
SHA1 (patch-ae) = 9235c20d2a60b3c48e87eb23463a14f558e0de4e
SHA1 (patch-af) = ca05a7ec786d48e488d3b29e0650da1ef4f67d37
SHA1 (patch-ag) = f62849869131a4ce3c87c4f3596fe2479ca3df8e
SHA1 (patch-ah) = 3c467cd0e1de340733b9feb9e9e9c9365f9205ea

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ah,v 1.1 2006/10/18 23:38:59 wiz Exp $
--- src/install_libscg.orig 2000-07-23 14:32:04.000000000 +0000
+++ src/install_libscg
@@ -9,7 +9,7 @@
#
# check arguments
#
-if [ $# -lt 1 ] || [ $# -gt 3 ] || [ "$1" == "--help" ]; then
+if [ $# -lt 1 ] || [ $# -gt 3 ] || [ "$1" = "--help" ]; then
echo "usage: $0 <cdrecord dir> <machine type (optional)>"
exit 0
fi
@@ -31,7 +31,7 @@ else
echo "please specify your machine type - libscg was compiled for:"
echo "$machine"
exit 10
- elif [ "$machine"x == x ]; then
+ elif [ "$machine"x = x ]; then
echo "please compile cdrecord for your machine first"
exit 10
fi