import rman & Makefile
This commit is contained in:
parent
2ff164b504
commit
0641a96c3e
7 changed files with 79 additions and 0 deletions
24
textproc/Makefile
Normal file
24
textproc/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
# $Id: Makefile,v 1.1.1.1 1997/10/30 01:04:20 hubertf Exp $
|
||||
#
|
||||
|
||||
SUBDIR += agrep
|
||||
SUBDIR += docbook
|
||||
SUBDIR += glimpse
|
||||
SUBDIR += html
|
||||
SUBDIR += info2html
|
||||
SUBDIR += isearch
|
||||
SUBDIR += iso12083
|
||||
SUBDIR += iso8879
|
||||
SUBDIR += ispell
|
||||
SUBDIR += jade
|
||||
SUBDIR += linuxdoc
|
||||
SUBDIR += mgdiff
|
||||
SUBDIR += par
|
||||
SUBDIR += pilot_makedoc
|
||||
SUBDIR += rman
|
||||
SUBDIR += sgmlformat
|
||||
SUBDIR += sp
|
||||
SUBDIR += unroff
|
||||
SUBDIR += wdiff
|
||||
|
||||
.include <bsd.port.subdir.mk>
|
22
textproc/rman/Makefile
Normal file
22
textproc/rman/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# New ports collection makefile for: rman
|
||||
# Version required: 3.0.3a12
|
||||
# Date created: 27 Dec 1994
|
||||
# Whom: Thomas Gellekum <tg@FreeBSD.org>
|
||||
#
|
||||
# $Id: Makefile,v 1.1.1.1 1997/10/30 01:04:20 hubertf Exp $
|
||||
#
|
||||
|
||||
DISTNAME= rman-3.0.3a12
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://ftp.cs.berkeley.edu/ucb/people/phelps/tcltk/
|
||||
EXTRACT_SUFX= .tar.Z
|
||||
|
||||
MAINTAINER= tg@FreeBSD.org
|
||||
|
||||
NO_CDROM= "License required"
|
||||
MAN1= rman.1
|
||||
|
||||
post-install:
|
||||
@strip ${PREFIX}/bin/rman
|
||||
|
||||
.include <bsd.port.mk>
|
1
textproc/rman/files/md5
Normal file
1
textproc/rman/files/md5
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (rman-3.0.3a12.tar.Z) = 19945ee55329bbbd1f26b5a05677e771
|
25
textproc/rman/patches/patch-aa
Normal file
25
textproc/rman/patches/patch-aa
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- Makefile.orig Sat Apr 12 08:59:15 1997
|
||||
+++ Makefile Sat May 31 04:52:01 1997
|
||||
@@ -15,17 +15,16 @@
|
||||
# this must be a directory that's in your bin PATH.
|
||||
# MANDIR holds the man page.
|
||||
|
||||
-BINDIR = /home/auspex/h/bair/phelps/bin
|
||||
-#BINDIR = /usr/local/bin
|
||||
-MANDIR = /home/auspex/h/bair/phelps/man/man1
|
||||
-#MANDIR = /usr/local/man/man1
|
||||
+PREFIX?= /usr/local
|
||||
+BINDIR = ${PREFIX}/bin
|
||||
+MANDIR =${PREFIX}/man/man1
|
||||
|
||||
|
||||
### if you have GNU gcc v2.x, use these definitions
|
||||
|
||||
-CC = gcc
|
||||
+# CC = gcc
|
||||
# if you don't have gcc v2.x, try -O for CFLAGS
|
||||
-CFLAGS = -O2 -finline-functions
|
||||
+CFLAGS += -finline-functions
|
||||
|
||||
### if you just have a standard UNIX, use these instead of GNU.
|
||||
### CC must be an ANSI C compiler
|
1
textproc/rman/pkg/COMMENT
Normal file
1
textproc/rman/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
Reverse compile man pages from formatted form.
|
4
textproc/rman/pkg/DESCR
Normal file
4
textproc/rman/pkg/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
RosettaMan takes formatted man pages from most of the popular flavours
|
||||
of UN*X and transforms them into any of a number of source formats. It
|
||||
can produce ASCII-only, section headers-only, TkMan, [tn]roff, Ensemble,
|
||||
SGML, HTML, LaTeX, RTF, Perl 5 POD.
|
2
textproc/rman/pkg/PLIST
Normal file
2
textproc/rman/pkg/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
bin/rman
|
||||
man/man1/rman.1.gz
|
Loading…
Reference in a new issue