Qt3 GUI for the wpa_supplicant(8) daemon shipped with NetBSD.

This commit is contained in:
rpaulo 2006-10-22 23:20:21 +00:00
parent 6060ed6f65
commit 0671ae5e79
5 changed files with 48 additions and 0 deletions

6
net/wpa_gui/DESCR Normal file
View file

@ -0,0 +1,6 @@
wpa_supplicant is a WPA Supplicant for Linux, BSD, and Windows with
support for WPA and WPA2 (IEEE 802.11i / RSN). It is suitable for both
desktop/laptop computers and embedded systems. Supplicant is the
IEEE 802.1X/WPA component that is used in the client stations.
This package only includes the wpa_gui frontent for wpa_supplicant.

21
net/wpa_gui/Makefile Normal file
View file

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1.1.1 2006/10/22 23:20:21 rpaulo Exp $
DISTNAME= wpa_supplicant-0.4.9
PKGNAME= ${DISTNAME:S/supplicant/gui/}
CATEGORIES= net
MASTER_SITES= http://hostap.epitest.fi/releases/
MAINTAINER= rpaulo@NetBSD.org
HOMEPAGE= http://hostap.epitest.fi/wpa_supplicant/
COMMENT= QT GUI for wpa_supplicant(8)
USE_LANGUAGES+= c++
BUILD_TARGET= wpa_gui
USE_TOOLS+= gmake
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wpa_gui/wpa_gui ${PREFIX}/sbin/wpa_gui
.include "../../x11/qt3-libs/buildlink3.mk"
.include "../../x11/qt3-tools/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2
net/wpa_gui/PLIST Normal file
View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2006/10/22 23:20:21 rpaulo Exp $
sbin/wpa_gui

6
net/wpa_gui/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2006/10/22 23:20:21 rpaulo Exp $
SHA1 (wpa_supplicant-0.4.9.tar.gz) = e6a5cd6fbb7f12cc0a074da212f4fd7fbde0aec0
RMD160 (wpa_supplicant-0.4.9.tar.gz) = 627ddb6c12f15e08448606f24b3082b50f814a43
Size (wpa_supplicant-0.4.9.tar.gz) = 483279 bytes
SHA1 (patch-aa) = 6168171f82fe6dc2262d1be47a1da620e6e81752

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2006/10/22 23:20:21 rpaulo Exp $
--- Makefile.orig 2006-10-22 19:05:39.000000000 -0400
+++ Makefile 2006-10-22 19:05:53.000000000 -0400
@@ -460,7 +460,7 @@ windows-bin: $(WINALL)
$(STRIP) $(WINALL)
wpa_gui/Makefile:
- qmake -o wpa_gui/Makefile wpa_gui/wpa_gui.pro
+ $(QMAKE) -o wpa_gui/Makefile wpa_gui/wpa_gui.pro
wpa_gui: wpa_gui/Makefile
$(MAKE) -C wpa_gui