Conversion of FreeBSD port of fbm-1.2 to NetBSD package as provided in PR

pkg/10199 by Richard Rauch <rkr@rkr.kcnet.com> with PLIST fixes by myself.
This commit is contained in:
rh 2000-08-03 19:20:43 +00:00
parent 6a232708e0
commit 068ac71d32
6 changed files with 63 additions and 67 deletions

View file

@ -1,25 +1,13 @@
# New ports collection makefile for: fbm
# Date created: 21 January 1998
# Whom: giffunip@asme.org
#
# $FreeBSD: ports/graphics/fbm/Makefile,v 1.5 2000/04/29 23:54:02 steve Exp $
#
# $NetBSD: Makefile,v 1.1.1.2 2000/08/03 19:20:43 rh Exp $
# FreeBSD Id: ports/graphics/fbm/Makefile,v 1.5 2000/04/29 23:54:02 steve Exp
PORTNAME= fbm
PORTVERSION= 1.2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/graphics/convert
DISTNAME= fbm-1.2
CATEGORIES= graphics converters
MASTER_SITES= ${MASTER_SITE_SUNSITE:=apps/graphics/convert/}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
MAINTAINER= packages@netbsd.org
NO_WRKSUBDIR= yes
MANL= clr2gray.l fbcat.l fbclean.l fbconv.l fbedge.l fbext.l fbhalf.l \
fbham.l fbhist.l fbinfo.l fbm.l fbm2pod.l fbmask.l fbmedian.l \
fbnorm.l fbps.l fbquant.l fbrot.l fbsample.l fbsharp.l fbthin.l \
gray2clr.l idiff.l pbm2ps.l pbmtitle.l qrt2fbm.l raw2fbm.l tiff2fbm.l \
uunet2fbm.l
.include <bsd.port.mk>
.include "../../mk/bsd.pkg.mk"

View file

@ -1 +1,3 @@
$NetBSD: md5,v 1.1.1.2 2000/08/03 19:20:43 rh Exp $
MD5 (fbm-1.2.tgz) = 9081bc67c6169e07688086d59efdc3a5

View file

@ -0,0 +1,3 @@
$NetBSD: patch-sum,v 1.1.1.1 2000/08/03 19:20:44 rh Exp $
MD5 (patch-aa) = 4dcaa1f51eadbc7b393143c8ec3b8f4d

View file

@ -1,3 +1,5 @@
$NetBSD: patch-aa,v 1.1.1.2 2000/08/03 19:20:45 rh Exp $
--- Makefile.orig Fri Jun 4 01:30:50 1993
+++ Makefile Thu Apr 27 03:27:43 2000
@@ -63,32 +63,33 @@

View file

@ -1,51 +1,22 @@
This collection provides a complete package for manipulating and
converting color and black and whites images, including 24bit RGB, 8bit
mapped color, 8bit grayscale, and 1bit bitmapped images.
The Fuzzy BitMap tools. (Adapted directly from the FreeBSD Ports
system.)
clr2gray Convert color to grayscale
fbcat Copy image (used for format conversion)
fbclean Flip isolated pixels (clean image)
fbconv Arbitrary convolutions
fbedge Compute derivative image (edge detection)
fbext Extract region, resize, change aspect ratio
fbgamma Gamma correct grayscale or color image for display
fbhalf Halftone grayscale image (Blue noise, Floyd-Steinberg, etc)
fbham Convert FBM 24bit RGB to Amiga HAM mode
fbhist Compute histogram
fbinfo Dump image header
fbm2pod Convert grayscale image to Diablo graphics (!)
fbm2tga Convert image to Targa format
fbm2tiff Convert FBM files to 1, 2, 4, 8, or 24 bit TIFF
fbmask Set region to gray value
fbmedian Median filter 3x3 regios
fbnorm Normalize image intensity / increase contrast
fbpalet Replace an imager's colormap with another, remove duplicates
fbps Convert to PostScript
fbquant Color quantization (24 bit to 8..256 colors) Mod. Heckbert
fbrot Rotate 90, 180, or 270 degrees
fbthin Thin 1bit images
fbsample Sample a 1bit file to produce an 8bit file
fbsharp Sharpen (edge enhancement) by digital Laplacian
gray2clr Add a "gray" colormap to a grayscale image
idiff (and udiff) convert raw byte stream into byte difference
pbm2ps Convert PBM file to PostScript
pbmtitle Add a title to a PBM file
raw2fbm Convert raw file to FBM format (eg: Amiga Digiview files)
tga2fbm Convert Targa file to FBM format
tiff2fbm Convert tiff file to FBM format
uunet2fbm Convert UseNet Facesaver file to FBM format
This package provides a set of UNIX filter commands which perform
image-processing steps, and can read and write multiple formats.
A NOP filter, fbcat, can be used to perform format conversions. Similar
to netpbm or urt. The key reason that I wanted fbm is because fbm can
deal with IFF FORM ILBM files, while other tools at my disposal cannot.
File Formats
Two caveats:
FBM (-F) FBM file with 256 byte header (with title & credits)
Sun (-S) Sun rasterfile with 32 byte header
Tiff (-T) Aldus TIFF
PBM (-P) Poskanzer format for 1bit files
GIF (-G) CompuServe GIF format
JPG (-J) JPEG JFIF format (cf The Independent JPEG Group)
RLE (-R) Utah RLE format
IFF (-I) Amiga IFF files (except HAM mode files)
PCX (-Z) PC PaintBrush format for IBM
Face (-B) Bennet Yee's 1bit files, used at CMU
___________
From the README file
I left in FreeBSD patches that keep fbm from using standard graphics
libraries. If, like me, you only use fbm to import an odd file or two,
then uninstall, then you might appreciate not needing to install
various graphics libraries.
There seems to be some buggy code for emitting ILBM's. IFF requires
that all chunks be padded to 16-bit boundaries; this also applies to
each scanline of each bitplane in FORM ILBM. It appears that fbcat
(at least) fails to properly handle this padding on at least one
case of reading or writing ILBM files. (This isn't a problem if
the ILBM width is a multiple of 16.)

View file

@ -1,3 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.2 2000/08/03 19:20:45 rh Exp $
bin/clr2gray
bin/fbcat
bin/fbclean
@ -34,3 +35,32 @@ bin/tga2fbm
bin/udiff
bin/unmap
bin/uunet2fbm
man/manl/clr2gray.l
man/manl/fbcat.l
man/manl/fbclean.l
man/manl/fbedge.l
man/manl/fbext.l
man/manl/fbhalf.l
man/manl/fbhist.l
man/manl/fbinfo.l
man/manl/fbm2pod.l
man/manl/fbmask.l
man/manl/fbnorm.l
man/manl/fbps.l
man/manl/fbquant.l
man/manl/fbrot.l
man/manl/fbsample.l
man/manl/fbsharp.l
man/manl/gray2clr.l
man/manl/idiff.l
man/manl/pbm2ps.l
man/manl/pbmtitle.l
man/manl/raw2fbm.l
man/manl/qrt2fbm.l
man/manl/fbm.l
man/manl/fbham.l
man/manl/uunet2fbm.l
man/manl/tiff2fbm.l
man/manl/fbmedian.l
man/manl/fbconv.l
man/manl/fbthin.l