fix some glitches with UPnP interaction, bump PKGREVISION
This commit is contained in:
parent
fd08847000
commit
068ac72538
4 changed files with 30 additions and 2 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.67 2009/07/31 08:50:27 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.68 2009/08/02 12:10:39 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= rhythmbox-0.12.3
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= audio gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/rhythmbox/0.12/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,7 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.29 2009/07/31 08:50:27 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.30 2009/08/02 12:10:39 drochner Exp $
|
||||
|
||||
SHA1 (rhythmbox-0.12.3.tar.bz2) = f1def95f92993ade14f7b0ec2323e9d2e4aaad03
|
||||
RMD160 (rhythmbox-0.12.3.tar.bz2) = 8fc030b320065578b4a0851ecd87c5753b6dce93
|
||||
Size (rhythmbox-0.12.3.tar.bz2) = 4999529 bytes
|
||||
SHA1 (patch-aa) = a31b22483c63ee73bf32ca583afcc82c29e9562a
|
||||
SHA1 (patch-ab) = ad082691fc80177a6d6f843278f04a0f5399c205
|
||||
SHA1 (patch-ac) = c5639f5ecef6c1b42a4071fc77338591f12683cc
|
||||
SHA1 (patch-ad) = a7c4ce6c5ce65b7262a9a7de2c2f8414cf27f100
|
||||
|
|
12
audio/rhythmbox/patches/patch-ac
Normal file
12
audio/rhythmbox/patches/patch-ac
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ac,v 1.7 2009/08/02 12:10:39 drochner Exp $
|
||||
|
||||
--- plugins/coherence/upnp_coherence/MediaStore.py.orig 2009-07-31 15:20:44.000000000 +0200
|
||||
+++ plugins/coherence/upnp_coherence/MediaStore.py
|
||||
@@ -295,6 +295,7 @@ class MediaStore(BackendStore):
|
||||
|
||||
def __init__(self, server, **kwargs):
|
||||
self.warning("__init__ MediaStore %r", kwargs)
|
||||
+ BackendStore.__init__(self,server,**kwargs)
|
||||
self.server = server
|
||||
self.db = kwargs['db']
|
||||
self.plugin = kwargs['plugin']
|
13
audio/rhythmbox/patches/patch-ad
Normal file
13
audio/rhythmbox/patches/patch-ad
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.8 2009/08/02 12:10:39 drochner Exp $
|
||||
|
||||
--- plugins/coherence/upnp_coherence/MediaPlayer.py.orig 2009-07-31 15:50:21.000000000 +0200
|
||||
+++ plugins/coherence/upnp_coherence/MediaPlayer.py
|
||||
@@ -260,7 +260,7 @@ class RhythmboxPlayer(log.Loggable):
|
||||
|
||||
if duration is not None:
|
||||
h,m,s = duration.split(':')
|
||||
- seconds = int(h)*3600 + int(m)*60 + int(s)
|
||||
+ seconds = int(h)*3600 + int(m)*60 + int(round(float(s)))
|
||||
self.info("%r %r:%r:%r %r", duration, h, m , s, seconds)
|
||||
self.shell.props.db.set(self.entry, rhythmdb.PROP_DURATION, seconds)
|
||||
|
Loading…
Reference in a new issue