Update to 1.4.8, provided by Mayuresh on pkgsrc-users.

* Changes since 1.4.7
This is mostly a bugfix release.

** fix cmd_sfdump with multiple screens
Broken since last release, from Joshua Leners.

** respect --enable-history=no
From Jeroen Roovers (jer@gentoo).

** fix for sloppy.c
The ugly sloppy.c had "a bug".  It may be fixed now.

** README improvements
From Jeff Abrahamson.

* Changes since 1.4.6
** More fixes and code cleanup.

** UTF-8 editing support in the input bar

** get rid of "XGetWMName failed" spam on stderr
Introduced in the previous release, sorry!

** groups can now be renumbered (`gnumber')

** contrib/rpdate.sh, fancy calendar shell script to use instead of `time'

** fix `meta', which was sending garbage and made firefox unusable

** handle errors about missing config files
- ratpoison -f missing-config-file -> error
- unreadable ~/.ratpoisonrc file -> warning

** respect --sysconfdir for the global ratpoisonrc file
Rather than a hardcoded /etc/ratpoisonrc location.

** rpws gains a new `current' command (prints the current workspace)

** new manpage, mdoc(7) formatted

** X socket closed before spawning processes
Let's save those precious file descriptors.

** DWIM windows/groups names matching
Window and group names are first looked up for exact match; in last
resort a fuzzy match is attempted.

** try to cope with unset/empty HOME env. variable

** ratpoison.el is now installed at the proper location
ie. in $prefix/share/emacs/site-lisp/

** ratpoison now restricts permissions on your history file

* Changes since 1.4.5
** *Lots* of reliability fixes in ratpoison itself
Please check out the ChangeLog for more details.

** Build process cleanup
e.g. detection of getline() was fixed, build is ok with old gcc's (2.95)

** ratpoison -c now reports errors ($? != 0)

** UTF-8 text is now printed correctly
Both with and without Xft support.

** contrib/ cleanup
Scripts should be more portable, ruby bindings work with newer ruby versions.

** New newwindow and titlechanged hooks

** Functionality was added to rpws
It can now move windows to other workspaces; workspaces can be dumped and
restored.
This commit is contained in:
wiz 2015-07-12 08:40:48 +00:00
parent a3167d27dd
commit 068b8d08f3
5 changed files with 11 additions and 42 deletions

View file

@ -1,14 +1,15 @@
# $NetBSD: Makefile,v 1.40 2015/06/12 10:51:47 wiz Exp $
# $NetBSD: Makefile,v 1.41 2015/07/12 08:40:48 wiz Exp $
#
DISTNAME= ratpoison-1.4.5
PKGREVISION= 8
DISTNAME= ratpoison-1.4.8
CATEGORIES= wm
MASTER_SITES= http://savannah.nongnu.org/download/ratpoison/
EXTRACT_SUFX= .tar.xz
MAINTAINER= tonio@NetBSD.org
HOMEPAGE= http://www.nongnu.org/ratpoison/
COMMENT= Simple window manager with no fat library dependencies
LICENSE= gnu-gpl-v2
GNU_CONFIGURE= YES
INFO_FILES= yes

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2009/06/14 18:19:01 joerg Exp $
@comment $NetBSD: PLIST,v 1.10 2015/07/12 08:40:48 wiz Exp $
bin/ratpoison
bin/rpws
info/ratpoison.info
@ -8,10 +8,11 @@ share/doc/ratpoison/COPYING
share/doc/ratpoison/ChangeLog
share/doc/ratpoison/NEWS
share/doc/ratpoison/README
share/emacs/site-lisp/ratpoison.el
share/ratpoison/allwindows.sh
share/ratpoison/clickframe.pl
share/ratpoison/genrpbindings
share/ratpoison/ratpoison.el
share/ratpoison/ratdate.sh
share/ratpoison/rpshowall.sh
share/ratpoison/rpws
share/ratpoison/sloppy.c

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.15 2009/09/01 18:19:15 tonio Exp $
$NetBSD: distinfo,v 1.16 2015/07/12 08:40:48 wiz Exp $
SHA1 (ratpoison-1.4.5.tar.gz) = e32430de49c4ab5d501653c03dd19dfb623cb08b
RMD160 (ratpoison-1.4.5.tar.gz) = ae2fc0cd7ef561944cf7aea0623875a7148771ce
Size (ratpoison-1.4.5.tar.gz) = 427366 bytes
SHA1 (patch-aa) = d59e993da5ed8408665592df898b07a7c0edba13
SHA1 (patch-ab) = 1e747e6b792fe627ba9699f1c6ce84d3d9842522
SHA1 (ratpoison-1.4.8.tar.xz) = 9adc4f0e89be41982d6b37dbd3ff4ffecae16394
RMD160 (ratpoison-1.4.8.tar.xz) = 5092d9e042167225dd7d5d8acf34590261ba0d23
Size (ratpoison-1.4.8.tar.xz) = 364700 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-aa,v 1.5 2009/09/01 18:19:15 tonio Exp $
Check for getline
--- configure.in.orig 2009-07-12 23:01:04.000000000 +0200
+++ configure.in
@@ -146,7 +146,7 @@ AC_CHECK_HEADERS(unistd.h stdarg.h)
dnl Checks for typedefs, structures, and compiler characteristics.
dnl Checks for library functions.
-AC_CHECK_FUNCS(getopt getopt_long setsid setpgid setpgrp putenv vsnprintf usleep)
+AC_CHECK_FUNCS(getopt getopt_long setsid setpgid setpgrp putenv vsnprintf usleep getline)
AC_TYPE_SIGNAL

View file

@ -1,16 +0,0 @@
$NetBSD: patch-ab,v 1.1 2009/09/01 18:19:15 tonio Exp $
Check for getline
--- src/config.h.in.orig 2009-07-12 14:07:02.000000000 +0200
+++ src/config.h.in
@@ -3,6 +3,9 @@
/* Define this to enable debugging messages */
#undef DEBUG
+/* Define to 1 if you have the `getline' function. */
+#undef HAVE_GETLINE
+
/* Define to 1 if you have the `getopt' function. */
#undef HAVE_GETOPT