Import gmock-1.6.0 (googlemock) as devel/gmock from wip/gmock
Inspired by jMock, EasyMock, and Hamcrest, and designed with C++'s specifics in mind, Google C++ Mocking Framework (or Google Mock for short) is a library for writing and using C++ mock classes. Google Mock: * lets you create mock classes trivially using simple macros, * supports a rich set of matchers and actions, * handles unordered, partially ordered, or completely ordered expectations, * is extensible by users, and * works on Linux, Mac OS X, Windows, Windows Mobile, minGW, and Symbian.
This commit is contained in:
parent
5667049ce8
commit
06a82b03ae
8 changed files with 147 additions and 0 deletions
9
devel/gmock/DESCR
Normal file
9
devel/gmock/DESCR
Normal file
|
@ -0,0 +1,9 @@
|
|||
Inspired by jMock, EasyMock, and Hamcrest, and designed with C++'s
|
||||
specifics in mind, Google C++ Mocking Framework (or Google Mock for
|
||||
short) is a library for writing and using C++ mock classes. Google Mock:
|
||||
|
||||
* lets you create mock classes trivially using simple macros,
|
||||
* supports a rich set of matchers and actions,
|
||||
* handles unordered, partially ordered, or completely ordered expectations,
|
||||
* is extensible by users, and
|
||||
* works on Linux, Mac OS X, Windows, Windows Mobile, minGW, and Symbian.
|
37
devel/gmock/Makefile
Normal file
37
devel/gmock/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/07/29 15:18:29 ryoon Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gmock-1.6.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://googlemock.googlecode.com/files/
|
||||
EXTRACT_SUFX= .zip
|
||||
|
||||
MAINTAINER= ryoon@NetBSD.org
|
||||
HOMEPAGE= http://code.google.com/p/googlemock/
|
||||
COMMENT= C++ Mocking Framework
|
||||
LICENSE= modified-bsd
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
INSTALLATION_DIRS= bin
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
SUBST_CLASSES+= fix-python
|
||||
SUBST_STAGE.fix-python= pre-configure
|
||||
SUBST_MESSAGE.fix-python= Fixing dynamic python
|
||||
SUBST_FILES.fix-python+= gtest/scripts/*py
|
||||
SUBST_SED.fix-python+= -e 's,/usr/bin/env python,${PYTHONBIN},'
|
||||
|
||||
CONFIGURE_ARGS+= --enable-external-gtest
|
||||
|
||||
pre-configure:
|
||||
${RM} -r ${WRKSRC}/gtest
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/scripts/gmock-config ${DESTDIR}${PREFIX}/bin
|
||||
|
||||
.include "../../devel/googletest/buildlink3.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
17
devel/gmock/PLIST
Normal file
17
devel/gmock/PLIST
Normal file
|
@ -0,0 +1,17 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/07/29 15:18:29 ryoon Exp $
|
||||
bin/gmock-config
|
||||
include/gmock/gmock-actions.h
|
||||
include/gmock/gmock-cardinalities.h
|
||||
include/gmock/gmock-generated-actions.h
|
||||
include/gmock/gmock-generated-function-mockers.h
|
||||
include/gmock/gmock-generated-matchers.h
|
||||
include/gmock/gmock-generated-nice-strict.h
|
||||
include/gmock/gmock-matchers.h
|
||||
include/gmock/gmock-more-actions.h
|
||||
include/gmock/gmock-spec-builders.h
|
||||
include/gmock/gmock.h
|
||||
include/gmock/internal/gmock-generated-internal-utils.h
|
||||
include/gmock/internal/gmock-internal-utils.h
|
||||
include/gmock/internal/gmock-port.h
|
||||
lib/libgmock.la
|
||||
lib/libgmock_main.la
|
14
devel/gmock/buildlink3.mk
Normal file
14
devel/gmock/buildlink3.mk
Normal file
|
@ -0,0 +1,14 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2011/07/29 15:18:29 ryoon Exp $
|
||||
|
||||
BUILDLINK_TREE+= gmock
|
||||
|
||||
.if !defined(GMOCK_BUILDLINK3_MK)
|
||||
GMOCK_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.gmock+= gmock>=1.6.0
|
||||
BUILDLINK_PKGSRCDIR.gmock?= ../../devel/gmock
|
||||
|
||||
.include "../../devel/googletest/buildlink3.mk"
|
||||
.endif # GMOCK_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -gmock
|
8
devel/gmock/distinfo
Normal file
8
devel/gmock/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/07/29 15:18:29 ryoon Exp $
|
||||
|
||||
SHA1 (gmock-1.6.0.zip) = 4702e98af194d320a915f1e6d2532a32b280819e
|
||||
RMD160 (gmock-1.6.0.zip) = e08ea01a82e119591eef9bab69629d0af247784f
|
||||
Size (gmock-1.6.0.zip) = 2053682 bytes
|
||||
SHA1 (patch-Makefile.in) = e82f7d84f6e2662bd1e64af833fff5261c473fc3
|
||||
SHA1 (patch-configure) = b3721fc233d1e21e5b023f5bbad85e49333c6e3d
|
||||
SHA1 (patch-gtest_configure) = 74873f4bc13306bc39c1c6ad87b1c1bb66eb950d
|
23
devel/gmock/patches/patch-Makefile.in
Normal file
23
devel/gmock/patches/patch-Makefile.in
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-Makefile.in,v 1.1.1.1 2011/07/29 15:18:29 ryoon Exp $
|
||||
|
||||
* Enable 'make install'
|
||||
|
||||
--- Makefile.in.orig 2011-04-15 19:55:44.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -1202,14 +1202,14 @@ info: info-recursive
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am: install-data-local install-pkgincludeHEADERS \
|
||||
+install-data-am: install-pkgincludeHEADERS \
|
||||
install-pkginclude_internalHEADERS
|
||||
|
||||
install-dvi: install-dvi-recursive
|
||||
|
||||
install-dvi-am:
|
||||
|
||||
-install-exec-am: install-exec-local install-libLTLIBRARIES
|
||||
+install-exec-am: install-libLTLIBRARIES
|
||||
|
||||
install-html: install-html-recursive
|
||||
|
24
devel/gmock/patches/patch-configure
Normal file
24
devel/gmock/patches/patch-configure
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-configure,v 1.1.1.1 2011/07/29 15:18:29 ryoon Exp $
|
||||
|
||||
* Improve compatibility.
|
||||
|
||||
--- configure.orig 2011-04-15 19:55:43.000000000 +0000
|
||||
+++ configure
|
||||
@@ -14896,7 +14896,7 @@ ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
|
||||
|
||||
have_pthreads="$acx_pthread_ok"
|
||||
fi
|
||||
- if test "x$have_pthreads" == "xyes"; then
|
||||
+ if test "x$have_pthreads" = "xyes"; then
|
||||
HAVE_PTHREADS_TRUE=
|
||||
HAVE_PTHREADS_FALSE='#'
|
||||
else
|
||||
@@ -14926,7 +14926,7 @@ else
|
||||
enable_external_gtest=yes
|
||||
fi
|
||||
|
||||
-if test "x$with_gtest" == "xno"; then :
|
||||
+if test "x$with_gtest" = "xno"; then :
|
||||
as_fn_error "Support for GoogleTest was explicitly disabled. Currently GoogleMock has a hard
|
||||
dependency upon GoogleTest to build, please provide a version, or allow
|
||||
GoogleMock to use any installed version and fall back upon its internal
|
15
devel/gmock/patches/patch-gtest_configure
Normal file
15
devel/gmock/patches/patch-gtest_configure
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-gtest_configure,v 1.1.1.1 2011/07/29 15:18:29 ryoon Exp $
|
||||
|
||||
* Improve compatibility.
|
||||
|
||||
--- gtest/configure.orig 2011-04-15 19:55:40.000000000 +0000
|
||||
+++ gtest/configure
|
||||
@@ -14861,7 +14861,7 @@ ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
|
||||
|
||||
have_pthreads="$acx_pthread_ok"
|
||||
fi
|
||||
- if test "x$have_pthreads" == "xyes"; then
|
||||
+ if test "x$have_pthreads" = "xyes"; then
|
||||
HAVE_PTHREADS_TRUE=
|
||||
HAVE_PTHREADS_FALSE='#'
|
||||
else
|
Loading…
Reference in a new issue