Do not link against -lcompat, it breaks DSO support. Bump revision.
This commit is contained in:
parent
bb4f29762e
commit
06f7a81831
3 changed files with 111 additions and 2 deletions
|
@ -1,8 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.28 2009/10/20 15:48:02 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.29 2009/11/09 12:56:00 joerg Exp $
|
||||
#
|
||||
|
||||
.include "Makefile.common"
|
||||
|
||||
PKGREVISION= 1
|
||||
PKGCONFIG_OVERRIDE= theora.pc.in theoradec.pc.in theoraenc.pc.in
|
||||
USE_LIBTOOL= YES
|
||||
TEST_TARGET= check
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.14 2009/10/20 15:48:02 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.15 2009/11/09 12:56:00 joerg Exp $
|
||||
|
||||
SHA1 (libtheora-1.1.1.tar.bz2) = 8dcaa8e61cd86eb1244467c0b64b9ddac04ae262
|
||||
RMD160 (libtheora-1.1.1.tar.bz2) = 1d07234bd7e2296c61d6e30fe9816415aa7fd8e5
|
||||
Size (libtheora-1.1.1.tar.bz2) = 1903175 bytes
|
||||
SHA1 (patch-aa) = 3e23582e299e476636a54aa19fb390d6e1052a99
|
||||
|
|
107
multimedia/libtheora/patches/patch-aa
Normal file
107
multimedia/libtheora/patches/patch-aa
Normal file
|
@ -0,0 +1,107 @@
|
|||
$NetBSD: patch-aa,v 1.6 2009/11/09 12:56:00 joerg Exp $
|
||||
|
||||
Never add -lcompat for ftime. If someone cares about the example,
|
||||
it should use gettimeofday.
|
||||
|
||||
--- configure.orig 2009-11-09 13:52:17.000000000 +0100
|
||||
+++ configure
|
||||
@@ -13734,99 +13734,6 @@ else
|
||||
fi
|
||||
|
||||
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-{ $as_echo "$as_me:$LINENO: checking for library containing ftime" >&5
|
||||
-$as_echo_n "checking for library containing ftime... " >&6; }
|
||||
-if test "${ac_cv_search_ftime+set}" = set; then
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- ac_func_search_save_LIBS=$LIBS
|
||||
-cat >conftest.$ac_ext <<_ACEOF
|
||||
-/* confdefs.h. */
|
||||
-_ACEOF
|
||||
-cat confdefs.h >>conftest.$ac_ext
|
||||
-cat >>conftest.$ac_ext <<_ACEOF
|
||||
-/* end confdefs.h. */
|
||||
-
|
||||
-/* Override any GCC internal prototype to avoid an error.
|
||||
- Use char because int might match the return type of a GCC
|
||||
- builtin and then its argument prototype would still apply. */
|
||||
-#ifdef __cplusplus
|
||||
-extern "C"
|
||||
-#endif
|
||||
-char ftime ();
|
||||
-int
|
||||
-main ()
|
||||
-{
|
||||
-return ftime ();
|
||||
- ;
|
||||
- return 0;
|
||||
-}
|
||||
-_ACEOF
|
||||
-for ac_lib in '' compat; do
|
||||
- if test -z "$ac_lib"; then
|
||||
- ac_res="none required"
|
||||
- else
|
||||
- ac_res=-l$ac_lib
|
||||
- LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
||||
- fi
|
||||
- rm -f conftest.$ac_objext conftest$ac_exeext
|
||||
-if { (ac_try="$ac_link"
|
||||
-case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
||||
-$as_echo "$ac_try_echo") >&5
|
||||
- (eval "$ac_link") 2>conftest.er1
|
||||
- ac_status=$?
|
||||
- grep -v '^ *+' conftest.er1 >conftest.err
|
||||
- rm -f conftest.er1
|
||||
- cat conftest.err >&5
|
||||
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } && {
|
||||
- test -z "$ac_c_werror_flag" ||
|
||||
- test ! -s conftest.err
|
||||
- } && test -s conftest$ac_exeext && {
|
||||
- test "$cross_compiling" = yes ||
|
||||
- $as_test_x conftest$ac_exeext
|
||||
- }; then
|
||||
- ac_cv_search_ftime=$ac_res
|
||||
-else
|
||||
- $as_echo "$as_me: failed program was:" >&5
|
||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||
-
|
||||
-
|
||||
-fi
|
||||
-
|
||||
-rm -rf conftest.dSYM
|
||||
-rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
|
||||
- conftest$ac_exeext
|
||||
- if test "${ac_cv_search_ftime+set}" = set; then
|
||||
- break
|
||||
-fi
|
||||
-done
|
||||
-if test "${ac_cv_search_ftime+set}" = set; then
|
||||
- :
|
||||
-else
|
||||
- ac_cv_search_ftime=no
|
||||
-fi
|
||||
-rm conftest.$ac_ext
|
||||
-LIBS=$ac_func_search_save_LIBS
|
||||
-fi
|
||||
-{ $as_echo "$as_me:$LINENO: result: $ac_cv_search_ftime" >&5
|
||||
-$as_echo "$ac_cv_search_ftime" >&6; }
|
||||
-ac_res=$ac_cv_search_ftime
|
||||
-if test "$ac_res" != no; then
|
||||
- test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
|
||||
-
|
||||
-fi
|
||||
-
|
||||
-
|
||||
{ $as_echo "$as_me:$LINENO: checking for getopt_long" >&5
|
||||
$as_echo_n "checking for getopt_long... " >&6; }
|
||||
if test "${ac_cv_func_getopt_long+set}" = set; then
|
Loading…
Reference in a new issue