Fix the use of 'inline' to avoid undefined symbols in the shared library

which is installed.  Bump PKGREVISION.
This commit is contained in:
dmcmahill 2010-01-29 03:44:53 +00:00
parent 0c4ad1fd13
commit 06f948b33d
4 changed files with 72 additions and 5 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.4 2008/03/30 05:01:31 jlam Exp $
# $NetBSD: Makefile,v 1.5 2010/01/29 03:44:53 dmcmahill Exp $
#
DISTNAME= libmemcache-1.4.0.b9
PKGNAME= ${DISTNAME:S/.b/beta/}
PKGREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://people.freebsd.org/~seanc/libmemcache/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.2 2008/07/27 13:39:24 joerg Exp $
$NetBSD: distinfo,v 1.3 2010/01/29 03:44:53 dmcmahill Exp $
SHA1 (libmemcache-1.4.0.b9.tar.bz2) = 09f8e059a7833a207b7dfbf6e30a42309801fdc9
RMD160 (libmemcache-1.4.0.b9.tar.bz2) = 8c97e89df37956584f743639440dd980fd277b92
Size (libmemcache-1.4.0.b9.tar.bz2) = 284358 bytes
SHA1 (patch-aa) = 379b0117e70316b02f61190d10e64fe04a765619
SHA1 (patch-ab) = 0864a80c3ee18bf48fc142973db97366cc0f8848
SHA1 (patch-ab) = fa91a0f9b9e6ed9c1d7abd4c7eb69f63045f5869
SHA1 (patch-ac) = f7dfb29b2e7f9c56d5d5bcb3c8dd63bb6f26825f

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ab,v 1.1.1.1 2005/10/11 15:31:20 joerg Exp $
$NetBSD: patch-ab,v 1.2 2010/01/29 03:44:53 dmcmahill Exp $
--- src/buffer.c.orig 2005-10-11 00:41:57.000000000 +0200
--- src/buffer.c.orig 2005-09-25 17:39:45.000000000 +0000
+++ src/buffer.c
@@ -35,7 +35,7 @@
#include <sys/types.h>
@ -11,3 +11,35 @@ $NetBSD: patch-ab,v 1.1.1.1 2005/10/11 15:31:20 joerg Exp $
#include "memcache/buffer.h"
@@ -259,12 +259,6 @@ mcm_buf_free(struct memcache_ctxt *ctxt,
}
-inline u_int32_t
-mcm_buf_len(const struct memcache_ctxt *ctxt, const struct memcache_buf *s) {
- return s->len;
-}
-
-
struct memcache_buf *
mcm_buf_new(struct memcache_ctxt *ctxt) {
struct memcache_buf *buf;
@@ -422,18 +416,6 @@ mcm_buf_realloc(struct memcache_ctxt *ct
}
-inline size_t
-mcm_buf_remain(const struct memcache_ctxt *ctxt, const struct memcache_buf *buf) {
- return mcm_buf_size(ctxt, buf) - mcm_buf_len(ctxt, buf);
-}
-
-
-inline size_t
-mcm_buf_remain_off(const struct memcache_ctxt *ctxt, const struct memcache_buf *buf) {
- return mcm_buf_len(ctxt, buf) - buf->off;
-}
-
-
int
mcm_buf_replace(struct memcache_ctxt *ctxt, struct memcache_buf *buf, const char *cp, const u_int32_t len) {
if (mcm_buf_reset(ctxt, buf) == 0)

View file

@ -0,0 +1,33 @@
$NetBSD: patch-ac,v 1.1 2010/01/29 03:44:53 dmcmahill Exp $
--- include/memcache/buffer.h.orig 2005-09-25 17:36:12.000000000 +0000
+++ include/memcache/buffer.h
@@ -63,14 +63,25 @@ struct memcache_buf *mcm_buf_find_replac
struct memcache_buf *mcm_buf_find_replace2(struct memcache_ctxt *, struct memcache_buf *,
const char *, struct memcache_buf *);
int mcm_buf_free(struct memcache_ctxt *, struct memcache_buf **);
-inline u_int32_t mcm_buf_len(const struct memcache_ctxt *, const struct memcache_buf *);
+inline u_int32_t
+mcm_buf_len(const struct memcache_ctxt *ctxt, const struct memcache_buf *s) {
+ return s->len;
+}
struct memcache_buf *mcm_buf_new(struct memcache_ctxt *);
struct memcache_buf *mcm_buf_new2(struct memcache_ctxt *, const char *, const u_int32_t);
struct memcache_buf *mcm_buf_new3(struct memcache_ctxt *, const char *);
size_t mcm_buf_read(struct memcache_ctxt *, struct memcache_buf *, int);
int mcm_buf_realloc(struct memcache_ctxt *, struct memcache_buf *, const u_int32_t);
-inline size_t mcm_buf_remain(const struct memcache_ctxt *, const struct memcache_buf *);
-inline size_t mcm_buf_remain_off(const struct memcache_ctxt *, const struct memcache_buf *);
+inline size_t
+mcm_buf_remain(const struct memcache_ctxt *ctxt, const struct memcache_buf *buf) {
+ return mcm_buf_size(ctxt, buf) - mcm_buf_len(ctxt, buf);
+}
+
+
+inline size_t
+mcm_buf_remain_off(const struct memcache_ctxt *ctxt, const struct memcache_buf *buf) {
+ return mcm_buf_len(ctxt, buf) - buf->off;
+}
int mcm_buf_replace(struct memcache_ctxt *, struct memcache_buf *, const char *, const u_int32_t);
int mcm_buf_replace2(struct memcache_ctxt *, struct memcache_buf *, const char *);
int mcm_buf_replace_buf(struct memcache_ctxt *, struct memcache_buf *, struct memcache_buf *);