Fix build with gcc 4.6
This commit is contained in:
parent
b9d89e8243
commit
07102bf573
2 changed files with 15 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.18 2012/03/07 16:17:05 adam Exp $
|
||||
$NetBSD: distinfo,v 1.19 2012/05/04 13:27:23 hans Exp $
|
||||
|
||||
SHA1 (gdal-1.9.0.tar.gz) = e2eaaf0fba39137b40c0d3069ac41dfb6f3c76db
|
||||
RMD160 (gdal-1.9.0.tar.gz) = 76957dd3f9dfd3b86281250f3be691f38ec4d762
|
||||
Size (gdal-1.9.0.tar.gz) = 9435584 bytes
|
||||
SHA1 (patch-configure) = 2da57c3b45b82b49d3c08217557c304f794e81ce
|
||||
SHA1 (patch-frmts_netcdf_netcdfdataset.cpp) = e7d67936e13177284aa07ac12e534477a1cc26d9
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-frmts_netcdf_netcdfdataset.cpp,v 1.1 2012/05/04 13:27:23 hans Exp $
|
||||
|
||||
--- frmts/netcdf/netcdfdataset.cpp.orig 2012-01-04 08:03:37.000000000 +0100
|
||||
+++ frmts/netcdf/netcdfdataset.cpp 2012-05-04 15:08:15.080833521 +0200
|
||||
@@ -962,7 +962,7 @@ void netCDFRasterBand::CheckValidData (
|
||||
/* check for nodata and nan */
|
||||
if ( CPLIsEqual( (double) ((T *)pImage)[i], dfNoDataValue ) )
|
||||
continue;
|
||||
- if( bCheckIsNan && CPLIsNan( ( (T *) pImage)[i] ) ) {
|
||||
+ if( bCheckIsNan && CPLIsNan( (double) ( (T *) pImage)[i] ) ) {
|
||||
( (T *)pImage )[i] = (T)dfNoDataValue;
|
||||
continue;
|
||||
}
|
Loading…
Reference in a new issue