update to 5.2.1

** Bug fixes

  mv could mistakenly fail to preserve hard links when moving two
  or more arguments between partitions.

  `cp --sparse=always F /dev/hdx' no longer tries to use lseek to create
  holes in the destination.

  nohup now sets the close-on-exec flag for its copy of the stderr file
  descriptor.  This avoids some nohup-induced hangs.  For example, before
  this change, if you ran `ssh localhost', then `nohup sleep 600 </dev/null &',
  and then exited that remote shell, the ssh session would hang until the
  10-minute sleep terminated.  With the fixed nohup, the ssh session
  terminates immediately.

  `expr' now conforms to POSIX better:

    Integers like -0 and 00 are now treated as zero.

    The `|' operator now returns 0, not its first argument, if both
    arguments are null or zero.  E.g., `expr "" \| ""' now returns 0,
    not the empty string.

    The `|' and `&' operators now use short-circuit evaluation, e.g.,
    `expr 1 \| 1 / 0' no longer reports a division by zero.

** New features

  `chown user.group file' now has its traditional meaning even when
  conforming to POSIX 1003.1-2001, so long as no user has a name
  containing `.' that happens to equal `user.group'.
This commit is contained in:
recht 2004-03-29 09:22:50 +00:00
parent 2685a488bc
commit 071dd1da05
3 changed files with 10 additions and 10 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.18 2004/03/07 11:31:34 recht Exp $
# $NetBSD: Makefile,v 1.19 2004/03/29 09:22:50 recht Exp $
DISTNAME= coreutils-5.2.0
DISTNAME= coreutils-5.2.1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_GNU:=coreutils/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.5 2004/02/22 21:32:18 recht Exp $
$NetBSD: distinfo,v 1.6 2004/03/29 09:22:50 recht Exp $
SHA1 (coreutils-5.2.0.tar.bz2) = cbfe111d30161520127f96980d069e0665c203b6
Size (coreutils-5.2.0.tar.bz2) = 4242493 bytes
SHA1 (patch-aa) = b5ee97f5ab19b4d7354c896036e9823feacc099a
SHA1 (coreutils-5.2.1.tar.bz2) = 1028755ae0fa9be840576e4837004cf5a9981c45
Size (coreutils-5.2.1.tar.bz2) = 4270776 bytes
SHA1 (patch-aa) = 36c3a4a810bdc9efd7b0c3a6dc4203e0cfcbfae5

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.2 2004/02/22 21:32:18 recht Exp $
$NetBSD: patch-aa,v 1.3 2004/03/29 09:22:51 recht Exp $
--- lib/Makefile.in.orig 2004-02-08 21:12:49.000000000 +0100
+++ lib/Makefile.in 2004-02-21 10:58:58.000000000 +0100
@@ -903,7 +903,7 @@
--- lib/Makefile.in.orig 2004-03-11 09:57:59.000000000 +0100
+++ lib/Makefile.in 2004-03-13 14:29:07.000000000 +0100
@@ -905,7 +905,7 @@
install-data-am: