defined(%hash) is not valid any more in perl 5.22; change to %hash

This commit is contained in:
bouyer 2015-09-26 14:30:24 +00:00
parent 5ec89f7a30
commit 072e49ae3e
4 changed files with 35 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.38 2015/06/12 10:50:20 wiz Exp $ # $NetBSD: Makefile,v 1.39 2015/09/26 14:30:24 bouyer Exp $
DISTNAME= MHonArc-2.6.19 DISTNAME= MHonArc-2.6.19
PKGNAME= mhonarc-2.6.19 PKGNAME= mhonarc-2.6.19
PKGREVISION= 2 PKGREVISION= 3
CATEGORIES= mail CATEGORIES= mail
MASTER_SITES= http://www.mhonarc.org/release/MHonArc/tar/ MASTER_SITES= http://www.mhonarc.org/release/MHonArc/tar/
EXTRACT_SUFX= .tar.bz2 EXTRACT_SUFX= .tar.bz2

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.19 2014/04/22 22:32:18 schnoebe Exp $ $NetBSD: distinfo,v 1.20 2015/09/26 14:30:24 bouyer Exp $
SHA1 (MHonArc-2.6.19.tar.bz2) = e8297b3da1ba3369a0292b2815cc356cbb7ff6bd SHA1 (MHonArc-2.6.19.tar.bz2) = e8297b3da1ba3369a0292b2815cc356cbb7ff6bd
RMD160 (MHonArc-2.6.19.tar.bz2) = 13614f38275795221131d7ba459c3a18d607c5cb RMD160 (MHonArc-2.6.19.tar.bz2) = 13614f38275795221131d7ba459c3a18d607c5cb
Size (MHonArc-2.6.19.tar.bz2) = 1577790 bytes Size (MHonArc-2.6.19.tar.bz2) = 1577790 bytes
SHA1 (patch-lib_mhamain.pl) = 56c0d55c11fb005f911b8430e5c683c834c861aa
SHA1 (patch-lib_mhopt.pl) = a077249040fc4f9b80380abd59c0472895983465
SHA1 (patch-lib_mhtxthtml.pl) = bfd6420fd9e0ffdbf1f781441f8c1b8b71ef94e7 SHA1 (patch-lib_mhtxthtml.pl) = bfd6420fd9e0ffdbf1f781441f8c1b8b71ef94e7

View file

@ -0,0 +1,15 @@
$NetBSD: patch-lib_mhamain.pl,v 1.3 2015/09/26 14:30:24 bouyer Exp $
perl 5.22 compatipility
--- lib/mhamain.pl.orig 2015-09-26 12:30:58.000000000 +0200
+++ lib/mhamain.pl 2015-09-26 12:31:37.000000000 +0200
@@ -1562,7 +1562,7 @@
##
sub defineIndex2MsgId {
no warnings qw(deprecated);
- if (!defined(%Index2MsgId)) {
+ if (!%Index2MsgId) {
foreach (keys %MsgId) {
$Index2MsgId{$MsgId{$_}} = $_;
}

View file

@ -0,0 +1,15 @@
$NetBSD: patch-lib_mhopt.pl,v 1.3 2015/09/26 14:30:24 bouyer Exp $
perl 5.22 compatipility
--- lib/mhopt.pl.orig 2015-09-26 12:35:06.000000000 +0200
+++ lib/mhopt.pl 2015-09-26 12:35:18.000000000 +0200
@@ -865,7 +865,7 @@
sub update_data_2_1_to_later {
no warnings qw(deprecated);
# we can preserve filter arguments
- if (defined(%main::MIMEFiltersArgs)) {
+ if (%main::MIMEFiltersArgs) {
warn qq/ preserving MIMEARGS...\n/;
%readmail::MIMEFiltersArgs = %main::MIMEFiltersArgs;
$IsDefault{'MIMEARGS'} = 0;