Update to 3.4.6. This is a bugfix release.
This commit is contained in:
parent
1d6e21738d
commit
07329b1022
9 changed files with 4 additions and 184 deletions
|
@ -1,10 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.21 2006/02/05 23:09:45 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.22 2006/04/05 11:43:12 shannonjr Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gcc-${GCC_VERSION}
|
||||
PKGNAME= gcc34-ada-${GCC_VERSION}
|
||||
#PKGREVISION= 1
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=gcc/gcc-${GCC_VERSION}/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -15,12 +13,14 @@ COMMENT= This is the gcc 3.4 Ada compiler
|
|||
|
||||
BUILD_USES_MSGFMT= YES
|
||||
|
||||
GCC_VERSION= 3.4.4
|
||||
GCC_VERSION= 3.4.6
|
||||
|
||||
USE_TOOLS+= gmake
|
||||
HAS_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= --enable-languages="c,ada"
|
||||
PLIST_SRC= ${WRKDIR}/PLIST_DYNAMIC
|
||||
PATCHDIR= ${.CURDIR}/../../lang/gcc34/patches
|
||||
DISTINFO_FILE= ${.CURDIR}/../../lang/gcc34/distinfo
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.10 2005/05/29 11:12:01 shannonjr Exp $
|
||||
|
||||
SHA1 (gcc-3.4.4.tar.bz2) = dbe5935c04f799c77b49d6806f9d7db6d9b5cd35
|
||||
RMD160 (gcc-3.4.4.tar.bz2) = cb9c4154c9e34d45c80eb80fd7bc30b036e6fec4
|
||||
Size (gcc-3.4.4.tar.bz2) = 27565872 bytes
|
||||
SHA1 (patch-ae) = 928fa6155e614ca85b02359cf893d6c62231b192
|
||||
SHA1 (patch-af) = cdd6b0d13c557996cb6582d7fa5dc651d37ee0ee
|
||||
SHA1 (patch-ag) = beee5294d387faafa640ab048823499da629e715
|
||||
SHA1 (patch-ba) = 6fc03fc155f630329f7dc831eece6b6464b453a6
|
||||
SHA1 (patch-bb) = aa088194fb073fcde8d2f558ed55ec36106d60d0
|
||||
SHA1 (patch-ca) = 771c14ce8cdd9e631694cd19108419f4003a6c08
|
||||
SHA1 (patch-cc) = 0af9845a62f9a6f8ec27657d0ae0c16394e9fc12
|
|
@ -1,63 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.3 2004/10/29 11:07:55 shannonjr Exp $
|
||||
|
||||
--- gcc/ada/Makefile.in.orig 2004-01-26 14:57:32.000000000 -0700
|
||||
+++ gcc/ada/Makefile.in
|
||||
@@ -1292,6 +1292,58 @@ ifeq ($(strip $(filter-out %x86_64 linux
|
||||
LIBRARY_VERSION := $(LIB_VERSION)
|
||||
endif
|
||||
|
||||
+ifeq ($(strip $(filter-out %86 netbsdelf%,$(arch) $(osys))),)
|
||||
+ LIBGNAT_TARGET_PAIRS = \
|
||||
+ a-numaux.adb<86numaux.adb \
|
||||
+ a-numaux.ads<86numaux.ads \
|
||||
+ a-intnam.ads<4netbsdintnam.ads \
|
||||
+ s-inmaop.adb<7sinmaop.adb \
|
||||
+ s-intman.adb<5netbsdintman.adb \
|
||||
+ s-mastop.adb<5omastop.adb \
|
||||
+ s-osinte.adb<5netbsdosinte.adb \
|
||||
+ s-osinte.ads<5netbsdosinte.ads \
|
||||
+ s-osprim.adb<5posprim.adb \
|
||||
+ s-parame.adb<5netbsdparame.adb \
|
||||
+ s-taprop.adb<5netbsdtaprop.adb \
|
||||
+ s-tasinf.ads<5ftasinf.ads \
|
||||
+ s-taspri.ads<7staspri.ads \
|
||||
+ s-tpopse.adb<5netbsdtpopse.adb \
|
||||
+ s-tpopsp.adb<7netbsdtpopsp.adb \
|
||||
+ system.ads<5netbsdsystem.ads
|
||||
+
|
||||
+ THREADSLIB=-pthread
|
||||
+ EXTRA_GNATRTL_TASKING_OBJS=adasignal.o ada_lwp_self.o dummy_pthreads.o
|
||||
+ GNATLIB_SHARED=gnatlib-shared-dual
|
||||
+ LIBRARY_VERSION := $(LIB_VERSION)
|
||||
+
|
||||
+endif
|
||||
+
|
||||
+ifeq ($(strip $(filter-out %x86_64 netbsd%,$(arch) $(osys))),)
|
||||
+ LIBGNAT_TARGET_PAIRS = \
|
||||
+ a-numaux.adb<86numaux.adb \
|
||||
+ a-numaux.ads<86numaux.ads \
|
||||
+ a-intnam.ads<4netbsdintnam.ads \
|
||||
+ s-inmaop.adb<7sinmaop.adb \
|
||||
+ s-intman.adb<5netbsdintman.adb \
|
||||
+ s-osinte.adb<5netbsdosinte.adb \
|
||||
+ s-osinte.ads<5netbsd64osinte.ads \
|
||||
+ s-osprim.adb<5posprim.adb \
|
||||
+ s-parame.adb<5netbsdparame.adb \
|
||||
+ s-taprop.adb<5netbsdtaprop.adb \
|
||||
+ s-tasinf.ads<5ftasinf.ads \
|
||||
+ s-taspri.ads<7staspri.ads \
|
||||
+ s-tpopse.adb<5netbsdtpopse.adb \
|
||||
+ s-tpopsp.adb<7netbsdtpopsp.adb \
|
||||
+ system.ads<5netbsd64system.ads
|
||||
+
|
||||
+ THREADSLIB=-pthread
|
||||
+ EXTRA_GNATRTL_TASKING_OBJS=adasignal.o ada_lwp_self.o dummy_pthreads.o
|
||||
+ GNATLIB_SHARED=gnatlib-shared-dual
|
||||
+ LIBRARY_VERSION := $(LIB_VERSION)
|
||||
+
|
||||
+endif
|
||||
+
|
||||
+
|
||||
# The runtime library for gnat comprises two directories. One contains the
|
||||
# Ada source files that the compiler (gnat1) needs -- these files are listed
|
||||
# by ADA_INCLUDE_SRCS -- and the other contains the object files and their
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 2004/06/29 18:00:17 shannonjr Exp $
|
||||
|
||||
--- gcc/ada/cstreams.c.orig 2003-11-18 03:00:42.000000000 -0700
|
||||
+++ gcc/ada/cstreams.c
|
||||
@@ -175,7 +175,7 @@ __gnat_full_name (char *nam, char *buffe
|
||||
#elif defined (MSDOS)
|
||||
_fixpath (nam, buffer);
|
||||
|
||||
-#elif defined (sgi) || defined (__FreeBSD__)
|
||||
+#elif defined (sgi) || defined (__FreeBSD__) || defined(__NetBSD__)
|
||||
|
||||
/* Use realpath function which resolves links and references to . and ..
|
||||
on those Unix systems that support it. Note that GNU/Linux provides it but
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.1.1.1 2004/06/29 18:00:17 shannonjr Exp $
|
||||
|
||||
--- gcc/ada/adaint.c.orig 2003-12-03 04:47:52.000000000 -0700
|
||||
+++ gcc/ada/adaint.c
|
||||
@@ -671,6 +671,8 @@ __gnat_open_new_temp (char *path, int fm
|
||||
return mkstemp (path);
|
||||
#elif defined (__Lynx__)
|
||||
mktemp (path);
|
||||
+#elif defined(__NetBSD__)
|
||||
+ return mkstemp (path);
|
||||
#else
|
||||
if (mktemp (path) == NULL)
|
||||
return -1;
|
||||
@@ -742,7 +744,7 @@ __gnat_tmp_name (char *tmp_filename)
|
||||
free (pname);
|
||||
}
|
||||
|
||||
-#elif defined (linux) || defined (__FreeBSD__)
|
||||
+#elif defined (linux) || defined (__FreeBSD__) || defined(__NetBSD__)
|
||||
#define MAX_SAFE_PATH 1000
|
||||
char *tmpdir = getenv ("TMPDIR");
|
||||
|
|
@ -1,32 +0,0 @@
|
|||
$NetBSD: patch-ba,v 1.1.1.1 2004/06/29 18:00:17 shannonjr Exp $
|
||||
|
||||
--- gcc/ada/5posprim.adb.orig 2003-10-21 15:41:52.000000000 +0200
|
||||
+++ gcc/ada/5posprim.adb 2004-04-26 17:00:57.000000000 +0200
|
||||
@@ -42,8 +42,8 @@
|
||||
-- the spec.
|
||||
|
||||
type struct_timeval is record
|
||||
- tv_sec : Integer;
|
||||
- tv_usec : Integer;
|
||||
+ tv_sec : Long_Integer;
|
||||
+ tv_usec : Long_Integer;
|
||||
end record;
|
||||
pragma Convention (C, struct_timeval);
|
||||
|
||||
@@ -102,14 +102,14 @@
|
||||
|
||||
if Rel_Time > 0.0 then
|
||||
loop
|
||||
- timeval.tv_sec := Integer (Rel_Time);
|
||||
+ timeval.tv_sec := Long_Integer (Rel_Time);
|
||||
|
||||
if Duration (timeval.tv_sec) > Rel_Time then
|
||||
timeval.tv_sec := timeval.tv_sec - 1;
|
||||
end if;
|
||||
|
||||
timeval.tv_usec :=
|
||||
- Integer ((Rel_Time - Duration (timeval.tv_sec)) * 10#1#E6);
|
||||
+ Long_Integer ((Rel_Time - Duration (timeval.tv_sec)) * 10#1#E6);
|
||||
|
||||
C_select (timeout => timeval'Unchecked_Access);
|
||||
Check_Time := Clock;
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-bb,v 1.1.1.1 2004/06/29 18:00:17 shannonjr Exp $
|
||||
|
||||
--- gcc/ada/init.c.orig 2004-04-26 21:32:09.000000000 +0200
|
||||
+++ gcc/ada/init.c 2004-04-26 21:33:31.000000000 +0200
|
||||
@@ -1840,7 +1840,7 @@
|
||||
void
|
||||
__gnat_init_float (void)
|
||||
{
|
||||
-#if defined (__i386__) || defined (i386)
|
||||
+#if defined (__i386__) || defined (i386) || defined(__x86_64__)
|
||||
|
||||
/* This is used to properly initialize the FPU on an x86 for each
|
||||
process thread. */
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ca,v 1.1 2004/07/22 21:57:16 shannonjr Exp $
|
||||
|
||||
--- gcc/configure.orig 2004-04-18 17:45:10.000000000 -0600
|
||||
+++ gcc/configure
|
||||
@@ -7693,7 +7693,7 @@ _ACEOF
|
||||
fi
|
||||
LIBICONV=
|
||||
if test "$am_cv_lib_iconv" = yes; then
|
||||
- LIBICONV="$am_cv_lib_iconv_ldpath -liconv"
|
||||
+ LIBICONV="$am_cv_lib_iconv_ldpath -liconv -Wl,-R${LOCALBASE}/lib"
|
||||
fi
|
||||
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-cc,v 1.1 2004/11/08 16:46:27 shannonjr Exp $
|
||||
|
||||
--- gcc/Makefile.in.orig 2004-06-17 15:56:58.000000000 -0600
|
||||
+++ gcc/Makefile.in
|
||||
@@ -1390,6 +1390,7 @@ c-pch.o : c-pch.c $(CONFIG_H) $(SYSTEM_H
|
||||
# Language-independent files.
|
||||
|
||||
DRIVER_DEFINES = \
|
||||
+ -DLINK_LIBGCC_SPEC="\"%D $(LINKER_RPATH_FLAG) $(exec_prefix)/lib\"" \
|
||||
-DSTANDARD_STARTFILE_PREFIX=\"$(unlibsubdir)/\" \
|
||||
-DSTANDARD_EXEC_PREFIX=\"$(libdir)/gcc/\" \
|
||||
-DSTANDARD_LIBEXEC_PREFIX=\"$(libexecdir)/gcc/\" \
|
Loading…
Reference in a new issue