this uses libpcap, so include the buildlink file,
and add some fixes to allow building against pkgsrc libpcap
This commit is contained in:
parent
cdab3d5757
commit
074841cd62
4 changed files with 38 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.5 2005/06/17 03:50:25 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2005/07/13 14:18:22 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= hping2.0.0-rc2
|
||||
|
@ -19,10 +19,14 @@ NOT_FOR_PLATFORM= NetBSD-0.* NetBSD-1.[0-4]*
|
|||
BINMODE= 4755
|
||||
INSTALLATION_DIRS= man/man8 sbin
|
||||
|
||||
CONFIGURE_ENV+= PCAPINCDIR=${BUILDLINK_PREFIX.libpcap}/include
|
||||
CONFIGURE_ENV+= PCAPLIBDIR=${BUILDLINK_PREFIX.libpcap}/lib
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/hping2 ${PREFIX}/sbin
|
||||
${LN} -s ../sbin/hping2 ${PREFIX}/sbin/hping
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/hping2.8 ${PREFIX}/man/man8
|
||||
${LN} -s ../../man/man8/hping2.8 ${PREFIX}/man/man8/hping.8
|
||||
|
||||
.include "../../net/libpcap/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,7 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.4 2005/02/24 12:13:49 agc Exp $
|
||||
$NetBSD: distinfo,v 1.5 2005/07/13 14:18:22 drochner Exp $
|
||||
|
||||
SHA1 (hping2.0.0-rc2.tar.gz) = ee10aa5cce7431ab0887ca0328b0fed86407cd3c
|
||||
RMD160 (hping2.0.0-rc2.tar.gz) = e32479f8d1f7408eaeaa9e507c8050618c81825e
|
||||
Size (hping2.0.0-rc2.tar.gz) = 100501 bytes
|
||||
SHA1 (patch-aa) = f0b60b33df37c5b5f332c4dd5b668c87f2f00780
|
||||
SHA1 (patch-ab) = 7862d487c5fa9940a51c82154e5427f426c93270
|
||||
SHA1 (patch-ac) = b39369c28ca8932f13d9500509b84e28a1db6058
|
||||
SHA1 (patch-ad) = 2bae52bcd2e0faa9aab0475175ab43a9a8a37158
|
||||
|
|
15
net/hping/patches/patch-ac
Normal file
15
net/hping/patches/patch-ac
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ac,v 1.1 2005/07/13 14:18:22 drochner Exp $
|
||||
|
||||
--- configure.orig 2005-07-13 15:30:53.000000000 +0200
|
||||
+++ configure
|
||||
@@ -61,8 +61,8 @@ if [ "$CONFIGOSTYPE" = "LINUX" ]; then
|
||||
PCAP=""
|
||||
PCAP_INCLUDE=""
|
||||
else
|
||||
- PCAP="PCAP=-lpcap"
|
||||
- PCAP_INCLUDE=""
|
||||
+ PCAP="PCAP=-L$PCAPLIBDIR -lpcap"
|
||||
+ PCAP_INCLUDE="-I$PCAPINCDIR"
|
||||
fi
|
||||
|
||||
for ARG in $*; do
|
15
net/hping/patches/patch-ad
Normal file
15
net/hping/patches/patch-ad
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ad,v 1.1 2005/07/13 14:18:22 drochner Exp $
|
||||
|
||||
--- libpcap_stuff.c.orig 2001-08-23 20:49:39.000000000 +0200
|
||||
+++ libpcap_stuff.c
|
||||
@@ -15,8 +15,9 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/ioctl.h>
|
||||
-#include <pcap.h>
|
||||
#include <net/bpf.h>
|
||||
+#define PCAP_DONT_INCLUDE_PCAP_BPF_H
|
||||
+#include <pcap.h>
|
||||
|
||||
#include "globals.h"
|
||||
|
Loading…
Reference in a new issue