Honor PKG_SYSCONFDIR, so that gnome-vfs2 can find files in vfolders (like
the "Start here" folder); Nautilus works better overall. Bump PKGREVISION to 1.
This commit is contained in:
parent
6f6874cc5f
commit
075bea54fe
4 changed files with 50 additions and 16 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/04/27 02:06:56 rh Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2003/04/27 16:05:03 jmmv Exp $
|
||||
#
|
||||
|
||||
DISTNAME= nautilus-2.2.3.1
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= sysutils gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/nautilus/2.2/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -15,14 +16,32 @@ USE_BUILDLINK2= yes
|
|||
USE_X11= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_PKGINSTALL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
PKGCONFIG_OVERRIDE+= ${WRKSRC}/libnautilus/libnautilus.pc.in
|
||||
PKGCONFIG_OVERRIDE= ${WRKSRC}/libnautilus/libnautilus.pc.in
|
||||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
||||
CONFIGURE_ENV+= GCONF_SCHEMA_FILE_DIR="${PREFIX}/share/gconf/schemas/"
|
||||
MAKE_ENV+= GCONF_SCHEMA_FILE_DIR="${PREFIX}/share/gconf/schemas/"
|
||||
|
||||
GCONF2_SCHEMAS+= apps_nautilus_preferences.schemas
|
||||
GCONF2_SCHEMAS= apps_nautilus_preferences.schemas
|
||||
|
||||
OWN_DIRS= ${PKG_SYSCONFDIR}/X11/serverconfig
|
||||
OWN_DIRS+= ${PKG_SYSCONFDIR}/X11/starthere
|
||||
OWN_DIRS+= ${PKG_SYSCONFDIR}/X11/sysconfig
|
||||
EGDIR= ${PREFIX}/share/examples/nautilus
|
||||
CONF_FILES=
|
||||
.for conffile in X11/serverconfig/.directory \
|
||||
X11/starthere/.directory \
|
||||
X11/starthere/applications.desktop \
|
||||
X11/starthere/preferences.desktop \
|
||||
X11/starthere/serverconfig.desktop \
|
||||
X11/starthere/sysconfig.desktop \
|
||||
X11/sysconfig/.directory
|
||||
CONF_FILES+= ${EGDIR}/${conffile} ${PKG_SYSCONFDIR}/${conffile}
|
||||
.endfor
|
||||
.undef conffile
|
||||
|
||||
pre-build:
|
||||
for d in libnautilus libnautilus-adapter libnautilus-private src ; \
|
||||
|
|
|
@ -1,14 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/04/27 02:06:55 rh Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2003/04/27 16:05:03 jmmv Exp $
|
||||
bin/nautilus
|
||||
bin/nautilus-file-management-properties
|
||||
bin/nautilus-server-connect
|
||||
etc/X11/serverconfig/.directory
|
||||
etc/X11/starthere/.directory
|
||||
etc/X11/starthere/applications.desktop
|
||||
etc/X11/starthere/preferences.desktop
|
||||
etc/X11/starthere/serverconfig.desktop
|
||||
etc/X11/starthere/sysconfig.desktop
|
||||
etc/X11/sysconfig/.directory
|
||||
include/libnautilus/libnautilus.h
|
||||
include/libnautilus/nautilus-bonobo-ui.h
|
||||
include/libnautilus/nautilus-clipboard.h
|
||||
|
@ -66,6 +59,13 @@ libexec/nautilus-throbber
|
|||
share/applications/nautilus.desktop
|
||||
share/applications/network-scheme.desktop
|
||||
share/control-center-2.0/capplets/nautilus-file-management-properties.desktop
|
||||
share/examples/nautilus/X11/serverconfig/.directory
|
||||
share/examples/nautilus/X11/starthere/.directory
|
||||
share/examples/nautilus/X11/starthere/applications.desktop
|
||||
share/examples/nautilus/X11/starthere/preferences.desktop
|
||||
share/examples/nautilus/X11/starthere/serverconfig.desktop
|
||||
share/examples/nautilus/X11/starthere/sysconfig.desktop
|
||||
share/examples/nautilus/X11/sysconfig/.directory
|
||||
share/gconf/schemas/apps_nautilus_preferences.schemas
|
||||
share/gnome-2.0/ui/nautilus-clipboard-ui.xml
|
||||
share/gnome-2.0/ui/nautilus-desktop-icon-view-ui.xml
|
||||
|
@ -350,8 +350,9 @@ share/pixmaps/nautilus/zoom_body.png
|
|||
@dirrm share/nautilus/patterns
|
||||
@dirrm share/nautilus/glade
|
||||
@dirrm share/nautilus
|
||||
@dirrm share/examples/nautilus/X11/sysconfig
|
||||
@dirrm share/examples/nautilus/X11/starthere
|
||||
@dirrm share/examples/nautilus/X11/serverconfig
|
||||
@dirrm share/examples/nautilus/X11
|
||||
@dirrm share/examples/nautilus
|
||||
@dirrm include/libnautilus
|
||||
@dirrm etc/X11/sysconfig
|
||||
@dirrm etc/X11/starthere
|
||||
@dirrm etc/X11/serverconfig
|
||||
@dirrm etc/X11
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/04/27 02:06:55 rh Exp $
|
||||
$NetBSD: distinfo,v 1.2 2003/04/27 16:05:03 jmmv Exp $
|
||||
|
||||
SHA1 (nautilus-2.2.3.1.tar.bz2) = 1e2055d4a6b9e35c2bc08a017a77601f7fc5074e
|
||||
Size (nautilus-2.2.3.1.tar.bz2) = 4558276 bytes
|
||||
|
@ -6,3 +6,4 @@ SHA1 (patch-aa) = 334a3c4b4fe5b93c817f04c2de1f130ad7b17592
|
|||
SHA1 (patch-ab) = 38390bb0d8b705f561f8e2d30a323b78a982a777
|
||||
SHA1 (patch-ac) = ee6b0d6df93fa3aa44ab86754322067f586dd0e2
|
||||
SHA1 (patch-ad) = b994f9e62aef5794ef7caf3f4da1335dac681e28
|
||||
SHA1 (patch-ae) = a67d8b7ba3a1b9a71958736ef4946be301e67124
|
||||
|
|
13
sysutils/nautilus/patches/patch-ae
Normal file
13
sysutils/nautilus/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1 2003/04/27 16:05:04 jmmv Exp $
|
||||
|
||||
--- data/Makefile.in.orig 2003-04-01 06:21:33.000000000 +0200
|
||||
+++ data/Makefile.in
|
||||
@@ -25,7 +25,7 @@ bindir = @bindir@
|
||||
sbindir = @sbindir@
|
||||
libexecdir = @libexecdir@
|
||||
datadir = @datadir@
|
||||
-sysconfdir = @sysconfdir@
|
||||
+sysconfdir = @datadir@/examples/@PACKAGE@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
localstatedir = @localstatedir@
|
||||
libdir = @libdir@
|
Loading…
Reference in a new issue