PR# pkg/40230: "libvolume_id" doesn't build under Mac OS X

Fix HAL build on OS X. Tested on 10.5.6 powerpc.
This commit is contained in:
jmcneill 2008-12-20 21:11:05 +00:00
parent a9507d6e4e
commit 075da553c1
7 changed files with 40 additions and 26 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.24 2008/12/20 16:23:26 reinoud Exp $
# $NetBSD: Makefile,v 1.25 2008/12/20 21:11:05 jmcneill Exp $
#
DISTNAME= hal-0.5.11
@ -58,6 +58,10 @@ PLIST_SRC= PLIST
CONFIGURE_ARGS+= --with-backend=linux
.endif
.if ${OPSYS} == "Darwin"
BUILDLINK_TRANSFORM+= rm:-Wl,--as-needed
.endif
REPLACE_INTERPRETER+= bash
REPLACE.bash.old= /bin/bash
REPLACE.bash.new= ${SH}
@ -69,6 +73,7 @@ HAL_USER?= haldaemon
HAL_GROUP?= haldaemon
CONFIGURE_ARGS+= --with-hal-user=${HAL_USER}
CONFIGURE_ARGS+= --with-hal-group=${HAL_GROUP}
CONFIGURE_ARGS+= --disable-pmu
RCD_SCRIPTS= hal
@ -96,4 +101,5 @@ pre-configure:
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../sysutils/dbus-glib/buildlink3.mk"
.include "../../sysutils/hal-info/buildlink3.mk"
.include "../../textproc/expat/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2008/11/23 21:50:51 hasso Exp $
@comment $NetBSD: PLIST,v 1.3 2008/12/20 21:11:05 jmcneill Exp $
bin/hal-device
bin/hal-disable-polling
bin/hal-find-by-capability
@ -40,7 +40,6 @@ libexec/hal-storage-eject
libexec/hal-storage-mount
libexec/hal-storage-unmount
libexec/hal-system-power-pm-is-supported
libexec/hal-system-power-pmu
libexec/hal-system-setserial
libexec/hald-generate-fdi-cache
libexec/hald-runner

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.7 2008/12/01 02:02:33 jmcneill Exp $
$NetBSD: distinfo,v 1.8 2008/12/20 21:11:05 jmcneill Exp $
SHA1 (hal-0.5.11.tar.bz2) = 1ddb7895d2ddc2464b553ad11f7ba38860478ae9
RMD160 (hal-0.5.11.tar.bz2) = 741cfe82f0bc2d67106b24cfe526a754ab36e45f
Size (hal-0.5.11.tar.bz2) = 1281251 bytes
SHA1 (patch-aa) = 1380aca775e5be6b21f755bc36656163394a9c32
SHA1 (patch-ab) = 8712f8bd3ab5d4f7f6d4ea2c30c11f8384615772
SHA1 (patch-ac) = cffdb9caa947366ff88310a750ab502bd2d98db8
SHA1 (patch-aa) = cad685075f8246397e3783fb3e9d094a2bee4d04
SHA1 (patch-ab) = 03723893f9219967a0e3b48c1a03592688389234
SHA1 (patch-ac) = 5836bb68f4742bdccc9c61fbf8cc86020007a0a5
SHA1 (patch-ad) = 2a2732f82a4fd8d7ffa311b4a0e747208dc9ad1c
SHA1 (patch-ae) = ebc98ede0b6e9535825434f2dc6185193d837f36
SHA1 (patch-af) = 161b59ee30d59dbc9e0c79f7f3162bcec5480d99
@ -18,6 +18,6 @@ SHA1 (patch-al) = 8279947ecb720f3e99777dae8c20d4afe0e19039
SHA1 (patch-am) = 6a4940006e583300d9a983511bdcb05268f74b1a
SHA1 (patch-an) = 0307b2f0f6bb5e4a6d7bf837163e74749b7d24b2
SHA1 (patch-ao) = 9099fa4783921a0389b874b8f6d3f7b890810b34
SHA1 (patch-na) = 410e84ef0ffc100f8c2731e8a5ba9b4ff5d4e526
SHA1 (patch-na) = 77b7c505bf3644fe19f26463eb1272b7cb3ceaf6
SHA1 (patch-nb) = 1693b7a2faa5bee20a594f0b60b8ff6caea0efdc
SHA1 (patch-nc) = 32453e49734902749ce24eb4364fc7f531986227

View file

@ -1,13 +1,13 @@
$NetBSD: patch-aa,v 1.3 2008/12/01 02:02:33 jmcneill Exp $
$NetBSD: patch-aa,v 1.4 2008/12/20 21:11:05 jmcneill Exp $
--- tools/hal-storage-mount.c.orig 2008-05-07 19:24:23.000000000 -0400
+++ tools/hal-storage-mount.c 2008-11-30 20:50:05.000000000 -0500
+++ tools/hal-storage-mount.c 2008-12-20 15:34:05.000000000 -0500
@@ -31,7 +31,7 @@
#include <string.h>
#include <glib.h>
#include <glib/gstdio.h>
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__DragonFly__)
+#if defined(__FreeBSD__) || defined(__DragonFly__) || defined(__APPLE__)
#include <fstab.h>
#include <sys/param.h>
#include <sys/ucred.h>

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ab,v 1.2 2008/11/23 21:50:51 hasso Exp $
$NetBSD: patch-ab,v 1.3 2008/12/20 21:11:05 jmcneill Exp $
--- tools/hal-storage-shared.c.orig 2008-05-08 02:24:24 +0300
+++ tools/hal-storage-shared.c 2008-11-23 13:38:53 +0200
@ -7,7 +7,7 @@ $NetBSD: patch-ab,v 1.2 2008/11/23 21:50:51 hasso Exp $
#include <glib.h>
#include <glib/gstdio.h>
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__DragonFly__)
+#if defined(__FreeBSD__) || defined(__DragonFly__) || defined(__APPLE__)
#include <fstab.h>
#include <sys/param.h>
#include <sys/ucred.h>
@ -27,7 +27,7 @@ $NetBSD: patch-ab,v 1.2 2008/11/23 21:50:51 hasso Exp $
#include "hal-storage-shared.h"
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__DragonFly__)
+#if defined(__FreeBSD__) || defined(__DragonFly__) || defined(__APPLE__)
struct mtab_handle
{
struct statfs *mounts;
@ -48,7 +48,7 @@ $NetBSD: patch-ab,v 1.2 2008/11/23 21:50:51 hasso Exp $
mtab_open (gpointer *handle)
{
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__) || defined(__APPLE__)
struct mtab_handle *mtab;
mtab = g_new0 (struct mtab_handle, 1);
@ -57,7 +57,7 @@ $NetBSD: patch-ab,v 1.2 2008/11/23 21:50:51 hasso Exp $
mtab_next (gpointer handle, char **mount_point)
{
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__) || defined(__APPLE__)
struct mtab_handle *mtab = handle;
if (mtab->iter < mtab->n_mounts) {
@ -66,7 +66,7 @@ $NetBSD: patch-ab,v 1.2 2008/11/23 21:50:51 hasso Exp $
mtab_close (gpointer handle)
{
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__) || defined(__APPLE__)
g_free (handle);
#else
fclose (handle);
@ -75,7 +75,7 @@ $NetBSD: patch-ab,v 1.2 2008/11/23 21:50:51 hasso Exp $
fstab_open (gpointer *handle)
{
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__) || defined(__APPLE__)
return setfsent () == 1;
#elif sun
*handle = fopen (VFSTAB, "r");
@ -84,7 +84,7 @@ $NetBSD: patch-ab,v 1.2 2008/11/23 21:50:51 hasso Exp $
fstab_next (gpointer handle, char **mount_point)
{
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__) || defined(__APPLE__)
struct fstab *fstab;
fstab = getfsent ();
@ -93,7 +93,7 @@ $NetBSD: patch-ab,v 1.2 2008/11/23 21:50:51 hasso Exp $
fstab_close (gpointer handle)
{
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__) || defined(__APPLE__)
endfsent ();
#else
fclose (handle);

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ac,v 1.2 2008/11/23 21:50:51 hasso Exp $
$NetBSD: patch-ac,v 1.3 2008/12/20 21:11:05 jmcneill Exp $
--- tools/hal-storage-unmount.c.orig 2008-05-08 02:24:17 +0300
+++ tools/hal-storage-unmount.c 2008-11-23 13:40:23 +0200
@ -7,7 +7,7 @@ $NetBSD: patch-ac,v 1.2 2008/11/23 21:50:51 hasso Exp $
#include <glib.h>
#include <glib/gstdio.h>
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__DragonFly__)
+#if defined(__FreeBSD__) || defined(__DragonFly__) || defined(__APPLE__)
#include <fstab.h>
#include <sys/param.h>
#include <sys/ucred.h>

View file

@ -1,7 +1,7 @@
$NetBSD: patch-na,v 1.2 2008/11/27 03:32:19 jmcneill Exp $
$NetBSD: patch-na,v 1.3 2008/12/20 21:11:05 jmcneill Exp $
--- configure.in.orig 2008-05-07 19:24:31.000000000 -0400
+++ configure.in 2008-11-26 21:32:46.000000000 -0500
+++ configure.in 2008-12-20 15:28:11.000000000 -0500
@@ -448,7 +448,7 @@
AC_ARG_WITH([backend],
@ -29,7 +29,16 @@ $NetBSD: patch-na,v 1.2 2008/11/27 03:32:19 jmcneill Exp $
AC_SUBST(HALD_BACKEND)
dnl DBUS API is subject to changes
@@ -1004,6 +1008,9 @@
@@ -644,6 +648,8 @@
case "$host" in
*-*-solaris*)
;;
+*-*-darwin*)
+ ;;
*)
PKG_CHECK_MODULES(VOLUME_ID, [$volume_id_module])
AC_SUBST(VOLUME_ID_CFLAGS)
@@ -1004,6 +1010,9 @@
hald/solaris/Makefile
hald/solaris/probing/Makefile
hald/solaris/addons/Makefile
@ -39,7 +48,7 @@ $NetBSD: patch-na,v 1.2 2008/11/27 03:32:19 jmcneill Exp $
hald/freebsd/Makefile
hald/freebsd/probing/Makefile
hald/freebsd/libprobe/Makefile
@@ -1014,6 +1021,7 @@
@@ -1014,6 +1023,7 @@
tools/Makefile
tools/freebsd/Makefile
tools/linux/Makefile