Update to 2.1.5:

Version 2.1.5 (3/24/2003)
  * Bug fix: Fortran wrappers were disabled in version 2.1.4.
Version 2.1.4 (3/16/2003)
  * Upgraded to newer versions of autoconf, etcetera, to fix compilation
    problems on various recent systems.
  * The configure script no longer picks the wrong architecture flags
    (which caused FFTW to crash) on newer IBM POWER machines running AIX.
  * Multi-threaded transforms should now utilize multiple CPUs on
    Solaris (which creates threads in single-processor mode by default).
  * Added experimental support for OpenMP (and SGI MP) compiler
    parallelization directives in the multi-threaded transforms,
    instead of using explicit thread spawning.  Enable by configuring
    --with-openmp or --with-sgi-mp in addition to --enable-threads.
  * Expanded FAQ.
This commit is contained in:
wiz 2003-06-05 21:32:54 +00:00
parent 79498ab6e3
commit 0769c1232e
4 changed files with 11 additions and 55 deletions

View file

@ -1,9 +1,10 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/06/05 20:50:29 wiz Exp $
# $NetBSD: Makefile,v 1.2 2003/06/05 21:32:54 wiz Exp $
DISTNAME= fftw-2.1.3
PKGNAME= fftw2-2.1.3
DISTNAME= fftw-2.1.5
PKGNAME= fftw2-2.1.5
CATEGORIES= math
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/ \
http://www.fftw.org/
MAINTAINER= root@garbled.net
HOMEPAGE= http://www.fftw.org/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/06/05 20:50:29 wiz Exp $
@comment $NetBSD: PLIST,v 1.2 2003/06/05 21:32:54 wiz Exp $
@unexec ${INSTALL_INFO} --delete %D/info/fftw.info %D/info/dir
info/fftw.info
info/fftw.info-1
@ -13,9 +13,9 @@ lib/libfftw.a
lib/libfftw.la
lib/libfftw.so
lib/libfftw.so.2
lib/libfftw.so.2.5
lib/libfftw.so.2.7
lib/librfftw.a
lib/librfftw.la
lib/librfftw.so
lib/librfftw.so.2
lib/librfftw.so.2.5
lib/librfftw.so.2.7

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2003/06/05 20:50:29 wiz Exp $
$NetBSD: distinfo,v 1.2 2003/06/05 21:32:54 wiz Exp $
SHA1 (fftw-2.1.3.tar.gz) = 5796f2f904f66630024bf130880ec845333cda18
Size (fftw-2.1.3.tar.gz) = 1139406 bytes
SHA1 (fftw-2.1.5.tar.gz) = 12020b58edc1b0490a83db4aa912fac5dfdfb26b
Size (fftw-2.1.5.tar.gz) = 1256888 bytes
SHA1 (patch-aa) = 7a451f7aa2d4fe0e5134d014006c63d077951726
SHA1 (patch-ab) = 64fdc5b9a8d6da22714ec0f05ff7716bfcbc696a

View file

@ -1,44 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/06/05 20:50:29 wiz Exp $
--- configure.orig Mon Nov 8 01:45:45 1999
+++ configure
@@ -2215,6 +2215,7 @@
int main() {
foobar();
; return 0; }
+void MAIN__(void){abort();}
EOF
if { (eval echo configure:2220: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
@@ -2230,6 +2231,7 @@
int main() {
foobar_();
; return 0; }
+void MAIN__(void){abort();}
EOF
if { (eval echo configure:2235: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
@@ -2245,6 +2247,7 @@
int main() {
FOOBAR();
; return 0; }
+void MAIN__(void){abort();}
EOF
if { (eval echo configure:2250: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
@@ -2260,6 +2263,7 @@
int main() {
FOOBAR_();
; return 0; }
+void MAIN__(void){abort();}
EOF
if { (eval echo configure:2265: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
@@ -2337,6 +2341,7 @@
int main() {
$mangle_try();
; return 0; }
+void MAIN__(void){abort();}
EOF
if { (eval echo configure:2342: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*