Update to 6.05:
Version 5.55 DEVELOPMENT Typo fix. ddascalescu Version 6.00 2009-11-23 Date::Manip 6.00 is a total rethink of the module, and a nearly complete rewrite. Please refer to the Date::Manip::Changes5to6 document for a list of incompatible changes. *** Massive reorganization and near total rewrite. *** Broke into several smaller modules *** Full timezone support Several config variables deprecated Added some functionality (suggested by James Elson to improve setting the "current time". Done with the ForceDate config variable. *** Converted languages to YAML for much easier maintenance. Patch and suggestion provided by Evan Carroll Added much better formats for deltas. Suggested by Jim Hranicky. Borrowed the _FindWindowsTZName function from the DateTime-TimeZone module. Added SetDate config variable (based on a suggestion by Christian Campbell). Added parse_format which was first suggested by Kim Ryan. Thanks to Jonathan Hogue for helping test Windows additions. It also contains a few bug fixes correcting problems in the 5.xx releases: Fixed a bug where "YYtoYYYY=c" wouldn't work. VMS bugfix to not call `date` command. Lane Fixed typo in turkish translation. Spelling fix in dutch. Bart Van Loon New Year's Day defined using a recurrence which might push the observed day to the previous year was broken. Reported by Alan Burlison I have received many suggestions over time which were automatically handled during the 6.00 rewrite. Although the changes weren't made because of the suggestions specifically, I wanted to acknowledge them since I appreciate the suggestions. Delta_Format initialization done outside of the function. Eric Boehm Added $subtract to calculation routines. First suggested by Steve Berlage. Version 6.01 2009-11-23 *** Fixed a bug where dates were sometimes getting the wrong timezone when SetDate/ForceDate in effect. Version 6.02 2009-11-24 A quick fix to make sure that the tests run correctly in other timezones. Disabled curr_zone_methods when taint checking on. I believe that Date::Manip is completely taint friendly at this point. Version 6.03 2009-11-24 Corrects a backward incompatibility with UnixDate. Rene Schickbauer A couple more corrections to the tests. Version 6.04 2009-11-25 Fixed a bug where events were not interpreted in the correct timezone if SetDate/ForceDate used. Version 6.05 Significant speedups. Thanks to Moritz Lenz and BrowserUK on perlmonks for suggestions (and a number of other people on perlmonks for suggestions that I did not end up using, but which provided a great discussion). Reduced the precision of 1 test to avoid a rounding difference when using a perl compiled with uselongdouble. Andreas Koenig Fixed a bug in parse_date where the current time was getting used instead of the documented 00:00:00 Bug fix where DateCalc didn't work with $mode in some cases. Fixed Makefile.PL/Build.PL to hanle Win32::TieRegistry requirement. Changed %z printf behavior back to 5.xx and added %N format. Gilles Lamiral Fixed bug where non-English Windows versions didn't get the timezone. Thanks to Rene Schickbauer for testing.
This commit is contained in:
parent
5a753efcbc
commit
07790fc281
3 changed files with 10 additions and 275 deletions
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.27 2008/10/19 19:17:51 he Exp $
|
||||
# $NetBSD: Makefile,v 1.28 2010/01/20 15:12:13 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Date-Manip-5.54
|
||||
DISTNAME= Date-Manip-6.05
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
PKGREVISION= 2
|
||||
SVR4_PKGNAME= p5dma
|
||||
CATEGORIES= textproc perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Date/}
|
||||
|
@ -12,6 +11,10 @@ MAINTAINER= pkgsrc-users@NetBSD.org
|
|||
HOMEPAGE= http://search.cpan.org/dist/Date-Manip/
|
||||
COMMENT= Perl5 module for date calculations
|
||||
|
||||
DEPENDS+= p5-Test-Pod-[0-9]*:../../devel/p5-Test-Pod
|
||||
DEPENDS+= p5-Test-Pod-Coverage-[0-9]*:../../devel/p5-Test-Pod-Coverage
|
||||
DEPENDS+= p5-YAML-Syck-[0-9]*:../../textproc/p5-YAML-Syck
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.9 2008/09/14 21:40:54 he Exp $
|
||||
$NetBSD: distinfo,v 1.10 2010/01/20 15:12:13 wiz Exp $
|
||||
|
||||
SHA1 (Date-Manip-5.54.tar.gz) = 88ce43556343024c3b86815e4938399226eab55a
|
||||
RMD160 (Date-Manip-5.54.tar.gz) = 58a81a1b94a23c837504f40c1490d20c70615818
|
||||
Size (Date-Manip-5.54.tar.gz) = 181841 bytes
|
||||
SHA1 (patch-aa) = 7f49bf10e7561cedbd9992b7175de80b7559270a
|
||||
SHA1 (Date-Manip-6.05.tar.gz) = daccee0843522213e461d35f76d8adc8f97f8d2b
|
||||
RMD160 (Date-Manip-6.05.tar.gz) = 0610fc3ff0cc5659ab23a61d9ac92781732c3a1c
|
||||
Size (Date-Manip-6.05.tar.gz) = 1219059 bytes
|
||||
|
|
|
@ -1,267 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2008/09/14 21:40:54 he Exp $
|
||||
|
||||
--- lib/Date/Manip.pm.orig 2008-05-09 15:56:41.000000000 +0200
|
||||
+++ lib/Date/Manip.pm
|
||||
@@ -549,24 +549,44 @@ sub Date_Init {
|
||||
# tz2z = hash of all tzdata timezones to full timezone (EST#EDT)
|
||||
|
||||
$zonesrfc=
|
||||
+ "gmt+12 -1200 ". # Etc/GMT+12
|
||||
"idlw -1200 ". # International Date Line West
|
||||
+ "gmt+11 -1100 ". # Etc/GMT+11
|
||||
"nt -1100 ". # Nome
|
||||
+ "nut -1100 ". # Pacific/Niue
|
||||
"hst -1000 ". # Hawaii Standard
|
||||
"cat -1000 ". # Central Alaska
|
||||
+ "ckt -1000 ". # Pacific/Rarotonga
|
||||
"ahst -1000 ". # Alaska-Hawaii Standard
|
||||
+ "hast -1000 ". # America/Adak America/Atka US/Aleutian
|
||||
+ "taht -1000 ". # Pacific/Tahiti
|
||||
+ "gmt+10 -1000 ". # Etc/GMT+10
|
||||
+ "tkt -1000 ". # Pacific/Fakaofo
|
||||
+ "mart -0930 ". # Pacific/Marquesas
|
||||
"akst -0900 ". # Alaska Standard
|
||||
+ "gamt -0900 ". # SystemV/YST9 Pacific/Gambier
|
||||
+ "gmt+9 -0900 ". # Etc/GMT+9
|
||||
+ "hadt -0900 ". # (DST) America/Adak America/Atka US/Aleutian
|
||||
"yst -0900 ". # Yukon Standard
|
||||
"hdt -0900 ". # Hawaii Daylight
|
||||
"akdt -0800 ". # Alaska Daylight
|
||||
+ "gmt+8 -0800 ". # Etc/GMT+8
|
||||
"ydt -0800 ". # Yukon Daylight
|
||||
"pst -0800 ". # Pacific Standard
|
||||
+ "gmt+7 -0700 ". # Etc/GMT+7
|
||||
"pdt -0700 ". # Pacific Daylight
|
||||
"mst -0700 ". # Mountain Standard
|
||||
+ "gmt+6 -0600 ". # Etc/GMT+6
|
||||
"mdt -0600 ". # Mountain Daylight
|
||||
"cst -0600 ". # Central Standard
|
||||
+ "galt -0600 ". # Pacific/Galapagos
|
||||
"cdt -0500 ". # Central Daylight
|
||||
+ "cot -0500 ". # America/Bogota
|
||||
"est -0500 ". # Eastern Standard
|
||||
"act -0500 ". # Brazil, Acre
|
||||
+ "gmt+5 -0500 ". # Etc/GMT+5
|
||||
+ "easst -0500 ". # (DST) Pacific/Easter Chile/EasterIsland
|
||||
+ "ect -0500 ". # America/Guayaquil
|
||||
"pet -0500 ". # Peruvian time
|
||||
"vet -0430 ". # Venezuela
|
||||
"sat -0400 ". # Chile
|
||||
@@ -574,30 +594,53 @@ sub Date_Init {
|
||||
"clst -0400 ". # Chile Standard
|
||||
"bot -0400 ". # Bolivia
|
||||
"amt -0400 ". # Brazil, Amazon
|
||||
+ "fkt -0400 ". # Atlantic/Stanley
|
||||
"acst -0400 ". # Brazil, Acre Daylight
|
||||
"edt -0400 ". # Eastern Daylight
|
||||
+ "gmt+4 -0400 ". # Etc/GMT+4
|
||||
+ "gyt -0400 ". # America/Guyana
|
||||
+ "pyt -0400 ". # America/Asuncion
|
||||
"ast -0400 ". # Atlantic Standard
|
||||
#"nst -0330 ". # Newfoundland Standard nst=North Sumatra +0630
|
||||
"nft -0330 ". # Newfoundland
|
||||
#"gst -0300 ". # Greenland Standard gst=Guam Standard +1000
|
||||
+ "clst -0300 ". # (DST) America/Santiago Antarctica/Palmer Chile/Continental
|
||||
"cldt -0300 ". # Chile Daylight
|
||||
#"bst -0300 ". # Brazil Standard bst=British Summer +0100
|
||||
"brt -0300 ". # Brazil Standard (official time)
|
||||
#"brst -0300 ". # Brazil Standard
|
||||
"adt -0300 ". # Atlantic Daylight
|
||||
"art -0300 ". # Argentina
|
||||
+ "gft -0300 ". # America/Cayenne
|
||||
"arst -0200 ". # Argentina, Daylight
|
||||
"amst -0300 ". # Brazil, Amazon Daylight
|
||||
+ "fkst -0300 ". # (DST) Atlantic/Stanley
|
||||
+ "gmt+3 -0300 ". # Etc/GMT+3
|
||||
+ "pmst -0300 ". # America/Miquelon
|
||||
+ "pyst -0300 ". # (DST) America/Asuncion
|
||||
+ "rott -0300 ". # Antarctica/Rothera
|
||||
+ "srt -0300 ". # America/Paramaribo
|
||||
"uyt -0300 ". # Uruguay
|
||||
+ "wgt -0300 ". # America/Godthab
|
||||
"ndt -0230 ". # Newfoundland Daylight
|
||||
"brst -0200 ". # Brazil Daylight (official time)
|
||||
"fnt -0200 ". # Brazil, Fernando de Noronha
|
||||
+ "gmt+2 -0200 ". # Etc/GMT+2
|
||||
"at -0200 ". # Azores
|
||||
+ "pmdt -0200 ". # (DST) America/Miquelon
|
||||
"uyst -0200 ". # Uruguay
|
||||
+ "wgst -0200 ". # (DST) America/Godthab
|
||||
+ "azot -0100 ". # Atlantic/Azores
|
||||
+ "gmt+1 -0100 ". # Etc/GMT+1
|
||||
+ "cvt -0100 ". # Atlantic/Cape_Verde
|
||||
+ "egt -0100 ". # America/Scoresbysund
|
||||
"wat -0100 ". # West Africa
|
||||
"fnst -0100 ". # Brazil, Fernando de Noronha Daylight
|
||||
+ "azost +0000 ". # (DST) Atlantic/Azores
|
||||
+ "egst +0000 ". # (DST) America/Scoresbysund
|
||||
"gmt +0000 ". # Greenwich Mean
|
||||
"ut +0000 ". # Universal
|
||||
+ "uct +0000 ". # Etc/UCT UCT
|
||||
"utc +0000 ". # Universal (Coordinated)
|
||||
"wet +0000 ". # Western European
|
||||
"cet +0100 ". # Central European
|
||||
@@ -608,64 +651,163 @@ sub Date_Init {
|
||||
"swt +0100 ". # Swedish Winter
|
||||
"bst +0100 ". # British Summer bst=Brazil standard -0300
|
||||
"gb +0100 ". # GMT with daylight savings
|
||||
+ "gmt-1 +0100 ". # Etc/GMT-1
|
||||
"west +0100 ". # Western European Daylight
|
||||
"eet +0200 ". # Eastern Europe, USSR Zone 1
|
||||
"cest +0200 ". # Central European Summer
|
||||
"fst +0200 ". # French Summer
|
||||
+ "gmt-2 +0200 ". # Etc/GMT-2
|
||||
"ist +0200 ". # Israel standard
|
||||
"mest +0200 ". # Middle European Summer
|
||||
"mesz +0200 ". # Middle European Summer
|
||||
"metdst +0200 ". # An alias for mest used by HP-UX
|
||||
"sast +0200 ". # South African Standard
|
||||
"sst +0200 ". # Swedish Summer sst=South Sumatra +0700
|
||||
+ "wast +0200 ". # (DST) Africa/Windhoek
|
||||
"bt +0300 ". # Baghdad, USSR Zone 2
|
||||
"eest +0300 ". # Eastern Europe Summer
|
||||
"eetdst +0300 ". # An alias for eest used by HP-UX
|
||||
"eetedt +0300 ". # Eastern Europe, USSR Zone 1
|
||||
+ "get +0300 ". # Asia/Tbilisi
|
||||
+ "gmt-3 +0300 ". # Etc/GMT-3
|
||||
"idt +0300 ". # Israel Daylight
|
||||
"msk +0300 ". # Moscow
|
||||
"eat +0300 ". # East Africa
|
||||
+ "syot +0300 ". # Antarctica/Syowa
|
||||
+ "zzz +0307 ". # Asia/Riyadh87 Asia/Riyadh89 Asia/Riyadh88 Mideast/Riyadh88 Mideast/Riyadh87 Mideast/Riyadh89
|
||||
"it +0330 ". # Iran
|
||||
+ "irst +0330 ". # Asia/Tehran Iran
|
||||
+ "aqtt +0400 ". # Asia/Aqtau
|
||||
+ "azt +0400 ". # Asia/Baku
|
||||
+ "gest +0400 ". # (DST) Asia/Tbilisi
|
||||
+ "gmt-4 +0400 ". # Etc/GMT-4
|
||||
+ "mut +0400 ". # Indian/Mauritius
|
||||
"zp4 +0400 ". # USSR Zone 3
|
||||
"msd +0400 ". # Moscow Daylight
|
||||
+ "orat +0400 ". # Asia/Oral
|
||||
+ "ret +0400 ". # Indian/Reunion
|
||||
+ "samt +0400 ". # Europe/Samara
|
||||
+ "sct +0400 ". # Indian/Mahe
|
||||
+ "aft +0430 ". # Asia/Kabul
|
||||
+ "irdt +0430 ". # (DST) Asia/Tehran Iran
|
||||
+ "gmt-5 +0500 ". # Etc/GMT-5
|
||||
+ "kgt +0500 ". # Asia/Bishkek
|
||||
+ "mvt +0500 ". # Indian/Maldives
|
||||
+ "pkt +0500 ". # Asia/Karachi
|
||||
+ "samst +0500 ". # (DST) Europe/Samara
|
||||
+ "tjt +0500 ". # Asia/Dushanbe
|
||||
+ "tft +0500 ". # Indian/Kerguelen
|
||||
+ "tmt +0500 ". # Asia/Ashkhabad Asia/Ashgabat
|
||||
+ "uzt +0500 ". # Asia/Tashkent Asia/Samarkand
|
||||
"zp5 +0500 ". # USSR Zone 4
|
||||
"yekt +0500 ". # Yeakaterinburg time zone, Russia
|
||||
"yekst +0500 ". # Yeakaterinburg summer time zone, Russia
|
||||
"ist +0530 ". # Indian Standard
|
||||
+ "npt +0545 ". # Asia/Katmandu
|
||||
+ "almt +0600 ". # Asia/Almaty
|
||||
+ "bdt +0600 ". # Asia/Dacca Asia/Dhaka
|
||||
+ "btt +0600 ". # Asia/Thimbu Asia/Thimphu
|
||||
+ "gmt-6 +0600 ". # Etc/GMT-6
|
||||
+ "kgst +0600 ". # (DST) Asia/Bishkek
|
||||
+ "iot +0600 ". # Indian/Chagos
|
||||
+ "lkt +0600 ". # Asia/Colombo
|
||||
"zp6 +0600 ". # USSR Zone 5
|
||||
+ "mawt +0600 ". # Antarctica/Mawson
|
||||
"novt +0600 ". # Novosibirsk winter time zone, Russia
|
||||
"omst +0600 ". # Omsk time zone, Russia
|
||||
+ "qyzt +0600 ". # Asia/Qyzylorda
|
||||
+ "vost +0600 ". # Antarctica/Vostok
|
||||
+ "mmt +0630 ". # Asia/Rangoon
|
||||
"nst +0630 ". # North Sumatra nst=Newfoundland Std -0330
|
||||
#"sst +0700 ". # South Sumatra, USSR Zone 6 sst=Swedish Summer +0200
|
||||
+ "cxt +0700 ". # Indian/Christmas
|
||||
+ "davt +0700 ". # Antarctica/Davis
|
||||
+ "gmt-7 +0700 ". # Etc/GMT-7
|
||||
"javt +0700 ". # Java
|
||||
+ "hovt +0700 ". # Asia/Hovd
|
||||
"ict +0700 ". # Indo China Time
|
||||
"novst +0700 ". # Novosibirsk summer time zone, Russia
|
||||
"krat +0700 ". # Krasnoyarsk, Russia
|
||||
+ "omsst +0700 ". # (DST) Asia/Omsk
|
||||
+ "wit +0700 ". # Asia/Pontianak Asia/Jakarta
|
||||
+ "bnt +0800 ". # Asia/Brunei
|
||||
+ "gmt-8 +0800 ". # Etc/GMT-8
|
||||
+ "hovst +0800 ". # (DST) Asia/Hovd
|
||||
"myt +0800 ". # Malaysia
|
||||
"hkt +0800 ". # Hong Kong
|
||||
"sgt +0800 ". # Singapore
|
||||
+ "cit +0800 ". # Asia/Makassar Asia/Ujung_Pandang
|
||||
"cct +0800 ". # China Coast, USSR Zone 7
|
||||
"krast +0800 ". # Krasnoyarsk, Russia Daylight
|
||||
+ "irkt +0800 ". # Asia/Irkutsk
|
||||
"awst +0800 ". # Australian Western Standard
|
||||
"wst +0800 ". # West Australian Standard
|
||||
"pht +0800 ". # Asia Manila
|
||||
+ "ulat +0800 ". # Asia/Ulan_Bator Asia/Ulaanbaatar
|
||||
+ "chot +0900 ". # Asia/Choibalsan
|
||||
+ "eit +0900 ". # Asia/Jayapura
|
||||
+ "gmt-9 +0900 ". # Etc/GMT-9
|
||||
+ "irkst +0900 ". # (DST) Asia/Irkutsk
|
||||
"kst +0900 ". # Republic of Korea
|
||||
"jst +0900 ". # Japan Standard, USSR Zone 8
|
||||
+ "pwt +0900 ". # Pacific/Palau
|
||||
"rok +0900 ". # Republic of Korea
|
||||
+ "tlt +0900 ". # Asia/Dili
|
||||
+ "ulast +0900 ". # (DST) Asia/Ulan_Bator Asia/Ulaanbaatar
|
||||
+ "yakt +0900 ". # Asia/Yakutsk
|
||||
"acst +0930 ". # Australian Central Standard
|
||||
"cast +0930 ". # Central Australian Standard
|
||||
"aest +1000 ". # Australian Eastern Standard
|
||||
+ "chost +1000 ". # (DST) Asia/Choibalsan
|
||||
+ "ddut +1000 ". # Antarctica/DumontDUrville
|
||||
+ #"east -0600 ". # Pacific/Easter Chile/EasterIsland
|
||||
"east +1000 ". # Eastern Australian Standard
|
||||
+ "gmt-10 +1000 ". # Etc/GMT-10
|
||||
"gst +1000 ". # Guam Standard, USSR Zone 9 gst=Greenland Std -0300
|
||||
"chst +1000 ". # Guam Standard, USSR Zone 9 gst=Greenland Std -0300
|
||||
+ "pgt +1000 ". # Pacific/Port_Moresby
|
||||
+ "sakt +1000 ". # Asia/Sakhalin
|
||||
+ "trut +1000 ". # Pacific/Yap Pacific/Truk
|
||||
+ "vlat +1000 ". # Asia/Vladivostok
|
||||
+ "yakst +1000 ". # (DST) Asia/Yakutsk
|
||||
"acdt +1030 ". # Australian Central Daylight
|
||||
"cadt +1030 ". # Central Australian Daylight
|
||||
+ "lhst +1030 ". # Australia/LHI Australia/Lord_Howe
|
||||
"aedt +1100 ". # Australian Eastern Daylight
|
||||
"eadt +1100 ". # Eastern Australian Daylight
|
||||
+ "gmt-11 +1100 ". # Etc/GMT-11
|
||||
+ "kost +1100 ". # Pacific/Kosrae
|
||||
+ "magt +1100 ". # Asia/Magadan
|
||||
+ "nct +1100 ". # Pacific/Noumea
|
||||
+ "pont +1100 ". # Pacific/Ponape
|
||||
+ "sakst +1100 ". # (DST) Asia/Sakhalin
|
||||
+ "sbt +1100 ". # Pacific/Guadalcanal
|
||||
+ "vlast +1100 ". # (DST) Asia/Vladivostok
|
||||
+ "vut +1100 ". # Pacific/Efate
|
||||
+ "anat +1200 ". # Asia/Anadyr
|
||||
+ "fjt +1200 ". # Fiji Standard
|
||||
+ "gmt-12 +1200 ". # Etc/GMT-12
|
||||
+ "gilt +1200 ". # Pacific/Tarawa
|
||||
"idle +1200 ". # International Date Line East
|
||||
+ "magst +1200 ". # (DST) Asia/Magadan
|
||||
+ "mht +1200 ". # Pacific/Majuro Pacific/Kwajalein Kwajalein
|
||||
+ "nrt +1200 ". # Pacific/Nauru
|
||||
"nzst +1200 ". # New Zealand Standard
|
||||
"nzt +1200 ". # New Zealand
|
||||
+ "pett +1200 ". # Asia/Kamchatka
|
||||
+ "tvt +1200 ". # Pacific/Funafuti
|
||||
+ "wakt +1200 ". # Pacific/Wake
|
||||
+ "wft +1200 ". # Pacific/Wallis
|
||||
+ "chast +1245 ". # Pacific/Chatham NZ-CHAT
|
||||
+ "anast +1300 ". # (DST) Asia/Anadyr
|
||||
+ "gmt-13 +1300 ". # Etc/GMT-13
|
||||
"nzdt +1300 ". # New Zealand Daylight
|
||||
+ "petst +1300 ". # (DST) Asia/Kamchatka
|
||||
+ "phot +1300 ". # Pacific/Enderbury
|
||||
+ "tot +1300 ". # Pacific/Tongatapu
|
||||
+ "chadt +1345 ". # (DST) Pacific/Chatham NZ-CHAT
|
||||
+ "gmt-14 +1400 ". # Etc/GMT-14
|
||||
+ "lint +1400 ". # Pacific/Kiritimati
|
||||
"z +0000 ".
|
||||
"a +0100 b +0200 c +0300 d +0400 e +0500 f +0600 g +0700 h +0800 ".
|
||||
"i +0900 k +1000 l +1100 m +1200 ".
|
Loading…
Reference in a new issue