Switch to using wxGTK30 and fix build with gcc6.

This commit is contained in:
markd 2016-07-16 03:32:32 +00:00
parent 94193de7f1
commit 077fd7ef7a
9 changed files with 118 additions and 4 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.87 2016/04/11 19:01:49 ryoon Exp $
# $NetBSD: Makefile,v 1.88 2016/07/16 03:32:32 markd Exp $
DISTNAME= rapidsvn-0.12.1
PKGREVISION= 20
PKGREVISION= 21
CATEGORIES= devel x11 scm
MASTER_SITES= http://www.rapidsvn.org/download/release/0.12.1/
@ -23,5 +23,5 @@ CONFIGURE_ARGS+= --with-doxygen=no
# subversion-base, following the precedent of devel/foo-subversion and
# www/ap2-subversion.
.include "../../devel/subversion-base/buildlink3.mk"
.include "../../x11/wxGTK28/buildlink3.mk"
.include "../../x11/wxGTK30/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,10 +1,17 @@
$NetBSD: distinfo,v 1.19 2016/03/31 09:00:39 markd Exp $
$NetBSD: distinfo,v 1.20 2016/07/16 03:32:32 markd Exp $
SHA1 (rapidsvn-0.12.1.tar.gz) = 65d051b5a84fe8b5b0ce906f2ba5cf134a560feb
RMD160 (rapidsvn-0.12.1.tar.gz) = dde655f385245ba9346a5fc4a051ef01c5551501
SHA512 (rapidsvn-0.12.1.tar.gz) = 892dab56e8ec19c5f26a0ddfab378187bc0325275f9fcf759c12beead70aab17876f7e5920bcf214fc86354faef58244ce25926ba010158f7354cd144e1c4c07
Size (rapidsvn-0.12.1.tar.gz) = 1087511 bytes
SHA1 (patch-configure) = caa479f6e17291a34cf4e4e1686d6685d7070f9a
SHA1 (patch-include_svncpp_dirent.hpp) = 2c1dca7f31227caeb6cc483e9d77e9e1c6e7a074
SHA1 (patch-src_filelist_ctrl.cpp) = b1e92220d09a5784c0800bf1a63fef061850e4a6
SHA1 (patch-src_filelist_ctrl.hpp) = 6db277d0b08766bd42201bae3ec66c449c433c15
SHA1 (patch-src_hist_val.cpp) = 6d9847ec414e50788751820b01d35e42d596c13e
SHA1 (patch-src_listener.cpp) = 91926fb1654014152799771bb50b71fab03c32b3
SHA1 (patch-src_locale_Makefile.in) = fe0fe3a74e03ef6f1f9c50cf4ae4db393aa21f9f
SHA1 (patch-src_log_dlg.cpp) = 5730c970f0334bb596304a023c045e01692efb34
SHA1 (patch-src_preferences_dlg.cpp) = d8a91a33218876120caddcf862d2b2d877bb3ff8
SHA1 (patch-src_svncpp_client_ls.cpp) = 223bc7a2b306ffcb5aa759c7b609af85eab38724
SHA1 (patch-src_svncpp_dirent.cpp) = b256d12e890efc2a7555c3ceeabb691e5c4369cf

View file

@ -0,0 +1,15 @@
$NetBSD: patch-configure,v 1.1 2016/07/16 03:32:32 markd Exp $
Allow latest wxWidgets
--- configure.orig 2012-06-28 08:35:03.000000000 +0000
+++ configure
@@ -15176,6 +15176,8 @@ case $WX_VERSION in
;;
2.[5-9].*)
;;
+ 3.*)
+ ;;
*)
as_fn_error $? "wxWidgets >= 2.4.2 required, found version $WX_VERSION" "$LINENO" 5
as_fn_error $? "Try --with-wx-config." "$LINENO" 5

View file

@ -0,0 +1,21 @@
$NetBSD: patch-src_filelist_ctrl.cpp,v 1.1 2016/07/16 03:32:32 markd Exp $
--- src/filelist_ctrl.cpp.orig 2012-06-28 06:39:35.000000000 +0000
+++ src/filelist_ctrl.cpp
@@ -1606,7 +1606,7 @@ FileListCtrl::GetColumnVisible(const int
}
}
-inline void
+inline bool
FileListCtrl::SetColumnWidth(const int col, const int width)
{
m->ColumnWidth[col] = width;
@@ -1616,6 +1616,7 @@ FileListCtrl::SetColumnWidth(const int c
{
wxListCtrl::SetColumnWidth(index, width);
}
+ return true;
}
int

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_filelist_ctrl.hpp,v 1.1 2016/07/16 03:32:32 markd Exp $
--- src/filelist_ctrl.hpp.orig 2012-06-28 06:39:35.000000000 +0000
+++ src/filelist_ctrl.hpp
@@ -118,7 +118,7 @@ public:
* @param col column number
* @param width
*/
- void
+ bool
SetColumnWidth(const int col, const int width);
/**

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_hist_val.cpp,v 1.1 2016/07/16 03:32:32 markd Exp $
--- src/hist_val.cpp.orig 2012-06-28 06:39:35.000000000 +0000
+++ src/hist_val.cpp
@@ -113,7 +113,7 @@ HistoryValidator::TransferToWindow()
}
// if we have an entry, select it
- if (!comboBox->IsEmpty())
+ if (!comboBox->wxItemContainerImmutable::IsEmpty())
comboBox->SetSelection(0, 0);
}

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_listener.cpp,v 1.1 2016/07/16 03:32:32 markd Exp $
Dont do things the old 2.6 way
--- src/listener.cpp.orig 2012-06-28 06:39:35.000000000 +0000
+++ src/listener.cpp
@@ -167,7 +167,7 @@ public:
wxMutexLocker lock(mutex);
wxString localCertFile = wxFileSelector(
_("Select Certificate File"), wxT(""), wxT(""), wxT(""),
- wxT("*.*"), wxOPEN | wxFILE_MUST_EXIST, parent);
+ wxT("*.*"), wxFD_OPEN | wxFD_FILE_MUST_EXIST, parent);
LocalToUtf8(localCertFile, certFile);
dataReceived = !localCertFile.empty();

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_log_dlg.cpp,v 1.1 2016/07/16 03:32:32 markd Exp $
wxWidgets 3.0 unicode fix
--- src/log_dlg.cpp.orig 2012-06-28 06:39:35.000000000 +0000
+++ src/log_dlg.cpp
@@ -211,7 +211,7 @@ private:
for (size_t idx = 0; idx < str.Length(); idx++)
{
- switch (str[idx])
+ switch (str[idx].GetValue())
{
case wxT('\r'):
case wxT('\n'):

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_preferences_dlg.cpp,v 1.1 2016/07/16 03:32:32 markd Exp $
Dont do things the old 2.6 way
--- src/preferences_dlg.cpp.orig 2012-06-28 06:39:35.000000000 +0000
+++ src/preferences_dlg.cpp
@@ -126,7 +126,7 @@ bool
PreferencesDlg::SelectExecutable(const wxString & title, wxTextCtrl * textCtrl)
{
wxFileDialog dlg(this, title, wxEmptyString, wxEmptyString,
- EXECUTABLE_WILDCARD, wxOPEN);
+ EXECUTABLE_WILDCARD, wxFD_OPEN);
dlg.SetPath(textCtrl->GetValue());
if (dlg.ShowModal() != wxID_OK)