Adapt syscall name patch for NetBSD>=6.0.
From Yasushi Oshima in PR 49759.
This commit is contained in:
parent
e4732dcf6a
commit
07b7bebeec
3 changed files with 38 additions and 10 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.77 2014/10/09 14:06:30 wiz Exp $
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.78 2015/03/21 16:18:12 wiz Exp $
|
||||
|
||||
DISTNAME= pth-2.0.7
|
||||
PKGREVISION= 3
|
||||
PKGREVISION= 4
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=pth/}
|
||||
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.16 2010/08/06 19:21:26 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.17 2015/03/21 16:18:12 wiz Exp $
|
||||
|
||||
SHA1 (pth-2.0.7.tar.gz) = 9a71915c89ff2414de69fe104ae1016d513afeee
|
||||
RMD160 (pth-2.0.7.tar.gz) = 80bc66777ba20d9648b7aaf3f58d593be6416910
|
||||
Size (pth-2.0.7.tar.gz) = 652640 bytes
|
||||
SHA1 (patch-ab) = 8495e25d31dadc9f0b56e48950eecf3e895a9f30
|
||||
SHA1 (patch-ac) = d3683f603c3e4f1826b55967639823b3295d1fb7
|
||||
SHA1 (patch-ad) = e93bd19c9f66e78d5d91dcb9dd3096bdc5d5b092
|
||||
SHA1 (patch-ad) = ddabeeff5bab8b580904861ea5437ed8f24f3965
|
||||
SHA1 (patch-ae) = 97e9546ce894a100b889dfacbd19e6c1cc1de87f
|
||||
SHA1 (patch-af) = 13aba228b9e8d8bedeac4018073c4fa5b3652caf
|
||||
SHA1 (patch-ag) = 66ba441a4efc85af4ef498d846d7ebc1115f3dcc
|
||||
|
|
|
@ -1,4 +1,6 @@
|
|||
$NetBSD: patch-ad,v 1.6 2007/02/18 11:40:10 wiz Exp $
|
||||
$NetBSD: patch-ad,v 1.7 2015/03/21 16:18:12 wiz Exp $
|
||||
|
||||
Fix syscall names on NetBSD.
|
||||
|
||||
--- pth_syscall.c.orig 2006-06-08 17:54:03.000000000 +0000
|
||||
+++ pth_syscall.c
|
||||
|
@ -18,7 +20,7 @@ $NetBSD: patch-ad,v 1.6 2007/02/18 11:40:10 wiz Exp $
|
|||
|
||||
/* internal data structures */
|
||||
#if cpp
|
||||
@@ -157,13 +159,18 @@ intern pth_syscall_fct_tab_t pth_syscall
|
||||
@@ -157,15 +159,28 @@ intern pth_syscall_fct_tab_t pth_syscall
|
||||
#define PTH_SCF_sendto 19
|
||||
#define PTH_SCF_pread 20
|
||||
#define PTH_SCF_pwrite 21
|
||||
|
@ -26,7 +28,11 @@ $NetBSD: patch-ad,v 1.6 2007/02/18 11:40:10 wiz Exp $
|
|||
{ "fork", NULL },
|
||||
{ "waitpid", NULL },
|
||||
{ "system", NULL },
|
||||
+#if defined(__NetBSD__) && defined(SYS___nanosleep50)
|
||||
+ { "__nanosleep50", NULL },
|
||||
+#else
|
||||
{ "nanosleep", NULL },
|
||||
+#endif
|
||||
{ "usleep", NULL },
|
||||
{ "sleep", NULL },
|
||||
+#if defined(__NetBSD__)
|
||||
|
@ -35,26 +41,47 @@ $NetBSD: patch-ad,v 1.6 2007/02/18 11:40:10 wiz Exp $
|
|||
{ "sigprocmask", NULL },
|
||||
+#endif
|
||||
{ "sigwait", NULL },
|
||||
+#if defined(__NetBSD__) && defined(SYS___select50)
|
||||
+ { "__select50", NULL },
|
||||
+#else
|
||||
{ "select", NULL },
|
||||
+#endif
|
||||
{ "poll", NULL },
|
||||
@@ -179,6 +186,7 @@ intern pth_syscall_fct_tab_t pth_syscall
|
||||
{ "connect", NULL },
|
||||
{ "accept", NULL },
|
||||
@@ -179,6 +194,11 @@ intern pth_syscall_fct_tab_t pth_syscall
|
||||
{ "sendto", NULL },
|
||||
{ "pread", NULL },
|
||||
{ "pwrite", NULL },
|
||||
+#if defined(__NetBSD__) && defined(SYS___wait450)
|
||||
+ { "__wait450", NULL },
|
||||
+#else
|
||||
+ { "wait4", NULL },
|
||||
+#endif
|
||||
{ NULL, NULL }
|
||||
};
|
||||
#endif
|
||||
@@ -405,6 +413,8 @@ intern pid_t pth_sc_waitpid(pid_t wpid,
|
||||
@@ -405,6 +425,10 @@ intern pid_t pth_sc_waitpid(pid_t wpid,
|
||||
(wpid, status, options);
|
||||
#if defined(HAVE_SYSCALL) && defined(SYS_waitpid)
|
||||
else return (pid_t)syscall(SYS_waitpid, wpid, status, options);
|
||||
+#elif defined(HAVE_SYSCALL) && defined(SYS_wait4)
|
||||
+ else return (pid_t)syscall(SYS_wait4, wpid, status, options, (struct rusage *) NULL);
|
||||
+#elif defined(HAVE_SYSCALL) && defined(SYS___wait450)
|
||||
+ else return (pid_t)syscall(SYS___wait450, wpid, status, options, (struct rusage *) NULL);
|
||||
#else
|
||||
else PTH_SYSCALL_ERROR(-1, ENOSYS, "waitpid");
|
||||
#endif
|
||||
@@ -721,5 +731,27 @@ intern ssize_t pth_sc_sendto(int fd, con
|
||||
@@ -491,6 +515,8 @@ intern int pth_sc_select(int nfds, fd_se
|
||||
else return (int)syscall(SYS__newselect, nfds, readfds, writefds, exceptfds, timeout);
|
||||
#elif defined(HAVE_SYSCALL) && defined(SYS_select)
|
||||
else return (int)syscall(SYS_select, nfds, readfds, writefds, exceptfds, timeout);
|
||||
+#elif defined(HAVE_SYSCALL) && defined(SYS___select50)
|
||||
+ else return (int)syscall(SYS___select50, nfds, readfds, writefds, exceptfds, timeout);
|
||||
#else
|
||||
else PTH_SYSCALL_ERROR(-1, ENOSYS, "accept");
|
||||
#endif
|
||||
@@ -721,5 +747,29 @@ intern ssize_t pth_sc_sendto(int fd, con
|
||||
#endif
|
||||
}
|
||||
|
||||
|
@ -75,6 +102,8 @@ $NetBSD: patch-ad,v 1.6 2007/02/18 11:40:10 wiz Exp $
|
|||
+ (wpid, status, options, rusage);
|
||||
+#if defined(HAVE_SYSCALL) && defined(SYS_wait4)
|
||||
+ else return (pid_t)syscall(SYS_wait4, wpid, status, options, rusage);
|
||||
+#elif defined(HAVE_SYSCALL) && defined(SYS___wait450)
|
||||
+ else return (pid_t)syscall(SYS___wait450, wpid, status, options, rusage);
|
||||
+#else
|
||||
+ else PTH_SYSCALL_ERROR(-1, ENOSYS, "wait4");
|
||||
+#endif
|
||||
|
|
Loading…
Reference in a new issue