Make configure detect libMesaGL correctly.
This commit is contained in:
parent
c752f6b81d
commit
07dc306a00
2 changed files with 42 additions and 1 deletions
|
@ -1,4 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/02/14 23:56:39 hubertf Exp $
|
||||
$NetBSD: distinfo,v 1.2 2004/12/28 15:00:50 wiz Exp $
|
||||
|
||||
SHA1 (bezier-0.0.3.tar.gz) = 682c634a02943add289de0e0a5ea60de4640babc
|
||||
Size (bezier-0.0.3.tar.gz) = 129507 bytes
|
||||
SHA1 (patch-aa) = 1c84d71205e5903de83a670d3057b16edf2cfd12
|
||||
|
|
40
audio/xmms-bezier/patches/patch-aa
Normal file
40
audio/xmms-bezier/patches/patch-aa
Normal file
|
@ -0,0 +1,40 @@
|
|||
$NetBSD: patch-aa,v 1.1 2004/12/28 15:00:50 wiz Exp $
|
||||
|
||||
--- configure.orig 2004-12-28 15:55:24.000000000 +0100
|
||||
+++ configure
|
||||
@@ -3308,7 +3308,7 @@ if eval "test \"`echo '$''{'ac_cv_lib_$a
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="-lMesaGL $LIBS"
|
||||
+LIBS="-lMesaGL -lXext $LIBS"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 3314 "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -3336,7 +3336,7 @@ LIBS="$ac_save_LIBS"
|
||||
fi
|
||||
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
echo "$ac_t""yes" 1>&6
|
||||
- OPENGL_LIBS="-lMesaGL"
|
||||
+ OPENGL_LIBS="-lMesaGL -lXext"
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
{ echo "configure: error: *** OpenGL libs not found - please install first ***" 1>&2; exit 1; }
|
||||
@@ -3422,7 +3422,7 @@ if eval "test \"`echo '$''{'ac_cv_lib_$a
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="-lMesaGLU $LIBS"
|
||||
+LIBS="-lMesaGLU -lXext $LIBS"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 3428 "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -3453,7 +3453,7 @@ if eval "test \"`echo '$ac_cv_lib_'$ac_l
|
||||
cat >> confdefs.h <<\EOF
|
||||
#define HAVE_GLU 1
|
||||
EOF
|
||||
- OPENGL_LIBS="$OPENGL_LIBS -l MesaGLU"
|
||||
+ OPENGL_LIBS="$OPENGL_LIBS -lMesaGLU -lXext"
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
fi
|
Loading…
Reference in a new issue