Add workaround for lack of fmax/fmin on NetBSD<6.
This commit is contained in:
parent
ed61570860
commit
07e4d9f3cd
2 changed files with 18 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.55 2010/07/14 17:04:22 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.56 2010/07/15 04:33:49 obache Exp $
|
||||
|
||||
SHA1 (poppler-0.14.1.tar.gz) = 28229f897451feba5682d74defe7d67361eeee11
|
||||
RMD160 (poppler-0.14.1.tar.gz) = 7b8d084b05ccc374e9add9771b781a88948907a7
|
||||
|
@ -10,3 +10,4 @@ SHA1 (patch-ag) = 7ef9ccdb1a6719510c6941864b8c7db3cc0255f1
|
|||
SHA1 (patch-ai) = a51dba3fb0e7131873ef82ae5e256fb1d17cee53
|
||||
SHA1 (patch-ao) = cf7e0f086522147a91f59b1b26ca510d1971ac74
|
||||
SHA1 (patch-ap) = fc985510d4ebabe097e55bc4cbb0477267e95a7d
|
||||
SHA1 (patch-aq) = e5dd7a45a2775c62b02d5d5b2fbf03a1f029fa8d
|
||||
|
|
16
print/poppler/patches/patch-aq
Normal file
16
print/poppler/patches/patch-aq
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-aq,v 1.1 2010/07/15 04:33:49 obache Exp $
|
||||
|
||||
--- poppler/TextOutputDev.cc.orig 2010-06-08 20:06:31.000000000 +0000
|
||||
+++ poppler/TextOutputDev.cc
|
||||
@@ -63,6 +63,11 @@
|
||||
#include "ICSupport.h"
|
||||
#endif
|
||||
|
||||
+#if !(defined(__DragonFly__) && __DragonFly_version >= 200204) && !(defined(__NetBSD) && __NetBSD_Version >= 599002100)
|
||||
+static double fmax(double x, double y) { if (isnan(x)) return y; if (isnan(y)) return x; return (x > y ? x : y);}
|
||||
+static double fmin(double x, double y) { if (isnan(x)) return y; if (isnan(y)) return x; return (x < y ? x : y);}
|
||||
+#endif
|
||||
+
|
||||
//------------------------------------------------------------------------
|
||||
// parameters
|
||||
//------------------------------------------------------------------------
|
Loading…
Reference in a new issue