Import new "kxicq" package:
KDE ICQ client
This commit is contained in:
parent
8fab5a14eb
commit
0811fc9be1
7 changed files with 168 additions and 0 deletions
28
net/kxicq/Makefile
Normal file
28
net/kxicq/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2000/07/06 16:51:23 tron Exp $
|
||||
|
||||
DISTNAME= kxicq-03132000
|
||||
CATEGORIES= net kde
|
||||
MASTER_SITES= http://download.sourceforge.net/kxicq/
|
||||
|
||||
MAINTAINER= tron@netbsd.org
|
||||
HOMEPAGE= http://www.kxicq.org/
|
||||
|
||||
DEPENDS+= esound>=0.2.7:../../audio/esound
|
||||
DEPENDS+= kdebase-1.1.2:../../x11/kdebase
|
||||
|
||||
USE_X11BASE= yes
|
||||
USE_GMAKE= yes
|
||||
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --datadir=${PREFIX}/share/kde \
|
||||
--with-qt-dir=${X11BASE}/qt1
|
||||
CONFIGURE_ENV+= KDEDIR=${PREFIX} \
|
||||
CPPFLAGS="${CPPFLAGS}" \
|
||||
CXXFLAGS="${CFLAGS}" \
|
||||
all_libraries="-Wl,-R${X11BASE}/qt1/lib -L${LOCALBASE}/lib -Wl,-R${LOCALBASE}/lib -L${X11BASE}/lib -Wl,-R${X11BASE}/lib -ltiff -ljpeg -lpng -lz"
|
||||
|
||||
post-extract:
|
||||
@${RM} -fr ${WRKSRC}/kxicq/ltdl
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
net/kxicq/files/md5
Normal file
3
net/kxicq/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2000/07/06 16:51:23 tron Exp $
|
||||
|
||||
MD5 (kxicq-03132000.tar.gz) = 0690a43dad83d89bbdff7c4143386300
|
3
net/kxicq/files/patch-sum
Normal file
3
net/kxicq/files/patch-sum
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2000/07/06 16:51:23 tron Exp $
|
||||
|
||||
MD5 (patch-aa) = 738273cfbe2256c24f3a4faffb7c6f20
|
42
net/kxicq/patches/patch-aa
Normal file
42
net/kxicq/patches/patch-aa
Normal file
|
@ -0,0 +1,42 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2000/07/06 16:51:23 tron Exp $
|
||||
|
||||
--- kxicq/Makefile.in.orig Mon Mar 13 12:43:21 2000
|
||||
+++ kxicq/Makefile.in Thu Jul 6 18:13:46 2000
|
||||
@@ -165,14 +165,14 @@
|
||||
x_includes = @x_includes@
|
||||
x_libraries = @x_libraries@
|
||||
|
||||
-SUBDIRS = ltdl checklistbox kconfigdlg dialogs STabCtl DockWidget
|
||||
+SUBDIRS = checklistbox kconfigdlg dialogs STabCtl DockWidget
|
||||
bin_PROGRAMS = kxicq
|
||||
|
||||
kxicq_LDFLAGS = $(all_libraries)
|
||||
-kxicq_LDADD = $(top_srcdir)/kxicq/DockWidget/libDockWidget.a $(top_srcdir)/kxicq/STabCtl/libSTabCtl.a $(top_srcdir)/kxicq/dialogs/libdialogs.a $(top_srcdir)/kxicq/kconfigdlg/libkconfigdlg.a $(top_srcdir)/kxicq/checklistbox/libchecklistbox.a $(top_srcdir)/kxicq/ltdl/libltdl.a $(LIB_KFILE) $(LIB_KHTMLW) $(LIB_MEDIATOOL) $(LIB_KDEUI) $(LIB_KIMGIO) $(XPMLIB) $(LIBDL)
|
||||
+kxicq_LDADD = $(top_srcdir)/kxicq/DockWidget/libDockWidget.a $(top_srcdir)/kxicq/STabCtl/libSTabCtl.a $(top_srcdir)/kxicq/dialogs/libdialogs.a $(top_srcdir)/kxicq/kconfigdlg/libkconfigdlg.a $(top_srcdir)/kxicq/checklistbox/libchecklistbox.a $(LOCALBASE)/lib/libltdl.a $(LIB_KFILE) $(LIB_KHTMLW) $(LIB_MEDIATOOL) $(LIB_KDEUI) $(LIB_KIMGIO) $(XPMLIB) $(LIBDL)
|
||||
|
||||
LDFLAGS = -export-dynamic
|
||||
-INCLUDES = $(all_includes) -I$(top_srcdir)/ -I$(top_srcdir)/kxicq -I$(top_srcdir)/kxicq/ltdl -I$(top_srcdir)/kxicq/checklistbox -I$(top_srcdir)/kxicq/kconfigdlg -I$(top_srcdir)/kxicq/dialogs -I$(top_srcdir)/kxicq/STabCtl -I$(top_srcdir)/kxicq/DockWidget
|
||||
+INCLUDES = $(all_includes) -I$(top_srcdir)/ -I$(top_srcdir)/kxicq -I$(LOCALBASE)/include -I$(top_srcdir)/kxicq/checklistbox -I$(top_srcdir)/kxicq/kconfigdlg -I$(top_srcdir)/kxicq/dialogs -I$(top_srcdir)/kxicq/STabCtl -I$(top_srcdir)/kxicq/DockWidget
|
||||
|
||||
DEFS = -I. -I$(srcdir) -I$(top_srcdir)
|
||||
kxicq_METASOURCES = MotifDNDHandler.moc.cpp kstartuplogo.moc.cpp kxapplication.moc.cpp kxchat.moc.cpp kxchat2.moc.cpp kxchatrequest.moc.cpp kxcontact.moc.cpp kxcontactview.moc.cpp kxcontactviewwidget.moc.cpp kxdocking.moc.cpp kxfile.moc.cpp kxhistoryview.moc.cpp kxincomingview.moc.cpp kxinputdialog.moc.cpp kxmainwindow.moc.cpp kxmessagehistory.moc.cpp kxmledit.moc.cpp kxnickcomplete.moc.cpp kxpopupmenu.moc.cpp kxsend.moc.cpp kxsock.moc.cpp kxtcp.moc.cpp kxudp.moc.cpp kxuseronline.moc.cpp kxutil.moc.cpp kxwidgets.moc.cpp
|
||||
@@ -202,8 +202,7 @@
|
||||
$(top_srcdir)/kxicq/STabCtl/libSTabCtl.a \
|
||||
$(top_srcdir)/kxicq/dialogs/libdialogs.a \
|
||||
$(top_srcdir)/kxicq/kconfigdlg/libkconfigdlg.a \
|
||||
-$(top_srcdir)/kxicq/checklistbox/libchecklistbox.a \
|
||||
-$(top_srcdir)/kxicq/ltdl/libltdl.a
|
||||
+$(top_srcdir)/kxicq/checklistbox/libchecklistbox.a
|
||||
CXXFLAGS = @CXXFLAGS@
|
||||
CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
|
||||
LTCXXCOMPILE = $(LIBTOOL) --mode=compile $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
|
||||
@@ -652,8 +651,7 @@
|
||||
kxcontactviewlist.h messagecount.h kxdocking.h kxtcp.h
|
||||
kxpacket.o: kxpacket.cpp kxpacket.h kxsock.h
|
||||
kxpluginmanager.o: kxpluginmanager.cpp kxpluginmanager.h kxplugin.h \
|
||||
- kconfigdlg/kconfigdlg.h kconfigdlg/kconfigitem.h ../config.h \
|
||||
- ltdl/ltdl.h
|
||||
+ kconfigdlg/kconfigdlg.h kconfigdlg/kconfigitem.h ../config.h
|
||||
kxplugin.o: kxplugin.cpp kxplugin.h kconfigdlg/kconfigdlg.h \
|
||||
kconfigdlg/kconfigitem.h
|
||||
kxpopupmenu.moc.o: kxpopupmenu.moc.cpp kxpopupmenu.h ../config.h
|
1
net/kxicq/pkg/COMMENT
Normal file
1
net/kxicq/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
KDE ICQ client
|
7
net/kxicq/pkg/DESCR
Normal file
7
net/kxicq/pkg/DESCR
Normal file
|
@ -0,0 +1,7 @@
|
|||
kicq is an KDE/Qt based clone which very closely resembles Mirabilis
|
||||
ICQ. This client allows you to send and recieve messages, search for
|
||||
users and add them to your contact list, as well as configure it from
|
||||
within the GUI. In addition to the other features it also implements
|
||||
the user search function, and makes use of a preferences dialog, so
|
||||
user info can be edited within the program itself. kicq is in the beta
|
||||
stage and therefore does not have all of the features of ICQ.
|
84
net/kxicq/pkg/PLIST
Normal file
84
net/kxicq/pkg/PLIST
Normal file
|
@ -0,0 +1,84 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2000/07/06 16:51:23 tron Exp $
|
||||
bin/kxicq
|
||||
lib/kxicq/plugins/libesound.a
|
||||
lib/kxicq/plugins/libesound.la
|
||||
lib/kxicq/plugins/libesound.so.0.1
|
||||
lib/kxicq/plugins/liblastOnline.a
|
||||
lib/kxicq/plugins/liblastOnline.la
|
||||
lib/kxicq/plugins/liblastOnline.so.0.1
|
||||
lib/kxicq/plugins/librussianConverter.a
|
||||
lib/kxicq/plugins/librussianConverter.la
|
||||
lib/kxicq/plugins/librussianConverter.so.0.1
|
||||
share/doc/kde/HTML/en/kxicq/index-1.html
|
||||
share/doc/kde/HTML/en/kxicq/index-2.html
|
||||
share/doc/kde/HTML/en/kxicq/index-3.html
|
||||
share/doc/kde/HTML/en/kxicq/index-4.html
|
||||
share/doc/kde/HTML/en/kxicq/index-5.html
|
||||
share/doc/kde/HTML/en/kxicq/index-6.html
|
||||
share/doc/kde/HTML/en/kxicq/index-7.html
|
||||
share/doc/kde/HTML/en/kxicq/index.html
|
||||
share/doc/kde/HTML/en/kxicq/index.sgml
|
||||
share/doc/kde/HTML/en/kxicq/layout_default.gif
|
||||
share/doc/kde/HTML/en/kxicq/registration-1.html
|
||||
share/doc/kde/HTML/en/kxicq/registration-2-KXicq.html
|
||||
share/doc/kde/HTML/en/kxicq/registration-3.html
|
||||
share/doc/kde/HTML/en/kxicq/registration-4.html
|
||||
share/doc/kde/HTML/en/kxicq/registration-5.html
|
||||
share/kde/applnk/Applications/kxicq.kdelnk
|
||||
share/kde/apps/kxicq/icons/default/available.xpm
|
||||
share/kde/apps/kxicq/icons/default/away.xpm
|
||||
share/kde/apps/kxicq/icons/default/dnd.xpm
|
||||
share/kde/apps/kxicq/icons/default/exit.xpm
|
||||
share/kde/apps/kxicq/icons/default/ffc.xpm
|
||||
share/kde/apps/kxicq/icons/default/history.xpm
|
||||
share/kde/apps/kxicq/icons/default/invisible.xpm
|
||||
share/kde/apps/kxicq/icons/default/na.xpm
|
||||
share/kde/apps/kxicq/icons/default/newmsg.xpm
|
||||
share/kde/apps/kxicq/icons/default/occupied.xpm
|
||||
share/kde/apps/kxicq/icons/default/offline.xpm
|
||||
share/kde/apps/kxicq/icons/default/online.xpm
|
||||
share/kde/apps/kxicq/icons/default/selectcolor.xpm
|
||||
share/kde/apps/kxicq/icons/default/selecttext.xpm
|
||||
share/kde/apps/kxicq/icons/default/send.xpm
|
||||
share/kde/apps/kxicq/icons/icq/available.xpm
|
||||
share/kde/apps/kxicq/icons/icq/away.xpm
|
||||
share/kde/apps/kxicq/icons/icq/dnd.xpm
|
||||
share/kde/apps/kxicq/icons/icq/exit.xpm
|
||||
share/kde/apps/kxicq/icons/icq/ffc.xpm
|
||||
share/kde/apps/kxicq/icons/icq/history.xpm
|
||||
share/kde/apps/kxicq/icons/icq/invisible.xpm
|
||||
share/kde/apps/kxicq/icons/icq/na.xpm
|
||||
share/kde/apps/kxicq/icons/icq/newmsg.xpm
|
||||
share/kde/apps/kxicq/icons/icq/occupied.xpm
|
||||
share/kde/apps/kxicq/icons/icq/offline.xpm
|
||||
share/kde/apps/kxicq/icons/icq/online.xpm
|
||||
share/kde/apps/kxicq/icons/icq/selectcolor.xpm
|
||||
share/kde/apps/kxicq/icons/icq/selecttext.xpm
|
||||
share/kde/apps/kxicq/icons/icq/send.xpm
|
||||
share/kde/apps/kxicq/pics/startlogo.bmp
|
||||
share/kde/apps/kxicq/skins/computer/Frame.xpm
|
||||
share/kde/apps/kxicq/skins/computer/MenuButtonDown.xpm
|
||||
share/kde/apps/kxicq/skins/computer/MenuButtonUp.xpm
|
||||
share/kde/apps/kxicq/skins/computer/computer.kxskin
|
||||
share/kde/apps/kxicq/skins/computer/field.xpm
|
||||
share/kde/apps/kxicq/utils/pine.kxutil
|
||||
share/kde/apps/kxicq/utils/ping.kxutil
|
||||
share/kde/apps/kxicq/wavs/message.wav
|
||||
share/kde/locale/de/LC_MESSAGES/kxicq.mo
|
||||
share/kde/locale/hr/LC_MESSAGES/kxicq.mo
|
||||
share/kde/locale/it/LC_MESSAGES/kxicq.mo
|
||||
share/kde/locale/ja/LC_MESSAGES/kxicq.mo
|
||||
share/kde/locale/nl/LC_MESSAGES/kxicq.mo
|
||||
share/kde/locale/sv/LC_MESSAGES/kxicq.mo
|
||||
@dirrm share/kde/apps/kxicq/wavs
|
||||
@dirrm share/kde/apps/kxicq/utils
|
||||
@dirrm share/kde/apps/kxicq/skins/computer
|
||||
@dirrm share/kde/apps/kxicq/skins
|
||||
@dirrm share/kde/apps/kxicq/pics
|
||||
@dirrm share/kde/apps/kxicq/icons/icq
|
||||
@dirrm share/kde/apps/kxicq/icons/default
|
||||
@dirrm share/kde/apps/kxicq/icons
|
||||
@dirrm share/kde/apps/kxicq
|
||||
@dirrm share/doc/kde/HTML/en/kxicq
|
||||
@dirrm lib/kxicq/plugins
|
||||
@dirrm lib/kxicq
|
Loading…
Reference in a new issue