Only create one directory per invocation of install(1), and run the Crack

script with ${SH} instead of /bin/sh since some OSes have dumb /bin/sh,
e.g. Solaris.  From pkg/22914 by Jonathan Perkin.
This commit is contained in:
jlam 2003-10-06 08:19:45 +00:00
parent d151742e36
commit 083b97acdf
3 changed files with 22 additions and 16 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.14 2003/07/17 22:52:52 grant Exp $
# $NetBSD: Makefile,v 1.15 2003/10/06 08:19:45 jlam Exp $
# FreeBSD Id: ports/security/crack/Makefile,v 1.11 1999/09/04 19:24:50 obrien Exp
DISTNAME= crack5.0
@ -21,12 +21,12 @@ pre-build:
${ECHO_MSG} "You may want to install the dict distribution into /usr/share/dict" ; \
${ECHO_MSG} "to increase the size of the cracking dictionary." ; \
fi)
@${SED} 's|@@PREFIX@@|${PREFIX}|g' < ${WRKSRC}/Crack > ${WRKSRC}/Crack.new
@${SED} 's|@@PREFIX@@|${PREFIX}|g;s|@@SH@@|${SH}|g' < ${WRKSRC}/Crack > ${WRKSRC}/Crack.new
@${RM} -f ${WRKSRC}/Crack && ${MV} ${WRKSRC}/Crack.new ${WRKSRC}/Crack
@${CHMOD} a+rx ${WRKSRC}/Crack
do-build:
(cd ${WRKSRC} ; ./Crack -makeonly)
cd ${WRKSRC} ; ./Crack -makeonly
do-install:
@${INSTALL_DATA_DIR} ${PREFIX}/libexec/crack
@ -35,12 +35,12 @@ do-install:
@${CHMOD} go-rwx ${PREFIX}/share/crack
@${INSTALL_DATA_DIR} ${PREFIX}/share/crack/dict
@${INSTALL_DATA_DIR} ${PREFIX}/share/doc/crack
@${INSTALL_DATA_DIR} ${PREFIX}/share/crack/extra \
${PREFIX}/share/crack/run
@${INSTALL_DATA_DIR} ${PREFIX}/share/crack/extra
@${INSTALL_DATA_DIR} ${PREFIX}/share/crack/run
@${INSTALL_DATA_DIR} ${PREFIX}/share/crack/scripts
@${INSTALL_DATA_DIR} ${PREFIX}/share/crack/dict/1\
${PREFIX}/share/crack/dict/2 \
${PREFIX}/share/crack/dict/3
@${INSTALL_DATA_DIR} ${PREFIX}/share/crack/dict/1
@${INSTALL_DATA_DIR} ${PREFIX}/share/crack/dict/2
@${INSTALL_DATA_DIR} ${PREFIX}/share/crack/dict/3
@${INSTALL_DATA_DIR} ${PREFIX}/share/crack/run
@${INSTALL_DATA_DIR} ${PREFIX}/crack/run/dict
${INSTALL_SCRIPT} ${WRKSRC}/Crack ${PREFIX}/sbin
@ -207,6 +207,6 @@ do-install:
done
post-install:
(${PREFIX}/sbin/Crack -makedict)
${PREFIX}/sbin/Crack -makedict
.include "../../mk/bsd.pkg.mk"

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.3 2003/07/02 17:33:17 jmmv Exp $
$NetBSD: distinfo,v 1.4 2003/10/06 08:19:45 jlam Exp $
SHA1 (crack5.0.tar.gz) = e5e59d1e5e9e42c816a4dbd3f24cc13e16a31365
Size (crack5.0.tar.gz) = 2964507 bytes
SHA1 (patch-aa) = 014a04ba7aa50f8514d5219a3269feeccc684708
SHA1 (patch-aa) = e05ef9f571f7e695790eb7a350f2eb320d68569e
SHA1 (patch-ab) = a60df3b47288abf28e44400e4035580da765e279
SHA1 (patch-ac) = efa6903c59be394db1282d0760d55953a955e1ee
SHA1 (patch-ad) = 49387a2aa147ff543d57e660dbe0d8b2861d8f52

View file

@ -1,7 +1,13 @@
$NetBSD: patch-aa,v 1.2 2003/07/02 17:33:18 jmmv Exp $
$NetBSD: patch-aa,v 1.3 2003/10/06 08:19:45 jlam Exp $
--- Crack.orig Sat Dec 21 02:09:41 1996
+++ Crack Sat Oct 2 19:53:07 1999
--- Crack.orig Fri Dec 20 17:09:41 1996
+++ Crack
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!@@SH@@
###
# This program was written by and is copyright Alec Muffett 1991,
# 1992, 1993, 1994, 1995, and 1996, and is provided as part of the
@@ -12,8 +12,8 @@
# User-configurable junk for Crack
###
@ -13,7 +19,7 @@ $NetBSD: patch-aa,v 1.2 2003/07/02 17:33:18 jmmv Exp $
# compiler options for crack 5.0
#
@@ -108,41 +108,11 @@
@@ -108,41 +108,11 @@ node=`uname -n`
# home base
###
@ -57,7 +63,7 @@ $NetBSD: patch-aa,v 1.2 2003/07/02 17:33:18 jmmv Exp $
###
# Flagwaving
@@ -279,110 +249,76 @@
@@ -279,110 +249,76 @@ fi
# Sanity test bindir - written in gruntscript for clarity.
###