Fix freetype2-2.2.1 breakage.

This commit is contained in:
wiz 2006-06-15 12:24:12 +00:00
parent ec5e4d7698
commit 086a53e0f8
2 changed files with 35 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.17 2006/03/12 12:30:05 wiz Exp $
$NetBSD: distinfo,v 1.18 2006/06/15 12:24:12 wiz Exp $
SHA1 (wesnoth-1.0.2.tar.gz) = c2313242615b79249f26371bd7c410e8385adc0a
RMD160 (wesnoth-1.0.2.tar.gz) = 20ba5be7078224f65a37d268eaf95be79e0e57c2
Size (wesnoth-1.0.2.tar.gz) = 40034289 bytes
SHA1 (patch-aa) = 28e6a2e8171336fb0f798b2f28ced9152e1678ae
SHA1 (patch-ab) = 6e7414a0fcdb5b0b306e7cf4a62383bfdc0f1fa5

View file

@ -0,0 +1,33 @@
$NetBSD: patch-ab,v 1.3 2006/06/15 12:24:12 wiz Exp $
From
http://www.freetype.org/freetype2/patches/SDL_ttf-2.0.7-noftinternals.patch
--- src/sdl_ttf/SDL_ttf.c.orig 2005-09-21 00:35:47.000000000 +0000
+++ src/sdl_ttf/SDL_ttf.c
@@ -43,16 +43,6 @@
#include FT_FREETYPE_H
#include FT_OUTLINE_H
#include FT_TRUETYPE_IDS_H
-/*
-#include <freetype/freetype.h>
-#include <freetype/ftoutln.h>
-#include <freetype/ttnameid.h>
-*/
-#include <freetype/internal/ftobjs.h>
-
-#ifndef FT_OPEN_STREAM
-#define FT_OPEN_STREAM ft_open_stream
-#endif
#include "SDL.h"
#include "SDL_endian.h"
@@ -282,7 +272,7 @@ TTF_Font* TTF_OpenFontIndexRW( SDL_RWops
}
memset(stream, 0, sizeof(*stream));
- stream->memory = library->memory;
+ stream->memory = NULL; /* set by FT_Open_Face */
stream->read = RWread;
stream->descriptor.pointer = src;
stream->pos = (unsigned long)position;