Update bzip2 to 1.0.2

A bug fix release, addressing various minor issues.

* Fix an infinite segfault loop in 1.0.1 when a directory is encountered
  in -f (force) mode.
* Avoid double fclose() of output file on certain I/O error paths.
* Don't fail with internal error 1007 when fed a long stream (> 48MB)
  of byte 251.  Also print useful message suggesting that 1007s may be
  caused by bad memory.
* Fix uninitialised variable silly bug in demo prog dlltest.c.
* Remove 512-MB limitation on recovered file size for bzip2recover
  on selected platforms which support 64-bit ints.
* Copy file access times correctly.
* Dereference symlinks when copying file permissions in -f mode.
* Majorly simplify implementation of uInt64_qrm10.
* Check the input file still exists before deleting the output one,
  when aborting in cleanUpAndFail().
* Wrapper scripts (with manpages): bzdiff, bzgrep, bzmore.
* Spelling changes and minor enhancements in bzip2.1.
* Avoid race condition between creating the output file and setting its
  interim permissions safely, by using fopen_output_safely().
* do not print senseless report with -v when compressing an empty file.
* bzcat -f works on non-bzip2 files.
* do not try to escape shell meta-characters on unix (the shell takes
  care of these).
* added --fast and --best aliases for -1 -9 for gzip compatibility.
This commit is contained in:
mjl 2002-03-24 14:02:35 +00:00
parent 5ef7d0f9e5
commit 0890bdc2cc
3 changed files with 35 additions and 33 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.17 2001/06/21 22:36:54 jlam Exp $
# $NetBSD: Makefile,v 1.18 2002/03/24 14:02:35 mjl Exp $
#
DISTNAME= bzip2-1.0.1
DISTNAME= bzip2-1.0.2
CATEGORIES= archivers
MASTER_SITES= ftp://sourceware.cygnus.com/pub/bzip2/v100/
MASTER_SITES= ftp://sourceware.cygnus.com/pub/bzip2/v102/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://sourceware.cygnus.com/bzip2/

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.5 2001/07/14 03:51:13 jlam Exp $
$NetBSD: distinfo,v 1.6 2002/03/24 14:02:36 mjl Exp $
SHA1 (bzip2-1.0.1.tar.gz) = 0a5a71eded51be0c15d9532b44060f61b564d4f5
Size (bzip2-1.0.1.tar.gz) = 464991 bytes
SHA1 (patch-aa) = 010dfa45e9ca95c3ea8e80253de2098beee3f847
SHA1 (bzip2-1.0.2.tar.gz) = d47793959c0d65a4d7246e0247ed1358662d9ebf
Size (bzip2-1.0.2.tar.gz) = 665198 bytes
SHA1 (patch-aa) = 41c6eb68818a6d2e81ea53830727fe421fcae125

View file

@ -1,20 +1,31 @@
$NetBSD: patch-aa,v 1.4 2001/07/14 03:51:14 jlam Exp $
$NetBSD: patch-aa,v 1.5 2002/03/24 14:02:36 mjl Exp $
--- Makefile.orig Fri Jun 23 16:34:47 2000
+++ Makefile Fri Jul 13 23:48:52 2001
@@ -1,8 +1,9 @@
--- Makefile.orig Sat Jan 26 00:34:53 2002
+++ Makefile Sun Mar 24 14:56:33 2002
@@ -2,18 +2,15 @@
SHELL=/bin/sh
# To assist in cross-compiling
-CC=gcc
+CC=${LIBTOOL} ${REALCC}
+LD=${LIBTOOL} ${REALCC}
AR=ar
RANLIB=ranlib
-LDFLAGS=
+LDFLAGS+=
# Suitably paranoid flags to avoid bugs in gcc-2.7
BIGFILES=-D_FILE_OFFSET_BITS=64
-CFLAGS=-Wall -Winline -O2 -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
-
-# Where you want it installed when you do 'make install'
-PREFIX=/usr
-
+CFLAGS+=-Wall -Winline -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
OBJS= blocksort.o \
huffman.o \
@@ -12,22 +13,18 @@
@@ -23,22 +20,18 @@
decompress.o \
bzlib.o
@ -22,35 +33,26 @@ $NetBSD: patch-aa,v 1.4 2001/07/14 03:51:14 jlam Exp $
+all: libbz2.la bzip2 bzip2recover test
-bzip2: libbz2.a bzip2.o
- $(CC) $(CFLAGS) -o bzip2 bzip2.o -L. -lbz2
- $(CC) $(CFLAGS) $(LDFLAGS) -o bzip2 bzip2.o -L. -lbz2
+bzip2: libbz2.la bzip2.o
+ $(CC) $(CFLAGS) -static -o bzip2 bzip2.o libbz2.la
+ $(CC) $(CFLAGS) $(LDFLAGS) -static -o bzip2 bzip2.o libbz2.la
bzip2recover: bzip2recover.o
- $(CC) $(CFLAGS) -o bzip2recover bzip2recover.o
+ $(CC) $(CFLAGS) -static -o bzip2recover bzip2recover.o
- $(CC) $(CFLAGS) $(LDFLAGS) -o bzip2recover bzip2recover.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -static -o bzip2recover bzip2recover.o
-libbz2.a: $(OBJS)
- rm -f libbz2.a
- ar cq libbz2.a $(OBJS)
- @if ( test -f /usr/bin/ranlib -o -f /bin/ranlib -o \
- -f /usr/ccs/bin/ranlib ) ; then \
- echo ranlib libbz2.a ; \
- ranlib libbz2.a ; \
- $(AR) cq libbz2.a $(OBJS)
- @if ( test -f $(RANLIB) -o -f /usr/bin/ranlib -o \
- -f /bin/ranlib -o -f /usr/ccs/bin/ranlib ) ; then \
- echo $(RANLIB) libbz2.a ; \
- $(RANLIB) libbz2.a ; \
- fi
+libbz2.la: $(OBJS)
+ rm -f libbz2.la
+ $(LD) $(LDFLAGS) -o libbz2.la $(OBJS:.o=.lo) -version-info 0:0 \
+ $(LD) $(LDFLAGS) -o libbz2.la $(OBJS:.o=.lo) -version-info 0:0 \
+ -rpath $(PREFIX)/lib
check: test
test: bzip2
@cat words1
@@ -44,8 +41,6 @@
cmp sample2.tst sample2.ref
cmp sample3.tst sample3.ref
@cat words3
-
-PREFIX=/usr
install: bzip2 bzip2recover
if ( test ! -d $(PREFIX)/bin ) ; then mkdir $(PREFIX)/bin ; fi