de to 1.6.0 from Anon Ymous

Changes since 1.1:

** gsasl: Add --no-cb to disable use of TLS channel bindings.
** build: Use silent build rules via automake.
    Use 'make V=99' to see the command lines used.
** Update gnulib files.
** gsasl: Support for TLS channel bindings.
    Requires GnuTLS 2.11.4 or later for the gnutls_session_channel_binding
    function.  Used by the SCRAM-SHA-1-PLUS mechanism.
** doc: Mention new property GSASL_CB_TLS_UNIQUE and SCRAM-SHA-1-PLUS.
** tests: Added self-tests for SCRAM-SHA-1-PLUS.
** gsasl: Avoid fixed size buffers.
    This caused problems on Windows where the BUFSIZ was too small for
    some line lengths with GS2-KRB5.
** tests: Fix error strings to be more unique.
** doc: Added section on how to build with MIT Kerberos for Windows.
** doc: Added PDF version of API reference manual.
    See doc/reference/gsasl.pdf.
** i18n: Updated translations.
    Thanks to Benno Schulenberg.
** doc: Explain GS2-related changes.
** doc: GTK-DOC manual improved.
    Now almost all symbols and types are explained.
** gsasl: Fix crash when getaddrinfo does not get a canonical name.
** gsasl: Improve error message when server rejects authentication.
** tests: Self checks are improved.
** gsasl: Improve application data throughput.
    Patch from Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> in
    <http://thread.gmane.org/gmane.comp.gnu.gsasl.general/256>.
** Improve MinGW builds.
** doc: Fix doc/cyclo/ output.
** tests/crypto: Also test newly added SHA-1 interfaces.
** tests/scram: Also test GSASL_SCRAM_SALTED_PASSWORD case.
    This code path triggered a crash in v1.3.
** i18n: Added Finnish translation.
    Thanks to Jorma Karvonen <karvonen.jorma@gmail.com>.
** Experimental support for SCRAM-SHA-1 added.
    Please test it but don't put it into production use, the RFC have not
    been finalized yet.  For this reason, the mechanism priority list is
    such that SCRAM-SHA-1 will never be selected over any other mechanism
    (including PLAIN, CRAM-MD5, and DIGEST-MD5).  When it has been tested
    further, we'll make SCRAM-SHA-1 the preferred mechanism after GSSAPI.
** gsasl: Fix libintl-related build errors on MinGW.
    Tiny patch from "carlo.bramix" <carlo.bramix@libero.it>.
** doc: Typo fixes to manual.
    Based on report by Marco Maggi <marco.maggi-ipsu@poste.it> in
    <http://thread.gmane.org/gmane.comp.gnu.gsasl.general/222>.
** tests: Rewrite basic self test using modern API.
** tests: New self-test 'crypto' to increase code coverage.
** gsasl: Fix out of bounds write when in IMAP/SMTP mode.
    Reported by Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> in
    <http://thread.gmane.org/gmane.comp.gnu.gsasl.general/230>.
** doc: Rewritten introduction material.
** doc: Improved sections for the info manual.
    We now follow the advice given by the texinfo manual on which
    directory categories to use.  In particular, libgsasl moved from the
    'GNU Libraries' section to the 'Software libraries' as GNU SASL, and
    'Invoking gsasl' moved from 'GNU utilities' to 'Security'.
** examples: Removed unneeded 'ctx' parameter from client_authenticate.
** Building with many warning flags now requires --enable-gcc-warnings.
    This avoids crying wolf for normal compiles.
** New configure parameters to set packaging specific information.
    The parameters are --with-packager, --with-packager-version, and
    --with-packager-bug-reports.  See
    <http://article.gmane.org/gmane.comp.lib.gnulib.bugs/17791> for more
    details.
This commit is contained in:
christos 2010-12-23 18:03:48 +00:00
parent 3a4ef8c91c
commit 089e24de2e
4 changed files with 6 additions and 33 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.29 2010/07/24 10:43:33 sborrill Exp $
# $NetBSD: Makefile,v 1.30 2010/12/23 18:03:48 christos Exp $
DISTNAME= gsasl-1.1
DISTNAME= gsasl-1.6.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNU:=gsasl/}

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.13 2010/06/03 09:23:34 wiz Exp $
$NetBSD: distinfo,v 1.14 2010/12/23 18:03:48 christos Exp $
SHA1 (gsasl-1.1.tar.gz) = 18ad50a16da8cbb53b720968545330fa5cdaa380
RMD160 (gsasl-1.1.tar.gz) = a6f4b77c4d9de37099e780471d4e16e0d5da9365
Size (gsasl-1.1.tar.gz) = 3775776 bytes
SHA1 (patch-aa) = 6dd2c9ba9e7828fbbbf7c7fad95bea492ba00b5c
SHA1 (patch-ab) = 40da8472cdd755ca2afd0dd0be054b462764fbe2
SHA1 (gsasl-1.6.0.tar.gz) = 56055324ebf1d1b823412b6fcee192c03452ea84
RMD160 (gsasl-1.6.0.tar.gz) = e2fc43899a18f19afa1a06d4e97788fe74689dc4
Size (gsasl-1.6.0.tar.gz) = 4611016 bytes

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.1 2010/06/03 02:28:31 dholland Exp $
--- gltests/Makefile.am~ 2009-03-24 06:24:41.000000000 +0000
+++ gltests/Makefile.am
@@ -10,6 +10,8 @@
#
# Generated by gnulib-tool.
+LINK_WARNING_H=$(top_srcdir)/build-aux/link-warning.h
+
AUTOMAKE_OPTIONS = 1.5 foreign
SUBDIRS =

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ab,v 1.1 2010/06/03 02:28:31 dholland Exp $
--- gltests/Makefile.in~ 2009-03-25 15:05:49.000000000 +0000
+++ gltests/Makefile.in
@@ -24,6 +24,7 @@
#
# Generated by gnulib-tool.
+LINK_WARNING_H = $(top_srcdir)/build-aux/link-warning.h
VPATH = @srcdir@