* Don't byte-compile the *.el files... just install them.
* Note conflict with coreutils (gid). * List the info files directly in the PLIST. Bump the PKGREVISION to 9.
This commit is contained in:
parent
42d56e7606
commit
08b3e5f84c
6 changed files with 20 additions and 201 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.44 2006/03/04 21:29:16 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.45 2006/04/08 21:20:06 jlam Exp $
|
||||
|
||||
DISTNAME= id-utils-3.2
|
||||
PKGREVISION= 8
|
||||
PKGREVISION= 9
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=id-utils/}
|
||||
|
||||
|
@ -9,43 +9,25 @@ MAINTAINER= pkgsrc-users@NetBSD.org
|
|||
HOMEPAGE= http://www.gnu.org/software/idutils/idutils.html
|
||||
COMMENT= Classic Berkeley gid/lid tools for looking up variables in code
|
||||
|
||||
CONFLICTS= sh-utils>=2.0nb2
|
||||
CONFLICTS= sh-utils>=2.0nb2 coreutils-[0-9]*
|
||||
|
||||
BUILD_USES_MSGFMT= yes
|
||||
|
||||
USE_PKGLOCALEDIR= yes
|
||||
|
||||
INFO_FILES= id-utils.info
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if defined(USE_XEMACS)
|
||||
EMACS= ${LOCALBASE}/bin/xemacs
|
||||
BUILD_DEPENDS+= xemacs-[0-9]*:../../editors/xemacs
|
||||
BUILD_DEPENDS+= xemacs-packages-[0-9]*:../../editors/xemacs-packages
|
||||
.elif defined(USE_EMACS)
|
||||
EMACS= ${LOCALBASE}/bin/emacs
|
||||
BUILD_DEPENDS+= emacs-[0-9]*:../../editors/emacs
|
||||
.endif
|
||||
|
||||
# install byte-compiled file here whenever we use emacs or xemacs...
|
||||
.if defined(USE_EMACS) || defined(USE_XEMACS)
|
||||
# we end-up installing .el file there whenever we use emacs or xemacs
|
||||
PLIST_SUBST+= LISPDIR=share/emacs/site-lisp
|
||||
PLIST_SUBST+= CLISPDIR=share/emacs/site-lisp
|
||||
.else
|
||||
# ...or don't install it at all
|
||||
PLIST_SUBST+= LISPDIR='@comment '
|
||||
PLIST_SUBST+= CLISPDIR='@comment '
|
||||
.endif
|
||||
# if not already, set this to the *full* pathname to false command
|
||||
# so configure won't search further for emacs
|
||||
EMACS?= ${FALSE:S|^false$|/usr/bin/false|}
|
||||
|
||||
CONFIGURE_ENV+= EMACS=${EMACS:Q}
|
||||
BUILD_DEFS+= EMACS
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= ac_cv_path_EMACS=no
|
||||
INFO_FILES= # PLIST
|
||||
MAKE_ENV+= BSD_SETENV=${SETENV:Q}
|
||||
|
||||
# Don't byte-compile the .el file.
|
||||
MAKE_FLAGS+= elc_SCRIPTS=
|
||||
|
||||
LISPDIR= ${PREFIX}/share/emacs/site-lisp
|
||||
REQD_DIRS= ${LISPDIR}
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/lisp/id-utils.el ${LISPDIR}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2004/02/16 10:18:28 seb Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2006/04/08 21:20:06 jlam Exp $
|
||||
bin/aid
|
||||
bin/defid
|
||||
bin/eid
|
||||
|
@ -8,8 +8,8 @@ bin/gid
|
|||
bin/lid
|
||||
bin/mkid
|
||||
bin/xtokid
|
||||
info/id-utils.info
|
||||
share/emacs/site-lisp/id-utils.el
|
||||
share/id-lang.map
|
||||
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/id-utils.mo
|
||||
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/id-utils.mo
|
||||
${CLISPDIR}/id-utils.elc
|
||||
${LISPDIR}/id-utils.el
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.13 2005/10/31 01:52:36 dbj Exp $
|
||||
$NetBSD: distinfo,v 1.14 2006/04/08 21:20:06 jlam Exp $
|
||||
|
||||
SHA1 (id-utils-3.2.tar.gz) = 14d96a2170745883d077fa8c436e4380f28951a5
|
||||
RMD160 (id-utils-3.2.tar.gz) = 4dada22d46cf791cf9ed61c69bbcafb0b9b1f99d
|
||||
|
@ -7,9 +7,6 @@ SHA1 (patch-aa) = 69cdce8f83d043ffabbec7639423e35a46a97175
|
|||
SHA1 (patch-ab) = aee2109a3cce77022cf4611542130fadc3842063
|
||||
SHA1 (patch-ac) = 67667057c39e7c5df048f22d2291649280c4299a
|
||||
SHA1 (patch-ad) = cd13aea19f0ac5dcdc8695ce40b409ecb15b1ec0
|
||||
SHA1 (patch-ae) = 3c3d118779b18bd91e2cd3ff88c3b47ec3236396
|
||||
SHA1 (patch-af) = 968b7ccaf20cda7afa781b043559e91bfb7e74d4
|
||||
SHA1 (patch-ag) = 9039dfd96f320f6da6dbeb1012fcd5c554500beb
|
||||
SHA1 (patch-ah) = 962276de4a6582e88e3eea8a6c2f8246c958bea0
|
||||
SHA1 (patch-ai) = be9f59a6a2e84338d6df945ba5d10285d3205560
|
||||
SHA1 (patch-aj) = 7f2b3f1eaadfc3a71169d16010375eaf0ce96b46
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.2 2001/11/03 09:59:36 seb Exp $
|
||||
|
||||
--- lisp/Makefile.am.orig Sun Jun 2 07:15:31 1996
|
||||
+++ lisp/Makefile.am
|
||||
@@ -1,10 +1,21 @@
|
||||
## Process this file with automake to create Makefile.in
|
||||
|
||||
+# Makefile.in's patch is produced after regen from Makefile.am with
|
||||
+# automake-1.1b
|
||||
+
|
||||
EXTRA_DIST = id-utils.el elisp-comp
|
||||
-elc_SCRIPTS = id-utils.elc
|
||||
+elc_DATA = id-utils.elc
|
||||
elcdir = @LISPDIR@
|
||||
+eldir = @LISPDIR@
|
||||
SUFFIXES = .el .elc
|
||||
+.SUFFIXES: .el .elc
|
||||
|
||||
.el.elc:
|
||||
@echo "WARNING: Warnings can be ignored. :-)"
|
||||
- $(SHELL) $(srcdir)/elisp-comp $<
|
||||
+ $(BSD_SETENV) EMACS=@EMACS@ $(SHELL) $(srcdir)/elisp-comp $<
|
||||
+
|
||||
+install-data-hook:
|
||||
+ if test -f id-utils.elc; then \
|
||||
+ $(mkinstalldirs) $(eldir); \
|
||||
+ $(INSTALL_DATA) $(srcdir)/id-utils.el $(eldir)/id-utils.el; \
|
||||
+ fi
|
|
@ -1,107 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.2 2001/11/03 09:59:36 seb Exp $
|
||||
|
||||
--- lisp/Makefile.in.orig Wed Aug 7 05:27:21 1996
|
||||
+++ lisp/Makefile.in
|
||||
@@ -4,6 +4,9 @@
|
||||
# This Makefile.in is free software; the Free Software Foundation
|
||||
# gives unlimited permission to copy, distribute and modify it.
|
||||
|
||||
+# Makefile.in's patch is produced after regen from Makefile.am with
|
||||
+# automake-1.1b
|
||||
+
|
||||
|
||||
SHELL = /bin/sh
|
||||
|
||||
@@ -39,12 +42,13 @@
|
||||
transform = @program_transform_name@
|
||||
|
||||
EXTRA_DIST = id-utils.el elisp-comp
|
||||
-elc_SCRIPTS = id-utils.elc
|
||||
+elc_DATA = id-utils.elc
|
||||
elcdir = @LISPDIR@
|
||||
+eldir = @LISPDIR@
|
||||
SUFFIXES = .el .elc
|
||||
mkinstalldirs = $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = ../config.h
|
||||
-SCRIPTS = $(elc_SCRIPTS)
|
||||
+DATA = $(elc_DATA)
|
||||
|
||||
DIST_COMMON = Makefile.am Makefile.in elisp-comp
|
||||
|
||||
@@ -67,20 +71,19 @@
|
||||
Makefile: $(top_builddir)/config.status Makefile.in
|
||||
cd $(top_builddir) && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= ./config.status
|
||||
|
||||
-install-elcSCRIPTS: $(elc_SCRIPTS)
|
||||
+install-elcDATA: $(elc_DATA)
|
||||
$(mkinstalldirs) $(elcdir)
|
||||
- list="$(elc_SCRIPTS)"; for p in $$list; do \
|
||||
- if test -f $$p; then \
|
||||
- $(INSTALL_SCRIPT) $$p $(elcdir)/`echo $$p|sed '$(transform)'`; \
|
||||
- else if test -f $(srcdir)/$$p; then \
|
||||
- $(INSTALL_SCRIPT) $(srcdir)/$$p \
|
||||
- $(elcdir)/`echo $$p|sed '$(transform)'`; \
|
||||
- else :; fi; fi; \
|
||||
+ list="$(elc_DATA)"; for p in $$list; do \
|
||||
+ if test -f $(srcdir)/$$p; then \
|
||||
+ $(INSTALL_DATA) $(srcdir)/$$p $(elcdir)/$$p; \
|
||||
+ else if test -f $$p; then \
|
||||
+ $(INSTALL_DATA) $$p $(elcdir)/$$p; \
|
||||
+ fi; fi; \
|
||||
done
|
||||
|
||||
-uninstall-elcSCRIPTS:
|
||||
- list="$(elc_SCRIPTS)"; for p in $$list; do \
|
||||
- rm -f $(elcdir)/`echo $$p|sed '$(transform)'`; \
|
||||
+uninstall-elcDATA:
|
||||
+ list="$(elc_DATA)"; for p in $$list; do \
|
||||
+ rm -f $(elcdir)/$$p; \
|
||||
done
|
||||
tags: TAGS
|
||||
TAGS:
|
||||
@@ -105,14 +108,15 @@
|
||||
|
||||
install-exec:
|
||||
|
||||
-install-data: install-elcSCRIPTS
|
||||
+install-data: install-elcDATA
|
||||
+ $(MAKE) install-data-hook
|
||||
|
||||
install: install-exec install-data all
|
||||
@:
|
||||
|
||||
-uninstall: uninstall-elcSCRIPTS
|
||||
+uninstall: uninstall-elcDATA
|
||||
|
||||
-all: $(SCRIPTS) Makefile
|
||||
+all: $(DATA) Makefile
|
||||
|
||||
install-strip:
|
||||
$(MAKE) INSTALL_PROGRAM='$(INSTALL_PROGRAM) -s' install
|
||||
@@ -144,15 +148,22 @@
|
||||
@echo "This command is intended for maintainers to use;"
|
||||
@echo "it deletes files that may require special tools to rebuild."
|
||||
|
||||
-.PHONY: default uninstall-elcSCRIPTS install-elcSCRIPTS tags distdir \
|
||||
-info dvi check installcheck install-exec install-data install uninstall \
|
||||
-all installdirs mostlyclean-generic distclean-generic clean-generic \
|
||||
+.PHONY: default uninstall-elcDATA install-elcDATA tags distdir info dvi \
|
||||
+check installcheck install-exec install-data install uninstall all \
|
||||
+installdirs mostlyclean-generic distclean-generic clean-generic \
|
||||
maintainer-clean-generic clean mostlyclean distclean maintainer-clean
|
||||
|
||||
+.SUFFIXES: .el .elc
|
||||
|
||||
.el.elc:
|
||||
@echo "WARNING: Warnings can be ignored. :-)"
|
||||
- $(SHELL) $(srcdir)/elisp-comp $<
|
||||
+ $(BSD_SETENV) EMACS=@EMACS@ $(SHELL) $(srcdir)/elisp-comp $<
|
||||
+
|
||||
+install-data-hook:
|
||||
+ if test -f id-utils.elc; then \
|
||||
+ $(mkinstalldirs) $(eldir); \
|
||||
+ $(INSTALL_DATA) $(srcdir)/id-utils.el $(eldir)/id-utils.el; \
|
||||
+ fi
|
||||
.SUFFIXES:
|
||||
.SUFFIXES: .el .elc
|
||||
|
|
@ -1,25 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.2 2001/11/03 09:59:36 seb Exp $
|
||||
|
||||
--- lisp/elisp-comp.orig Tue Aug 8 00:39:31 1995
|
||||
+++ lisp/elisp-comp
|
||||
@@ -28,13 +28,19 @@
|
||||
if test $# = 0; then
|
||||
echo 1>&2 "No files given to $0"
|
||||
else
|
||||
+ if test -z "$EMACS" || test "$EMACS" = "t"; then
|
||||
+ # Value of "t" means we are running in a shell under Emacs.
|
||||
+ # Just assume Emacs is called "emacs".
|
||||
+ EMACS=emacs
|
||||
+ fi
|
||||
+
|
||||
tempdir=elc.$$
|
||||
mkdir $tempdir
|
||||
cp $* $tempdir
|
||||
cd $tempdir
|
||||
|
||||
echo "(setq load-path (cons nil load-path))" > script
|
||||
- emacs -batch -l script -f batch-byte-compile *.el
|
||||
+ $EMACS -batch -l script -f batch-byte-compile *.el
|
||||
mv *.elc ..
|
||||
|
||||
cd ..
|
Loading…
Reference in a new issue