* Update configure for auto detection of system libx264 configuration
* Add tile format frame packing value
* Stricter validation of crop-rect values
* Add mono frame packing value
* Validate frame packing value instead of clipping
* x86inc: Correctly warn on use of SSE2 instructions in SSE functions
* x86inc: Fix instantiation of YMM registers
* matroska: Correctly write display width and height in stereo mode
* Use POC type 0 for AVC-Intra
* Fix ARCH variable name conflict with BSD ports (bsd.port.mk) read-only variable
* Fix negative percentages in final stats output
This commit is contained in:
adam 2015-07-18 11:08:21 +00:00
parent 3c53afd582
commit 08ce239b9a
3 changed files with 14 additions and 15 deletions

View file

@ -1,10 +1,9 @@
# $NetBSD: Makefile,v 1.53 2015/06/12 10:50:39 wiz Exp $
# $NetBSD: Makefile,v 1.54 2015/07/18 11:08:21 adam Exp $
SNAPSHOT_DATE= 20141218
SNAPSHOT_DATE= 20150717
DISTNAME= x264-snapshot-${SNAPSHOT_DATE}-2245
PKGNAME= x264-devel-${SNAPSHOT_DATE}
PKGREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.videolan.org/pub/videolan/x264/snapshots/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.36 2015/01/21 18:15:17 adam Exp $
$NetBSD: distinfo,v 1.37 2015/07/18 11:08:21 adam Exp $
SHA1 (x264-snapshot-20141218-2245.tar.bz2) = 24a3b20e2c49a112e40df9f64885cbd81250298a
RMD160 (x264-snapshot-20141218-2245.tar.bz2) = dda0759d0f8f2284618009cd6a8f296c034637ae
Size (x264-snapshot-20141218-2245.tar.bz2) = 652228 bytes
SHA1 (x264-snapshot-20150717-2245.tar.bz2) = 491bfd031e4e4708173bacf4646098f22126c604
RMD160 (x264-snapshot-20150717-2245.tar.bz2) = 3d5eb71c3dcf2bddcff53e3da355459b1a053a6c
Size (x264-snapshot-20150717-2245.tar.bz2) = 673063 bytes
SHA1 (patch-aa) = cfb5c8f90548aa2ee2cdfadc34010033f2288258
SHA1 (patch-ab) = e0cbdf86c506c3c3efa515099b544b918f25d254
SHA1 (patch-ab) = c85db90485a397262bc4b0fea0d17075182ab3e3
SHA1 (patch-ac) = e81a4c74cca30a0d3191817ada915fc956362509
SHA1 (patch-ba) = a8f12131e23953704361fb499b568f8f233c6be6

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ab,v 1.21 2015/01/20 09:37:53 wiz Exp $
$NetBSD: patch-ab,v 1.22 2015/07/18 11:08:22 adam Exp $
--- Makefile.orig 2014-12-18 21:45:04.000000000 +0000
--- Makefile.orig 2015-07-17 20:45:05.000000000 +0000
+++ Makefile
@@ -99,9 +99,9 @@ endif
@ -23,7 +23,7 @@ $NetBSD: patch-ab,v 1.21 2015/01/20 09:37:53 wiz Exp $
endif
endif
@@ -159,20 +159,23 @@ GENERATED += common/oclobj.h
@@ -162,20 +162,23 @@ GENERATED += common/oclobj.h
SRCS += common/opencl.c encoder/slicetype-cl.c
endif
@ -54,7 +54,7 @@ $NetBSD: patch-ab,v 1.21 2015/01/20 09:37:53 wiz Exp $
$(SONAME): $(GENERATED) .depend $(OBJS) $(OBJASM) $(OBJSO)
$(LD)$@ $(OBJS) $(OBJASM) $(OBJSO) $(SOFLAGS) $(LDFLAGS)
@@ -184,20 +187,19 @@ checkasm: checkasm$(EXE)
@@ -187,20 +190,19 @@ checkasm: checkasm$(EXE)
example: example$(EXE)
endif
@ -81,8 +81,8 @@ $NetBSD: patch-ab,v 1.21 2015/01/20 09:37:53 wiz Exp $
%.o: %.S
$(AS) $(ASFLAGS) -o $@ $<
@@ -267,8 +269,7 @@ distclean: clean
rm -f config.mak x264_config.h config.h config.log x264.pc x264.def
@@ -270,8 +272,7 @@ distclean: clean
rm -f config.mak x264_config.h config.h config.log x264.pc x264.def conftest*
install-cli: cli
- $(INSTALL) -d $(DESTDIR)$(bindir)
@ -91,7 +91,7 @@ $NetBSD: patch-ab,v 1.21 2015/01/20 09:37:53 wiz Exp $
install-lib-dev:
$(INSTALL) -d $(DESTDIR)$(includedir)
@@ -279,8 +280,7 @@ install-lib-dev:
@@ -282,8 +283,7 @@ install-lib-dev:
$(INSTALL) -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
install-lib-static: lib-static install-lib-dev