Use explicit conversion to bool.
This commit is contained in:
parent
8d77520555
commit
08e21a905f
2 changed files with 15 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.52 2015/03/10 05:16:28 mef Exp $
|
||||
$NetBSD: distinfo,v 1.53 2015/03/22 20:05:28 joerg Exp $
|
||||
|
||||
SHA1 (wesnoth-1.12.1.tar.bz2) = 081f0d839ccbd011a672ba7e134431a32eb8791c
|
||||
RMD160 (wesnoth-1.12.1.tar.bz2) = 961689d065a5f5c0076673e8028305e3dcc8e5b2
|
||||
|
@ -11,3 +11,4 @@ SHA1 (patch-data_tools_addon__manager_html_py) = 5cacb24b3441916d3e8832f9d9a6e96
|
|||
SHA1 (patch-data_tools_castle-clutter_mk_all-castles_sh) = 0c05566e6cf361199031d2104608e5e78e807a9e
|
||||
SHA1 (patch-data_tools_unit__tree_helpers_py) = 79de075b33eb7d6d30a8d69635de7f48c19a8c30
|
||||
SHA1 (patch-data_tools_wesnoth_campaignserver__client_py) = b7591e23b4c049ee22e080ea20160d82dd631722
|
||||
SHA1 (patch-src_game__config__manager.cpp) = 362f017cc8cbdfcaaea4f43fa11c5af0d8b58105
|
||||
|
|
13
games/wesnoth/patches/patch-src_game__config__manager.cpp
Normal file
13
games/wesnoth/patches/patch-src_game__config__manager.cpp
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-src_game__config__manager.cpp,v 1.1 2015/03/22 20:05:29 joerg Exp $
|
||||
|
||||
--- src/game_config_manager.cpp.orig 2015-03-21 22:11:07.000000000 +0000
|
||||
+++ src/game_config_manager.cpp
|
||||
@@ -68,7 +68,7 @@ bool game_config_manager::init_game_conf
|
||||
// Add preproc defines according to the command line arguments.
|
||||
game_config::scoped_preproc_define multiplayer("MULTIPLAYER",
|
||||
cmdline_opts_.multiplayer);
|
||||
- game_config::scoped_preproc_define test("TEST", cmdline_opts_.test);
|
||||
+ game_config::scoped_preproc_define test("TEST", bool(cmdline_opts_.test));
|
||||
game_config::scoped_preproc_define editor("EDITOR", jump_to_editor_);
|
||||
game_config::scoped_preproc_define title_screen("TITLE_SCREEN",
|
||||
!cmdline_opts_.multiplayer && !cmdline_opts_.test && !jump_to_editor_);
|
Loading…
Reference in a new issue