Update to KDE 3.5.5
Changes: Version 0.12.3 of Kopete replaces 0.11.3 in KDE 3.5.5, it includes support for Adium themes, performance improvements and better support for the Yahoo!
This commit is contained in:
parent
39c97cc105
commit
08f26899a7
10 changed files with 503 additions and 510 deletions
File diff suppressed because it is too large
Load diff
|
@ -1,11 +1,15 @@
|
|||
$NetBSD: distinfo,v 1.39 2006/08/02 13:53:31 markd Exp $
|
||||
$NetBSD: distinfo,v 1.40 2006/10/12 10:47:18 markd Exp $
|
||||
|
||||
SHA1 (kdenetwork-3.5.4.tar.bz2) = 35fb92f0c76346ca38a63f796d505487b15ba748
|
||||
RMD160 (kdenetwork-3.5.4.tar.bz2) = 8c120d4fc80d1679289f3d60457e1812d9a7ae6a
|
||||
Size (kdenetwork-3.5.4.tar.bz2) = 7526158 bytes
|
||||
SHA1 (patch-aa) = e89ce73221ef840ed600ae53acad16eaad824fa0
|
||||
SHA1 (kdenetwork-3.5.5.tar.bz2) = a95bac9de9770f551870fb73ce456d779ba36878
|
||||
RMD160 (kdenetwork-3.5.5.tar.bz2) = 3e757d10ee5bf24b2ccf131e693fb614b9fdb9f4
|
||||
Size (kdenetwork-3.5.5.tar.bz2) = 9235564 bytes
|
||||
SHA1 (patch-aa) = e075ad19377786359849263b9b872dd8116bec7c
|
||||
SHA1 (patch-ab) = cd2fe9a73be928e391923947cb29cbbdeb79ae03
|
||||
SHA1 (patch-ac) = a0e2fbcf1348d5e91434878bac4977b649c94855
|
||||
SHA1 (patch-ad) = 83bd8b1131366a093783f5dcbf498a0cd977009f
|
||||
SHA1 (patch-am) = e0511acfd35ebde0c919612f52dd63304934e8cf
|
||||
SHA1 (patch-an) = b86d93cc8173629f5fb46fa9538a834e7b3edebe
|
||||
SHA1 (patch-ae) = 401d126a6df6225641dd35803d3d467ec587c683
|
||||
SHA1 (patch-af) = d1955d7712b980db173f765586e6dc373cf3eea0
|
||||
SHA1 (patch-ag) = 6fad1af3bd383c01f80b7fa4da64184ad7172bb3
|
||||
SHA1 (patch-ah) = f13a567b6be1bd04e9d50185bab995f1a8a4d231
|
||||
SHA1 (patch-ai) = 27ff86fa25381bcb05c321b4f54acc225e9b90dd
|
||||
SHA1 (patch-am) = 4499a932b118175c87ad540b56a265f2864d71e8
|
||||
|
|
|
@ -1,8 +1,11 @@
|
|||
$NetBSD: patch-aa,v 1.15 2005/12/11 11:12:50 markd Exp $
|
||||
$NetBSD: patch-aa,v 1.16 2006/10/12 10:47:18 markd Exp $
|
||||
|
||||
--- configure.orig 2005-11-21 09:19:40.000000000 +1300
|
||||
utmpx patch gets ktalkd to build on Solaris 10 but wont actually
|
||||
read the file properly - needs to be fixed.
|
||||
|
||||
--- configure.orig 2006-10-03 07:24:51.000000000 +1300
|
||||
+++ configure
|
||||
@@ -42014,7 +42014,11 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
@@ -43422,7 +43422,11 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
#endif
|
||||
#include <unistd.h>
|
||||
#include <arpa/inet.h>
|
||||
|
@ -14,7 +17,7 @@ $NetBSD: patch-aa,v 1.15 2005/12/11 11:12:50 markd Exp $
|
|||
#include <netinet/in.h>
|
||||
|
||||
#ifdef __svr4__
|
||||
@@ -42030,6 +42034,8 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
@@ -43438,6 +43442,8 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
|
||||
#if defined(linux)
|
||||
#include <linux/if_ppp.h>
|
||||
|
@ -23,3 +26,11 @@ $NetBSD: patch-aa,v 1.15 2005/12/11 11:12:50 markd Exp $
|
|||
#else
|
||||
#include <net/if_ppp.h> /* BSD, NeXT, etc. */
|
||||
#endif
|
||||
@@ -44334,6 +44340,7 @@ else
|
||||
/var/run/utmp \
|
||||
/var/adm/utmp \
|
||||
/etc/utmp \
|
||||
+ /var/adm/utmpx \
|
||||
; \
|
||||
do
|
||||
if test -r "$ac_file"; then
|
||||
|
|
22
net/kdenetwork3/patches/patch-ae
Normal file
22
net/kdenetwork3/patches/patch-ae
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ae,v 1.4 2006/10/12 10:47:18 markd Exp $
|
||||
|
||||
--- kopete/protocols/groupwise/libgroupwise/rtf.ll.orig 2005-09-10 20:20:20.000000000 +1200
|
||||
+++ kopete/protocols/groupwise/libgroupwise/rtf.ll
|
||||
@@ -633,7 +633,7 @@ const unsigned RED = 2;
|
||||
const unsigned GREEN = 3;
|
||||
const unsigned BLUE = 4;
|
||||
const unsigned CF = 5;
|
||||
-const unsigned FS = 6;
|
||||
+const unsigned KDE_FS = 6;
|
||||
const unsigned HIGHLIGHT = 7;
|
||||
const unsigned PARD = 8;
|
||||
const unsigned PAR = 9;
|
||||
@@ -797,7 +797,7 @@ QString RTF2HTML::Parse(const char *rtf,
|
||||
case CF:
|
||||
cur_level.setFontColor(cmd_value);
|
||||
break;
|
||||
- case FS:
|
||||
+ case KDE_FS:
|
||||
cur_level.setFontSizeHalfPoints(cmd_value);
|
||||
break;
|
||||
case HIGHLIGHT:
|
22
net/kdenetwork3/patches/patch-af
Normal file
22
net/kdenetwork3/patches/patch-af
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-af,v 1.9 2006/10/12 10:47:18 markd Exp $
|
||||
|
||||
--- kopete/protocols/groupwise/libgroupwise/rtf.cc.orig 2005-09-10 20:20:20.000000000 +1200
|
||||
+++ kopete/protocols/groupwise/libgroupwise/rtf.cc
|
||||
@@ -2298,7 +2298,7 @@ const unsigned RED = 2;
|
||||
const unsigned GREEN = 3;
|
||||
const unsigned BLUE = 4;
|
||||
const unsigned CF = 5;
|
||||
-const unsigned FS = 6;
|
||||
+const unsigned KDE_FS = 6;
|
||||
const unsigned HIGHLIGHT = 7;
|
||||
const unsigned PARD = 8;
|
||||
const unsigned PAR = 9;
|
||||
@@ -2462,7 +2462,7 @@ QString RTF2HTML::Parse(const char *rtf,
|
||||
case CF:
|
||||
cur_level.setFontColor(cmd_value);
|
||||
break;
|
||||
- case FS:
|
||||
+ case KDE_FS:
|
||||
cur_level.setFontSizeHalfPoints(cmd_value);
|
||||
break;
|
||||
case HIGHLIGHT:
|
22
net/kdenetwork3/patches/patch-ag
Normal file
22
net/kdenetwork3/patches/patch-ag
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ag,v 1.3 2006/10/12 10:47:18 markd Exp $
|
||||
|
||||
--- kopete/protocols/oscar/liboscar/rtf.cc.orig 2005-09-10 20:20:23.000000000 +1200
|
||||
+++ kopete/protocols/oscar/liboscar/rtf.cc
|
||||
@@ -2194,7 +2194,7 @@ const unsigned RED = 2;
|
||||
const unsigned GREEN = 3;
|
||||
const unsigned BLUE = 4;
|
||||
const unsigned CF = 5;
|
||||
-const unsigned FS = 6;
|
||||
+const unsigned KDE_FS = 6;
|
||||
const unsigned HIGHLIGHT = 7;
|
||||
const unsigned PARD = 8;
|
||||
const unsigned PAR = 9;
|
||||
@@ -2358,7 +2358,7 @@ QString RTF2HTML::Parse(const char *rtf,
|
||||
case CF:
|
||||
cur_level.setFontColor(cmd_value);
|
||||
break;
|
||||
- case FS:
|
||||
+ case KDE_FS:
|
||||
cur_level.setFontSizeHalfPoints(cmd_value);
|
||||
break;
|
||||
case HIGHLIGHT:
|
22
net/kdenetwork3/patches/patch-ah
Normal file
22
net/kdenetwork3/patches/patch-ah
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ah,v 1.3 2006/10/12 10:47:18 markd Exp $
|
||||
|
||||
--- kopete/protocols/oscar/liboscar/rtf.ll.orig 2005-09-10 20:20:23.000000000 +1200
|
||||
+++ kopete/protocols/oscar/liboscar/rtf.ll
|
||||
@@ -631,7 +631,7 @@ const unsigned RED = 2;
|
||||
const unsigned GREEN = 3;
|
||||
const unsigned BLUE = 4;
|
||||
const unsigned CF = 5;
|
||||
-const unsigned FS = 6;
|
||||
+const unsigned KDE_FS = 6;
|
||||
const unsigned HIGHLIGHT = 7;
|
||||
const unsigned PARD = 8;
|
||||
const unsigned PAR = 9;
|
||||
@@ -795,7 +795,7 @@ QString RTF2HTML::Parse(const char *rtf,
|
||||
case CF:
|
||||
cur_level.setFontColor(cmd_value);
|
||||
break;
|
||||
- case FS:
|
||||
+ case KDE_FS:
|
||||
cur_level.setFontSizeHalfPoints(cmd_value);
|
||||
break;
|
||||
case HIGHLIGHT:
|
22
net/kdenetwork3/patches/patch-ai
Normal file
22
net/kdenetwork3/patches/patch-ai
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ai,v 1.4 2006/10/12 10:47:18 markd Exp $
|
||||
|
||||
--- ktalkd/mail.local/mail.local.c.orig 2005-09-10 20:20:38.000000000 +1200
|
||||
+++ ktalkd/mail.local/mail.local.c
|
||||
@@ -232,7 +232,7 @@ static char copyright[] =
|
||||
# define _BSD_VA_LIST_ va_list
|
||||
#endif
|
||||
|
||||
-#if !defined(BSD4_4) && !defined(linux) && !defined(_UNIXWARE)
|
||||
+#if !defined(BSD4_4) && !defined(linux) && !defined(_UNIXWARE) && !defined(HAVE_STRERROR)
|
||||
extern char *strerror __P((int));
|
||||
extern FILE *fdopen __P((int, const char *));
|
||||
#endif
|
||||
@@ -831,7 +831,7 @@ e_to_sys(num)
|
||||
}
|
||||
}
|
||||
|
||||
-#if !defined(BSD4_4) && !defined(__osf__) && !defined(__GLIBC__)
|
||||
+#if !defined(BSD4_4) && !defined(__osf__) && !defined(__GLIBC__) && !defined(HAVE_STRERROR)
|
||||
|
||||
char *
|
||||
strerror(eno)
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-am,v 1.3 2004/02/04 14:42:24 markd Exp $
|
||||
$NetBSD: patch-am,v 1.4 2006/10/12 10:47:18 markd Exp $
|
||||
|
||||
--- krfb/libvncserver/rfb.h.orig 2003-07-21 19:38:18.000000000 +1200
|
||||
+++ krfb/libvncserver/rfb.h
|
||||
|
@ -11,3 +11,12 @@ $NetBSD: patch-am,v 1.3 2004/02/04 14:42:24 markd Exp $
|
|||
#include <sys/types.h>
|
||||
#include <machine/endian.h>
|
||||
#ifndef _BYTE_ORDER
|
||||
@@ -76,7 +76,7 @@
|
||||
#if defined(__sparc)
|
||||
/* SPARC here (big endian) */
|
||||
#define _BYTE_ORDER 4321
|
||||
-#elif defined(__i386)
|
||||
+#elif defined(__i386) || defined(__amd64)
|
||||
#define _BYTE_ORDER 1234
|
||||
#else
|
||||
#error Solaris 2.5.1 had ppc support did it not? :-)
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-an,v 1.9 2006/08/02 13:53:31 markd Exp $
|
||||
|
||||
--- kopete/protocols/oscar/liboscar/oscartypes.h.orig 2006-07-22 20:11:33.000000000 +1200
|
||||
+++ kopete/protocols/oscar/liboscar/oscartypes.h
|
||||
@@ -237,7 +237,7 @@ struct ChatRoomInfo
|
||||
const WORD ICQ_MAJOR = 0x0014;
|
||||
const WORD ICQ_MINOR = 0x0034;
|
||||
const WORD ICQ_POINT = 0x0000;
|
||||
- const WORD ICQ_BUILD = 0x0A0F;
|
||||
+ const WORD ICQ_BUILD = 0x0BB8;
|
||||
const char ICQ_OTHER[] = { 0x00, 0x00, 0x04, 0x3d };
|
||||
const char ICQ_COUNTRY[] = "us";
|
||||
const char ICQ_LANG[] = "en";
|
Loading…
Reference in a new issue