Update xmame to 0.69.1.

Changes since 0.68.1 includes:
- Almost everything from MAME 0.69.
- Re-added Ben Collins' core change that adds support for extra mice.
- Reverted to using the original fronthlp.c (from 0.67.2) modified to
  work with the 0.69 core.
- Fixed a logic bug in the XInput devices button-handling.  (Ben
  Collins)
- Made a tiny fix in fileio.c that allows specifying direct paths to
  roms to work again; e.g., ./xmame.x11 ./moo.zip
This commit is contained in:
kristerw 2003-05-27 12:42:38 +00:00
parent 7481001464
commit 0941141283
5 changed files with 47 additions and 47 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.94 2003/05/23 13:53:33 kristerw Exp $
# $NetBSD: Makefile,v 1.95 2003/05/27 12:42:38 kristerw Exp $
#
DISTNAME= xmame-0.68.1
DISTNAME= xmame-0.69.1
CATEGORIES= emulators games x11
MASTER_SITES= http://x.mame.net/download/
EXTRACT_SUFX= .tar.bz2
@ -24,11 +24,6 @@ UNLIMIT_RESOURCES= datasize
.include "../../mk/bsd.prefs.mk"
# XXX On arm(32)/sparc, the src/unix/video_drivers/x11_window.c causes problems
.if (${MACHINE_ARCH} == "arm32" || ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "sparc")
CFLAGS+= -DBROKEN_COMPILER
.endif
ROMPATH= ${PREFIX}/share/${TARGET}
SPOOLDIR= /var/games/${TARGET}
@ -105,6 +100,5 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/${TARGET}rc ${ROMPATH}/${TARGET}rc
.include "../../audio/esound/buildlink2.mk"
.include "../../graphics/xpm/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.36 2003/05/23 13:53:34 kristerw Exp $
$NetBSD: distinfo,v 1.37 2003/05/27 12:42:39 kristerw Exp $
SHA1 (xmame-0.68.1.tar.bz2) = 0b7b4ed80f50edfd1342ecc966f17cd758643fe2
Size (xmame-0.68.1.tar.bz2) = 9790085 bytes
SHA1 (patch-aa) = f20dd759dc9350dc37e3be4a2b7e4aa0b1c85129
SHA1 (patch-ab) = af6d9ef293ed2c840eb6cfcada77b8556aeeddd3
SHA1 (patch-ad) = e389102fc29bd7c40711cfd493bad902ee102ae2
SHA1 (xmame-0.69.1.tar.bz2) = 1c9cb0bc26a22cef95cc9e80eaa9faf7117b8b9e
Size (xmame-0.69.1.tar.bz2) = 9803019 bytes
SHA1 (patch-aa) = cf7e599022fe0b3bc6f12d57c4c2d5ece7d82d0a
SHA1 (patch-ad) = 1d9726bb43e53da8f8edc56d4aa0929d890496d0
SHA1 (patch-ae) = df9ce91871bfcff611ff8f616482d4ff2e8204a3

View file

@ -1,6 +1,6 @@
$NetBSD: patch-aa,v 1.32 2003/04/13 17:37:16 kristerw Exp $
--- makefile.unix.orig Sun Apr 13 18:22:02 2003
+++ makefile.unix Sun Apr 13 18:31:53 2003
$NetBSD: patch-aa,v 1.33 2003/05/27 12:42:39 kristerw Exp $
--- makefile.unix.orig Mon May 26 22:09:26 2003
+++ makefile.unix Tue May 27 14:07:48 2003
@@ -33,7 +33,7 @@
###########################################################################
@ -28,6 +28,15 @@ $NetBSD: patch-aa,v 1.32 2003/04/13 17:37:16 kristerw Exp $
###########################################################################
@@ -106,7 +106,7 @@
###########################################################################
# gcc on x86
-CFLAGS = -O -Wall -Wno-unused
+# CFLAGS = -O -Wall -Wno-unused
# gcc on x86 with some optimizations
# CFLAGS = -O2 -Wall -Wno-unused -mcpu=i686 -fomit-frame-pointer \
@@ -397,7 +397,7 @@
###########################################################################
@ -46,7 +55,7 @@ $NetBSD: patch-aa,v 1.32 2003/04/13 17:37:16 kristerw Exp $
# FreeBSD
# ARCH = freebsd
@@ -555,7 +555,7 @@
@@ -560,7 +560,7 @@
X11_MITSHM = 1
# Use Xv extension for hardware scaling.
@ -55,7 +64,7 @@ $NetBSD: patch-aa,v 1.32 2003/04/13 17:37:16 kristerw Exp $
# Enable XFree86 DGA. This also causes "make install" to set the suid bit
# on the executable.
@@ -575,8 +575,8 @@
@@ -580,8 +580,8 @@
# X11LIB = -L/usr/lib/X11
# Standard location for XFree86

View file

@ -1,16 +0,0 @@
$NetBSD: patch-ab,v 1.17 2003/03/20 19:01:56 kristerw Exp $
--- src/unix/Makefile.orig Thu Mar 20 19:26:45 2003
+++ src/unix/Makefile Thu Mar 20 19:29:35 2003
@@ -133,9 +133,12 @@
$(OBJDIR)/effect.o: effect.h
$(VID_DIR)/x11_window.o: video-drivers/blit.h video-drivers/blit_core.h effect.h
+ $(CC_COMPILE) $(CC) $(MY_CFLAGS) -O -o $@ -c video-drivers/x11_window.c
$(VID_DIR)/svgalib.o: video-drivers/blit.h video-drivers/blit_core.h video-drivers/twkmodes.h video-drivers/twkuser.c effect.h
$(VID_DIR)/xf86_dga1.o: video-drivers/xf86_dga1.c video-drivers/blit.h video-drivers/blit_core.h effect.h
+ $(CC_COMPILE) $(CC) $(MY_CFLAGS) -O -o $@ -c video-drivers/xf86_dga1.c
$(VID_DIR)/xf86_dga2.o: video-drivers/xf86_dga2.c video-drivers/blit.h video-drivers/blit_core.h effect.h
+ $(CC_COMPILE) $(CC) $(MY_CFLAGS) -O -o $@ -c video-drivers/xf86_dga2.c
$(VID_DIR)/SDL.o: video-drivers/blit.h video-drivers/blit_core.h effect.h
$(VID_DIR)/xinput.o: video-drivers/xkeyboard.h video-drivers/glmame.h
$(VID_DIR)/xinput.o: video-drivers/xkeyboard.h video-drivers/glmame.h

View file

@ -1,7 +1,21 @@
$NetBSD: patch-ad,v 1.3 2002/12/07 20:59:53 kristerw Exp $
--- src/unix/video-drivers/blit.h.orig Sat Dec 7 03:00:00 2002
+++ src/unix/video-drivers/blit.h Sat Dec 7 03:02:49 2002
@@ -156,6 +156,7 @@
$NetBSD: patch-ad,v 1.4 2003/05/27 12:42:40 kristerw Exp $
--- src/unix/video-drivers/blit.h.orig Sat May 24 21:36:36 2003
+++ src/unix/video-drivers/blit.h Tue May 27 13:57:14 2003
@@ -27,6 +27,13 @@
These routines use long copies so everything should always be long aligned.
*/
+#if __GNUC__ <= 2
+/* The massive unrolling in this file causes a memory explosion in
+ * GCC 2.95 (e.g. x11_window.c needas about 450 Mbytes of memory
+ * to compile). Limit the code unrolling for GCC 2.x. */
+#define BROKEN_COMPILER
+#endif
+
#ifdef PACK_BITS
/* scale destptr delta's by 3/4 since we're using 32 bits ptr's for a 24 bits
dest */
@@ -156,6 +163,7 @@
@ -9,7 +23,7 @@ $NetBSD: patch-ad,v 1.3 2002/12/07 20:59:53 kristerw Exp $
case 2:
#define SCALE_X(X) ((X)*2)
#ifdef INDIRECT
@@ -265,6 +266,7 @@
@@ -265,6 +273,7 @@
#include "blit_core.h"
break;
@ -17,15 +31,15 @@ $NetBSD: patch-ad,v 1.3 2002/12/07 20:59:53 kristerw Exp $
#undef SCALE_X
#undef COPY_LINE2
@@ -503,6 +505,7 @@
#define SCALE_Y(Y) (Y)
@@ -517,6 +526,7 @@
#define SCALE_Y(Y) ((Y)<<1)
/* 1x1 we don't do scanlines with 1x1 */
/* 1x2 no scanlines */
+#ifndef BROKEN_COMPILER
case 0x00101:
case 0x10101:
#define COPY_LINE(SRC, END, DST) { COPY_LINE2(SRC, END, DST) }
@@ -958,6 +961,10 @@
case 0x00102:
#ifdef DOUBLEBUFFER
@@ -958,6 +968,10 @@
/* This is what happens when you give an assembly-language programmer
a C compiler. Thanks to td, of course. -JDL */