grpc: updated to 1.33.1

Release v1.33.1

This release contains refinements, improvements, and bug fixes, with highlights listed below.

Core

Deprecate GRPC_ARG_HTTP2_MIN_SENT_PING_INTERVAL_WITHOUT_DATA_MS.
Expose Cronet error message to the application layer.
Remove grpc_channel_ping from surface API.
Do not send BDP pings if there is no receive side activity.

C++

Makefile: only support building deps from submodule.

C#

Add trimming attribute to BindServiceMethodAttribute.
Fix incremental build of csproj projects depending on grpc.

Python

[Backport] Make Python 2 an optional dependency for Bazel build.
Allow asyncio API to be imported as grpc.aio.
[gRPC Easy] Fix import errors on Windows.
Make version check for importlib.abc in grpcio-tools more stringent.
This commit is contained in:
adam 2020-10-21 20:01:20 +00:00
parent dc3593703a
commit 094a409cb1
10 changed files with 46 additions and 70 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.31 2020/09/10 07:18:33 adam Exp $
# $NetBSD: Makefile,v 1.32 2020/10/21 20:01:20 adam Exp $
DISTNAME= grpc-1.32.0
DISTNAME= grpc-1.33.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GITHUB:=grpc/}
GITHUB_TAG= v${PKGVERSION_NOREV}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.20 2020/09/10 07:18:33 adam Exp $
@comment $NetBSD: PLIST,v 1.21 2020/10/21 20:01:20 adam Exp $
bin/grpc_cpp_plugin
bin/grpc_csharp_plugin
bin/grpc_node_plugin
@ -141,7 +141,6 @@ include/grpc/support/thd_id.h
include/grpc/support/time.h
include/grpc/support/workaround_list.h
include/grpcpp/alarm.h
include/grpcpp/alarm_impl.h
include/grpcpp/channel.h
include/grpcpp/client_context.h
include/grpcpp/completion_queue.h
@ -160,9 +159,7 @@ include/grpcpp/impl/channel_argument_option.h
include/grpcpp/impl/client_unary_call.h
include/grpcpp/impl/codegen/async_generic_service.h
include/grpcpp/impl/codegen/async_stream.h
include/grpcpp/impl/codegen/async_stream_impl.h
include/grpcpp/impl/codegen/async_unary_call.h
include/grpcpp/impl/codegen/async_unary_call_impl.h
include/grpcpp/impl/codegen/byte_buffer.h
include/grpcpp/impl/codegen/call.h
include/grpcpp/impl/codegen/call_hook.h
@ -171,7 +168,6 @@ include/grpcpp/impl/codegen/call_op_set_interface.h
include/grpcpp/impl/codegen/callback_common.h
include/grpcpp/impl/codegen/channel_interface.h
include/grpcpp/impl/codegen/client_callback.h
include/grpcpp/impl/codegen/client_callback_impl.h
include/grpcpp/impl/codegen/client_context.h
include/grpcpp/impl/codegen/client_interceptor.h
include/grpcpp/impl/codegen/client_unary_call.h
@ -190,7 +186,6 @@ include/grpcpp/impl/codegen/interceptor_common.h
include/grpcpp/impl/codegen/message_allocator.h
include/grpcpp/impl/codegen/metadata_map.h
include/grpcpp/impl/codegen/method_handler.h
include/grpcpp/impl/codegen/method_handler_impl.h
include/grpcpp/impl/codegen/proto_buffer_reader.h
include/grpcpp/impl/codegen/proto_buffer_writer.h
include/grpcpp/impl/codegen/proto_utils.h
@ -200,9 +195,7 @@ include/grpcpp/impl/codegen/security/auth_context.h
include/grpcpp/impl/codegen/serialization_traits.h
include/grpcpp/impl/codegen/server_callback.h
include/grpcpp/impl/codegen/server_callback_handlers.h
include/grpcpp/impl/codegen/server_callback_impl.h
include/grpcpp/impl/codegen/server_context.h
include/grpcpp/impl/codegen/server_context_impl.h
include/grpcpp/impl/codegen/server_interceptor.h
include/grpcpp/impl/codegen/server_interface.h
include/grpcpp/impl/codegen/service_type.h
@ -213,7 +206,6 @@ include/grpcpp/impl/codegen/string_ref.h
include/grpcpp/impl/codegen/stub_options.h
include/grpcpp/impl/codegen/sync.h
include/grpcpp/impl/codegen/sync_stream.h
include/grpcpp/impl/codegen/sync_stream_impl.h
include/grpcpp/impl/codegen/time.h
include/grpcpp/impl/grpc_library.h
include/grpcpp/impl/method_handler_impl.h
@ -221,10 +213,8 @@ include/grpcpp/impl/rpc_method.h
include/grpcpp/impl/rpc_service_method.h
include/grpcpp/impl/serialization_traits.h
include/grpcpp/impl/server_builder_option.h
include/grpcpp/impl/server_builder_option_impl.h
include/grpcpp/impl/server_builder_plugin.h
include/grpcpp/impl/server_initializer.h
include/grpcpp/impl/server_initializer_impl.h
include/grpcpp/impl/service_type.h
include/grpcpp/resource_quota.h
include/grpcpp/security/alts_context.h
@ -237,16 +227,12 @@ include/grpcpp/security/tls_credentials_options.h
include/grpcpp/server.h
include/grpcpp/server_builder.h
include/grpcpp/server_context.h
include/grpcpp/server_impl.h
include/grpcpp/server_posix.h
include/grpcpp/support/async_stream.h
include/grpcpp/support/async_stream_impl.h
include/grpcpp/support/async_unary_call.h
include/grpcpp/support/async_unary_call_impl.h
include/grpcpp/support/byte_buffer.h
include/grpcpp/support/channel_arguments.h
include/grpcpp/support/client_callback.h
include/grpcpp/support/client_callback_impl.h
include/grpcpp/support/client_interceptor.h
include/grpcpp/support/config.h
include/grpcpp/support/error_details.h
@ -256,7 +242,6 @@ include/grpcpp/support/method_handler.h
include/grpcpp/support/proto_buffer_reader.h
include/grpcpp/support/proto_buffer_writer.h
include/grpcpp/support/server_callback.h
include/grpcpp/support/server_callback_impl.h
include/grpcpp/support/server_interceptor.h
include/grpcpp/support/slice.h
include/grpcpp/support/status.h
@ -264,7 +249,6 @@ include/grpcpp/support/status_code_enum.h
include/grpcpp/support/string_ref.h
include/grpcpp/support/stub_options.h
include/grpcpp/support/sync_stream.h
include/grpcpp/support/sync_stream_impl.h
include/grpcpp/support/time.h
include/grpcpp/support/validate_service_config.h
lib/cmake/grpc/gRPCConfig.cmake
@ -272,12 +256,13 @@ lib/cmake/grpc/gRPCConfigVersion.cmake
lib/cmake/grpc/gRPCTargets-noconfig.cmake
lib/cmake/grpc/gRPCTargets.cmake
lib/cmake/grpc/modules/Findc-ares.cmake
lib/cmake/grpc/modules/Findre2.cmake
lib/libaddress_sorting.so
lib/libaddress_sorting.so.12
lib/libaddress_sorting.so.12.0.0
lib/libaddress_sorting.so.13
lib/libaddress_sorting.so.13.0.0
lib/libgpr.so
lib/libgpr.so.12
lib/libgpr.so.12.0.0
lib/libgpr.so.13
lib/libgpr.so.13.0.0
lib/libgrpc++.so
lib/libgrpc++.so.${PKGVERSION}
lib/libgrpc++.so.1
@ -294,20 +279,20 @@ lib/libgrpc++_unsecure.so
lib/libgrpc++_unsecure.so.${PKGVERSION}
lib/libgrpc++_unsecure.so.1
lib/libgrpc.so
lib/libgrpc.so.12
lib/libgrpc.so.12.0.0
lib/libgrpc.so.13
lib/libgrpc.so.13.0.0
lib/libgrpc_plugin_support.so
lib/libgrpc_plugin_support.so.${PKGVERSION}
lib/libgrpc_plugin_support.so.1
lib/libgrpc_unsecure.so
lib/libgrpc_unsecure.so.12
lib/libgrpc_unsecure.so.12.0.0
lib/libgrpc_unsecure.so.13
lib/libgrpc_unsecure.so.13.0.0
lib/libgrpcpp_channelz.so
lib/libgrpcpp_channelz.so.${PKGVERSION}
lib/libgrpcpp_channelz.so.1
lib/libupb.so
lib/libupb.so.12
lib/libupb.so.12.0.0
lib/libupb.so.13
lib/libupb.so.13.0.0
lib/pkgconfig/gpr.pc
lib/pkgconfig/grpc++.pc
lib/pkgconfig/grpc++_unsecure.pc

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.31 2020/09/10 07:18:33 adam Exp $
$NetBSD: distinfo,v 1.32 2020/10/21 20:01:20 adam Exp $
SHA1 (grpc-1.32.0.tar.gz) = 5c5821d40bd1c9e73992867c260421b7b539fa7d
RMD160 (grpc-1.32.0.tar.gz) = a80e022f024db2ec8bd378a9b7ec1195d0e4eca8
SHA512 (grpc-1.32.0.tar.gz) = 90136042327cea4e3680e19484f23cc00322914a7aae7987bf00b6e0901721d14c487555fdd94888192d6beb950172361ac57fbd02d43b40552f7ff5cac442ed
Size (grpc-1.32.0.tar.gz) = 7174251 bytes
SHA1 (grpc-1.33.1.tar.gz) = 8dff8b2836153e58e437f26e4180138db8e671ac
RMD160 (grpc-1.33.1.tar.gz) = f831f368d8e4432028a1b4e1f1157f56aac764cb
SHA512 (grpc-1.33.1.tar.gz) = 52ba9ae849917dc122f5208133a5c97498993c2993993bda69ffbc54f958d2c82462566dd6e3d86d865abb228541292fecc248a4b879c87867e6fa834c6077c4
Size (grpc-1.33.1.tar.gz) = 7272703 bytes
SHA1 (patch-CMakeLists.txt) = af17a03bdbb2b7905ced111b3c13c80b0cf3fec2
SHA1 (patch-cmake_benchmark.cmake) = 6a7880c30019a723a35b56b0c5bd2d730b36550d
SHA1 (patch-include_grpc_impl_codegen_port__platform.h) = b8d07e5bbf04694df00d0d19884844b791eb002c

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.9 2020/09/10 07:18:34 adam Exp $
# $NetBSD: Makefile,v 1.10 2020/10/21 20:01:20 adam Exp $
DISTNAME= grpcio-testing-1.32.0
DISTNAME= grpcio-testing-1.33.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=g/grpcio-testing/}

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.8 2020/09/10 07:18:34 adam Exp $
$NetBSD: distinfo,v 1.9 2020/10/21 20:01:20 adam Exp $
SHA1 (grpcio-testing-1.32.0.tar.gz) = cd93e31d3d6798e109b7087cea16f35398446b52
RMD160 (grpcio-testing-1.32.0.tar.gz) = 61b29392d34e0ba90f11b33b94de1a2928f90396
SHA512 (grpcio-testing-1.32.0.tar.gz) = 3ee10912a090287d3f039f350b11b8fc2ed656939e02a3e616911fd1af838e3f3570a7b3444c0ef54a25797a61edde87d545a9b9cabaf251a862b94100a45473
Size (grpcio-testing-1.32.0.tar.gz) = 16814 bytes
SHA1 (grpcio-testing-1.33.1.tar.gz) = bfc75947fe317d50c6a74cf6285c7129d8de69f6
RMD160 (grpcio-testing-1.33.1.tar.gz) = 9489baad8f5ccac2d70694ed0387fb4e43dd61b8
SHA512 (grpcio-testing-1.33.1.tar.gz) = 40d2d9415cf64bddd1dded3c9b1917aba15f38da68d2756f7265fcb1a5cfb42364cb14d1da7d638b943c18eb7d88b3ec66e0820b12500e8d4f74c3c3f1806398
Size (grpcio-testing-1.33.1.tar.gz) = 16929 bytes

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.19 2020/09/10 07:18:34 adam Exp $
# $NetBSD: Makefile,v 1.20 2020/10/21 20:01:20 adam Exp $
DISTNAME= grpcio-tools-1.32.0
DISTNAME= grpcio-tools-1.33.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=g/grpcio-tools/}

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.17 2020/09/10 07:18:34 adam Exp $
$NetBSD: distinfo,v 1.18 2020/10/21 20:01:20 adam Exp $
SHA1 (grpcio-tools-1.32.0.tar.gz) = d3ec09e2b698cc7f38a42927bc3ba76079a8f6ce
RMD160 (grpcio-tools-1.32.0.tar.gz) = 96dcf904437cb0f00441343ca2f5b8274c13f4a7
SHA512 (grpcio-tools-1.32.0.tar.gz) = aad072eb6de60d162d4ed6e353ced9d1b7d72e4ffd012237294fc5839c7d411dc640ea235746057007d289ee37235aa93c8ac23108299ab150c24f99cf050a4a
Size (grpcio-tools-1.32.0.tar.gz) = 2103777 bytes
SHA1 (grpcio-tools-1.33.1.tar.gz) = 11614bd167b16228d306c1ffb3364b11378e339a
RMD160 (grpcio-tools-1.33.1.tar.gz) = 4c4e3d532b30c975e52a9e2129ee8790ed422b0a
SHA512 (grpcio-tools-1.33.1.tar.gz) = 5270b70d49c696dd3f11cb11da630eecd5b06ac5d8abe3dc329fd78a4ed691b2e48d55dc1d220794987f774dcb919ed998dabc99ab9e159185838d46f7bca18a
Size (grpcio-tools-1.33.1.tar.gz) = 2100233 bytes
SHA1 (patch-setup.py) = 080ba75a31b51631000e79006316e0a2d5ce6cee

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.21 2020/09/10 07:18:33 adam Exp $
# $NetBSD: Makefile,v 1.22 2020/10/21 20:01:20 adam Exp $
DISTNAME= grpcio-1.32.0
DISTNAME= grpcio-1.33.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=g/grpcio/}

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.21 2020/09/10 07:18:33 adam Exp $
$NetBSD: distinfo,v 1.22 2020/10/21 20:01:20 adam Exp $
SHA1 (grpcio-1.32.0.tar.gz) = d75f61c7cb530a03dd582f2e783f842cc1a32ac5
RMD160 (grpcio-1.32.0.tar.gz) = cf6ec81caeda32454f1fbf922b56874e6fc4f08b
SHA512 (grpcio-1.32.0.tar.gz) = f802a7b83bd166502fdcbfaf162652adcda36da1b2e91b5073e3b3d97d38191fe989a6dcbec6c1bf27fff162633e54bdbdb20a92e74e14280fac4576baa92157
Size (grpcio-1.32.0.tar.gz) = 20809917 bytes
SHA1 (patch-setup.py) = a581ebfd280ce306c9caac8bfecf88a86efee79b
SHA1 (grpcio-1.33.1.tar.gz) = ada26c37bc16037119fded1b5d248c01668d1306
RMD160 (grpcio-1.33.1.tar.gz) = d770090d97d617ba52fcadef87afc7362483aaad
SHA512 (grpcio-1.33.1.tar.gz) = 9e6987370d9682a0a791007ee2b441b3dd347ba52237db34a6dbc23b83fc7f805a00f122a7249db45e542aa3c8d9295113d6f7660ad6c3a57e98922b6f9878a0
Size (grpcio-1.33.1.tar.gz) = 20881997 bytes
SHA1 (patch-setup.py) = bd669c39998ebcdb9ed671ed85e01250f68b0baf
SHA1 (patch-src_core_lib_iomgr_port.h) = 8f088cbf22110c03a684c24c9e17ef5fc64e925a

View file

@ -1,20 +1,11 @@
$NetBSD: patch-setup.py,v 1.9 2020/09/10 07:18:33 adam Exp $
$NetBSD: patch-setup.py,v 1.10 2020/10/21 20:01:20 adam Exp $
Fix libatomic detection.
Use dependencies in pkgsrc.
--- setup.py.orig 2020-09-08 21:38:30.000000000 +0000
--- setup.py.orig 2020-10-20 20:24:08.000000000 +0000
+++ setup.py
@@ -166,7 +166,7 @@ def check_linker_need_libatomic():
"""Test if linker on system needs libatomic."""
code_test = (b'#include <atomic>\n' +
b'int main() { return std::atomic<int64_t>{}; }')
- cc_test = subprocess.Popen(['cc', '-x', 'c++', '-std=c++11', '-'],
+ cc_test = subprocess.Popen(['c++', '-x', 'c++', '-std=c++11', '-'],
stdin=PIPE,
stdout=PIPE,
stderr=PIPE)
@@ -252,26 +252,7 @@ EXTENSION_INCLUDE_DIRECTORIES = ((PYTHON
@@ -264,26 +264,7 @@ EXTENSION_INCLUDE_DIRECTORIES = ((PYTHON
UPB_GRPC_GENERATED_INCLUDE +
UPBDEFS_GRPC_GENERATED_INCLUDE + ZLIB_INCLUDE)
@ -42,7 +33,7 @@ Use dependencies in pkgsrc.
DEFINE_MACROS = (('_WIN32_WINNT', 0x600),)
asm_files = []
@@ -349,7 +330,7 @@ def cython_extensions_and_necessity():
@@ -361,7 +342,7 @@ def cython_extensions_and_necessity():
]
config = os.environ.get('CONFIG', 'opt')
prefix = 'libs/' + config + '/'
@ -51,7 +42,7 @@ Use dependencies in pkgsrc.
extra_objects = [
prefix + 'libares.a', prefix + 'libboringssl.a',
prefix + 'libgpr.a', prefix + 'libgrpc.a'
@@ -361,8 +342,7 @@ def cython_extensions_and_necessity():
@@ -373,8 +354,7 @@ def cython_extensions_and_necessity():
extensions = [
_extension.Extension(
name=module_name,