Changes 1.1:
- stream disposition information printing in ffprobe - filter for loudness analysis following EBU R128 - Opus encoder using libopus - ffprobe -select_streams option - Pinnacle TARGA CineWave YUV16 decoder - TAK demuxer, decoder and parser - DTS-HD demuxer - remove -same_quant, it hasn't worked for years - FFM2 support - X-Face image encoder and decoder - 24-bit FLAC encoding - multi-channel ALAC encoding up to 7.1 - metadata (INFO tag) support in WAV muxer - subtitles raw text decoder - support for building DLLs using MSVC - LVF demuxer - ffescape tool - metadata (info chunk) support in CAF muxer - field filter ported from libmpcodecs - AVR demuxer - geq filter ported from libmpcodecs - remove ffserver daemon mode - AST muxer/demuxer - new expansion syntax for drawtext - BRender PIX image decoder - ffprobe -show_entries option - ffprobe -sections option - ADPCM IMA Dialogic decoder - BRSTM demuxer - animated GIF decoder and demuxer - PVF demuxer - subtitles filter - IRCAM muxer/demuxer - Paris Audio File demuxer - Virtual concatenation demuxer - VobSub demuxer - JSON captions for TED talks decoding support - SOX Resampler support in libswresample - aselect filter - SGI RLE 8-bit decoder - Silicon Graphics Motion Video Compressor 1 & 2 decoder - Silicon Graphics Movie demuxer - apad filter - Resolution & pixel format change support with multithreading for H.264 - documentation split into per-component manuals - pp (postproc) filter ported from MPlayer - NIST Sphere demuxer - MPL2, VPlayer, MPlayer, AQTitle, PJS and SubViewer v1 subtitles demuxers and decoders - Sony Wave64 muxer - adobe and limelight publisher authentication in RTMP - data: URI scheme - support building on the Plan 9 operating system - kerndeint filter ported from MPlayer - histeq filter ported from VirtualDub - Megalux Frame demuxer - 012v decoder - Improved AVC Intra decoding support
This commit is contained in:
parent
620fa4aa29
commit
099e9da9ea
10 changed files with 77 additions and 130 deletions
|
@ -1,8 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.97 2012/12/19 14:58:33 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.98 2013/01/16 20:55:47 adam Exp $
|
||||
|
||||
PKGNAME= ffmpeg-20121209.${DISTVERSION}
|
||||
|
||||
PKGREVISION= 1
|
||||
PKGNAME= ffmpeg-20130106.${DISTVERSION}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://ffmpeg.mplayerhq.hu/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.26 2012/12/18 10:48:09 jperkin Exp $
|
||||
# $NetBSD: Makefile.common,v 1.27 2013/01/16 20:55:47 adam Exp $
|
||||
# used by multimedia/ffplay/Makefile
|
||||
# used by multimedia/ffmpeg/Makefile
|
||||
|
||||
|
@ -9,7 +9,7 @@ EXTRACT_SUFX= .tar.bz2
|
|||
|
||||
LICENSE= gnu-lgpl-v2.1 AND gnu-gpl-v2
|
||||
|
||||
DISTVERSION= 1.0.1
|
||||
DISTVERSION= 1.1
|
||||
PREV_PKGPATH= multimedia/ffmpeg-devel
|
||||
PATCHDIR= ${.CURDIR}/../../multimedia/ffmpeg/patches
|
||||
|
||||
|
@ -45,7 +45,6 @@ CONFIGURE_ARGS+= --enable-memalign-hack
|
|||
# Let's not put garbage into /tmp
|
||||
CONFIGURE_ENV+= TMPDIR=${WRKSRC}/tmp
|
||||
|
||||
|
||||
.include "../../mk/compiler.mk"
|
||||
|
||||
.if ${OPSYS} == "SunOS" && empty(CC_VERSION:Mgcc*)
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.19 2012/11/08 19:57:29 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.20 2013/01/16 20:55:47 adam Exp $
|
||||
bin/ffmpeg
|
||||
bin/ffprobe
|
||||
bin/ffserver
|
||||
|
@ -36,6 +36,7 @@ include/libavutil/base64.h
|
|||
include/libavutil/blowfish.h
|
||||
include/libavutil/bprint.h
|
||||
include/libavutil/bswap.h
|
||||
include/libavutil/channel_layout.h
|
||||
include/libavutil/common.h
|
||||
include/libavutil/cpu.h
|
||||
include/libavutil/crc.h
|
||||
|
@ -54,6 +55,7 @@ include/libavutil/lzo.h
|
|||
include/libavutil/mathematics.h
|
||||
include/libavutil/md5.h
|
||||
include/libavutil/mem.h
|
||||
include/libavutil/old_pix_fmts.h
|
||||
include/libavutil/opt.h
|
||||
include/libavutil/parseutils.h
|
||||
include/libavutil/pixdesc.h
|
||||
|
@ -68,41 +70,43 @@ include/libavutil/timestamp.h
|
|||
include/libavutil/version.h
|
||||
include/libavutil/xtea.h
|
||||
include/libpostproc/postprocess.h
|
||||
include/libpostproc/version.h
|
||||
include/libswresample/swresample.h
|
||||
include/libswresample/version.h
|
||||
include/libswscale/swscale.h
|
||||
include/libswscale/version.h
|
||||
lib/libavcodec.a
|
||||
lib/libavcodec.so
|
||||
lib/libavcodec.so.54
|
||||
lib/libavcodec.so.54.59.100
|
||||
lib/libavcodec.so.54.86.100
|
||||
lib/libavdevice.a
|
||||
lib/libavdevice.so
|
||||
lib/libavdevice.so.54
|
||||
lib/libavdevice.so.54.2.101
|
||||
lib/libavdevice.so.54.3.102
|
||||
lib/libavfilter.a
|
||||
lib/libavfilter.so
|
||||
lib/libavfilter.so.3
|
||||
lib/libavfilter.so.3.17.100
|
||||
lib/libavfilter.so.3.32.100
|
||||
lib/libavformat.a
|
||||
lib/libavformat.so
|
||||
lib/libavformat.so.54
|
||||
lib/libavformat.so.54.29.104
|
||||
lib/libavformat.so.54.59.106
|
||||
lib/libavutil.a
|
||||
lib/libavutil.so
|
||||
lib/libavutil.so.51
|
||||
lib/libavutil.so.51.73.101
|
||||
lib/libavutil.so.52
|
||||
lib/libavutil.so.52.13.100
|
||||
lib/libpostproc.a
|
||||
lib/libpostproc.so
|
||||
lib/libpostproc.so.52
|
||||
lib/libpostproc.so.52.0.100
|
||||
lib/libpostproc.so.52.2.100
|
||||
lib/libswresample.a
|
||||
lib/libswresample.so
|
||||
lib/libswresample.so.0
|
||||
lib/libswresample.so.0.15.100
|
||||
lib/libswresample.so.0.17.102
|
||||
lib/libswscale.a
|
||||
lib/libswscale.so
|
||||
lib/libswscale.so.2
|
||||
lib/libswscale.so.2.1.101
|
||||
lib/libswscale.so.2.1.103
|
||||
lib/pkgconfig/libavcodec.pc
|
||||
lib/pkgconfig/libavdevice.pc
|
||||
lib/pkgconfig/libavfilter.pc
|
||||
|
@ -130,12 +134,14 @@ share/doc/ffmpeg/tablegen.txt
|
|||
share/doc/ffmpeg/viterbi.txt
|
||||
share/examples/ffmpeg/ffserver.conf
|
||||
share/ffmpeg/examples/Makefile
|
||||
share/ffmpeg/examples/README
|
||||
share/ffmpeg/examples/decoding_encoding.c
|
||||
share/ffmpeg/examples/demuxing.c
|
||||
share/ffmpeg/examples/filtering_audio.c
|
||||
share/ffmpeg/examples/filtering_video.c
|
||||
share/ffmpeg/examples/metadata.c
|
||||
share/ffmpeg/examples/muxing.c
|
||||
share/ffmpeg/examples/resampling_audio.c
|
||||
share/ffmpeg/examples/scaling_video.c
|
||||
share/ffmpeg/ffprobe.xsd
|
||||
share/ffmpeg/libvpx-1080p.ffpreset
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.62 2012/12/19 14:58:33 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.63 2013/01/16 20:55:47 adam Exp $
|
||||
|
||||
SHA1 (ffmpeg-1.0.1.tar.bz2) = 007465d01dcd4cae973285f89f5c6c500602a3ec
|
||||
RMD160 (ffmpeg-1.0.1.tar.bz2) = 363ba32002ed79def6d0f160975b751d15818c1e
|
||||
Size (ffmpeg-1.0.1.tar.bz2) = 6446587 bytes
|
||||
SHA1 (patch-SA51464) = ffafc874ef3313c1228d0bba1bae7f327bec7b9c
|
||||
SHA1 (patch-aa) = 43f68708e26723ec2e523578090d13bc79014066
|
||||
SHA1 (patch-ac) = 1c1c4f086328216f5d0cd9339171efa22065259a
|
||||
SHA1 (patch-ap) = 0ea32afb145b55f0186fb14b1b07568d7442ddf3
|
||||
SHA1 (patch-configure) = 7b89801bffb8d5e41c1c7f6bb5c69ed0cd1c1de4
|
||||
SHA1 (ffmpeg-1.1.tar.bz2) = a006d8833dd7a03dd5b7823671995640322177fe
|
||||
RMD160 (ffmpeg-1.1.tar.bz2) = 457524e69a51901fb27ad561cc6a5ccba96515fe
|
||||
Size (ffmpeg-1.1.tar.bz2) = 5808278 bytes
|
||||
SHA1 (patch-aa) = 14006874aee07e7e41803269040f0ae0157d931d
|
||||
SHA1 (patch-ac) = ff8a7a5fdfd4987ef2835bd7360a78efd4310253
|
||||
SHA1 (patch-ap) = ebbd0c169f228af37ae2dd54b27d5dba11a34c5e
|
||||
SHA1 (patch-configure) = 2a1085bef529b883270a4d55450c202f83c478db
|
||||
SHA1 (patch-libavcodec_x86_dsputil_mmx.c) = ac2230a524673ac42f7e1a29090ab7ab5561b3d2
|
||||
|
|
|
@ -1,85 +0,0 @@
|
|||
$NetBSD: patch-SA51464,v 1.1 2012/12/19 14:58:33 drochner Exp $
|
||||
|
||||
see https://trac.videolan.org/vlc/ticket/7860
|
||||
|
||||
--- libavformat/swfdec.c.orig 2012-12-03 21:17:35.000000000 +0000
|
||||
+++ libavformat/swfdec.c
|
||||
@@ -153,6 +153,10 @@ static int swf_read_packet(AVFormatConte
|
||||
tag = get_swf_tag(pb, &len);
|
||||
if (tag < 0)
|
||||
return tag;
|
||||
+ if (len < 0) {
|
||||
+ av_log(s, AV_LOG_ERROR, "invalid tag length: %d\n", len);
|
||||
+ return AVERROR_INVALIDDATA;
|
||||
+ }
|
||||
if (tag == TAG_VIDEOSTREAM) {
|
||||
int ch_id = avio_rl16(pb);
|
||||
len -= 2;
|
||||
@@ -208,7 +212,10 @@ static int swf_read_packet(AVFormatConte
|
||||
st = s->streams[i];
|
||||
if (st->codec->codec_type == AVMEDIA_TYPE_VIDEO && st->id == ch_id) {
|
||||
frame = avio_rl16(pb);
|
||||
- if ((res = av_get_packet(pb, pkt, len-2)) < 0)
|
||||
+ len -= 2;
|
||||
+ if (len <= 0)
|
||||
+ goto skip;
|
||||
+ if ((res = av_get_packet(pb, pkt, len)) < 0)
|
||||
return res;
|
||||
pkt->pos = pos;
|
||||
pkt->pts = frame;
|
||||
@@ -220,17 +227,22 @@ static int swf_read_packet(AVFormatConte
|
||||
for (i = 0; i < s->nb_streams; i++) {
|
||||
st = s->streams[i];
|
||||
if (st->codec->codec_type == AVMEDIA_TYPE_AUDIO && st->id == -1) {
|
||||
- if (st->codec->codec_id == AV_CODEC_ID_MP3) {
|
||||
- avio_skip(pb, 4);
|
||||
- if ((res = av_get_packet(pb, pkt, len-4)) < 0)
|
||||
- return res;
|
||||
- } else { // ADPCM, PCM
|
||||
- if ((res = av_get_packet(pb, pkt, len)) < 0)
|
||||
- return res;
|
||||
- }
|
||||
- pkt->pos = pos;
|
||||
- pkt->stream_index = st->index;
|
||||
- return pkt->size;
|
||||
+ if (st->codec->codec_id == AV_CODEC_ID_MP3) {
|
||||
+ avio_skip(pb, 4);
|
||||
+ len -= 4;
|
||||
+ if (len <= 0)
|
||||
+ goto skip;
|
||||
+ if ((res = av_get_packet(pb, pkt, len)) < 0)
|
||||
+ return res;
|
||||
+ } else { // ADPCM, PCM
|
||||
+ if (len <= 0)
|
||||
+ goto skip;
|
||||
+ if ((res = av_get_packet(pb, pkt, len)) < 0)
|
||||
+ return res;
|
||||
+ }
|
||||
+ pkt->pos = pos;
|
||||
+ pkt->stream_index = st->index;
|
||||
+ return pkt->size;
|
||||
}
|
||||
}
|
||||
} else if (tag == TAG_JPEG2) {
|
||||
@@ -250,7 +262,10 @@ static int swf_read_packet(AVFormatConte
|
||||
st = vst;
|
||||
}
|
||||
avio_rl16(pb); /* BITMAP_ID */
|
||||
- if ((res = av_new_packet(pkt, len-2)) < 0)
|
||||
+ len -= 2;
|
||||
+ if (len < 4)
|
||||
+ goto skip;
|
||||
+ if ((res = av_new_packet(pkt, len)) < 0)
|
||||
return res;
|
||||
avio_read(pb, pkt->data, 4);
|
||||
if (AV_RB32(pkt->data) == 0xffd8ffd9 ||
|
||||
@@ -267,6 +282,9 @@ static int swf_read_packet(AVFormatConte
|
||||
return pkt->size;
|
||||
}
|
||||
skip:
|
||||
+ if(len<0)
|
||||
+ av_log(s, AV_LOG_WARNING, "Cliping len %d\n", len);
|
||||
+ len = FFMAX(0, len);
|
||||
avio_skip(pb, len);
|
||||
}
|
||||
}
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.12 2012/11/08 19:57:29 adam Exp $
|
||||
$NetBSD: patch-aa,v 1.13 2013/01/16 20:55:47 adam Exp $
|
||||
|
||||
--- libavutil/x86/cpu.c.orig 2012-09-28 01:37:35.000000000 +0000
|
||||
--- libavutil/x86/cpu.c.orig 2013-01-06 21:53:29.000000000 +0000
|
||||
+++ libavutil/x86/cpu.c
|
||||
@@ -126,6 +126,7 @@ int ff_get_cpu_flags_x86(void)
|
||||
@@ -115,6 +115,7 @@ int ff_get_cpu_flags_x86(void)
|
||||
#if HAVE_SSE
|
||||
if (std_caps & (1 << 25))
|
||||
rval |= AV_CPU_FLAG_SSE;
|
||||
|
@ -10,7 +10,7 @@ $NetBSD: patch-aa,v 1.12 2012/11/08 19:57:29 adam Exp $
|
|||
if (std_caps & (1 << 26))
|
||||
rval |= AV_CPU_FLAG_SSE2;
|
||||
if (ecx & 1)
|
||||
@@ -145,6 +146,7 @@ int ff_get_cpu_flags_x86(void)
|
||||
@@ -134,6 +135,7 @@ int ff_get_cpu_flags_x86(void)
|
||||
rval |= AV_CPU_FLAG_AVX;
|
||||
}
|
||||
#endif /* HAVE_AVX */
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.13 2012/11/08 19:57:29 adam Exp $
|
||||
$NetBSD: patch-ac,v 1.14 2013/01/16 20:55:47 adam Exp $
|
||||
|
||||
--- Makefile.orig 2012-09-28 01:37:35.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -138,8 +138,8 @@ install-progs: install-progs-yes $(PROGS
|
||||
@@ -139,8 +139,8 @@ install-progs: install-progs-yes $(PROGS
|
||||
|
||||
install-data: $(DATA_FILES) $(EXAMPLES_FILES)
|
||||
$(Q)mkdir -p "$(DATADIR)/examples"
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-ap,v 1.5 2012/10/10 13:33:44 drochner Exp $
|
||||
$NetBSD: patch-ap,v 1.6 2013/01/16 20:55:47 adam Exp $
|
||||
|
||||
--- libavutil/common.h.orig 2012-01-12 21:34:32.000000000 +0000
|
||||
--- libavutil/common.h.orig 2013-01-06 21:53:29.000000000 +0000
|
||||
+++ libavutil/common.h
|
||||
@@ -37,6 +37,22 @@
|
||||
#include "attributes.h"
|
||||
@@ -39,6 +39,22 @@
|
||||
#include "version.h"
|
||||
#include "libavutil/avconfig.h"
|
||||
|
||||
+#if defined(__cplusplus)
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-configure,v 1.17 2012/11/08 19:57:29 adam Exp $
|
||||
$NetBSD: patch-configure,v 1.18 2013/01/16 20:55:47 adam Exp $
|
||||
|
||||
--- configure.orig 2012-09-28 01:37:35.000000000 +0000
|
||||
--- configure.orig 2013-01-06 21:53:29.000000000 +0000
|
||||
+++ configure
|
||||
@@ -3019,6 +3019,11 @@ case $target_os in
|
||||
@@ -3134,6 +3134,11 @@ case $target_os in
|
||||
;;
|
||||
netbsd)
|
||||
disable symver
|
||||
|
@ -14,7 +14,7 @@ $NetBSD: patch-configure,v 1.17 2012/11/08 19:57:29 adam Exp $
|
|||
oss_indev_extralibs="-lossaudio"
|
||||
oss_outdev_extralibs="-lossaudio"
|
||||
enabled gcc || check_ldflags -Wl,-zmuldefs
|
||||
@@ -3300,10 +3305,13 @@ check_cc <<EOF && enable attribute_may_a
|
||||
@@ -3469,10 +3474,13 @@ check_cc <<EOF && enable attribute_may_a
|
||||
union { int x; } __attribute__((may_alias)) x;
|
||||
EOF
|
||||
|
||||
|
@ -31,7 +31,7 @@ $NetBSD: patch-configure,v 1.17 2012/11/08 19:57:29 adam Exp $
|
|||
|
||||
if enabled alpha; then
|
||||
|
||||
@@ -3827,6 +3835,7 @@ enabled xmm_clobber_test &&
|
||||
@@ -4010,6 +4018,7 @@ enabled xmm_clobber_test &&
|
||||
-Wl,--wrap,sws_scale ||
|
||||
disable xmm_clobber_test
|
||||
|
||||
|
@ -39,15 +39,15 @@ $NetBSD: patch-configure,v 1.17 2012/11/08 19:57:29 adam Exp $
|
|||
echo "X{};" > $TMPV
|
||||
if test_ldflags -Wl,--version-script,$TMPV; then
|
||||
append SHFLAGS '-Wl,--version-script,\$(SUBDIR)lib\$(NAME).ver'
|
||||
@@ -3839,6 +3848,7 @@ __asm__(".symver ff_foo,av_foo@VERSION")
|
||||
@@ -4022,6 +4031,7 @@ __asm__(".symver ff_foo,av_foo@VERSION")
|
||||
void ff_foo(void) {}
|
||||
EOF
|
||||
fi
|
||||
+fi
|
||||
|
||||
if [ -n "$optflags" ]; then
|
||||
add_cflags $optflags
|
||||
@@ -4336,7 +4346,7 @@ Version: $version
|
||||
if [ -z "$optflags" ]; then
|
||||
if enabled small; then
|
||||
@@ -4517,7 +4527,7 @@ Version: $version
|
||||
Requires: $(enabled shared || echo $requires)
|
||||
Requires.private: $(enabled shared && echo $requires)
|
||||
Conflicts:
|
||||
|
|
29
multimedia/ffmpeg/patches/patch-libavcodec_x86_dsputil_mmx.c
Normal file
29
multimedia/ffmpeg/patches/patch-libavcodec_x86_dsputil_mmx.c
Normal file
|
@ -0,0 +1,29 @@
|
|||
$NetBSD: patch-libavcodec_x86_dsputil_mmx.c,v 1.1 2013/01/16 20:55:47 adam Exp $
|
||||
|
||||
--- libavcodec/x86/dsputil_mmx.c.orig 2013-01-06 21:53:29.000000000 +0000
|
||||
+++ libavcodec/x86/dsputil_mmx.c
|
||||
@@ -1785,6 +1785,7 @@ static av_always_inline void gmc(uint8_t
|
||||
}
|
||||
}
|
||||
|
||||
+#if CONFIG_VIDEODSP
|
||||
#if HAVE_YASM
|
||||
#if ARCH_X86_32
|
||||
static void gmc_mmx(uint8_t *dst, uint8_t *src,
|
||||
@@ -1814,6 +1815,7 @@ static void gmc_mmx(uint8_t *dst, uint8_
|
||||
width, height, &ff_emulated_edge_mc_8);
|
||||
}
|
||||
#endif
|
||||
+#endif
|
||||
|
||||
#endif /* HAVE_INLINE_ASM */
|
||||
|
||||
@@ -2518,7 +2520,7 @@ static void dsputil_init_sse(DSPContext
|
||||
c->scalarproduct_float = ff_scalarproduct_float_sse;
|
||||
c->butterflies_float_interleave = ff_butterflies_float_interleave_sse;
|
||||
|
||||
-#if HAVE_INLINE_ASM
|
||||
+#if HAVE_INLINE_ASM && CONFIG_VIDEODSP
|
||||
c->gmc = gmc_sse;
|
||||
#endif
|
||||
#endif /* HAVE_YASM */
|
Loading…
Reference in a new issue