Update nagios-base to 3.2.3. While there, add DESTDIR support and set LICENSE.
ChangeLog: * Fixes problem where disabling all active hosts/services was not taking effect * Fixes for compiler warnings (code cleanup by Stephen Gran) * Fixes for format errors in event handler logging (Guillaume Rousse) * Fixed incorrect info in sample nagios.cfg file for state_retention_file (Michael Friedrich) * Fixed broker_event_handler() to return ERR if data is NULL (Michael Friedrich) * Patch to new_mini_epn to allow any command line length without breaking on extra trailing or leading whitespace (Ray Bengen) * Patch to mini_epn to allow any command line length (Thomas Guyot-Sionnest) * Patch to speed up loading of state retention data (Matthieu Kermagoret) * Custom notifications are now suppressed during scheduled downtime (Sven Nierlein) * Added code to warn user about exit code of 126 meaning plugin is not executable (bug #153) * Scheduled downtime can now start on SOFT error states (bug #47) * Main window frame URL can now be specify with a "corewindow=" parameter * Improved config CGI shows commands, command args in an easier to use manner (Jochen Bern) * Added ability for NEB modules to override execution of event handlers (Sven Nierlein) * Custom macros are no longer cleaned/stripped as they are user-defined and should be trusted (Peter Morch) * Fix for choosing next valid time on day of DST change when clocks go one hour backwards * Fix for nagios now erroring when "Error: Could not find any contactgroup matching..." displayed * Fix tap tests for Sol0 and newer versions of Test::Harness * Fix for notifications not being sent out when scheduled downtime is canceluzzner) * Fix for first notification delay being calculated incorrectly, and notifications potentially going out early (Plachowski) * Fix for text of scheduling downtime of all services on a host (Holger Weiss) * Fix for services inheriting notification period from hosts if not defined (Gordon Messmer) * Fix for incorrect service states on host failures (bug #130 Pet) * Fix for incorrect service state attributes being set on host failures (bug #128 Petya Kohts) * Fix for non-scheduled hostsnd services not being updated in NDOUtils * Fix for typos in TAC, CMD CGIs (bugs #150, #144, #148) * Fix for types in documentation (bugs #145, #105, #106) * Fix for incorrect host state counts in status CGI when viewing servicegroups (bug #72) * Fix few Splunk integration query parameters (bug #136) * Fix for extra field header in availability CSV export (bug #113) * Fix foracro processing code modifying input string (Jochen Bern) * Fix for update check API * Fix for CGI speedup when persistent=0 f comments * Fix for event execution loop re-scheduling host checks instead of executing them if service checks are disabled (b #152) * Fix for segfaults on Solaris (Torsten Huebler) * Fix for incorrect comment expiration times being passed to event bror (Mattieu Kermagot) * Doc updates related to cleaning of custom macros (Peter Valdemar Morch) * Fix to sample notify-service--email command (bug #62) * Fix for retaining host display name and alias, as well as service display name (Folkert van Heusden* Link to allow scheduling downtime for all services on a host (Hendrik Baecker) * Speedup to CGIs when lots of comments or dotimes in status.dat file (Jonathan Kamens) * Patch for new_mini_epn to allow for any command line length without breaking extra trailing or leading whitespace (Ray Bengen) * Fix for incorrect scheduling when time has gone back an hour (partial fix for 24x7) * Fix for compile on Fedora Core 3 (bug #0000082) * Fix for compile on Solaris * Fix for logging test, which was not timezone aware (bug #0000077 - Allan Clark) * Trivial cleanups for autoconf (Allan Clark) * Fix for CSS validation of padding: X * Fix for documentation re: case-insensitive nature of custom variables (Marc Powell) * Fix for template configurations which use negated wildcards (Tim Wilde) * Fix for read-only permissions bug in CGIs that caused problems viewing comments (bug #0000029) * Fix for incorrect CGI reports (availability, trends, etc.) when reporting period spans Daylight Savings Time (bug #0000046) * Fix for detection of truecolor support in GD library (Lars Hecking) * Reverted to use --datadir configure script option instead of the more recently introduced --datarootdir option * Status and retention files are now flushed/synced to disk to prevent incomplete information being displayed in CGIs * Fix for incorrect next service check time calculation when Nagios is reloaded with different timeperiod ranges * Updated Fedora quistart guide to indicate PHP requirements * Known issue: Service checks that are defined with timeperiods that contain "exclude" directives are incorrectly re-scheduled. Don't use these for now - we'll get this fixed for 3.4
This commit is contained in:
parent
d732f75064
commit
09b0e8361a
13 changed files with 85 additions and 78 deletions
|
@ -1,15 +1,17 @@
|
|||
# $NetBSD: Makefile,v 1.30 2011/01/13 13:39:06 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.31 2011/04/08 22:37:24 morr Exp $
|
||||
#
|
||||
|
||||
DISTNAME= nagios-3.1.2
|
||||
DISTNAME= nagios-3.2.3
|
||||
PKGNAME= ${DISTNAME:S/-/-base-/}
|
||||
PKGREVISION= 4
|
||||
CATEGORIES= net sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=nagios/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.nagios.org/
|
||||
COMMENT= Network monitor
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.include "../../net/nagios-base/Makefile.common"
|
||||
|
@ -25,18 +27,13 @@ CONFIGURE_ARGS+= --with-nagios-group=${NAGIOS_GROUP}
|
|||
CONFIGURE_ARGS+= --with-command-user=${NAGIOS_USER}
|
||||
CONFIGURE_ARGS+= --with-command-group=${NAGIOSCMD_GROUP}
|
||||
CONFIGURE_ARGS+= --with-init-dir=${PREFIX}/share/examples/rc.d
|
||||
CONFIGURE_ARGS+= --with-lockfile=/var/run/nagios.lock
|
||||
CONFIGURE_ARGS+= --with-lockfile=/var/run/nagios/nagios.lock
|
||||
|
||||
USE_TOOLS+= mail:run perl
|
||||
CONFIGURE_ARGS+= --with-mail=${TOOLS_PLATFORM.mail:Q}
|
||||
|
||||
RCD_SCRIPTS+= nagios
|
||||
FILES_SUBST+= NAGIOS_USER=${NAGIOS_USER}
|
||||
# XXX Merge this into the package proper.
|
||||
# Nagios drops permissions before creating the log file, so the
|
||||
# default location doesn't work. In the config file, change
|
||||
# lock_file=/var/run/nagios.lock to
|
||||
# lock_file=/var/run/nagios/nagios.lock
|
||||
|
||||
INSTALL_TARGET= install install-config
|
||||
|
||||
|
@ -70,6 +67,7 @@ CONF_FILES+= ${EGDIR}/nagios.conf ${PKG_SYSCONFDIR}/nagios.conf
|
|||
OWN_DIRS_PERMS+=${NAGIOSDIR} ${NAGIOS_USER} ${NAGIOS_GROUP} 0775
|
||||
OWN_DIRS_PERMS+=${NAGIOSDIR}/archives ${NAGIOS_USER} ${NAGIOS_GROUP} 0775
|
||||
OWN_DIRS_PERMS+=${NAGIOSDIR}/rw ${NAGIOS_USER} ${NAGIOSCMD_GROUP} 0775
|
||||
OWN_DIRS_PERMS+=${NAGIOSDIR}/checkresults ${NAGIOS_USER} ${NAGIOSCMD_GROUP} 0775
|
||||
|
||||
SUBST_CLASSES+= files
|
||||
SUBST_STAGE.files= post-build
|
||||
|
@ -81,7 +79,7 @@ pre-build:
|
|||
${CP} ${FILESDIR}/nagios.conf.dist ${WRKSRC}/nagios.conf.dist
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/nagios.conf.dist ${EGDIR}/nagios.conf
|
||||
${INSTALL_DATA} ${WRKSRC}/nagios.conf.dist ${DESTDIR}/${EGDIR}/nagios.conf
|
||||
|
||||
.include "../../graphics/gd/buildlink3.mk"
|
||||
.include "../../lang/php/phpversion.mk"
|
||||
|
|
|
@ -1,6 +1,9 @@
|
|||
# $NetBSD: Makefile.common,v 1.10 2010/04/07 17:57:41 joerg Exp $
|
||||
# $NetBSD: Makefile.common,v 1.11 2011/04/08 22:37:24 morr Exp $
|
||||
#
|
||||
# used by net/nagios-base/Makefile
|
||||
# used by net/nagios-nsca/Makefile
|
||||
# used by net/nagios-plugins/Makefile.common
|
||||
# used by net/nagios-plugin-ldap/Makefile
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.8 2009/12/15 18:56:01 bouyer Exp $
|
||||
@comment $NetBSD: PLIST,v 1.9 2011/04/08 22:37:24 morr Exp $
|
||||
bin/nagios
|
||||
bin/nagiostats
|
||||
bin/p1.pl
|
||||
|
@ -235,6 +235,7 @@ share/nagios/docs/index.html
|
|||
share/nagios/docs/int-snmptrap.html
|
||||
share/nagios/docs/int-tcpwrappers.html
|
||||
share/nagios/docs/integration.html
|
||||
share/nagios/docs/knownissues.html
|
||||
share/nagios/docs/largeinstalltweaks.html
|
||||
share/nagios/docs/macrolist.html
|
||||
share/nagios/docs/macros.html
|
||||
|
@ -321,6 +322,7 @@ share/nagios/images/restart.gif
|
|||
share/nagios/images/right.gif
|
||||
share/nagios/images/sblogo.png
|
||||
share/nagios/images/serviceevent.gif
|
||||
share/nagios/images/sflogo.png
|
||||
share/nagios/images/splunk1.gif
|
||||
share/nagios/images/splunk2.gif
|
||||
share/nagios/images/start.gif
|
||||
|
@ -368,3 +370,4 @@ share/nagios/stylesheets/summary.css
|
|||
share/nagios/stylesheets/tac.css
|
||||
share/nagios/stylesheets/trends.css
|
||||
@pkgdir share/nagios/ssi
|
||||
@pkgdir etc/nagios/objects
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
$NetBSD: distinfo,v 1.11 2009/12/15 18:56:01 bouyer Exp $
|
||||
$NetBSD: distinfo,v 1.12 2011/04/08 22:37:24 morr Exp $
|
||||
|
||||
SHA1 (nagios-3.1.2.tar.gz) = 91d6e0dc19b4f09d1c0c7d4220bc69df8af07b1b
|
||||
RMD160 (nagios-3.1.2.tar.gz) = cb633f316cc6108a9b4fe387b3e8097a2e8546a9
|
||||
Size (nagios-3.1.2.tar.gz) = 3172982 bytes
|
||||
SHA1 (patch-aa) = 1079c24f0d42b69522ca04ab91e77cf53065e63d
|
||||
SHA1 (patch-ab) = 0f5b7ab0d13be9eca22ffed921ee8e22e3f8fa1b
|
||||
SHA1 (patch-ac) = ac60819f5c4f9b385637a6c8d0b5dd62622c2622
|
||||
SHA1 (patch-ad) = 72565abe365a4488d519169822bfcad7a6cc2eba
|
||||
SHA1 (patch-ae) = e1f80e7b0496d19545321f9d05306cfcd0f9af31
|
||||
SHA1 (patch-af) = 8041ca50021a41bdd7897363f6ea68afdddaab28
|
||||
SHA1 (patch-ag) = 9904acb53998a9efeecf37efe722e61a3edf2053
|
||||
SHA1 (patch-ah) = 88122296f9d74648c3dadbd7f6e12e7ef1f32081
|
||||
SHA1 (patch-ai) = 738039e46af95a035bf0220eaa5c621938b651fd
|
||||
SHA1 (nagios-3.2.3.tar.gz) = fcb2c016c1b803bac71442d0ee8375b737906421
|
||||
RMD160 (nagios-3.2.3.tar.gz) = 3c09034069416c5f4dd5071e34516b1154c276b2
|
||||
Size (nagios-3.2.3.tar.gz) = 3249447 bytes
|
||||
SHA1 (patch-aa) = d56ae45ad54b43fe28e1d83fe916f04e8f8741a7
|
||||
SHA1 (patch-ab) = 37beee7195879806a2cd44cde2f376e07fc13470
|
||||
SHA1 (patch-ac) = cb2c6a28fc4d46eb41c942998251171ddd946bf2
|
||||
SHA1 (patch-ad) = 22d2a083f485e0da323403a2e27d6ee83e8cea27
|
||||
SHA1 (patch-ae) = 35418dbe26f2e7c14d6a98951e62247344ae80b0
|
||||
SHA1 (patch-af) = a91ab37f16e8adda3146a2dde7273ebf841ef9af
|
||||
SHA1 (patch-ag) = ae2811e97fc91e937ef240fc671c069181c97861
|
||||
SHA1 (patch-ah) = 3e73f1256f2364855598a94092744968b88c78e6
|
||||
SHA1 (patch-ai) = 9212106c141be6faaf65e4e4909fcf92907c0e58
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.7 2009/12/15 18:56:02 bouyer Exp $
|
||||
$NetBSD: patch-aa,v 1.8 2011/04/08 22:37:25 morr Exp $
|
||||
|
||||
--- Makefile.in.orig 2009-06-17 05:57:21.000000000 +0200
|
||||
+++ Makefile.in 2009-12-15 16:53:59.000000000 +0100
|
||||
@@ -24,17 +24,16 @@
|
||||
--- Makefile.in.orig 2009-12-31 10:12:08.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -24,17 +24,16 @@ prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
LOGDIR=@localstatedir@
|
||||
CHECKRESULTDIR=@CHECKRESULTDIR@
|
||||
|
@ -23,7 +23,7 @@ $NetBSD: patch-aa,v 1.7 2009/12/15 18:56:02 bouyer Exp $
|
|||
CGICFGDIR=$(CGIDIR)
|
||||
PERLDIR=@PERLDIR@
|
||||
|
||||
@@ -64,66 +63,6 @@
|
||||
@@ -64,66 +63,6 @@ all:
|
||||
cd $(SRC_BASE) && $(MAKE)
|
||||
cd $(SRC_CGI) && $(MAKE)
|
||||
cd $(SRC_HTM) && $(MAKE)
|
||||
|
@ -90,7 +90,7 @@ $NetBSD: patch-aa,v 1.7 2009/12/15 18:56:02 bouyer Exp $
|
|||
|
||||
nagios:
|
||||
cd $(SRC_BASE) && $(MAKE)
|
||||
@@ -214,14 +153,10 @@
|
||||
@@ -214,14 +153,10 @@ install-unstripped:
|
||||
$(MAKE) install-basic
|
||||
|
||||
install-basic:
|
||||
|
@ -107,7 +107,7 @@ $NetBSD: patch-aa,v 1.7 2009/12/15 18:56:02 bouyer Exp $
|
|||
@echo ""
|
||||
@echo "*** Main program, CGIs and HTML files installed ***"
|
||||
@echo ""
|
||||
@@ -241,20 +176,20 @@
|
||||
@@ -241,20 +176,20 @@ install-basic:
|
||||
|
||||
|
||||
install-config:
|
||||
|
@ -127,22 +127,22 @@ $NetBSD: patch-aa,v 1.7 2009/12/15 18:56:02 bouyer Exp $
|
|||
-
|
||||
+ [ -d $(DESTDIR)$(SAMPDIR) ] || ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(SAMPDIR)
|
||||
+ [ -d $(DESTDIR)$(SAMPDIR)/objects ] || ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(SAMPDIR)/objects
|
||||
+ $(INSTALL) -m 644 $(INSTALL_OPTS) sample-config/nagios.cfg $(DESTDIR)$(SAMPDIR)/nagios.cfg-sample
|
||||
+ $(INSTALL) -m 644 $(INSTALL_OPTS) sample-config/cgi.cfg $(DESTDIR)$(SAMPDIR)/cgi.cfg-sample
|
||||
+ $(INSTALL) -m 640 $(INSTALL_OPTS) sample-config/resource.cfg $(DESTDIR)$(SAMPDIR)/resource.cfg-sample
|
||||
+ $(INSTALL) -m 644 $(INSTALL_OPTS) sample-config/template-object/templates.cfg $(DESTDIR)$(SAMPDIR)/objects/templates.cfg-sample
|
||||
+ $(INSTALL) -m 644 $(INSTALL_OPTS) sample-config/template-object/commands.cfg $(DESTDIR)$(SAMPDIR)/objects/commands.cfg-sample
|
||||
+ $(INSTALL) -m 644 $(INSTALL_OPTS) sample-config/template-object/contacts.cfg $(DESTDIR)$(SAMPDIR)/objects/contacts.cfg-sample
|
||||
+ $(INSTALL) -m 644 $(INSTALL_OPTS) sample-config/template-object/timeperiods.cfg $(DESTDIR)$(SAMPDIR)/objects/timeperiods.cfg-sample
|
||||
+ $(INSTALL) -m 644 $(INSTALL_OPTS) sample-config/template-object/localhost.cfg $(DESTDIR)$(SAMPDIR)/objects/localhost.cfg-sample
|
||||
+ $(INSTALL) -m 644 $(INSTALL_OPTS) sample-config/template-object/windows.cfg $(DESTDIR)$(SAMPDIR)/objects/windows.cfg-sample
|
||||
+ $(INSTALL) -m 644 $(INSTALL_OPTS) sample-config/template-object/printer.cfg $(DESTDIR)$(SAMPDIR)/objects/printer.cfg-sample
|
||||
+ $(INSTALL) -m 644 $(INSTALL_OPTS) sample-config/template-object/switch.cfg $(DESTDIR)$(SAMPDIR)/objects/switch.cfg-sample
|
||||
+ ${BSD_INSTALL_DATA} -m 644 sample-config/nagios.cfg $(DESTDIR)$(SAMPDIR)/nagios.cfg-sample
|
||||
+ ${BSD_INSTALL_DATA} -m 644 sample-config/cgi.cfg $(DESTDIR)$(SAMPDIR)/cgi.cfg-sample
|
||||
+ ${BSD_INSTALL_DATA} -m 640 sample-config/resource.cfg $(DESTDIR)$(SAMPDIR)/resource.cfg-sample
|
||||
+ ${BSD_INSTALL_DATA} -m 644 sample-config/template-object/templates.cfg $(DESTDIR)$(SAMPDIR)/objects/templates.cfg-sample
|
||||
+ ${BSD_INSTALL_DATA} -m 644 sample-config/template-object/commands.cfg $(DESTDIR)$(SAMPDIR)/objects/commands.cfg-sample
|
||||
+ ${BSD_INSTALL_DATA} -m 644 sample-config/template-object/contacts.cfg $(DESTDIR)$(SAMPDIR)/objects/contacts.cfg-sample
|
||||
+ ${BSD_INSTALL_DATA} -m 644 sample-config/template-object/timeperiods.cfg $(DESTDIR)$(SAMPDIR)/objects/timeperiods.cfg-sample
|
||||
+ ${BSD_INSTALL_DATA} -m 644 sample-config/template-object/localhost.cfg $(DESTDIR)$(SAMPDIR)/objects/localhost.cfg-sample
|
||||
+ ${BSD_INSTALL_DATA} -m 644 sample-config/template-object/windows.cfg $(DESTDIR)$(SAMPDIR)/objects/windows.cfg-sample
|
||||
+ ${BSD_INSTALL_DATA} -m 644 sample-config/template-object/printer.cfg $(DESTDIR)$(SAMPDIR)/objects/printer.cfg-sample
|
||||
+ ${BSD_INSTALL_DATA} -m 644 sample-config/template-object/switch.cfg $(DESTDIR)$(SAMPDIR)/objects/switch.cfg-sample
|
||||
+
|
||||
@echo ""
|
||||
@echo "*** Config files installed ***"
|
||||
@echo ""
|
||||
@@ -282,7 +217,10 @@
|
||||
@@ -282,7 +217,10 @@ install-daemoninit:
|
||||
|
||||
|
||||
install-commandmode:
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.5 2009/12/15 18:56:02 bouyer Exp $
|
||||
$NetBSD: patch-ab,v 1.6 2011/04/08 22:37:25 morr Exp $
|
||||
|
||||
--- cgi/Makefile.in.orig 2009-06-17 05:57:21.000000000 +0200
|
||||
+++ cgi/Makefile.in 2009-12-15 16:54:45.000000000 +0100
|
||||
@@ -15,7 +15,7 @@
|
||||
--- cgi/Makefile.in.orig 2010-08-28 13:01:25.000000000 +0000
|
||||
+++ cgi/Makefile.in
|
||||
@@ -15,7 +15,7 @@ exec_prefix=@exec_prefix@
|
||||
LOGDIR=@localstatedir@
|
||||
CFGDIR=@sysconfdir@
|
||||
BINDIR=@bindir@
|
||||
|
@ -11,7 +11,7 @@ $NetBSD: patch-ab,v 1.5 2009/12/15 18:56:02 bouyer Exp $
|
|||
HTMLDIR=@datarootdir@
|
||||
INSTALL=@INSTALL@
|
||||
INSTALL_OPTS=@INSTALL_OPTS@
|
||||
@@ -196,9 +196,9 @@
|
||||
@@ -199,9 +199,9 @@ install-unstripped:
|
||||
$(MAKE) install-basic
|
||||
|
||||
install-basic:
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.6 2009/12/15 18:56:02 bouyer Exp $
|
||||
$NetBSD: patch-ac,v 1.7 2011/04/08 22:37:25 morr Exp $
|
||||
|
||||
--- base/Makefile.in.orig 2009-06-17 05:57:21.000000000 +0200
|
||||
+++ base/Makefile.in 2009-12-15 16:55:30.000000000 +0100
|
||||
@@ -36,7 +36,7 @@
|
||||
--- base/Makefile.in.orig 2009-06-17 03:57:21.000000000 +0000
|
||||
+++ base/Makefile.in
|
||||
@@ -36,7 +36,7 @@ exec_prefix=@exec_prefix@
|
||||
LOGDIR=@localstatedir@
|
||||
CFGDIR=@sysconfdir@
|
||||
BINDIR=@bindir@
|
||||
|
@ -11,15 +11,16 @@ $NetBSD: patch-ac,v 1.6 2009/12/15 18:56:02 bouyer Exp $
|
|||
HTMLDIR=@datarootdir@
|
||||
INSTALL=@INSTALL@
|
||||
INSTALL_OPTS=@INSTALL_OPTS@
|
||||
@@ -202,9 +202,8 @@
|
||||
@@ -202,9 +202,9 @@ install-unstripped:
|
||||
$(MAKE) install-basic
|
||||
|
||||
install-basic:
|
||||
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
|
||||
- $(INSTALL) -m 774 $(INSTALL_OPTS) @nagios_name@ $(DESTDIR)$(BINDIR)
|
||||
- $(INSTALL) -m 774 $(INSTALL_OPTS) @nagiostats_name@ $(DESTDIR)$(BINDIR)
|
||||
+ ${BSD_INSTALL_PROGRAM_DIR} $(DESTDIR)$(BINDIR)
|
||||
+ ${BSD_INSTALL_PROGRAM} @nagios_name@ $(DESTDIR)$(BINDIR)
|
||||
+ $(INSTALL) -m 550 $(INSTALL_OPTS) @nagiostats_name@ $(DESTDIR)$(BINDIR)
|
||||
+ ${BSD_INSTALL_PROGRAM} -m 550 @nagiostats_name@ $(DESTDIR)$(BINDIR)
|
||||
|
||||
strip-post-install:
|
||||
$(STRIP) $(DESTDIR)$(BINDIR)/@nagios_name@
|
||||
|
|
|
@ -1,17 +1,19 @@
|
|||
$NetBSD: patch-ad,v 1.6 2009/12/15 18:56:02 bouyer Exp $
|
||||
$NetBSD: patch-ad,v 1.7 2011/04/08 22:37:25 morr Exp $
|
||||
|
||||
--- html/Makefile.in.orig 2009-06-17 05:57:21.000000000 +0200
|
||||
+++ html/Makefile.in 2009-12-15 17:01:07.000000000 +0100
|
||||
@@ -7,7 +7,7 @@
|
||||
--- html/Makefile.in.orig 2009-07-07 22:34:51.000000000 +0000
|
||||
+++ html/Makefile.in
|
||||
@@ -7,8 +7,8 @@ exec_prefix=@exec_prefix@
|
||||
LOGDIR=@localstatedir@
|
||||
CFGDIR=@sysconfdir@
|
||||
BINDIR=@bindir@
|
||||
-CGIDIR=@sbindir@
|
||||
-HTMLDIR=@datadir@
|
||||
+CGIDIR=@libexecdir@
|
||||
HTMLDIR=@datarootdir@
|
||||
+HTMLDIR=@datarootdir@
|
||||
INSTALL=@INSTALL@
|
||||
INSTALL_OPTS=@INSTALL_OPTS@
|
||||
@@ -33,46 +33,45 @@
|
||||
COMMAND_OPTS=@COMMAND_OPTS@
|
||||
@@ -33,46 +33,45 @@ distclean: clean
|
||||
devclean: distclean
|
||||
|
||||
install:
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ae,v 1.3 2009/12/15 18:56:02 bouyer Exp $
|
||||
$NetBSD: patch-ae,v 1.4 2011/04/08 22:37:25 morr Exp $
|
||||
|
||||
--- common/Makefile.in.orig 2009-06-17 05:57:21.000000000 +0200
|
||||
+++ common/Makefile.in 2009-12-15 17:01:52.000000000 +0100
|
||||
@@ -17,7 +17,7 @@
|
||||
--- common/Makefile.in.orig 2009-06-17 03:57:21.000000000 +0000
|
||||
+++ common/Makefile.in
|
||||
@@ -17,7 +17,7 @@ exec_prefix=@exec_prefix@
|
||||
LOGDIR=@localstatedir@
|
||||
CFGDIR=@sysconfdir@
|
||||
BINDIR=@bindir@
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-af,v 1.3 2009/12/15 18:56:02 bouyer Exp $
|
||||
$NetBSD: patch-af,v 1.4 2011/04/08 22:37:25 morr Exp $
|
||||
|
||||
--- sample-config/nagios.cfg.in.orig 2008-12-14 15:52:23.000000000 +0100
|
||||
+++ sample-config/nagios.cfg.in 2009-12-15 17:02:13.000000000 +0100
|
||||
@@ -198,7 +198,7 @@
|
||||
--- sample-config/nagios.cfg.in.orig 2010-10-04 02:27:55.000000000 +0000
|
||||
+++ sample-config/nagios.cfg.in
|
||||
@@ -198,7 +198,7 @@ lock_file=@lockfile@
|
||||
# is created, used, and deleted throughout the time that Nagios is
|
||||
# running.
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ag,v 1.6 2009/12/15 18:56:02 bouyer Exp $
|
||||
$NetBSD: patch-ag,v 1.7 2011/04/08 22:37:25 morr Exp $
|
||||
|
||||
--- configure.orig 2009-06-23 19:40:46.000000000 +0200
|
||||
+++ configure 2009-12-15 17:03:08.000000000 +0100
|
||||
@@ -6061,7 +6061,7 @@
|
||||
--- configure.orig 2010-10-04 03:56:55.000000000 +0000
|
||||
+++ configure
|
||||
@@ -6239,7 +6239,7 @@ else
|
||||
fi
|
||||
|
||||
if test x$CHECKRESULTDIR = xno; then
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-ah,v 1.1 2006/05/17 20:47:41 bouyer Exp $
|
||||
$NetBSD: patch-ah,v 1.2 2011/04/08 22:37:25 morr Exp $
|
||||
|
||||
--- cgi/getcgi.c.orig 2006-05-17 22:25:16.000000000 +0200
|
||||
+++ cgi/getcgi.c 2006-05-17 22:25:26.000000000 +0200
|
||||
--- cgi/getcgi.c.orig 2006-05-15 16:59:24.000000000 +0000
|
||||
+++ cgi/getcgi.c
|
||||
@@ -10,6 +10,7 @@
|
||||
#include "../include/getcgi.h"
|
||||
#include <stdio.h>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ai,v 1.3 2008/07/21 00:36:11 tonnerre Exp $
|
||||
$NetBSD: patch-ai,v 1.4 2011/04/08 22:37:25 morr Exp $
|
||||
|
||||
--- include/locations.h.in.orig 2007-05-01 00:45:57.000000000 +0200
|
||||
--- include/locations.h.in.orig 2008-11-30 17:22:59.000000000 +0000
|
||||
+++ include/locations.h.in
|
||||
@@ -20,7 +20,7 @@
|
||||
|
||||
|
|
Loading…
Reference in a new issue