Include sys/types.h before sys/socket.h for DragonFly. Fix errno.

This commit is contained in:
joerg 2005-12-11 20:29:12 +00:00
parent 6df2c7c46f
commit 09b74498d3
4 changed files with 43 additions and 6 deletions

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.2 2005/02/23 20:39:54 agc Exp $
$NetBSD: distinfo,v 1.3 2005/12/11 20:29:12 joerg Exp $
SHA1 (liveice-xmms.tar.gz) = a1986bbd7532cc3eb148bc98e0a3baca680b5d96
RMD160 (liveice-xmms.tar.gz) = d2356bc0bd1ce7268cad9b603c8127de4bcb266e
Size (liveice-xmms.tar.gz) = 132719 bytes
SHA1 (patch-aa) = ce7742e899051fd6cccb4bf783701c7c3339ed04
SHA1 (patch-aa) = c6dc0b3d423b3f8cbbb3174867a1e037ca9f34d8
SHA1 (patch-ab) = 2ff694005c49f69ea47fce4a3a30df59ccc961b6
SHA1 (patch-ac) = 5805b66113494c5f6bab194055662c05d98bbd54

View file

@ -1,8 +1,17 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/06/01 12:27:43 jmmv Exp $
$NetBSD: patch-aa,v 1.2 2005/12/11 20:29:12 joerg Exp $
--- src/liveice.c.orig 2000-05-14 21:42:20.000000000 +0200
--- src/liveice.c.orig 2000-05-14 19:42:20.000000000 +0000
+++ src/liveice.c
@@ -167,7 +167,7 @@ static void init(void)
@@ -27,8 +27,6 @@
-extern int errno;
-
static sckt *liveice_sp=NULL;
static gboolean config_read = FALSE;
@@ -167,7 +165,7 @@ static void init(void)
if(!xmms_cfg_read_string(cfg, "LiveIce", "description", &lv_conf.description))
lv_conf.description=g_strdup("Music from XMMS");
if(!xmms_cfg_read_string(cfg, "LiveIce", "encoder_path", &lv_conf.encoder_path))
@ -11,7 +20,7 @@ $NetBSD: patch-aa,v 1.1.1.1 2003/06/01 12:27:43 jmmv Exp $
if(!xmms_cfg_read_string(cfg, "LiveIce", "remote_dumpfile", &lv_conf.remote_dumpfile))
lv_conf.encoder_path=g_strdup("liveice_xmms.mp3");
@@ -182,7 +182,7 @@ static void init(void)
@@ -182,7 +180,7 @@ static void init(void)
lv_conf.genre=g_strdup("live");
lv_conf.url=g_strdup("http://www.icecast.org");
lv_conf.description=g_strdup("Music from XMMS");

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2005/12/11 20:29:12 joerg Exp $
--- src/serverlib.c.orig 2005-12-11 20:21:28.000000000 +0000
+++ src/serverlib.c
@@ -12,8 +12,6 @@
-extern int errno;
-
/* Create a new socket which can be bound to a socket later */

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1 2005/12/11 20:29:12 joerg Exp $
--- src/serverlib.h.orig 2005-12-11 20:21:44.000000000 +0000
+++ src/serverlib.h
@@ -18,7 +18,7 @@
*
*/
-
+#include <sys/types.h>
#include <sys/socket.h>
#include <netdb.h>
#include <netinet/in.h>