Update to 0.14.0.

Supports slrn and XNews-style scorefiles.
Added sixth layout mode in the Preferences|Layout dialog.
Added a default character set to the Posting Profiles.
Faster article filters.
Lots of bugfixes.
This commit is contained in:
wiz 2003-05-09 10:02:15 +00:00
parent c8f09aaf1f
commit 09e6371cde
3 changed files with 5 additions and 33 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.22 2003/05/05 16:44:19 jmmv Exp $
# $NetBSD: Makefile,v 1.23 2003/05/09 10:02:15 wiz Exp $
#
DISTNAME= pan-0.13.4
PKGREVISION= 2
DISTNAME= pan-0.14.0
CATEGORIES= news
MASTER_SITES= http://pan.rebelbase.com/download/releases/${DISTNAME:C/pan-//}/SOURCE/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.9 2003/04/15 10:28:45 wiz Exp $
$NetBSD: distinfo,v 1.10 2003/05/09 10:02:15 wiz Exp $
SHA1 (pan-0.13.4.tar.bz2) = d8e13268f89723796bfd36b07cce6b14ee81c724
Size (pan-0.13.4.tar.bz2) = 1639281 bytes
SHA1 (pan-0.14.0.tar.bz2) = eefbe6fc699f214f88315e2dda85c989ee707df2
Size (pan-0.14.0.tar.bz2) = 1753632 bytes
SHA1 (patch-ag) = 4ba365c425f5f754346465d857178331ab47e307
SHA1 (patch-ah) = 0d383f75c7f6f9ab8413cad65461362db66b57c3

View file

@ -1,26 +0,0 @@
$NetBSD: patch-ah,v 1.1 2003/04/15 10:28:46 wiz Exp $
--- pan/sockets.c.orig Wed Feb 12 19:37:43 2003
+++ pan/sockets.c Sun Mar 30 21:33:25 2003
@@ -86,6 +86,9 @@
int port)
{
PanSocket * sock;
+# ifdef SIGPIPE
+ struct sigaction sig;
+# endif
/* sanity clause */
g_return_val_if_fail (is_nonempty_string (server_name), NULL);
@@ -94,7 +97,10 @@
/* needed on Unix */
# ifdef SIGPIPE
- sigignore (SIGPIPE);
+ sig.sa_handler = SIG_IGN;
+ sig.sa_flags = 0;
+ sigprocmask(0, NULL, &sig.sa_mask);
+ sigaction(SIGPIPE, &sig, NULL);
# endif
/* create the socket */