Update to SBCL 1.0.38

changes in sbcl-1.0.38 relative to sbcl-1.0.37:

  * incompatible change: Thread names are now restricted to SIMPLE-STRINGs
    like for any other thread-related datastructure, MUTEX, etc. (lp#547095)
  * deprecation: the SB-QUEUE contrib was merged into the SB-CONCURRENCY
    contrib module. New code should depend on SB-CONCURRENCY, not SB-QUEUE.
  * deprecation: SB-THEAD:GET-MUTEX was deprecated in favor of
    SB-THREAD:GRAB-MUTEX.
  * new contributed module: SB-CONCURRENCY is a new contrib; it's supposed to
    contain additional data structures and tools for concurrent programming;
    at the moment it contains a lock-free queue, and a lock-free mailbox
    implementation.
  * new feature: added SB-THREAD:GRAB-MUTEX; it's like the now deprecated
    GET-MUTEX but takes &key rather than &optional parameters.  Also added
    :TIMEOUT argument to GRAB-MUTEX on non-sb-lutex platforms like Linux and
    BSD.
  * new feature: added SB-THREAD:TRY-SEMAPHORE, a non-blocking variant of
    SB-THREAD:WAIT-ON-SEMAPHORE.
  * new feature: SB-EXT:ATOMIC-DECF has been added as a companion to
    SB-EXT:ATOMIC-INCF.
  * new feature: a CANCEL-DEADLINE is associated with DEADLINE-TIMEOUT
    conditions to defer the deadline for forever.
  * enhancement: *STANDARD-OUTPUT*, *STANDARD-INPUT*, and *ERROR-OUTPUT* are
    now bivalent.
  * enhancement: errors from NO-APPLICABLE-METHOD and
    NO-PRIMARY-METHOD now have a RETRY restart available to retry the
    generic function call.
  * enhancement: SB-BSD-SOCKET improvements
    ** sockets and socket streams now have a more informative printed
       representation based on the corresponding SOCKET-NAME and
       SOCKET-PEERNAME.
    ** SOCKET-MAKE-STREAM once more supports the :AUTO-CLOSE option.
       (lp#540413)
    ** SOCKET-CLOSE now accepts :ABORT argument, which is passed on to
       CL:CLOSE when appropriate, and no longer disassociates the stream
       from the socket if close failed. (lp#543951)
  * improvements to the instrumenting profiler
    ** new feature: report per-function GC overhead. (thanks to John Fremlin)
    ** optimization: counters no longer use locks for the overflow mode.
    ** bug fix: whenever a profiling counter wrapped into overflow mode, it
       incurred an off-by-one miscount.
  * enhancement: improved MAKE-HASH-TABLE documentation (lp#543473)
  * enhancement: improved DEFMETHOD pretty-printing.
  * enhancement: perform range reduction when arguments are too large for
    x87's transcendentals (instead of returning 0). (lp#327192)
  * enhancement: eliminate some spurious TYPE-WARNINGs. Should help with
    some of CL-PPCRE's macros. (lp#570079)
  * enhancement: our machine code is slightly less hostile to valgrind on
    x86-64.
  * enhancement: up-to-date versions of NetBSD-current are supported.  (Thanks
    to Robert Swindells and Aleksej Saushev)
  * bug fix: correct restart text for the continuable error in MAKE-PACKAGE.
  * bug fix: a rare case of startup-time page table corruption.
  * bug fix: a semaphore with multiple waiters and some of them unwinding due
    to timeouts could be left in an inconsistent state.
  * bug fix: fix typo in "Reporting Bugs" section of the manual (lp#520366)
  * bug fix: misoptimization of multiplication by one in
    (SB-C::FLOAT-ACCURACY 0) policies.
  * bug fix: miscounts in SB-PROFILE.
  * bug fix: Fix lost wakeup bug between SB-THREAD:CONDITION-WAIT and
    CONDITION-NOTIFY on Linux. See threads "lost wakeup in condition-wait /
    condition-notify" (Feb 2010) and "Condition-Wait, Deadline handler, waking
    up itself" (March 2010) for further details.
  * bug fix: allow forward FIND and POSITION on lists to elide checking :END
    against length of the list if the element is found before the specified
    END is reached. (thanks to Alec Berryman, lp#554385)
  * bug fix: errors signalled during package graph modification no longer
    block FIND-SYMBOL and FIND-PACKAGE in other threads. (lp#511072)
  * bug fix: SB-POSIX build was broken when SBCL was compiled without the
    :SB-DOC feature. (lp#552564)
  * bug fix: SB-INTROSPECT build issues on GENGC/PPC. (lp#490490)
  * bug fix: more robust runtime executable path detection. (lp#375549)
  * bug fix: GCD always returns positive values. (lp#413680)
  * bug fix: Converting division to multiplication by reciprocal handles
    denormals.
  * bug fix: We were too eager in eliding range reduction tests on x87.
    The maximal magnitude is 2^63, not 2^64.
  * bug fix: Transforms for TRUNCATE don't die when the result is completely
    ignored anymore.
  * bug fix: Maybe restore buildability on Alpha.
  * bug fix: READ-BYTE isn't inline anymore, fixing weird streams failures.
    (lp#569404)
  * bug fix: RANDOM-STATE can be printed readably again.
  * bug fix: Unreadable objects were sometimes printed like #<\nFoo>.
  * bug fix: Using EQL with non-constant values of constant type (e.g. EQL
    types) could result in type mismatches during compilation.


changes in sbcl-1.0.37 relative to sbcl-1.0.36:

  * enhancement: Backtrace from THROW to uncaught tag on x86oids now shows
    stack frame thrown from.
  * enhancement: WITH-COMPILATION-UNIT :POLICY allows restricting changes to
    compiler optimization qualities inside dynamic extent of its body.
  * enhancement: LOAD-LOGICAL-PATHNAME-TRANSLATIONS can be used to load
    translations from SYS:SITE;<HOST>.TRANSLATIONS.NEWEST (thanks to Michael
    Weber)
  * optimization: SLOT-VALUE and (SETF SLOT-VALUE) take advantage of
    constraint propgation, allowing better compilation eg. when used to
    access structures with WITH-SLOTS. (lp#520366)
  * optimization: the compiler is now more aware of the type of the underlying
    storage vector for multidimensional simple arrays resulting in better code
    for accessing such arrays.
  * optimization: passing NIL as the environment argument to TYPEP no longer
    inhibits optimizing it. (lp#309788)
  * optimization: more efficient register usage when handling single-float
    arguments on x86-64. (thanks to Lutz Euler)
  * optimization: ADJUST-ARRAY and STABLE-SORT on vectors no longer use
    pre-allocated temporary vectors. (lp#496249)
  * bug fix: Fix compiler error involving MAKE-ARRAY and IF forms
    in :INITIAL-CONTENTS. (lp#523612)
  * bug fix: FUNCTION-LAMBDA-EXPRESSION lost declarations from interpreted
    functions. (lp#524707)
  * bug fix: bogus style warnings from certain (SETF SLOT-VALUE) and
    WITH-SLOTS usages during compilation.
  * bug fix: SB-C::CLASS-INFO now prints correctly. (lp#514762)
  * enhancement: Can now build with ud2 instead of int3 as trap instruction on
    all x86oid platforms with :UD2-BREAKPOINTS target feature.
  * bug fix: Breakpoints now work when using ud2 instead of int3 as trap
    instruction (tested on x86oid linux with ud2-breakpoints).
  * bug fix: slam.sh now works on win32.
  * bug fix: better differences of numeric types. (lp#309124)
  * bug fix: arrays declared intersection and union types can have their
    upgraded element type derived. (lp#316078)
  * bug fix: SB-SPROF allocation profiling for all threads failed to profile
    threads started during profiling. (lp#472499)
  * bug fix: SB-INTROSPECT test failure when building without SB-EVAL feature.
    (lp#535658)
  * bug fix: SB-CLTL2:DECLARATION-INFORMATION did not take
    SB-EXT:RESTRICT-COMPILER-POLICY into account. (lp#313337)
  * bug fix: Comma inside a backquoted array or structure resulted in nonsense
    values instead of signaling an error. (lp#309093)
  * bug fix: Spurious unused variable warning in a DEFSTRUCT edge case.
    (lp#528807)
  * bug fix: More consistent warnings and notes for ignored DYNAMIC-EXTENT
    declarations (lp#497321)
  * bug fix: FIND and POSITION on lists did not check sequence bounds properly
    and failed to detect circular lists (lp#452008)
  * bug fix: leakage from ~/.asdf-install into the ASDf-INSTALL contrib build
    (lp#538974)
  * bug fix: LOOP OF-TYPE VECTOR compile-time error. (lp#540186)
  * bug fix: SIGNAL SB-SYS:INTERACTIVE-INTERRUPT before entering the debugger
    due to it, so that handlers can run.
  * bug fix: reparsing undefined types if they have become defined since
    parsing. (lp#309128)
  * bug fix: missing &REST type in a proclamation for a function with both
    &REST and &KEY in lambda-list caused miscompilation (lp#458354)
  * bug fix: WHO-CALLS information for source-transformed and compiler-macro
    expanded calls (lp#542174)
  * bug fix: more accurate WHO-MACROEXPANDS information; point into rather
    than just at toplevel form.
This commit is contained in:
asau 2010-05-01 17:01:20 +00:00
parent bafcde085c
commit 0a278ce442
4 changed files with 65 additions and 13 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.23 2010/04/10 05:13:09 dholland Exp $
# $NetBSD: Makefile,v 1.24 2010/05/01 17:01:20 asau Exp $
DISTNAME= ${PKGNAME_NOREV}-source
PKGNAME= sbcl-1.0.36
PKGNAME= sbcl-1.0.38
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=sbcl/}
EXTRACT_SUFX= .tar.bz2
@ -43,7 +43,7 @@ WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
.if !defined(SBCL_BOOT_SYSTEM)
# Use "clisp -ansi -on-error abort" to make the build more reproducible,
# per Christophe Rhodes:
SBCL_BOOT_SYSTEM= clisp -ansi -on-error abort
SBCL_BOOT_SYSTEM= clisp -norc -ansi -on-error abort
BUILD_DEPENDS+= clisp-[0-9]*:../../lang/clisp
UNLIMIT_RESOURCES= datasize
.elif ${SBCL_BOOT_SYSTEM} == clisp

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2010/03/05 14:20:25 asau Exp $
@comment $NetBSD: PLIST,v 1.10 2010/05/01 17:01:20 asau Exp $
bin/sbcl
lib/sbcl/asdf-install/.cvsignore
lib/sbcl/asdf-install/Makefile
@ -78,6 +78,25 @@ lib/sbcl/sb-cltl2/sb-cltl2.fasl
lib/sbcl/sb-cltl2/test-passed
lib/sbcl/sb-cltl2/tests.fasl
lib/sbcl/sb-cltl2/tests.lisp
lib/sbcl/sb-concurrency/Makefile
lib/sbcl/sb-concurrency/mailbox.fasl
lib/sbcl/sb-concurrency/mailbox.lisp
lib/sbcl/sb-concurrency/package.fasl
lib/sbcl/sb-concurrency/package.lisp
lib/sbcl/sb-concurrency/queue.fasl
lib/sbcl/sb-concurrency/queue.lisp
lib/sbcl/sb-concurrency/sb-concurrency.asd
lib/sbcl/sb-concurrency/sb-concurrency.fasl
lib/sbcl/sb-concurrency/sb-concurrency.texinfo
lib/sbcl/sb-concurrency/test-passed
lib/sbcl/sb-concurrency/tests/package.fasl
lib/sbcl/sb-concurrency/tests/package.lisp
lib/sbcl/sb-concurrency/tests/test-mailbox.fasl
lib/sbcl/sb-concurrency/tests/test-mailbox.lisp
lib/sbcl/sb-concurrency/tests/test-queue.fasl
lib/sbcl/sb-concurrency/tests/test-queue.lisp
lib/sbcl/sb-concurrency/tests/test-utils.fasl
lib/sbcl/sb-concurrency/tests/test-utils.lisp
lib/sbcl/sb-cover/.cvsignore
lib/sbcl/sb-cover/Makefile
lib/sbcl/sb-cover/cover.fasl
@ -153,20 +172,19 @@ lib/sbcl/sb-posix/macros.fasl
lib/sbcl/sb-posix/macros.lisp
lib/sbcl/sb-posix/posix-tests.fasl
lib/sbcl/sb-posix/posix-tests.lisp
lib/sbcl/sb-posix/posix-tests.lisp.orig
lib/sbcl/sb-posix/sb-posix.asd
lib/sbcl/sb-posix/sb-posix.fasl
lib/sbcl/sb-posix/sb-posix.texinfo
lib/sbcl/sb-posix/test-passed
lib/sbcl/sb-queue/.cvsignore
lib/sbcl/sb-queue/Makefile
lib/sbcl/sb-queue/queue.fasl
lib/sbcl/sb-queue/queue.lisp
lib/sbcl/sb-queue/package.fasl
lib/sbcl/sb-queue/package.lisp
lib/sbcl/sb-queue/sb-queue.asd
lib/sbcl/sb-queue/sb-queue.fasl
lib/sbcl/sb-queue/sb-queue.texinfo
lib/sbcl/sb-queue/test-passed
lib/sbcl/sb-queue/test-queue.fasl
lib/sbcl/sb-queue/test-queue.lisp
lib/sbcl/sb-rotate-byte/.cvsignore
lib/sbcl/sb-rotate-byte/Makefile
lib/sbcl/sb-rotate-byte/README
@ -174,7 +192,7 @@ lib/sbcl/sb-rotate-byte/compiler.fasl
lib/sbcl/sb-rotate-byte/compiler.lisp
lib/sbcl/sb-rotate-byte/package.fasl
lib/sbcl/sb-rotate-byte/package.lisp
lib/sbcl/sb-rotate-byte/p${LOWER_VENDOR}-vm.lisp
lib/sbcl/sb-rotate-byte/ppc-vm.lisp
lib/sbcl/sb-rotate-byte/rotate-byte-tests.fasl
lib/sbcl/sb-rotate-byte/rotate-byte-tests.lisp
lib/sbcl/sb-rotate-byte/rotate-byte.fasl

View file

@ -1,9 +1,10 @@
$NetBSD: distinfo,v 1.9 2010/03/05 14:20:25 asau Exp $
$NetBSD: distinfo,v 1.10 2010/05/01 17:01:20 asau Exp $
SHA1 (sbcl-1.0.36-source.tar.bz2) = 58263e0f6d17833bc722846e1be01c2a9af90228
RMD160 (sbcl-1.0.36-source.tar.bz2) = 160e2adf42557a12879e0476aa8e46d6c255e6aa
Size (sbcl-1.0.36-source.tar.bz2) = 3393142 bytes
SHA1 (sbcl-1.0.38-source.tar.bz2) = 39d09bec3821ad07761361f9300752d53c5bac87
RMD160 (sbcl-1.0.38-source.tar.bz2) = 95f424df58cbeb5ad9bb9e220d77da542a06f62d
Size (sbcl-1.0.38-source.tar.bz2) = 3415742 bytes
SHA1 (patch-aa) = 3bd72ba259fc23c3ae09bf104c8e395f3826fff0
SHA1 (patch-ab) = e8420a7aa51f6920d6556e84ef3f0ca32fdeb2fd
SHA1 (patch-ac) = bce87555a5944cfeb25c65df9d41c3f49b5d4866
SHA1 (patch-ad) = 4a10e7d498b686a09b067c527010981c15f0f8c8
SHA1 (patch-ae) = ea29307779f7aede89ab368a9a7901f95d16d5b2

View file

@ -0,0 +1,33 @@
$NetBSD: patch-ae,v 1.1 2010/05/01 17:01:20 asau Exp $
Disable failing tests.
--- contrib/sb-posix/posix-tests.lisp.orig 2010-02-03 13:04:33.000000000 +0300
+++ contrib/sb-posix/posix-tests.lisp 2010-04-21 17:00:44.000000000 +0400
@@ -429,7 +429,7 @@
sb-posix::o-nonblock)))
t)
-#-(or hpux win32) ; fix: cant handle c-vargs
+#-(or hpux win32 netbsd) ; fix: cant handle c-vargs
(deftest fcntl.flock.1
(locally (declare (sb-ext:muffle-conditions sb-ext:compiler-note))
(let ((flock (make-instance 'sb-posix:flock
@@ -464,7 +464,7 @@
42)
-#-win32
+#-(or win32 netbsd)
(deftest fcntl.flock.2
(locally (declare (sb-ext:muffle-conditions sb-ext:compiler-note))
(let ((flock (make-instance 'sb-posix:flock
@@ -613,7 +613,7 @@
(plusp (sb-posix:time))
t)
-#-win32
+#-(or win32 netbsd)
(deftest utimes.1
(let ((file (merge-pathnames #p"utimes.1" *test-directory*))
(atime (random (1- (expt 2 31))))