- Remove patch-aa, no file found, no similar lines found.
 - Add LICENSE= public-domain, following line is found in README
   Berkeley Yacc is in the public domain.
(upstream)
 - Update from 20050813 to 20141128
 - CHANGLOG found but too huge to quote here.
This commit is contained in:
mef 2014-12-15 06:04:13 +00:00
parent 57dc8b6db6
commit 0a376afa3b
3 changed files with 6 additions and 36 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.12 2014/12/15 05:52:01 mef Exp $
# $NetBSD: Makefile,v 1.13 2014/12/15 06:04:13 mef Exp $
#
DISTNAME= byacc-20050813
PKGREVISION= 1
DISTNAME= byacc-20141128
CATEGORIES= devel
MASTER_SITES= ftp://invisible-island.net/byacc/
EXTRACT_SUFX= .tgz

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.5 2014/12/15 05:52:01 mef Exp $
$NetBSD: distinfo,v 1.6 2014/12/15 06:04:13 mef Exp $
SHA1 (byacc-20050813.tgz) = 3258494f3422eb3150944c1823af1c9c2c386062
RMD160 (byacc-20050813.tgz) = 3ee159857a79025a83e2b0807577925fe460f816
Size (byacc-20050813.tgz) = 138684 bytes
SHA1 (patch-aa) = 4f8f8283d8ff9dd2c896c00d674ed63ba363447f
SHA1 (byacc-20141128.tgz) = 59ea0a166b10eaec99edacc4c38fcb006c6e84d3
RMD160 (byacc-20141128.tgz) = 246dece91262b8f1f8746b03a8a0b32249e47f84
Size (byacc-20141128.tgz) = 710145 bytes

View file

@ -1,28 +0,0 @@
$NetBSD: patch-aa,v 1.4 2014/12/15 05:52:01 mef Exp $
(from cvs log)
date: 2008-07-25 02:13:00 +0900; author: tonnerre; state: Exp; lines: +23 -14;
Fix denial of sevice vulnerability in Berkeley yacc (CVE-2008-3196).
--- skeleton.c.orig 2005-05-05 01:39:36.000000000 +0200
+++ skeleton.c
@@ -87,6 +87,7 @@ char *header[] =
"short *yyssp;",
"YYSTYPE *yyvsp;",
"YYSTYPE yyval;",
+ "static YYSTYPE yyvalzero;", /* no "const", must compile as C++ */
"YYSTYPE yylval;",
"",
"/* variables for the parser stack */",
@@ -275,7 +275,10 @@ char *body[] =
" YYPREFIX, yystate, yyn, yyrule[yyn]);",
"#endif",
" yym = yylen[yyn];",
- " yyval = yyvsp[1-yym];",
+ " if (yym)",
+ " yyval = yyvsp[1-yym];",
+ " else",
+ " yyval = yyvalzero;",
" switch (yyn)",
" {",
0