Fix errno.

This commit is contained in:
joerg 2005-12-09 13:47:58 +00:00
parent 0a0557eab1
commit 0a3d088637
3 changed files with 44 additions and 1 deletions

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.5 2005/02/23 17:15:10 agc Exp $
$NetBSD: distinfo,v 1.6 2005/12/09 13:47:58 joerg Exp $
SHA1 (bvi-1.3.2.src.tar.gz) = 0ff213ebb5cd0993c5d1f7c8d4172aaec709aac1
RMD160 (bvi-1.3.2.src.tar.gz) = d50aa06d5c978026d363002fee194802b2096cbc
Size (bvi-1.3.2.src.tar.gz) = 170444 bytes
SHA1 (patch-aa) = e62f72fd84d03a0109a0b02950aff468ba5639b6
SHA1 (patch-ab) = b3aa82a7fea3122328a2bee8e532684bf7f306c2

View file

@ -0,0 +1,21 @@
$NetBSD: patch-aa,v 1.3 2005/12/09 13:47:58 joerg Exp $
--- comm.c.orig 2005-12-09 13:37:50.000000000 +0000
+++ comm.c
@@ -32,6 +32,8 @@
#include "bvi.h"
#include "set.h"
+#include <errno.h>
+
#ifdef HAVE_UNISTD_H
# include <unistd.h>
#endif
@@ -81,7 +83,6 @@ PTR end_addr;
extern char *name; /* actual filename */
extern char **files; /* used for "next" and "rewind" */
extern int numfiles, curfile;
-extern int errno;
static char oldbuf[CMDSZ]; /** for :!! command **/

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ab,v 1.1 2005/12/09 13:47:58 joerg Exp $
--- bm_unix.c.orig 2005-12-09 13:38:29.000000000 +0000
+++ bm_unix.c
@@ -25,6 +25,7 @@
#include "bmore.h"
+#include <errno.h>
#include <termios.h>
#define TBUFSIZ 1024
@@ -257,7 +258,6 @@ int
vgetc()
{
char cha;
- extern int errno;
errno = 0;
if (read(2, &cha, 1) <= 0) {