enable this on NetBSD>1.5U on alpha since alpha FPC code is now in place.
While here, add some missing headers and squish a LP64 bug. Passes all self tests and all but 2 examples on a 1.5ZA alpha.
This commit is contained in:
parent
551f52dce4
commit
0a4fa9dcb2
12 changed files with 190 additions and 16 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.29 2001/12/22 00:03:25 dmcmahill Exp $
|
||||
# $NetBSD: Makefile,v 1.30 2002/03/05 21:05:52 dmcmahill Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ${SCIBASE}.src
|
||||
PKGNAME= ${SCIBASE}
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
SCIBASE= scilab-2.6
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:.src=}
|
||||
CATEGORIES= math
|
||||
|
@ -16,10 +16,9 @@ COMMENT= High-level scientific math programming environment with graphics
|
|||
DEPENDS+= xless-[0-9]*:../../x11/xless
|
||||
DEPENDS+= pvm-3.4.3:../../parallel/pvm3
|
||||
|
||||
# needs full floating point math. Once the FPC code for alpha is integrated
|
||||
# this line can be changed to only exclude older versions of the operating
|
||||
# system. Additionally, -mieee will need to be added.
|
||||
NOT_FOR_PLATFORM= *-*-alpha
|
||||
#needs FPC code not found in older versions of NetBSD
|
||||
NOT_FOR_PLATFORM= NetBSD-1.[0-4]*-alpha NetBSD-1.5-alpha \
|
||||
NetBSD-1.5.*-alpha NetBSD-1.5[A-U]-alpha
|
||||
|
||||
USE_FORTRAN= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
@ -37,6 +36,22 @@ CONFIGURE_ENV+= PVM_ROOT=${PVM_ROOT}
|
|||
CONFIGURE_ENV+= X11BASE=${X11BASE}
|
||||
PLIST_SUBST+= SCIBASE=${SCIBASE}
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if (${MACHINE_ARCH} == "alpha")
|
||||
pre-fetch:
|
||||
@${ECHO} "===> Checking if you have working FPC"
|
||||
@${MKDIR} ${WRKDIR}
|
||||
${CC} ${CFLAGS} -o ${WRKDIR}/chk_ieee ${FILESDIR}/chk_ieee.c
|
||||
@cd ${WRKDIR} && if ./chk_ieee ; then ${ECHO} "yes" ; else \
|
||||
${ECHO} "no" ; \
|
||||
${ECHO} "${PKGNAME} requires floating point completion on this system" ;\
|
||||
${ECHO} "Possible causes for this check failing are:" ;\
|
||||
${ECHO} " - you have an old /usr/lib/* which was not compiled with -mieee" ;\
|
||||
${ECHO} " - you have overridden CFLAGS for pkgsrc removing the -mieee flag" ;\
|
||||
${ECHO} "Without fixing this problem ${PKGNAME} will not work." ; ${FALSE} ; fi
|
||||
.endif
|
||||
|
||||
# remove some stuff which is broken in the distfile. The config's
|
||||
# are links to ../config (ie circular).
|
||||
post-extract:
|
||||
|
@ -58,7 +73,7 @@ post-build:
|
|||
pre-install:
|
||||
cd ${WRKSRC}/tests && ${MAKE_PROGRAM} distclean
|
||||
cd ${WRKSRC}/examples && ${MAKE_PROGRAM} distclean
|
||||
find ${WRKSRC}/ -name \*.orig -print -exec rm {} \;
|
||||
${FIND} ${WRKSRC}/ -name \*.orig -print -exec ${RM} {} \;
|
||||
|
||||
post-install:
|
||||
${LN} -sf ${X11PREFIX}/bin/xless ${PREFIX}/${SCIBASE}/bin/xless
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.5 2001/12/22 00:03:25 dmcmahill Exp $
|
||||
$NetBSD: distinfo,v 1.6 2002/03/05 21:05:52 dmcmahill Exp $
|
||||
|
||||
SHA1 (scilab-2.6.src.tar.gz) = a91d9a33e849844ec8d6ce98657ded085c5928e0
|
||||
Size (scilab-2.6.src.tar.gz) = 6725259 bytes
|
||||
SHA1 (patch-aa) = a4028254852fb938eb9e3a64b9964526195e13ab
|
||||
SHA1 (patch-ab) = 8896079c2b11e41faf1760d5e88cfc2771a30120
|
||||
SHA1 (patch-ac) = f1f5f90b7f0c3ca2cf5dd0e602395a0b4c56cd1b
|
||||
SHA1 (patch-ad) = b44dc5cfc08a3c91c6230bff9cedd28d3cc62427
|
||||
SHA1 (patch-ac) = fb7bddba451b7737c031a7eabe12c341daa7b4d0
|
||||
SHA1 (patch-ad) = dd61bb74802f892d558e282450073ac013a89599
|
||||
SHA1 (patch-ae) = 5dc250f876b0932adbc7f2771843f71440c9038e
|
||||
SHA1 (patch-af) = 5a94f300bfbaf7791cc3dc52382ee48693189647
|
||||
SHA1 (patch-ag) = ba61ea2d65f4e4dfef8e32b1383a956140f61871
|
||||
|
@ -19,3 +19,10 @@ SHA1 (patch-an) = c0086cf9d5f89c952ec3d5b9ddf8b25835ec696d
|
|||
SHA1 (patch-ao) = 7ce1918c057a9f55626dcdd511c7dcbda9ff53d6
|
||||
SHA1 (patch-ap) = 50f6adb8083c317e9f61b6d85236b41dd850f696
|
||||
SHA1 (patch-aq) = 41326a5f035c827a0c9c8595e175273297dc20c8
|
||||
SHA1 (patch-ar) = 2162ecb3f6571b6ac81288c3ac74c8986147a319
|
||||
SHA1 (patch-as) = fbd24619bcd50d0975bdd687f7458300b3598c05
|
||||
SHA1 (patch-at) = 7b7911f192bd5fb9cda288b65bfd2f1b4ed22759
|
||||
SHA1 (patch-au) = 6d4bb69d7ff1bc1c06c1bc7359725c14da6222da
|
||||
SHA1 (patch-av) = 96297761da050b71096f41d32566152a52e470a5
|
||||
SHA1 (patch-aw) = b243b52711a6219811d26d8640e185b698585493
|
||||
SHA1 (patch-ax) = 760f7b506fbe47d6db6ecfdf4440c03dce07d6cf
|
||||
|
|
14
math/scilab/files/chk_ieee.c
Normal file
14
math/scilab/files/chk_ieee.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
/* $NetBSD: chk_ieee.c,v 1.1 2002/03/05 21:05:53 dmcmahill Exp $ */
|
||||
|
||||
#include <stdio.h>
|
||||
|
||||
int main(int argc, char **argv)
|
||||
{
|
||||
double x=0.0;
|
||||
double y=1.0;
|
||||
double z;
|
||||
|
||||
z=y/x;
|
||||
|
||||
return 0;
|
||||
}
|
|
@ -1,11 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.4 2001/04/08 16:25:28 dmcmahill Exp $
|
||||
$NetBSD: patch-ac,v 1.5 2002/03/05 21:05:53 dmcmahill Exp $
|
||||
|
||||
check for the fortran libs. We need to check this way
|
||||
to keep compatibility with both f2c and f77 rather than
|
||||
hard coding something like "-lg2c".
|
||||
|
||||
also honor {C,F,LD}FLAGS
|
||||
|
||||
--- configure.in.orig Mon Mar 26 07:08:33 2001
|
||||
+++ configure.in Fri Mar 30 06:08:18 2001
|
||||
+++ configure.in Sun Mar 3 13:19:35 2002
|
||||
@@ -112,4 +112,12 @@
|
||||
fi
|
||||
|
||||
|
@ -19,6 +21,27 @@ hard coding something like "-lg2c".
|
|||
+
|
||||
#############################################
|
||||
## Compilers and options according to machine
|
||||
@@ -847,7 +855,7 @@
|
||||
# C Compiler
|
||||
#
|
||||
- CC=cc
|
||||
- CC_OPTIONS='-O2 -Dnetbsd'
|
||||
- CC_LDFLAGS="-Wl,-R${X11BASE}/lib"
|
||||
+ CC="${CC}"
|
||||
+ CC_OPTIONS="${CFLAGS} -Dnetbsd"
|
||||
+ CC_LDFLAGS="${LDFLAGS} -Wl,-R${X11BASE}/lib"
|
||||
CC_PICFLAGS='-fPIC'
|
||||
# check for --export-dynamic
|
||||
@@ -875,7 +883,7 @@
|
||||
fi
|
||||
FC="$F77"
|
||||
- FC_OPTIONS='-O2'
|
||||
+ FC_OPTIONS="${FFLAGS}"
|
||||
FC_OPTIONS_O0=
|
||||
- FC_LDFLAGS="-Wl,-R${X11BASE}/lib"
|
||||
+ FC_LDFLAGS="${LDFLAGS} -Wl,-R${X11BASE}/lib"
|
||||
FC_PICFLAGS='-fPIC'
|
||||
# check for --export-dynamic
|
||||
@@ -1339,4 +1347,5 @@
|
||||
AC_SUBST(LDFLAGS)
|
||||
AC_SUBST(LIBS)
|
||||
|
|
|
@ -1,10 +1,9 @@
|
|||
$NetBSD: patch-ad,v 1.4 2001/04/08 16:25:28 dmcmahill Exp $
|
||||
$NetBSD: patch-ad,v 1.5 2002/03/05 21:05:53 dmcmahill Exp $
|
||||
|
||||
Result of running 'autoconf' after patching configure.in
|
||||
no other manual changes.
|
||||
result of running autoconf on patched configure.in
|
||||
|
||||
--- configure.orig Mon Mar 26 07:10:37 2001
|
||||
+++ configure Fri Mar 30 06:08:41 2001
|
||||
+++ configure Sun Mar 3 13:19:25 2002
|
||||
@@ -991,4 +991,303 @@
|
||||
fi
|
||||
|
||||
|
@ -561,6 +560,17 @@ no other manual changes.
|
|||
+echo "configure:2734: checking for $ac_word" >&5
|
||||
if eval "test \"`echo '$''{'ac_cv_prog_F77'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
@@ -2558,7 +2857,7 @@
|
||||
# C Compiler
|
||||
#
|
||||
- CC=cc
|
||||
- CC_OPTIONS='-O2 -Dnetbsd'
|
||||
- CC_LDFLAGS="-Wl,-R${X11BASE}/lib"
|
||||
+ CC="${CC}"
|
||||
+ CC_OPTIONS="${CFLAGS} -Dnetbsd"
|
||||
+ CC_LDFLAGS="${LDFLAGS} -Wl,-R${X11BASE}/lib"
|
||||
CC_PICFLAGS='-fPIC'
|
||||
# check for --export-dynamic
|
||||
@@ -2566,7 +2865,7 @@
|
||||
LDFLAGS='-Wl,--export-dynamic'
|
||||
echo $ac_n "checking if the linker accepts --export-dynamic""... $ac_c" 1>&6
|
||||
|
@ -592,6 +602,16 @@ no other manual changes.
|
|||
+echo "configure:2937: checking for $ac_word" >&5
|
||||
if eval "test \"`echo '$''{'ac_cv_prog_F77'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
@@ -2670,7 +2969,7 @@
|
||||
fi
|
||||
FC="$F77"
|
||||
- FC_OPTIONS='-O2'
|
||||
+ FC_OPTIONS="${FFLAGS}"
|
||||
FC_OPTIONS_O0=
|
||||
- FC_LDFLAGS="-Wl,-R${X11BASE}/lib"
|
||||
+ FC_LDFLAGS="${LDFLAGS} -Wl,-R${X11BASE}/lib"
|
||||
FC_PICFLAGS='-fPIC'
|
||||
# check for --export-dynamic
|
||||
@@ -2678,7 +2977,7 @@
|
||||
LDFLAGS='-Wl,--export-dynamic'
|
||||
echo $ac_n "checking if the linker accepts --export-dynamic""... $ac_c" 1>&6
|
||||
|
|
24
math/scilab/patches/patch-ar
Normal file
24
math/scilab/patches/patch-ar
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-ar,v 1.4 2002/03/05 21:05:53 dmcmahill Exp $
|
||||
|
||||
longs aren't always 32 bits...
|
||||
|
||||
--- routines/sound/misc.c.orig Mon Feb 5 07:19:35 2001
|
||||
+++ routines/sound/misc.c Mon Mar 4 16:43:06 2002
|
||||
@@ -12,4 +12,6 @@
|
||||
****************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
#include "st.h"
|
||||
#include "../machine.h"
|
||||
@@ -326,5 +328,9 @@
|
||||
{
|
||||
union {
|
||||
- unsigned long l; /** we assume here long i s4 bytes **/
|
||||
+#ifdef netbsd
|
||||
+ u_int32_t l;
|
||||
+#else
|
||||
+ unsigned long l; /** we assume here long i s4 bytes **/
|
||||
+#endif
|
||||
float f;
|
||||
} u;
|
12
math/scilab/patches/patch-as
Normal file
12
math/scilab/patches/patch-as
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-as,v 1.4 2002/03/05 21:05:53 dmcmahill Exp $
|
||||
|
||||
--- routines/interf/intfilestat.c.orig Fri Jul 21 07:54:59 2000
|
||||
+++ routines/interf/intfilestat.c Mon Mar 4 20:55:04 2002
|
||||
@@ -4,4 +4,7 @@
|
||||
#include <locale.h>
|
||||
#include <stdio.h>
|
||||
+#ifdef netbsd
|
||||
+#include <string.h>
|
||||
+#endif
|
||||
#include "../stack-c.h"
|
||||
int C2F(intfilestat)(fname)
|
13
math/scilab/patches/patch-at
Normal file
13
math/scilab/patches/patch-at
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-at,v 1.4 2002/03/05 21:05:53 dmcmahill Exp $
|
||||
|
||||
--- routines/dcd/DcdInterf.c.orig Mon Feb 5 07:19:39 2001
|
||||
+++ routines/dcd/DcdInterf.c Tue Mar 5 07:18:35 2002
|
||||
@@ -2,4 +2,8 @@
|
||||
ENPC */
|
||||
|
||||
+#ifdef __NetBSD__
|
||||
+#include <string.h>
|
||||
+#endif
|
||||
+
|
||||
#include "../../routines/stack-c.h"
|
||||
|
13
math/scilab/patches/patch-au
Normal file
13
math/scilab/patches/patch-au
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-au,v 1.6 2002/03/05 21:05:54 dmcmahill Exp $
|
||||
|
||||
--- routines/randlib/Rand.c.orig Mon Jul 17 09:02:35 2000
|
||||
+++ routines/randlib/Rand.c Tue Mar 5 07:21:27 2002
|
||||
@@ -1,4 +1,8 @@
|
||||
/* Copyright Enpc/Cergrene */
|
||||
|
||||
+#ifdef __NetBSD__
|
||||
+#include <string.h>
|
||||
+#endif
|
||||
+
|
||||
#include "../../routines/stack-c.h"
|
||||
#include "grand.h"
|
11
math/scilab/patches/patch-av
Normal file
11
math/scilab/patches/patch-av
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-av,v 1.4 2002/03/05 21:05:54 dmcmahill Exp $
|
||||
|
||||
--- routines/int/genmdsp.c.orig Thu Jun 29 08:12:16 2000
|
||||
+++ routines/int/genmdsp.c Tue Mar 5 07:27:06 2002
|
||||
@@ -1,2 +1,6 @@
|
||||
+#ifdef __NetBSD__
|
||||
+#include <string.h>
|
||||
+#endif
|
||||
+
|
||||
#include "../machine.h"
|
||||
#include <math.h>
|
11
math/scilab/patches/patch-aw
Normal file
11
math/scilab/patches/patch-aw
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-aw,v 1.4 2002/03/05 21:05:54 dmcmahill Exp $
|
||||
|
||||
--- routines/int/mgeti.c.orig Wed Jan 5 12:25:48 2000
|
||||
+++ routines/int/mgeti.c Tue Mar 5 07:35:39 2002
|
||||
@@ -1,3 +1,6 @@
|
||||
/* Copyright INRIA */
|
||||
+#ifdef __NetBSD__
|
||||
+#include <string.h>
|
||||
+#endif
|
||||
#include <stdio.h>
|
||||
#ifdef __STDC__
|
11
math/scilab/patches/patch-ax
Normal file
11
math/scilab/patches/patch-ax
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-ax,v 1.4 2002/03/05 21:05:54 dmcmahill Exp $
|
||||
|
||||
--- routines/int/mputi.c.orig Wed Feb 28 05:16:14 2001
|
||||
+++ routines/int/mputi.c Tue Mar 5 07:36:06 2002
|
||||
@@ -1,3 +1,6 @@
|
||||
/* Copyright INRIA */
|
||||
+#ifdef __NetBSD__
|
||||
+#include <string.h>
|
||||
+#endif
|
||||
#include <stdio.h>
|
||||
#ifdef __STDC__
|
Loading…
Reference in a new issue