Initial import of wormz-1.0b5:
a networked game for X11
This commit is contained in:
parent
ebc2324865
commit
0b38579fc1
9 changed files with 208 additions and 0 deletions
23
games/wormz/Makefile
Normal file
23
games/wormz/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 1998/11/05 08:24:12 garbled Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Wormz-1.0b5
|
||||
PKGNAME= wormz-1.0b5
|
||||
CATEGORIES= games x11
|
||||
MASTER_SITES= http://lide.punknet.cz/miri/
|
||||
|
||||
MAINTAINER= root@garbled.net
|
||||
HOMEPAGE= http://lide.punknet.cz/miri/wormz.html
|
||||
|
||||
WRKSRC= ${WRKDIR}/Wormz
|
||||
USE_GMAKE= yes
|
||||
USE_X11= yes
|
||||
|
||||
post-extract:
|
||||
${MKDIR} ${WRKSRC}/NetBSD
|
||||
${TOUCH} ${WRKSRC}/NetBSD/.depend
|
||||
|
||||
do-configure:
|
||||
(cd ${WRKSRC} && ${GMAKE} ${MAKE_ENV} depend)
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
games/wormz/files/md5
Normal file
3
games/wormz/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1998/11/05 08:24:12 garbled Exp $
|
||||
|
||||
MD5 (Wormz-1.0b5.tar.gz) = bd00b1aa7c49f203b06f8d90c48a8d9a
|
91
games/wormz/patches/patch-aa
Normal file
91
games/wormz/patches/patch-aa
Normal file
|
@ -0,0 +1,91 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1998/11/05 08:24:12 garbled Exp $
|
||||
--- Makefile.orig Tue Jul 14 06:41:40 1998
|
||||
+++ Makefile Wed Nov 4 21:36:13 1998
|
||||
@@ -3,8 +3,8 @@
|
||||
|
||||
#BinInstallPath=$(ARCH)/
|
||||
#LibInstallPath=images/
|
||||
-BinInstallPath=/usr/X11R6/bin/
|
||||
-LibInstallPath=/usr/lib/Wormz/
|
||||
+BinInstallPath=$(PREFIX)/bin/
|
||||
+LibInstallPath=$(PREFIX)/share/Wormz/
|
||||
|
||||
#AllDepths=16
|
||||
AllDepths=8 16 24
|
||||
@@ -29,13 +29,18 @@
|
||||
ifeq ($(TYPEOS),Linux)
|
||||
ARCH=Linux
|
||||
EXTRALIBS=-lm
|
||||
+else
|
||||
+ifeq ($(TYPEOS),NetBSD)
|
||||
+ARCH=NetBSD
|
||||
+EXTRALIBS=-lm
|
||||
+else
|
||||
#!!!
|
||||
#EXTRALIBS=-lefence
|
||||
-else
|
||||
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
+endif
|
||||
|
||||
ifdef USE_GGI
|
||||
EXTRAGGILIBS=-lggi -lt1
|
||||
@@ -43,8 +48,8 @@
|
||||
|
||||
ifdef ARCH
|
||||
|
||||
-INSTALL=install
|
||||
-INSTALLBIN=install -s
|
||||
+INSTALL=install -c
|
||||
+INSTALLBIN=install -c -s
|
||||
INSTALLDIR=install -d
|
||||
|
||||
CC=gcc
|
||||
@@ -60,8 +65,8 @@
|
||||
#-lefence
|
||||
CFLAGS=-pipe $(INCLUDE) $(OPTFLAGS) $(DEBUGFLAGS) $(WARNFLAGS) $(CDEFS)
|
||||
#-Wshadow
|
||||
-X11INCLUDE=-I/usr/openwin/share/include/
|
||||
-STDINCLUDE=-I/usr/local/lib/g++-include/ -I/usr/include/g++/
|
||||
+X11INCLUDE=-I${PREFIX}/include
|
||||
+STDINCLUDE=-I${LOCALBASE}/include
|
||||
INCLUDE=-I./include -I. $(X11INCLUDE) $(STDINCLUDE)
|
||||
|
||||
|
||||
@@ -108,7 +113,7 @@
|
||||
|
||||
SrcsClient=$(SrcsClientND) $(SrcsClientDD)
|
||||
ObjsClient=$(ObjsClientND) $(ObjsClientDD)
|
||||
-LibsClient=-L/usr/X11R6/lib/ -L/usr/local/lib/ -lX11 -lXext $(EXTRALIBS) $(EXTRAGGILIBS)
|
||||
+LibsClient=${LDFLAGS} -L${LOCALBASE}/lib -L${PREFIX}/lib -lX11 -lXext $(EXTRALIBS) $(EXTRAGGILIBS)
|
||||
|
||||
SrcsServer=$(foreach dir,$(DirsServer),$(wildcard $(dir)/*.cc))
|
||||
SrcsServerNotDir=$(notdir $(SrcsServer))
|
||||
@@ -120,7 +125,7 @@
|
||||
SrcsRunnerNotDir=$(notdir $(SrcsRunner))
|
||||
ObjsRunnerNotDir=$(SrcsRunnerNotDir:.cc=.o)
|
||||
ObjsRunner=$(addprefix $(OBJDIR),$(ObjsRunnerNotDir))
|
||||
-LibsRunner=-L/usr/X11R6/lib/ -L/usr/local/lib/ -lX11
|
||||
+LibsRunner=${LDFLAGS} -L${LOCALBASE}/lib -L${PREFIX}/lib/ -lX11
|
||||
|
||||
AllDSrcs=$(foreach dir,$(DepthDepenceDirs),$(wildcard $(dir)/*.cc))
|
||||
AllNSrcs=$(foreach dir,$(NotDepthDepenceDirs),$(wildcard $(dir)/*.cc))
|
||||
@@ -178,14 +183,14 @@
|
||||
Create-PathConfig:
|
||||
echo '#ifndef _PathConfig_hh_' > $(PathConfig)
|
||||
echo '#define _PathConfig_hh_' >> $(PathConfig)
|
||||
- echo '#define ClientBinInstallPath "$(LibInstallPath)$(TargetNameClient)"' >> $(PathConfig)
|
||||
+ echo '#define ClientBinInstallPath "$(BinInstallPath)$(TargetNameClient)"' >> $(PathConfig)
|
||||
echo '#define ServerBinInstallPath "$(BinInstallPath)$(TargetNameServer)"' >> $(PathConfig)
|
||||
echo '#define LibInstallPath "$(LibInstallPath)"' >> $(PathConfig)
|
||||
echo '#define '$(DEF_USE_GGI) >> $(PathConfig)
|
||||
echo '#endif' >> $(PathConfig)
|
||||
|
||||
install-client2:
|
||||
- $(INSTALLBIN) $(TargetClient) $(LibInstallPath)$(TargetNameClient)
|
||||
+ $(INSTALLBIN) $(TargetClient) $(BinInstallPath)$(TargetNameClient)
|
||||
|
||||
install: all
|
||||
$(INSTALLDIR) $(BinInstallPath)
|
31
games/wormz/patches/patch-ab
Normal file
31
games/wormz/patches/patch-ab
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 1998/11/05 08:24:12 garbled Exp $
|
||||
--- include/Compat.hh.orig Tue Jul 7 14:02:01 1998
|
||||
+++ include/Compat.hh Wed Nov 4 23:57:19 1998
|
||||
@@ -22,7 +22,9 @@
|
||||
memset(data, 0, size);
|
||||
}
|
||||
|
||||
+#ifndef __NetBSD__
|
||||
const double PI=3.1415926535797;
|
||||
+#endif
|
||||
|
||||
inline int byteswap(int old)
|
||||
{
|
||||
@@ -34,12 +36,15 @@
|
||||
|
||||
inline int byteswapshort(unsigned short old)
|
||||
{
|
||||
- return ((old & 0xff) << 8)
|
||||
- + ((old & 0xff00) >> 8);
|
||||
+/* return ((old & 0xff) << 8)
|
||||
+ + ((old & 0xff00) >> 8);*/
|
||||
+ return(old);
|
||||
}
|
||||
+#ifndef __NetBSD__
|
||||
extern "C" {
|
||||
int usleep(unsigned int);
|
||||
}
|
||||
+#endif
|
||||
|
||||
#endif
|
||||
#ifdef Linux
|
16
games/wormz/patches/patch-ac
Normal file
16
games/wormz/patches/patch-ac
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 1998/11/05 08:24:12 garbled Exp $
|
||||
--- PaintInterface/T1FontCreator.cc.orig Thu Nov 5 01:09:50 1998
|
||||
+++ PaintInterface/T1FontCreator.cc Thu Nov 5 01:10:08 1998
|
||||
@@ -1,3 +1,4 @@
|
||||
+#ifdef USE_GGI
|
||||
#include "T1FontCreator.hh"
|
||||
#include "Utils.hh"
|
||||
#include "PathConfig.hh"
|
||||
@@ -6,7 +7,6 @@
|
||||
#include <t1lib.h>
|
||||
#include <unistd.h>
|
||||
|
||||
-#ifdef USE_GGI
|
||||
|
||||
T1FontCreator::T1FontCreator()
|
||||
{
|
1
games/wormz/pkg/COMMENT
Normal file
1
games/wormz/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
a networked game for X11
|
7
games/wormz/pkg/DESCR
Normal file
7
games/wormz/pkg/DESCR
Normal file
|
@ -0,0 +1,7 @@
|
|||
A networked game for X11. Up to ten worms can battle it out over the network,
|
||||
to attempt to cage one another in. Very much like tron. Excellent graphics,
|
||||
works on 8, 16 and 24 bit displays.
|
||||
|
||||
To play, click on the "X" to set up your players, and click on the box
|
||||
marked <none> to set up your controls, you may then type the key you wish
|
||||
to use for left, and right.
|
4
games/wormz/pkg/MESSAGE
Normal file
4
games/wormz/pkg/MESSAGE
Normal file
|
@ -0,0 +1,4 @@
|
|||
To play, click on the "X" to set up your players, and click on the box
|
||||
marked <none> to set up your controls, you may then type the key you wish
|
||||
to use for left, and right.
|
||||
|
32
games/wormz/pkg/PLIST
Normal file
32
games/wormz/pkg/PLIST
Normal file
|
@ -0,0 +1,32 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1998/11/05 08:24:12 garbled Exp $
|
||||
share/Wormz/ArrowL.tga
|
||||
share/Wormz/ArrowR.tga
|
||||
share/Wormz/CPUChip.tga
|
||||
share/Wormz/Human.tga
|
||||
share/Wormz/Network.tga
|
||||
share/Wormz/None.tga
|
||||
share/Wormz/README.fonts
|
||||
share/Wormz/Title.tga
|
||||
share/Wormz/bchr.afm
|
||||
share/Wormz/bchr.pfb
|
||||
share/Wormz/bchri.afm
|
||||
share/Wormz/bchri.pfb
|
||||
share/Wormz/blue-wood.tga
|
||||
share/Wormz/checkbox-c.tga
|
||||
share/Wormz/checkbox-u.tga
|
||||
share/Wormz/checker.tga
|
||||
share/Wormz/darkwood.tga
|
||||
share/Wormz/grass.tga
|
||||
share/Wormz/linux.tga
|
||||
share/Wormz/parquet.tga
|
||||
share/Wormz/plasma.tga
|
||||
share/Wormz/plasma2-cubism.tga
|
||||
share/Wormz/plasma2.tga
|
||||
share/Wormz/plasma2-mosaic.tga
|
||||
share/Wormz/plasma3-mosaic.tga
|
||||
bin/Wormz
|
||||
bin/Wormz-server
|
||||
bin/Wormz-client8
|
||||
bin/Wormz-client16
|
||||
bin/Wormz-client24
|
||||
@dirrm share/Wormz
|
Loading…
Reference in a new issue