add the qt4 version of the pinentry widget, from Sverre Froyen per PM
This commit is contained in:
parent
ddda6b8306
commit
0b423e35c2
7 changed files with 232 additions and 3 deletions
4
security/pinentry-qt4/DESCR
Normal file
4
security/pinentry-qt4/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
This is a collection of simple PIN or passphrase entry dialogs which
|
||||
utilize the Assuan protocol as described by the aegypten project.
|
||||
It provides programs for several graphical toolkits, such as GTK+ and
|
||||
QT, as well as for the console, using curses.
|
41
security/pinentry-qt4/Makefile
Normal file
41
security/pinentry-qt4/Makefile
Normal file
|
@ -0,0 +1,41 @@
|
|||
# $NetBSD: Makefile,v 1.1 2010/02/25 11:30:03 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pinentry-0.7.6
|
||||
PKGNAME= pinentry-qt4-0.7.6
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ftp://ftp.gnupg.org/gcrypt/pinentry/
|
||||
|
||||
MAINTAINER= shannonjr@NetBSD.org
|
||||
HOMEPAGE= ftp://ftp.gnupg.org/gcrypt/pinentry/
|
||||
COMMENT= Applications for entering PINs or Passphrases
|
||||
|
||||
PATCHDIR= ${.CURDIR}/../../security/pinentry/patches
|
||||
DISTINFO_FILE= ${.CURDIR}/../../security/pinentry/distinfo
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-libiconv-prefix=${BUILDLINK_PREFIX.iconv}
|
||||
CONFIGURE_ARGS+= --enable-pinentry-qt4
|
||||
CONFIGURE_ARGS+= --with-qt-dir=${QTDIR:Q}
|
||||
CONFIGURE_ARGS+= --with-qt-includes=${BUILDLINK_PREFIX.qt4-libs}/qt4/include
|
||||
CONFIGURE_ARGS+= --with-qt-libraries=${BUILDLINK_PREFIX.qt4-libs}/qt4/lib
|
||||
CONFIGURE_ARGS+= --disable-pinentry-curses
|
||||
#CONFIGURE_ARGS+= --disable-fallback-curses
|
||||
CONFIGURE_ARGS+= --disable-pinentry-gtk
|
||||
CONFIGURE_ARGS+= --disable-pinentry-gtk2
|
||||
CONFIGURE_ARGS+= --disable-pinentry-qt
|
||||
|
||||
USE_LANGUAGES+= c c++
|
||||
USE_TOOLS+= pkg-config gmake
|
||||
INFO_FILES= yes
|
||||
|
||||
INSTALL_DIRS= qt4
|
||||
|
||||
BUILDLINK_API_DEPENDS.libgpg-error+= libgpg-error>=1.0.0
|
||||
.include "../../x11/qt4-libs/buildlink3.mk"
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
#.include "../../security/libgpg-error/buildlink3.mk"
|
||||
#.include "../../security/libksba/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
security/pinentry-qt4/PLIST
Normal file
2
security/pinentry-qt4/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2010/02/25 11:30:03 drochner Exp $
|
||||
bin/pinentry-qt4
|
|
@ -1,6 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.6 2010/02/22 17:19:09 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.7 2010/02/25 11:30:03 drochner Exp $
|
||||
|
||||
SHA1 (pinentry-0.7.6.tar.gz) = 0c525ce81e5589bc9a4f2eb72705bed2b3e9a8b9
|
||||
RMD160 (pinentry-0.7.6.tar.gz) = 6e69eee88b5cbb919ced79971cd4794f5e659023
|
||||
Size (pinentry-0.7.6.tar.gz) = 475101 bytes
|
||||
SHA1 (patch-aa) = cd30ad4f3a3737687dc5786ebd861ef3b17c600e
|
||||
SHA1 (patch-ab) = 2b38195696dc841c5ae9c895e324d27c887d672a
|
||||
SHA1 (patch-ac) = 1974e3ea91c187544a2c240547fe76e0b3a5da60
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.7 2010/02/08 11:43:23 drochner Exp $
|
||||
# $NetBSD: options.mk,v 1.8 2010/02/25 11:30:03 drochner Exp $
|
||||
#
|
||||
|
||||
# XXX This usage of bsd.options.mk is incorrect. The package should
|
||||
|
@ -8,7 +8,7 @@
|
|||
# pinentry-qt
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.pinentry
|
||||
PKG_SUPPORTED_OPTIONS= gtk gtk2 qt
|
||||
PKG_SUPPORTED_OPTIONS= gtk gtk2 qt qt4
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
CONFIGURE_ARGS+= --disable-pinentry-gtk
|
||||
|
@ -28,3 +28,9 @@ CONFIGURE_ARGS+= --disable-pinentry-qt
|
|||
DEPENDS+= pinentry-qt-[0-9]*:../../security/pinentry-qt
|
||||
PINENTRY_DEFAULT= qt
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS+= --disable-pinentry-qt4
|
||||
.if !empty(PKG_OPTIONS:Mqt4)
|
||||
DEPENDS+= pinentry-qt4-[0-9]*:../../security/pinentry-qt4
|
||||
PINENTRY_DEFAULT= qt4
|
||||
.endif
|
||||
|
|
68
security/pinentry/patches/patch-ab
Normal file
68
security/pinentry/patches/patch-ab
Normal file
|
@ -0,0 +1,68 @@
|
|||
$NetBSD: patch-ab,v 1.1 2010/02/25 11:30:03 drochner Exp $
|
||||
|
||||
--- qt4/pinentrydialog.moc.orig 2009-04-03 08:18:25.000000000 -0600
|
||||
+++ qt4/pinentrydialog.moc 2010-02-24 13:54:20.000000000 -0700
|
||||
@@ -1,8 +1,8 @@
|
||||
/****************************************************************************
|
||||
** Meta object code from reading C++ file 'pinentrydialog.h'
|
||||
**
|
||||
-** Created: Mon Mar 16 13:03:03 2009
|
||||
-** by: The Qt Meta Object Compiler version 59 (Qt 4.4.1)
|
||||
+** Created: Wed Feb 24 13:54:20 2010
|
||||
+** by: The Qt Meta Object Compiler version 62 (Qt 4.6.2)
|
||||
**
|
||||
** WARNING! All changes made in this file will be lost!
|
||||
*****************************************************************************/
|
||||
@@ -10,8 +10,8 @@
|
||||
#include "pinentrydialog.h"
|
||||
#if !defined(Q_MOC_OUTPUT_REVISION)
|
||||
#error "The header file 'pinentrydialog.h' doesn't include <QObject>."
|
||||
-#elif Q_MOC_OUTPUT_REVISION != 59
|
||||
-#error "This file was generated using the moc from 4.4.1. It"
|
||||
+#elif Q_MOC_OUTPUT_REVISION != 62
|
||||
+#error "This file was generated using the moc from 4.6.2. It"
|
||||
#error "cannot be used with the include files from this version of Qt."
|
||||
#error "(The moc has changed too much.)"
|
||||
#endif
|
||||
@@ -20,12 +20,15 @@ QT_BEGIN_MOC_NAMESPACE
|
||||
static const uint qt_meta_data_PinEntryDialog[] = {
|
||||
|
||||
// content:
|
||||
- 1, // revision
|
||||
+ 4, // revision
|
||||
0, // classname
|
||||
0, 0, // classinfo
|
||||
- 3, 10, // methods
|
||||
- 4, 25, // properties
|
||||
+ 3, 14, // methods
|
||||
+ 4, 29, // properties
|
||||
0, 0, // enums/sets
|
||||
+ 0, 0, // constructors
|
||||
+ 0, // flags
|
||||
+ 2, // signalCount
|
||||
|
||||
// signals: signature, parameters, type, tag, flags
|
||||
16, 15, 15, 15, 0x05,
|
||||
@@ -55,9 +58,13 @@ const QMetaObject PinEntryDialog::static
|
||||
qt_meta_data_PinEntryDialog, 0 }
|
||||
};
|
||||
|
||||
+#ifdef Q_NO_DATA_RELOCATION
|
||||
+const QMetaObject &PinEntryDialog::getStaticMetaObject() { return staticMetaObject; }
|
||||
+#endif //Q_NO_DATA_RELOCATION
|
||||
+
|
||||
const QMetaObject *PinEntryDialog::metaObject() const
|
||||
{
|
||||
- return &staticMetaObject;
|
||||
+ return QObject::d_ptr->metaObject ? QObject::d_ptr->metaObject : &staticMetaObject;
|
||||
}
|
||||
|
||||
void *PinEntryDialog::qt_metacast(const char *_clname)
|
||||
@@ -78,6 +85,7 @@ int PinEntryDialog::qt_metacall(QMetaObj
|
||||
case 0: accepted(); break;
|
||||
case 1: rejected(); break;
|
||||
case 2: updateQuality((*reinterpret_cast< const secqstring(*)>(_a[1]))); break;
|
||||
+ default: ;
|
||||
}
|
||||
_id -= 3;
|
||||
}
|
106
security/pinentry/patches/patch-ac
Normal file
106
security/pinentry/patches/patch-ac
Normal file
|
@ -0,0 +1,106 @@
|
|||
$NetBSD: patch-ac,v 1.1 2010/02/25 11:30:03 drochner Exp $
|
||||
|
||||
--- qt4/qsecurelineedit.moc.orig 2009-04-03 08:18:25.000000000 -0600
|
||||
+++ qt4/qsecurelineedit.moc 2010-02-24 13:54:48.000000000 -0700
|
||||
@@ -1,8 +1,8 @@
|
||||
/****************************************************************************
|
||||
** Meta object code from reading C++ file 'qsecurelineedit.h'
|
||||
**
|
||||
-** Created: Mon Mar 16 13:03:26 2009
|
||||
-** by: The Qt Meta Object Compiler version 59 (Qt 4.4.1)
|
||||
+** Created: Wed Feb 24 13:54:48 2010
|
||||
+** by: The Qt Meta Object Compiler version 62 (Qt 4.6.2)
|
||||
**
|
||||
** WARNING! All changes made in this file will be lost!
|
||||
*****************************************************************************/
|
||||
@@ -10,8 +10,8 @@
|
||||
#include "qsecurelineedit.h"
|
||||
#if !defined(Q_MOC_OUTPUT_REVISION)
|
||||
#error "The header file 'qsecurelineedit.h' doesn't include <QObject>."
|
||||
-#elif Q_MOC_OUTPUT_REVISION != 59
|
||||
-#error "This file was generated using the moc from 4.4.1. It"
|
||||
+#elif Q_MOC_OUTPUT_REVISION != 62
|
||||
+#error "This file was generated using the moc from 4.6.2. It"
|
||||
#error "cannot be used with the include files from this version of Qt."
|
||||
#error "(The moc has changed too much.)"
|
||||
#endif
|
||||
@@ -20,12 +20,15 @@ QT_BEGIN_MOC_NAMESPACE
|
||||
static const uint qt_meta_data_QSecureLineEdit[] = {
|
||||
|
||||
// content:
|
||||
- 1, // revision
|
||||
+ 4, // revision
|
||||
0, // classname
|
||||
0, 0, // classinfo
|
||||
- 14, 10, // methods
|
||||
- 16, 80, // properties
|
||||
- 1, 128, // enums/sets
|
||||
+ 14, 14, // methods
|
||||
+ 16, 84, // properties
|
||||
+ 1, 148, // enums/sets
|
||||
+ 0, 0, // constructors
|
||||
+ 0, // flags
|
||||
+ 6, // signalCount
|
||||
|
||||
// signals: signature, parameters, type, tag, flags
|
||||
17, 16, 16, 16, 0x05,
|
||||
@@ -47,7 +50,7 @@ static const uint qt_meta_data_QSecureLi
|
||||
|
||||
// properties: name, type, flags
|
||||
280, 272, 0x0a095103,
|
||||
- 301, 290, 0x0019510b,
|
||||
+ 301, 290, 0x0059510b,
|
||||
310, 306, 0x02095103,
|
||||
325, 320, 0x01095103,
|
||||
340, 331, 0x00095009,
|
||||
@@ -63,8 +66,26 @@ static const uint qt_meta_data_QSecureLi
|
||||
473, 320, 0x01095001,
|
||||
487, 320, 0x01095001,
|
||||
|
||||
+ // properties: notify_signal_id
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+ 0,
|
||||
+
|
||||
// enums: name, flags, count, data
|
||||
- 331, 0x0, 4, 132,
|
||||
+ 331, 0x0, 4, 152,
|
||||
|
||||
// enum data: key, value
|
||||
503, uint(QSecureLineEdit::Normal),
|
||||
@@ -98,9 +119,13 @@ const QMetaObject QSecureLineEdit::stati
|
||||
qt_meta_data_QSecureLineEdit, 0 }
|
||||
};
|
||||
|
||||
+#ifdef Q_NO_DATA_RELOCATION
|
||||
+const QMetaObject &QSecureLineEdit::getStaticMetaObject() { return staticMetaObject; }
|
||||
+#endif //Q_NO_DATA_RELOCATION
|
||||
+
|
||||
const QMetaObject *QSecureLineEdit::metaObject() const
|
||||
{
|
||||
- return &staticMetaObject;
|
||||
+ return QObject::d_ptr->metaObject ? QObject::d_ptr->metaObject : &staticMetaObject;
|
||||
}
|
||||
|
||||
void *QSecureLineEdit::qt_metacast(const char *_clname)
|
||||
@@ -132,6 +157,7 @@ int QSecureLineEdit::qt_metacall(QMetaOb
|
||||
case 11: d_func()->_q_clipboardChanged(); break;
|
||||
case 12: d_func()->_q_handleWindowActivate(); break;
|
||||
case 13: d_func()->_q_deleteSelected(); break;
|
||||
+ default: ;
|
||||
}
|
||||
_id -= 14;
|
||||
}
|
Loading…
Reference in a new issue