Faroese language support for aspell, e.g. `aspell -d faroese -c $myfile'.

This commit is contained in:
salo 2003-01-17 06:46:34 +00:00
parent 59cac7fc3a
commit 0b4f2b834b
5 changed files with 58 additions and 0 deletions

View file

@ -0,0 +1 @@
Faroese language support for aspell, e.g. `aspell -d faroese -c $myfile'.

View file

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/01/17 06:46:34 salo Exp $
#
DISTNAME= aspell-fo-0.50-2
PKGNAME= ${DISTNAME:C/fo-(.*)-(.*)$/faroese-\1.\2/}
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU:=aspell/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://aspell.net/
COMMENT= Faroese language support for aspell
USE_BUILDLINK2= YES
HAS_CONFIGURE= YES
CONFIGURE_ENV+= ASPELL=${PREFIX}/bin/aspell
CONFIGURE_ENV+= WORD_LIST_COMPRESS=${PREFIX}/bin/word-list-compress
MAKE_ENV+= INSTALL_DATA="${INSTALL_DATA}"
MAKE_ENV+= INSTALL_DATA_DIR="${INSTALL_DATA_DIR}"
.include "../../textproc/aspell/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,7 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/01/17 06:46:34 salo Exp $
lib/aspell/faroese.alias
lib/aspell/fo.multi
lib/aspell/fo.rws
lib/aspell/føroyskt.alias
share/aspell/fo.dat
share/aspell/fo_phonet.dat

View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2003/01/17 06:46:34 salo Exp $
SHA1 (aspell-fo-0.50-2.tar.bz2) = 3e46bcda037f40783da0f1ae85c00fe7c1b9b070
Size (aspell-fo-0.50-2.tar.bz2) = 73174 bytes
SHA1 (patch-aa) = df35f94688de5a020875e2c3d1a6557e92923799

View file

@ -0,0 +1,21 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/01/17 06:46:34 salo Exp $
--- Makefile.pre.orig Fri Jan 3 18:39:33 2003
+++ Makefile.pre Wed Jan 15 00:48:39 2003
@@ -16,12 +16,10 @@
all: ${rws_files} ${data_files}
install: all
- mkdir -p ${DESTDIR}${dictdir}/
- cp ${rws_files} ${multi_files} ${DESTDIR}${dictdir}/
- cd ${DESTDIR}${dictdir}/ && chmod 644 ${rws_files} ${multi_files}
- mkdir -p ${DESTDIR}${datadir}/
- cp ${data_files} ${DESTDIR}${datadir}/
- cd ${DESTDIR}${datadir}/ && chmod 644 ${data_files}
+ ${INSTALL_DATA_DIR} ${DESTDIR}${dictdir}/
+ ${INSTALL_DATA} ${rws_files} ${multi_files} ${DESTDIR}${dictdir}/
+ ${INSTALL_DATA_DIR} ${DESTDIR}${datadir}/
+ ${INSTALL_DATA} ${data_files} ${DESTDIR}${datadir}/
clean:
rm -f ${rws_files}