dnsmasq: remove patches that were removed from distinfo during update

This commit is contained in:
wiz 2024-02-29 07:49:02 +00:00
parent f1a2415bb8
commit 0b5c0af85f
2 changed files with 0 additions and 30 deletions

View File

@ -1,15 +0,0 @@
$NetBSD: patch-src_rfc2131.c,v 1.3 2023/02/25 03:30:47 riastradh Exp $
Fix ctype(3) misuse.
--- src/rfc2131.c.orig 2023-02-02 20:24:24.000000000 +0000
+++ src/rfc2131.c
@@ -1678,7 +1678,7 @@ static int sanitise(unsigned char *opt,
for (i = option_len(opt); i > 0; i--)
{
char c = *p++;
- if (isprint((int)c))
+ if (isprint((unsigned char)c))
*buf++ = c;
}
*buf = 0; /* add terminator */

View File

@ -1,15 +0,0 @@
$NetBSD: patch-src_tftp.c,v 1.1 2023/02/25 03:30:47 riastradh Exp $
Fix ctype(3) misuse.
--- src/tftp.c.orig 2023-02-02 20:24:24.000000000 +0000
+++ src/tftp.c
@@ -405,7 +405,7 @@ void tftp_request(struct listener *liste
if (*p == '\\')
*p = '/';
else if (option_bool(OPT_TFTP_LC))
- *p = tolower(*p);
+ *p = tolower((unsigned char)*p);
strcpy(daemon->namebuff, "/");
if (prefix)