Updated flex to 2.6.2.
Slightly based on wip/flex by Makoto Fujiwara and Juraj Lutter. * version 2.6.2 released 2016-10-24 ** flex internals *** a segfalt involving yyrestart(NULL) has been fixed *** flex should now handle quoting when mixed with m4 processing correctly *** flex handles `[[' and `]]' correctly *** flex no longer generates non-ANSI code *** more compilation warnings were squashed in generated scanners *** prevented a buffer overflow that could occur when input buffers were the exact wrong size ** test suite *** input filenames on MSWindows are now calculated correctly *** general code cleanups in a number of tests now make the test suite compile much more cleanly ** build system *** the xz archive has been replaced with an lzip archive *** a new option to configure --enable-warnings to encapsulate passing of warning-related flags which is useful in testing flex *** make indent now works for out of source builds *** Portability warnings when generating Makefile.in files are now suppressed; they were just noise and the use of GNU extensions in Makefile.{am,in,} was intentional and well known. ** bugs *** resolved gh#67 ** new sv translation from the translation project * version 2.6.1 released 2016-03-01 ** flex resources *** The flex project is now hosted at github. Consider this a "period of transition". In particular, you should start at https://github.com/westes/flex for the flex codebase, issue tracking and pull requests. *** New releases of flex are to be found at https://github.com/westes/flex/releases. ** flex internals *** Flex now uses more modern and more standard names for variable types. There's more work to be done on that front yet, though. *** A number of compiler warnings have been remedied. *** Line directives should now work as expected and be absent when that is expected. ** test suite *** When running the test suite, c++ files are compiled with the c++ header inside the flex distribution, rather than relying on the build system's flex header , which might not be installed yet or which might be out of date with respect to what flex tests expect. *** Some portability fixes in the test suite such as opening files for reading in binary mode ** Building flex *** The file src/scan.c asdistributed with flex source is now built with the current version of flex. Occasionally this had to be done manually to pick up new flex features. It's now just a part of flex's build system. *** The pdf version of the manual is no longer distributed with flex, although if you have the texinfo package installed, you can still build it. *** lots of general build system cleanup *** the build system tries a bit harder to find libtoolize and texi2dvi. *** When help2man and texi2dvi are missing, the error messages are now much more helpful. ** bug fixes *** resolved github issues #53, #54, #55, #61. *** Resolved sf bugs #128, #129, #155, #160, #184, #187, #195.
This commit is contained in:
parent
9349b1d6b0
commit
0b7c7788f2
9 changed files with 382 additions and 92 deletions
|
@ -1,18 +1,20 @@
|
|||
# $NetBSD: Makefile,v 1.51 2016/08/12 10:12:23 mef Exp $
|
||||
# $NetBSD: Makefile,v 1.52 2016/11/06 21:31:38 wiz Exp $
|
||||
|
||||
DISTNAME= flex-2.6.0
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=flex/}
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
DISTNAME= flex-2.6.2
|
||||
CATEGORIES= devel lang
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=westes/}
|
||||
GITHUB_RELEASE= v${PKGVERSION_NOREV}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://github.com/westes/flex
|
||||
COMMENT= Fast clone of lex(1), the lexical scanner generator
|
||||
LICENSE= 2-clause-bsd
|
||||
|
||||
BUILD_DEPENDS+= help2man-[0-9]*:../../converters/help2man
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_TOOLS+= gm4:run
|
||||
USE_TOOLS+= gm4:run makeinfo gettext
|
||||
GNU_CONFIGURE= yes
|
||||
INFO_FILES= yes
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.11 2016/08/12 10:12:23 mef Exp $
|
||||
@comment $NetBSD: PLIST,v 1.12 2016/11/06 21:31:38 wiz Exp $
|
||||
bin/flex
|
||||
bin/flex++
|
||||
include/FlexLexer.h
|
||||
|
@ -10,8 +10,7 @@ share/doc/flex/AUTHORS
|
|||
share/doc/flex/COPYING
|
||||
share/doc/flex/NEWS
|
||||
share/doc/flex/ONEWS
|
||||
share/doc/flex/README
|
||||
share/doc/flex/flex.pdf
|
||||
share/doc/flex/README.md
|
||||
share/locale/ca/LC_MESSAGES/flex.mo
|
||||
share/locale/da/LC_MESSAGES/flex.mo
|
||||
share/locale/de/LC_MESSAGES/flex.mo
|
||||
|
|
|
@ -1,10 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.24 2016/08/12 10:12:23 mef Exp $
|
||||
$NetBSD: distinfo,v 1.25 2016/11/06 21:31:38 wiz Exp $
|
||||
|
||||
SHA1 (flex-2.6.0.tar.xz) = 684c927c9f1b170e9627338de12e99cf2c224b91
|
||||
RMD160 (flex-2.6.0.tar.xz) = 07c8ffa268fc4a9a117e9c12736f8b58a583dde8
|
||||
SHA512 (flex-2.6.0.tar.xz) = 9cd48aa79ce70814902745d6e67f677bcc67f23dcc46ebb5f2963efac0d8f6f6c10ee87369d2d7557d29e390a3502dd99246db0fd2e096b9e7bb6e16d51d3abe
|
||||
Size (flex-2.6.0.tar.xz) = 1369552 bytes
|
||||
SHA1 (patch-src_Makefile.am) = b50c07da46385500c1a220967c84bea1027b4081
|
||||
SHA1 (patch-src_Makefile.in) = 8d36fbd12918986715c53c772df549a5057325b7
|
||||
SHA1 (patch-src_filter.c) = 377be93afefeca93efa1f8eae0407374bd006ab3
|
||||
SHA1 (patch-tests_Makefile.in) = cff98017e0cc0046b57d3b50c9d07ca43d7ce4f7
|
||||
SHA1 (flex-2.6.2.tar.gz) = 9eab5eddb6efb34d420b3162fd619a01940b9438
|
||||
RMD160 (flex-2.6.2.tar.gz) = f58dca039f2b77b9477e45ac92a57804a6458f13
|
||||
SHA512 (flex-2.6.2.tar.gz) = 481fe3f1c370fe04d5a605a826c53dd0afa5b6ea655f0d14fa9bb9cb498c016f68cef8fea806458f07baa7ae5bc1ac729be427cb4e0cc39ce744a809ef6442b3
|
||||
Size (flex-2.6.2.tar.gz) = 1402237 bytes
|
||||
SHA1 (patch-configure) = 8eeb54c913794d9489b6e2a6d9ae9ce2d32fb7f1
|
||||
SHA1 (patch-tests_Makefile.am) = f30524f9b8c22a37cb04b4406ec142ea1ecb8e59
|
||||
SHA1 (patch-tests_Makefile.in) = 709d5f117418bbcbcc54926f582bc808daf12f3b
|
||||
|
|
15
devel/flex/patches/patch-configure
Normal file
15
devel/flex/patches/patch-configure
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-configure,v 1.1 2016/11/06 21:31:38 wiz Exp $
|
||||
|
||||
Fix unportable test(1) operator.
|
||||
|
||||
--- configure.orig 2016-11-06 21:14:32.894863747 +0000
|
||||
+++ configure
|
||||
@@ -18200,7 +18200,7 @@ done
|
||||
|
||||
# Check whether --enable-warnings was given.
|
||||
if test "${enable_warnings+set}" = set; then :
|
||||
- enableval=$enable_warnings; if test "x$GCC" == xyes; then :
|
||||
+ enableval=$enable_warnings; if test "x$GCC" = xyes; then :
|
||||
: ${WARNINGFLAGS="-Wall -Wextra -Wmissing-prototypes -Wstrict-prototypes -Wnested-externs -Wold-style-definition -Wredundant-decls -Wconversion -Wno-unused-but-set-variable"}
|
||||
fi
|
||||
fi
|
|
@ -1,25 +0,0 @@
|
|||
$NetBSD: patch-src_Makefile.am,v 1.3 2016/08/12 10:12:23 mef Exp $
|
||||
|
||||
libfl* do not need to be linked against libintl, only the binaries do.
|
||||
https://sourceforge.net/p/flex/bugs/198/
|
||||
|
||||
--- src/Makefile.am.orig 2015-11-13 19:32:53.000000000 +0000
|
||||
+++ src/Makefile.am
|
||||
@@ -1,7 +1,7 @@
|
||||
AM_YFLAGS = -d
|
||||
localedir = $(datadir)/locale
|
||||
AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
|
||||
-LIBS = @LIBINTL@ @LIBS@
|
||||
+LIBS = @LIBS@
|
||||
|
||||
m4 = @M4@
|
||||
|
||||
@@ -33,7 +33,7 @@ flex_SOURCES = \
|
||||
filter.c \
|
||||
regex.c
|
||||
|
||||
-LDADD = ../lib/libcompat.la
|
||||
+LDADD = ../lib/libcompat.la @LIBINTL@
|
||||
|
||||
libfl_la_SOURCES = \
|
||||
libmain.c \
|
|
@ -1,25 +0,0 @@
|
|||
$NetBSD: patch-src_Makefile.in,v 1.3 2016/08/12 10:12:23 mef Exp $
|
||||
|
||||
libfl* do not need to be linked against libintl, only the binaries do.
|
||||
https://sourceforge.net/p/flex/bugs/198/
|
||||
|
||||
--- src/Makefile.in.orig 2015-11-17 16:19:45.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -302,7 +302,7 @@ LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
|
||||
LIBICONV = @LIBICONV@
|
||||
LIBINTL = @LIBINTL@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
-LIBS = @LIBINTL@ @LIBS@
|
||||
+LIBS = @LIBS@
|
||||
LIBTOOL = @LIBTOOL@
|
||||
LIPO = @LIPO@
|
||||
LN_S = @LN_S@
|
||||
@@ -428,7 +428,7 @@ flex_SOURCES = \
|
||||
filter.c \
|
||||
regex.c
|
||||
|
||||
-LDADD = ../lib/libcompat.la
|
||||
+LDADD = ../lib/libcompat.la @LIBINTL@
|
||||
libfl_la_SOURCES = \
|
||||
libmain.c \
|
||||
libyywrap.c
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-src_filter.c,v 1.3 2016/08/12 10:12:23 mef Exp $
|
||||
|
||||
Improve stdin-to-pipe hack on NetBSD
|
||||
https://sourceforge.net/p/flex/bugs/198/
|
||||
|
||||
--- src/filter.c.orig 2015-11-10 23:10:20.000000000 +0000
|
||||
+++ src/filter.c
|
||||
@@ -174,6 +174,8 @@ clearerr(stdin);
|
||||
flexfatal (_("dup2(pipes[0],0)"));
|
||||
close (pipes[0]);
|
||||
fseek (stdin, 0, SEEK_CUR);
|
||||
+ ungetc(' ', stdin); /* still an evil hack, but one that works better */
|
||||
+ (void)fgetc(stdin); /* on NetBSD than the fseek attempt does */
|
||||
|
||||
/* run as a filter, either internally or by exec */
|
||||
if (chain->filter_func) {
|
86
devel/flex/patches/patch-tests_Makefile.am
Normal file
86
devel/flex/patches/patch-tests_Makefile.am
Normal file
|
@ -0,0 +1,86 @@
|
|||
$NetBSD: patch-tests_Makefile.am,v 1.3 2016/11/06 21:31:38 wiz Exp $
|
||||
|
||||
Disable bison tests since we don't want to build with bison
|
||||
to avoid a dependency cycle, since bison depends on flex.
|
||||
https://github.com/westes/flex/issues/49
|
||||
|
||||
--- tests/Makefile.am.orig Sun Nov 6 20:09:47 2016
|
||||
+++ tests/Makefile.am Sun Nov 6 20:10:43 2016
|
||||
@@ -66,9 +66,6 @@
|
||||
array_r \
|
||||
basic_nr \
|
||||
basic_r \
|
||||
- bison_nr \
|
||||
- bison_yylloc \
|
||||
- bison_yylval \
|
||||
c_cxx_nr \
|
||||
c_cxx_r \
|
||||
ccl \
|
||||
@@ -127,9 +124,6 @@
|
||||
array_r_SOURCES = array_r.l
|
||||
basic_nr_SOURCES = basic_nr.l
|
||||
basic_r_SOURCES = basic_r.l
|
||||
-bison_nr_SOURCES = bison_nr_scanner.l bison_nr_parser.y bison_nr_main.c
|
||||
-bison_yylloc_SOURCES = bison_yylloc_scanner.l bison_yylloc_parser.y bison_yylloc_main.c
|
||||
-bison_yylval_SOURCES = bison_yylval_scanner.l bison_yylval_parser.y bison_yylval_main.c
|
||||
c_cxx_nr_SOURCES = c_cxx_nr.lll
|
||||
c_cxx_r_SOURCES = c_cxx_r.lll
|
||||
ccl_SOURCES = ccl.l
|
||||
@@ -170,12 +164,6 @@
|
||||
yyextra_SOURCES = yyextra.l
|
||||
|
||||
BUILT_SOURCES = \
|
||||
- bison_nr_parser.h \
|
||||
- bison_nr_scanner.h \
|
||||
- bison_yylloc_parser.h \
|
||||
- bison_yylloc_scanner.h \
|
||||
- bison_yylval_parser.h \
|
||||
- bison_yylval_scanner.h \
|
||||
header_nr_scanner.h \
|
||||
header_r_scanner.h \
|
||||
multiple_scanners_nr_1.h \
|
||||
@@ -198,18 +186,6 @@
|
||||
array_r.c \
|
||||
basic_nr.c \
|
||||
basic_r.c \
|
||||
- bison_nr_parser.c \
|
||||
- bison_nr_parser.h \
|
||||
- bison_nr_scanner.c \
|
||||
- bison_nr_scanner.h \
|
||||
- bison_yylloc_parser.c \
|
||||
- bison_yylloc_parser.h \
|
||||
- bison_yylloc_scanner.c \
|
||||
- bison_yylloc_scanner.h \
|
||||
- bison_yylval_parser.c \
|
||||
- bison_yylval_parser.h \
|
||||
- bison_yylval_scanner.c \
|
||||
- bison_yylval_scanner.h \
|
||||
c_cxx_nr.cc \
|
||||
c_cxx_r.cc \
|
||||
ccl.c \
|
||||
@@ -276,9 +252,6 @@
|
||||
array_r.txt \
|
||||
basic_nr.txt \
|
||||
basic_r.txt \
|
||||
- bison_nr.txt \
|
||||
- bison_yylloc.txt \
|
||||
- bison_yylval.txt \
|
||||
c_cxx_nr.txt \
|
||||
c_cxx_r.txt \
|
||||
ccl.txt \
|
||||
@@ -340,15 +313,6 @@
|
||||
.ll.cc: $(FLEX)
|
||||
$(FLEX) -+ -o $@ $<
|
||||
|
||||
-bison_nr_main.($OBJEXT): bison_nr_parser.h bison_nr_scanner.h
|
||||
-bison_nr_scanner.h: bison_nr_scanner.c
|
||||
-
|
||||
-bison_yylloc_main.$(OBJEXT): bison_yylloc_parser.h bison_yylloc_scanner.h
|
||||
-bison_yylloc_scanner.h: bison_yylloc_scanner.c
|
||||
-
|
||||
-bison_yylval_main.$(OBJEXT): bison_yylval_parser.h bison_yylval_scanner.h
|
||||
-bison_yylval_scanner.h: bison_yylval_scanner.c
|
||||
-
|
||||
# automake does not support compiling flex scanners output in C as C++
|
||||
# so we explicitly sayhow, using the .lll suffix for the lex input file
|
||||
|
|
@ -1,22 +1,125 @@
|
|||
$NetBSD: patch-tests_Makefile.in,v 1.3 2016/08/12 10:12:23 mef Exp $
|
||||
$NetBSD: patch-tests_Makefile.in,v 1.4 2016/11/06 21:31:38 wiz Exp $
|
||||
|
||||
Disable bison tests since we don't want to build with bison
|
||||
to avoid a dependency cycle, since bison depends on flex.
|
||||
https://github.com/westes/flex/issues/49
|
||||
|
||||
--- tests/Makefile.in.orig 2015-11-17 16:19:46.000000000 +0000
|
||||
--- tests/Makefile.in.orig 2016-10-24 22:33:38.000000000 +0000
|
||||
+++ tests/Makefile.in
|
||||
@@ -131,8 +131,8 @@ CONFIG_HEADER = $(top_builddir)/src/conf
|
||||
@@ -131,8 +131,7 @@ CONFIG_HEADER = $(top_builddir)/src/conf
|
||||
CONFIG_CLEAN_FILES =
|
||||
CONFIG_CLEAN_VPATH_FILES =
|
||||
am__EXEEXT_1 = alloc_extra$(EXEEXT) array_nr$(EXEEXT) array_r$(EXEEXT) \
|
||||
- basic_nr$(EXEEXT) basic_r$(EXEEXT) bison_nr$(EXEEXT) \
|
||||
- bison_yylloc$(EXEEXT) bison_yylval$(EXEEXT) c_cxx_nr$(EXEEXT) \
|
||||
+ basic_nr$(EXEEXT) basic_r$(EXEEXT) \
|
||||
+ c_cxx_nr$(EXEEXT) \
|
||||
+ basic_nr$(EXEEXT) basic_r$(EXEEXT) c_cxx_nr$(EXEEXT) \
|
||||
c_cxx_r$(EXEEXT) ccl$(EXEEXT) cxx_basic$(EXEEXT) \
|
||||
cxx_multiple_scanners$(EXEEXT) debug_nr$(EXEEXT) \
|
||||
debug_r$(EXEEXT) extended$(EXEEXT) header_nr$(EXEEXT) \
|
||||
@@ -1440,12 +1440,6 @@ string_r_SOURCES = string_r.l
|
||||
cxx_multiple_scanners$(EXEEXT) cxx_restart$(EXEEXT) \
|
||||
debug_nr$(EXEEXT) debug_r$(EXEEXT) extended$(EXEEXT) \
|
||||
@@ -237,18 +236,6 @@ basic_nr_LDADD = $(LDADD)
|
||||
am_basic_r_OBJECTS = basic_r.$(OBJEXT)
|
||||
basic_r_OBJECTS = $(am_basic_r_OBJECTS)
|
||||
basic_r_LDADD = $(LDADD)
|
||||
-am_bison_nr_OBJECTS = bison_nr_scanner.$(OBJEXT) \
|
||||
- bison_nr_parser.$(OBJEXT) bison_nr_main.$(OBJEXT)
|
||||
-bison_nr_OBJECTS = $(am_bison_nr_OBJECTS)
|
||||
-bison_nr_LDADD = $(LDADD)
|
||||
-am_bison_yylloc_OBJECTS = bison_yylloc_scanner.$(OBJEXT) \
|
||||
- bison_yylloc_parser.$(OBJEXT) bison_yylloc_main.$(OBJEXT)
|
||||
-bison_yylloc_OBJECTS = $(am_bison_yylloc_OBJECTS)
|
||||
-bison_yylloc_LDADD = $(LDADD)
|
||||
-am_bison_yylval_OBJECTS = bison_yylval_scanner.$(OBJEXT) \
|
||||
- bison_yylval_parser.$(OBJEXT) bison_yylval_main.$(OBJEXT)
|
||||
-bison_yylval_OBJECTS = $(am_bison_yylval_OBJECTS)
|
||||
-bison_yylval_LDADD = $(LDADD)
|
||||
am_c_cxx_nr_OBJECTS = c_cxx_nr.$(OBJEXT)
|
||||
c_cxx_nr_OBJECTS = $(am_c_cxx_nr_OBJECTS)
|
||||
c_cxx_nr_LDADD = $(LDADD)
|
||||
@@ -686,24 +673,14 @@ am__v_LEX_ = $(am__v_LEX_@AM_DEFAULT_V@)
|
||||
am__v_LEX_0 = @echo " LEX " $@;
|
||||
am__v_LEX_1 =
|
||||
YLWRAP = $(top_srcdir)/build-aux/ylwrap
|
||||
-am__yacc_c2h = sed -e s/cc$$/hh/ -e s/cpp$$/hpp/ -e s/cxx$$/hxx/ \
|
||||
- -e s/c++$$/h++/ -e s/c$$/h/
|
||||
-YACCCOMPILE = $(YACC) $(AM_YFLAGS) $(YFLAGS)
|
||||
-LTYACCCOMPILE = $(LIBTOOL) $(AM_V_lt) $(AM_LIBTOOLFLAGS) \
|
||||
- $(LIBTOOLFLAGS) --mode=compile $(YACC) $(AM_YFLAGS) $(YFLAGS)
|
||||
-AM_V_YACC = $(am__v_YACC_@AM_V@)
|
||||
-am__v_YACC_ = $(am__v_YACC_@AM_DEFAULT_V@)
|
||||
-am__v_YACC_0 = @echo " YACC " $@;
|
||||
-am__v_YACC_1 =
|
||||
SOURCES = $(alloc_extra_SOURCES) $(array_nr_SOURCES) \
|
||||
$(array_r_SOURCES) $(basic_nr_SOURCES) $(basic_r_SOURCES) \
|
||||
- $(bison_nr_SOURCES) $(bison_yylloc_SOURCES) \
|
||||
- $(bison_yylval_SOURCES) $(c_cxx_nr_SOURCES) $(c_cxx_r_SOURCES) \
|
||||
- $(ccl_SOURCES) $(cxx_basic_SOURCES) \
|
||||
- $(cxx_multiple_scanners_SOURCES) $(cxx_restart_SOURCES) \
|
||||
- $(cxx_yywrap_i3_SOURCES) $(debug_nr_SOURCES) \
|
||||
- $(debug_r_SOURCES) $(extended_SOURCES) $(header_nr_SOURCES) \
|
||||
- $(header_r_SOURCES) $(include_by_buffer_direct_SOURCES) \
|
||||
+ $(c_cxx_nr_SOURCES) $(c_cxx_r_SOURCES) $(ccl_SOURCES) \
|
||||
+ $(cxx_basic_SOURCES) $(cxx_multiple_scanners_SOURCES) \
|
||||
+ $(cxx_restart_SOURCES) $(cxx_yywrap_i3_SOURCES) \
|
||||
+ $(debug_nr_SOURCES) $(debug_r_SOURCES) $(extended_SOURCES) \
|
||||
+ $(header_nr_SOURCES) $(header_r_SOURCES) \
|
||||
+ $(include_by_buffer_direct_SOURCES) \
|
||||
$(include_by_push_direct_SOURCES) \
|
||||
$(include_by_reentrant_direct_SOURCES) \
|
||||
$(lineno_nr_one_SOURCES) $(lineno_r_one_SOURCES) \
|
||||
@@ -785,13 +762,12 @@ SOURCES = $(alloc_extra_SOURCES) $(array
|
||||
$(yyextra_SOURCES)
|
||||
DIST_SOURCES = $(alloc_extra_SOURCES) $(array_nr_SOURCES) \
|
||||
$(array_r_SOURCES) $(basic_nr_SOURCES) $(basic_r_SOURCES) \
|
||||
- $(bison_nr_SOURCES) $(bison_yylloc_SOURCES) \
|
||||
- $(bison_yylval_SOURCES) $(c_cxx_nr_SOURCES) $(c_cxx_r_SOURCES) \
|
||||
- $(ccl_SOURCES) $(cxx_basic_SOURCES) \
|
||||
- $(cxx_multiple_scanners_SOURCES) $(cxx_restart_SOURCES) \
|
||||
- $(cxx_yywrap_i3_SOURCES) $(debug_nr_SOURCES) \
|
||||
- $(debug_r_SOURCES) $(extended_SOURCES) $(header_nr_SOURCES) \
|
||||
- $(header_r_SOURCES) $(include_by_buffer_direct_SOURCES) \
|
||||
+ $(c_cxx_nr_SOURCES) $(c_cxx_r_SOURCES) $(ccl_SOURCES) \
|
||||
+ $(cxx_basic_SOURCES) $(cxx_multiple_scanners_SOURCES) \
|
||||
+ $(cxx_restart_SOURCES) $(cxx_yywrap_i3_SOURCES) \
|
||||
+ $(debug_nr_SOURCES) $(debug_r_SOURCES) $(extended_SOURCES) \
|
||||
+ $(header_nr_SOURCES) $(header_r_SOURCES) \
|
||||
+ $(include_by_buffer_direct_SOURCES) \
|
||||
$(include_by_push_direct_SOURCES) \
|
||||
$(include_by_reentrant_direct_SOURCES) \
|
||||
$(lineno_nr_one_SOURCES) $(lineno_r_one_SOURCES) \
|
||||
@@ -1136,11 +1112,7 @@ am__DIST_COMMON = $(srcdir)/Makefile.in
|
||||
$(top_srcdir)/build-aux/depcomp \
|
||||
$(top_srcdir)/build-aux/test-driver \
|
||||
$(top_srcdir)/build-aux/ylwrap README alloc_extra.c array_nr.c \
|
||||
- array_r.c basic_nr.c basic_r.c bison_nr_parser.c \
|
||||
- bison_nr_parser.h bison_nr_scanner.c bison_yylloc_parser.c \
|
||||
- bison_yylloc_parser.h bison_yylloc_scanner.c \
|
||||
- bison_yylval_parser.c bison_yylval_parser.h \
|
||||
- bison_yylval_scanner.c ccl.c cxx_basic.cc \
|
||||
+ array_r.c basic_nr.c basic_r.c ccl.c cxx_basic.cc \
|
||||
cxx_multiple_scanners_1.cc cxx_multiple_scanners_2.cc \
|
||||
cxx_restart.cc cxx_yywrap.cc debug_nr.c debug_r.c extended.c \
|
||||
header_nr_scanner.c header_r_scanner.c \
|
||||
@@ -1336,9 +1306,6 @@ simple_tests = \
|
||||
array_r \
|
||||
basic_nr \
|
||||
basic_r \
|
||||
- bison_nr \
|
||||
- bison_yylloc \
|
||||
- bison_yylval \
|
||||
c_cxx_nr \
|
||||
c_cxx_r \
|
||||
ccl \
|
||||
@@ -1395,9 +1362,6 @@ array_nr_SOURCES = array_nr.l
|
||||
array_r_SOURCES = array_r.l
|
||||
basic_nr_SOURCES = basic_nr.l
|
||||
basic_r_SOURCES = basic_r.l
|
||||
-bison_nr_SOURCES = bison_nr_scanner.l bison_nr_parser.y bison_nr_main.c
|
||||
-bison_yylloc_SOURCES = bison_yylloc_scanner.l bison_yylloc_parser.y bison_yylloc_main.c
|
||||
-bison_yylval_SOURCES = bison_yylval_scanner.l bison_yylval_parser.y bison_yylval_main.c
|
||||
c_cxx_nr_SOURCES = c_cxx_nr.lll
|
||||
c_cxx_r_SOURCES = c_cxx_r.lll
|
||||
ccl_SOURCES = ccl.l
|
||||
@@ -1437,12 +1401,6 @@ string_r_SOURCES = string_r.l
|
||||
top_SOURCES = top.l top_main.c
|
||||
yyextra_SOURCES = yyextra.l
|
||||
BUILT_SOURCES = \
|
||||
|
@ -29,3 +132,155 @@ to avoid a dependency cycle, since bison depends on flex.
|
|||
header_nr_scanner.h \
|
||||
header_r_scanner.h \
|
||||
multiple_scanners_nr_1.h \
|
||||
@@ -1465,18 +1423,6 @@ CLEANFILES = \
|
||||
array_r.c \
|
||||
basic_nr.c \
|
||||
basic_r.c \
|
||||
- bison_nr_parser.c \
|
||||
- bison_nr_parser.h \
|
||||
- bison_nr_scanner.c \
|
||||
- bison_nr_scanner.h \
|
||||
- bison_yylloc_parser.c \
|
||||
- bison_yylloc_parser.h \
|
||||
- bison_yylloc_scanner.c \
|
||||
- bison_yylloc_scanner.h \
|
||||
- bison_yylval_parser.c \
|
||||
- bison_yylval_parser.h \
|
||||
- bison_yylval_scanner.c \
|
||||
- bison_yylval_scanner.h \
|
||||
c_cxx_nr.cc \
|
||||
c_cxx_r.cc \
|
||||
ccl.c \
|
||||
@@ -1538,9 +1484,6 @@ EXTRA_DIST = \
|
||||
array_r.txt \
|
||||
basic_nr.txt \
|
||||
basic_r.txt \
|
||||
- bison_nr.txt \
|
||||
- bison_yylloc.txt \
|
||||
- bison_yylval.txt \
|
||||
c_cxx_nr.txt \
|
||||
c_cxx_r.txt \
|
||||
ccl.txt \
|
||||
@@ -1738,7 +1681,7 @@ all: $(BUILT_SOURCES)
|
||||
$(MAKE) $(AM_MAKEFLAGS) all-am
|
||||
|
||||
.SUFFIXES:
|
||||
-.SUFFIXES: .c .cc .cn .cn$(EXEEXT) .direct .direct$(EXEEXT) .i3 .i3$(EXEEXT) .l .ll .lll .lo .log .o .obj .one .one$(EXEEXT) .opt .opt$(EXEEXT) .pthread .pthread$(EXEEXT) .reject .reject$(EXEEXT) .ser .ser$(EXEEXT) .table .table$(EXEEXT) .trs .ver .ver$(EXEEXT) .y
|
||||
+.SUFFIXES: .c .cc .cn .cn$(EXEEXT) .direct .direct$(EXEEXT) .i3 .i3$(EXEEXT) .l .ll .lll .lo .log .o .obj .one .one$(EXEEXT) .opt .opt$(EXEEXT) .pthread .pthread$(EXEEXT) .reject .reject$(EXEEXT) .ser .ser$(EXEEXT) .table .table$(EXEEXT) .trs .ver .ver$(EXEEXT)
|
||||
$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(srcdir)/tableopts.am $(am__configure_deps)
|
||||
@for dep in $?; do \
|
||||
case '$(am__configure_deps)' in \
|
||||
@@ -1798,27 +1741,6 @@ basic_nr$(EXEEXT): $(basic_nr_OBJECTS) $
|
||||
basic_r$(EXEEXT): $(basic_r_OBJECTS) $(basic_r_DEPENDENCIES) $(EXTRA_basic_r_DEPENDENCIES)
|
||||
@rm -f basic_r$(EXEEXT)
|
||||
$(AM_V_CCLD)$(LINK) $(basic_r_OBJECTS) $(basic_r_LDADD) $(LIBS)
|
||||
-bison_nr_parser.h: bison_nr_parser.c
|
||||
- @if test ! -f $@; then rm -f bison_nr_parser.c; else :; fi
|
||||
- @if test ! -f $@; then $(MAKE) $(AM_MAKEFLAGS) bison_nr_parser.c; else :; fi
|
||||
-
|
||||
-bison_nr$(EXEEXT): $(bison_nr_OBJECTS) $(bison_nr_DEPENDENCIES) $(EXTRA_bison_nr_DEPENDENCIES)
|
||||
- @rm -f bison_nr$(EXEEXT)
|
||||
- $(AM_V_CCLD)$(LINK) $(bison_nr_OBJECTS) $(bison_nr_LDADD) $(LIBS)
|
||||
-bison_yylloc_parser.h: bison_yylloc_parser.c
|
||||
- @if test ! -f $@; then rm -f bison_yylloc_parser.c; else :; fi
|
||||
- @if test ! -f $@; then $(MAKE) $(AM_MAKEFLAGS) bison_yylloc_parser.c; else :; fi
|
||||
-
|
||||
-bison_yylloc$(EXEEXT): $(bison_yylloc_OBJECTS) $(bison_yylloc_DEPENDENCIES) $(EXTRA_bison_yylloc_DEPENDENCIES)
|
||||
- @rm -f bison_yylloc$(EXEEXT)
|
||||
- $(AM_V_CCLD)$(LINK) $(bison_yylloc_OBJECTS) $(bison_yylloc_LDADD) $(LIBS)
|
||||
-bison_yylval_parser.h: bison_yylval_parser.c
|
||||
- @if test ! -f $@; then rm -f bison_yylval_parser.c; else :; fi
|
||||
- @if test ! -f $@; then $(MAKE) $(AM_MAKEFLAGS) bison_yylval_parser.c; else :; fi
|
||||
-
|
||||
-bison_yylval$(EXEEXT): $(bison_yylval_OBJECTS) $(bison_yylval_DEPENDENCIES) $(EXTRA_bison_yylval_DEPENDENCIES)
|
||||
- @rm -f bison_yylval$(EXEEXT)
|
||||
- $(AM_V_CCLD)$(LINK) $(bison_yylval_OBJECTS) $(bison_yylval_LDADD) $(LIBS)
|
||||
|
||||
c_cxx_nr$(EXEEXT): $(c_cxx_nr_OBJECTS) $(c_cxx_nr_DEPENDENCIES) $(EXTRA_c_cxx_nr_DEPENDENCIES)
|
||||
@rm -f c_cxx_nr$(EXEEXT)
|
||||
@@ -1967,15 +1889,6 @@ distclean-compile:
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/array_r.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/basic_nr.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/basic_r.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bison_nr_main.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bison_nr_parser.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bison_nr_scanner.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bison_yylloc_main.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bison_yylloc_parser.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bison_yylloc_scanner.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bison_yylval_main.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bison_yylval_parser.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/bison_yylval_scanner.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/c_cxx_nr.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/c_cxx_r.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ccl.Po@am__quote@
|
||||
@@ -2062,9 +1975,6 @@ distclean-compile:
|
||||
@AMDEP_TRUE@@am__fastdepCXX_FALSE@ DEPDIR=$(DEPDIR) $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
@am__fastdepCXX_FALSE@ $(AM_V_CXX@am__nodep@)$(LTCXXCOMPILE) -c -o $@ $<
|
||||
|
||||
-.y.c:
|
||||
- $(AM_V_YACC)$(am__skipyacc) $(SHELL) $(YLWRAP) $< y.tab.c $@ y.tab.h `echo $@ | $(am__yacc_c2h)` y.output $*.output -- $(YACCCOMPILE)
|
||||
-
|
||||
mostlyclean-libtool:
|
||||
-rm -f *.lo
|
||||
|
||||
@@ -2299,27 +2209,6 @@ basic_r.log: basic_r$(EXEEXT)
|
||||
--log-file $$b.log --trs-file $$b.trs \
|
||||
$(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
||||
"$$tst" $(AM_TESTS_FD_REDIRECT)
|
||||
-bison_nr.log: bison_nr$(EXEEXT)
|
||||
- @p='bison_nr$(EXEEXT)'; \
|
||||
- b='bison_nr'; \
|
||||
- $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
|
||||
- --log-file $$b.log --trs-file $$b.trs \
|
||||
- $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
||||
- "$$tst" $(AM_TESTS_FD_REDIRECT)
|
||||
-bison_yylloc.log: bison_yylloc$(EXEEXT)
|
||||
- @p='bison_yylloc$(EXEEXT)'; \
|
||||
- b='bison_yylloc'; \
|
||||
- $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
|
||||
- --log-file $$b.log --trs-file $$b.trs \
|
||||
- $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
||||
- "$$tst" $(AM_TESTS_FD_REDIRECT)
|
||||
-bison_yylval.log: bison_yylval$(EXEEXT)
|
||||
- @p='bison_yylval$(EXEEXT)'; \
|
||||
- b='bison_yylval'; \
|
||||
- $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
|
||||
- --log-file $$b.log --trs-file $$b.trs \
|
||||
- $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
||||
- "$$tst" $(AM_TESTS_FD_REDIRECT)
|
||||
c_cxx_nr.log: c_cxx_nr$(EXEEXT)
|
||||
@p='c_cxx_nr$(EXEEXT)'; \
|
||||
b='c_cxx_nr'; \
|
||||
@@ -2710,15 +2599,6 @@ maintainer-clean-generic:
|
||||
-rm -f array_r.c
|
||||
-rm -f basic_nr.c
|
||||
-rm -f basic_r.c
|
||||
- -rm -f bison_nr_parser.c
|
||||
- -rm -f bison_nr_parser.h
|
||||
- -rm -f bison_nr_scanner.c
|
||||
- -rm -f bison_yylloc_parser.c
|
||||
- -rm -f bison_yylloc_parser.h
|
||||
- -rm -f bison_yylloc_scanner.c
|
||||
- -rm -f bison_yylval_parser.c
|
||||
- -rm -f bison_yylval_parser.h
|
||||
- -rm -f bison_yylval_scanner.c
|
||||
-rm -f ccl.c
|
||||
-rm -f cxx_basic.cc
|
||||
-rm -f cxx_multiple_scanners_1.cc
|
||||
@@ -2856,15 +2736,6 @@ dist-hook:
|
||||
.ll.cc: $(FLEX)
|
||||
$(FLEX) -+ -o $@ $<
|
||||
|
||||
-bison_nr_main.($OBJEXT): bison_nr_parser.h bison_nr_scanner.h
|
||||
-bison_nr_scanner.h: bison_nr_scanner.c
|
||||
-
|
||||
-bison_yylloc_main.$(OBJEXT): bison_yylloc_parser.h bison_yylloc_scanner.h
|
||||
-bison_yylloc_scanner.h: bison_yylloc_scanner.c
|
||||
-
|
||||
-bison_yylval_main.$(OBJEXT): bison_yylval_parser.h bison_yylval_scanner.h
|
||||
-bison_yylval_scanner.h: bison_yylval_scanner.c
|
||||
-
|
||||
# automake does not support compiling flex scanners output in C as C++
|
||||
# so we explicitly sayhow, using the .lll suffix for the lex input file
|
||||
|
||||
|
|
Loading…
Reference in a new issue