- Honor CFLAGS.

- Do not run mkdep, which is unnecessary in package buildling.
This commit is contained in:
minskim 2004-12-27 01:00:28 +00:00
parent 477be03389
commit 0babe32e56
2 changed files with 21 additions and 1 deletions

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/12/24 16:51:33 manu Exp $
$NetBSD: distinfo,v 1.2 2004/12/27 01:00:28 minskim Exp $
SHA1 (mdd-20041224.tgz) = 2d66bdea10779a80e5b5eb0be325a18035dbbdd5
Size (mdd-20041224.tgz) = 6993 bytes
SHA1 (patch-aa) = 50adeddaa2757106e74e9e043b44e86b10ae5d21

View file

@ -0,0 +1,19 @@
$NetBSD: patch-aa,v 1.1 2004/12/27 01:00:28 minskim Exp $
--- Makefile.orig 2004-12-24 10:46:49.000000000 -0600
+++ Makefile
@@ -1,12 +1,11 @@
-CFLAGS= -Werror -Wall -ansi
SRC= mdd.c sender.c receiver.c sniffer.c
OBJ= mdd.o sender.o receiver.o sniffer.o
-all: depend mdd
+all: mdd
mdd: ${OBJ}
- ${CC} -static -o $@ ${OBJ}
+ ${CC} ${CFLAGS} -static -o $@ ${OBJ}
depend:
mkdep ${CFLAGS} ${SRC}