Update to 0.5. No change log.

This commit is contained in:
shattered 2012-11-25 21:37:50 +00:00
parent 4fa28ba07d
commit 0bb0d2eedb
5 changed files with 20 additions and 39 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.14 2012/10/29 05:07:13 asau Exp $
# $NetBSD: Makefile,v 1.15 2012/11/25 21:37:50 shattered Exp $
#
DISTNAME= xkbset-0.3
PKGREVISION= 3
DISTNAME= xkbset-0.5
CATEGORIES= x11
MASTER_SITES= http://www.math.missouri.edu/~stephen/software/xkbset/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2012/06/16 03:15:32 dholland Exp $
bin/mskacc-gui
@comment $NetBSD: PLIST,v 1.3 2012/11/25 21:37:50 shattered Exp $
bin/xkbset-gui
bin/xkbset
man/man1/xkbset.1

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.5 2009/07/07 21:34:58 joerg Exp $
$NetBSD: distinfo,v 1.6 2012/11/25 21:37:50 shattered Exp $
SHA1 (xkbset-0.3.tar.gz) = 23133cc74b09182c1ce8efc2dc2ff1a78feb34b6
RMD160 (xkbset-0.3.tar.gz) = 7bc55cb450af3c32353c29f5e329e8f8b522b5f8
Size (xkbset-0.3.tar.gz) = 13279 bytes
SHA1 (patch-aa) = ce46af55720ecdae4f6b12c0aceb93b4d0496655
SHA1 (patch-ab) = b74e6eb1cbca4a3d9d20ebee7af874d5f4a4b7dd
SHA1 (xkbset-0.5.tar.gz) = aa2f067e0963f351323b947bfbdfdb0be9e7d52d
RMD160 (xkbset-0.5.tar.gz) = be1b29d9dc695b5c4848c0ac78c170b6c2ce5d67
Size (xkbset-0.5.tar.gz) = 13933 bytes
SHA1 (patch-aa) = 149bc1e2c4b141b836b52c125d6d92fc8b9537b8

View file

@ -1,19 +1,17 @@
$NetBSD: patch-aa,v 1.3 2009/07/07 21:34:58 joerg Exp $
$NetBSD: patch-aa,v 1.4 2012/11/25 21:37:50 shattered Exp $
--- Makefile.orig Sun May 13 06:09:39 2001
--- Makefile.orig 2002-11-24 23:14:18.000000000 +0000
+++ Makefile
@@ -1,10 +1,10 @@
# The following are for XFree86 on FreeBSD
-INC_PATH=-I/usr/X11R6/include
-LIB_PATH=-L/usr/X11R6/lib
+INC_PATH=-I${X11BASE}/include
@@ -1,11 +1,8 @@
-X11PREFIX=/usr/X11R6
-X11BASE=/usr/X11R6
-
INSTALL_BIN=${DESTDIR}${X11PREFIX}/bin
INSTALL_MAN1=${DESTDIR}${X11PREFIX}/man/man1
INC_PATH=-I${X11BASE}/include
-LIB_PATH=-L${X11BASE}/lib
+LIB_PATH= -Wl,-R${X11BASE}/lib -L${X11BASE}/lib
LIBS=-lX11
CC=cc ${INC_PATH} ${LIB_PATH} -Wall
-INSTALL_BIN=/usr/X11R6/bin
-INSTALL_MAN1=/usr/X11R6/man/man1
+INSTALL_BIN=${DESTDIR}${X11PREFIX}/bin
+INSTALL_MAN1=${DESTDIR}${X11PREFIX}/man/man1
all: xkbset xkbset.1

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ab,v 1.1 2002/09/25 10:23:45 hubertf Exp $
--- main.c.orig Thu Aug 17 06:36:15 2000
+++ main.c
@@ -91,6 +91,10 @@
}
xkb = XkbGetKeyboard(display,XkbControlsMask,XkbUseCoreKbd);
+ if (xkb == 0) {
+ fprintf(stderr, "XKB not supported for display %s\n", getenv("DISPLAY"));
+ exit(1);
+ }
XkbGetControls(display, XkbAccessXTimeoutMask|XkbAllControlsMask, xkb);
if (query) {